Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-06-2014 19:07:54

sultan225
Membre
Distrib. : Debian Wheezy 7
Noyau : linux 3.2.0-4-686-pae
(G)UI : xfce4
Inscription : 05-05-2014

Installation de BerkeleyDB sous Debian wheezy

Bonjour,
s'ils vous plait, je viens de réinstallé mon serveur HP proliant avec Debian 7 wheezy en mode commande. puis j'ai ajouté l'environnement graphique xfce4 !
Je souhaite maintenant installé BerkeleyDB afin de mettre en place mon serveur LDAP. Mais après avoir suivi le README de BerkeleyDB.4.2 (BerkeleyDB/docs/index.html), j'ai le message d'erreur:
Tous mes checking if ....donnent no comme reponse et en dernières lignes j'ai:
checking for ar... missing_ar
configure: error: No ar utility found.

Pour le moment, je n'ai pas accès à mon navigateur web, j'attend que "apt-get update" finisse et je telecharge iceweeasel afin de naviguer directement sur mon serveur, pour le moment sur le post je suis sous une autre machine de mon réseau.
Merci d'avance:)

Hors ligne

#2 03-06-2014 21:35:48

sultan225
Membre
Distrib. : Debian Wheezy 7
Noyau : linux 3.2.0-4-686-pae
(G)UI : xfce4
Inscription : 05-05-2014

Re : Installation de BerkeleyDB sous Debian wheezy

Je suis de retour pour plus d'informations comme promis !
j'ai installer iceweasel maintenant et je peux accéder à un navigateur directement sur mon serveur afin de vous poster mes messages d'erreurs.
J'ai d'abord fais un "apt-cache search standard c compiler" puis installer grace au "apt-get install <paquet>" tous les logiciels qui attrayaient à le compilation C, C++, make, clang, ...
Et maintenant (comme l'indique le README de BerkeleyDB.4.2), j'ai copier db.4.2.52.tar, patch.4.2.52.1, patch.4.2.52.2, patch.4.2.52.3, patch.4.2.52.4, patch.4.2.52.5 dans le /tmp !
Puis j'ai de compresser le db.4.2.52.tar avec "tar xvzf db.4.2.52.tar", tous c'est bien passé. Et j'ai copier encore les atch.4.2.52.1, patch.4.2.52.2, patch.4.2.52.3, patch.4.2.52.4, patch.4.2.52.5 dans le /tmp/db.4.2.52. Ensuite j'ai appliquer les patchs:

patch -p0 < patch.4.2.52.1
patch -p0 < patch.4.2.52.2
patch -p0 < patch.4.2.52.3
patch -p0 < patch.4.2.52.4
patch -p0 < patch.4.2.52.5


Enfin une fois que je me rend dans /tmp/db.4.2.52/build_unix et que je fais "../dist/configure" j'ai le message:

../dist/configure


checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking if building in the top-level or dist directories... no
checking if --disable-cryptography option specified... no
checking if --disable-hash option specified... no
checking if --disable-queue option specified... no
checking if --disable-replication option specified... no
checking if --disable-verify option specified... no
checking if --enable-compat185 option specified... no
checking if --enable-cxx option specified... no
checking if --enable-debug option specified... no
checking if --enable-debug_rop option specified... no
checking if --enable-debug_wop option specified... no
checking if --enable-diagnostic option specified... no
checking if --enable-dump185 option specified... no
checking if --enable-java option specified... no
checking if --enable-mingw option specified... no
checking if --enable-posixmutexes option specified... no
checking if --enable-rpc option specified... no
checking if --enable-smallbuild option specified... no
checking if --enable-tcl option specified... no
checking if --enable-test option specified... no
checking if --enable-uimutexes option specified... no
checking if --enable-umrw option specified... no
checking if --with-mutex=MUTEX option specified... no
checking if --with-mutexalign=ALIGNMENT option specified... no
checking if --with-rpm=ARCHIVE option specified... no
checking if --with-tcl=DIR option specified... no
checking if --with-uniquename=NAME option specified... no
checking for ar... ar
checking for chmod... chmod
checking for cp... cp
checking for ln... ln
checking for mkdir... mkdir
checking for ranlib... ranlib
checking for ranlib... /usr/bin/ranlib
checking for rm... rm
checking for sh... sh
checking for sh... /bin/sh
checking for strip... strip
checking for strip... /usr/bin/strip
checking for a BSD-compatible install... /usr/bin/install -c
checking for cc... no
checking for gcc... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
root@serveur:/tmp/db-4.2.52/build_unix#

Et en listant le fichier /tmp/db.4.2.52/build_unix/config.log, j'ai:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by Berkeley DB configure 4.2.52, which was
generated by GNU Autoconf 2.57.  Invocation command line was

  $ ../dist/configure

## --------- ##
## Platform. ##
## --------- ##

hostname = serveur
uname -m = i686
uname -r = 3.2.0-4-686-pae
uname -s = Linux
uname -v = #1 SMP Debian 3.2.54-2

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1543: checking build system type
configure:1561: result: i686-pc-linux-gnu
configure:1569: checking host system type
configure:1583: result: i686-pc-linux-gnu
configure:1606: checking if building in the top-level or dist directories
configure:1615: result: no
configure:1700: checking if --disable-cryptography option specified
configure:1713: result: no
configure:1717: checking if --disable-hash option specified
configure:1730: result: no
configure:1734: checking if --disable-queue option specified
configure:1747: result: no
configure:1751: checking if --disable-replication option specified
configure:1764: result: no
configure:1768: checking if --disable-verify option specified
configure:1781: result: no
configure:1785: checking if --enable-compat185 option specified
configure:1794: result: no
configure:1797: checking if --enable-cxx option specified
configure:1806: result: no
configure:1809: checking if --enable-debug option specified
configure:1818: result: no
configure:1821: checking if --enable-debug_rop option specified
configure:1830: result: no
configure:1833: checking if --enable-debug_wop option specified
configure:1842: result: no
configure:1845: checking if --enable-diagnostic option specified
configure:1869: result: no
configure:1873: checking if --enable-dump185 option specified
configure:1882: result: no
configure:1885: checking if --enable-java option specified
configure:1894: result: no
configure:1897: checking if --enable-mingw option specified
configure:1906: result: no
configure:1909: checking if --enable-posixmutexes option specified
configure:1918: result: no
configure:1921: checking if --enable-rpc option specified
onfigure:1930: result: no
configure:1933: checking if --enable-smallbuild option specified
configure:1949: result: no
configure:1952: checking if --enable-tcl option specified
configure:1961: result: no
configure:1964: checking if --enable-test option specified
configure:1973: result: no
configure:1976: checking if --enable-uimutexes option specified
configure:1985: result: no
configure:1988: checking if --enable-umrw option specified
configure:1997: result: no
configure:2000: checking if --with-mutex=MUTEX option specified
configure:2018: result: no
configure:2023: checking if --with-mutexalign=ALIGNMENT option specified
configure:2044: result: no
configure:2047: checking if --with-rpm=ARCHIVE option specified
configure:2069: result: no
configure:2072: checking if --with-tcl=DIR option specified
configure:2082: result: no
configure:2088: checking if --with-uniquename=NAME option specified
configure:2101: result: no
configure:2210: checking for ar
configure:2226: found /usr/bin/ar
configure:2237: result: ar
configure:2296: checking for chmod
configure:2312: found /bin/chmod
configure:2323: result: chmod
configure:2382: checking for cp
configure:2398: found /bin/cp
configure:2409: result: cp
configure:2595: checking for ln
configure:2611: found /bin/ln
configure:2622: result: ln
configure:2681: checking for mkdir
configure:2697: found /bin/mkdir
configure:2708: result: mkdir
configure:2769: checking for ranlib
configure:2785: found /usr/bin/ranlib
configure:2796: result: ranlib
configure:2810: checking for ranlib
configure:2828: found /usr/bin/ranlib
configure:2841: result: /usr/bin/ranlib
configure:2890: checking for rm
configure:2906: found /bin/rm
configure:2917: result: rm
configure:3066: checking for sh
configure:3082: found /bin/sh
configure:3093: result: sh
configure:3107: checking for sh
configure:3125: found /bin/sh
configure:3138: result: /bin/sh
configure:3196: checking for strip
configure:3212: found /usr/bin/strip
configure:3223: result: strip
configure:3237: checking for strip
configure:3255: found /usr/bin/strip
configure:3268: result: /usr/bin/strip
configure:3378: checking for a BSD-compatible install
configure:3432: result: /usr/bin/install -c
configure:3600: checking for cc
configure:3629: result: no
configure:3600: checking for gcc
configure:3629: result: no
configure:3641: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_ct_db_cv_path_ar=ar
ac_ct_db_cv_path_chmod=chmod
ac_ct_db_cv_path_cp=cp
ac_ct_db_cv_path_ln=ln
ac_ct_db_cv_path_mkdir=mkdir
ac_ct_db_cv_path_rm=rm
ac_cv_build=i686-pc-linux-gnu
ac_cv_build_alias=i686-pc-linux-gnu
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=
ac_cv_env_FFLAGS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux-gnu
ac_cv_host_alias=i686-pc-linux-gnu
ac_cv_path_db_cv_path_ranlib=/usr/bin/ranlib
ac_cv_path_db_cv_path_sh=/bin/sh
ac_cv_path_db_cv_path_strip=/usr/bin/strip
ac_cv_path_install='/usr/bin/install -c'
ac_cv_prog_ac_ct_db_cv_path_ar=ar
ac_cv_prog_ac_ct_db_cv_path_chmod=chmod
ac_cv_prog_ac_ct_db_cv_path_cp=cp
ac_cv_prog_ac_ct_db_cv_path_ln=ln
ac_cv_prog_ac_ct_db_cv_path_mkdir=mkdir
ac_cv_prog_ac_ct_db_cv_path_rm=rm
ac_cv_prog_ac_ct_path_ranlib=ranlib
ac_cv_prog_ac_ct_path_sh=sh
ac_cv_prog_ac_ct_path_strip=strip
db_cv_build_cryptography=yes
b_cv_build_hash=yes
db_cv_build_queue=yes
db_cv_build_replication=yes
db_cv_build_type=release
db_cv_build_verify=yes
db_cv_compat185=no
db_cv_cxx=no
db_cv_debug=no
db_cv_debug_rop=no
db_cv_debug_wop=no
db_cv_diagnostic=no
db_cv_dump185=no
db_cv_java=no
db_cv_mingw=no
db_cv_path_ar=ar
db_cv_path_chmod=chmod
db_cv_path_cp=cp
db_cv_path_ln=ln
db_cv_path_mkdir=mkdir
db_cv_path_ranlib=/usr/bin/ranlib
b_cv_path_rm=rm
db_cv_path_rpm_archive=Not-configured-with-rpm=ARCHIVE
db_cv_path_sh=/bin/sh
db_cv_path_strip=/usr/bin/strip
db_cv_posixmutexes=no
db_cv_rpc=no
db_cv_rpm=no
db_cv_smallbuild=no
db_cv_tcl=no
db_cv_test=no
db_cv_uimutexes=no
db_cv_umrw=no
db_cv_uniquename=no

## ----------------- ##
## Output variables. ##
## ----------------- ##

ADDITIONAL_INCS=''
ADDITIONAL_LANG=''
ADDITIONAL_OBJS=''
ADDITIONAL_PROGS=''
AR=''
BUILD_TARGET='library_build'
CC=''
CCC=''
CFLAGS='-O2'
CONFIGURATION_ARGS=''
CONFIGURATION_PATH='/tmp/db-4.2.52/build_unix'
CPP=''
CPPFLAGS=' -D_GNU_SOURCE -D_REENTRANT'
CRYPTO_OBJS=''
CXX=''
CXXCPP=''
CXXFLAGS='-O2'
DB_CONST=''
DB_PROTO1=''
DB_PROTO2=''
DB_VERSION_MAJOR='4'
DB_VERSION_MINOR='2'
B_VERSION_PATCH='52'
DB_VERSION_STRING='"Sleepycat Software: Berkeley DB 4.2.52: (December  3, 2003)"'
DB_VERSION_UNIQUE_NAME=''
DEFAULT_LIB=''
DEFAULT_LIB_CXX=''
DEFS=''
ECHO='echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
F77=''
FFLAGS=''
INSTALLER=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_LIBS=''
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_TARGET='library_install'
JAR=''
JAVA=''
JAVAC=''
JAVACFLAGS=''
JMODSUFFIX=''
LDFLAGS=''
LIBJSO_LIBS=''
LIBOBJS=''
LIBS=''
LIBSO_LIBS=''
LIBTOOL=''
LIBTSO_LIBS=''
LIBTSO_MODSUFFIX=''
LIBTSO_MODULE=''
LIBXSO_LIBS=''
LN_S=''
LOAD_LIBS=''
LTLIBOBJS=''
MAKEFILE_CC=''
MAKEFILE_CCLINK=''
MAKEFILE_CXX=''
MAKEFILE_CXXLINK=''
MAKEFILE_SOLINK=''
MAKEFILE_XSOLINK=''
MODSUFFIX=''
OBJEXT=''
OSDIR=''
PACKAGE_BUGREPORT='support@sleepycat.com'
PACKAGE_NAME='Berkeley DB'
PACKAGE_STRING='Berkeley DB 4.2.52'
PACKAGE_TARNAME='db-4.2.52'
PACKAGE_VERSION='4.2.52'
PATH_SEPARATOR=':'
POSTLINK=''
RANLIB=''
REPLACEMENT_OBJS=''
RPC_CLIENT_OBJS=''
RPM_BUILD=''
RPM_POST_INSTALL=''
RPM_POST_UNINSTALL=''
SHELL='/bin/bash'
SOFLAGS=''
SOSUFFIX=''
STRIP=''
TCFLAGS=''
TCL_BIN_DIR=''
TCL_LIB_FILE=''
TCL_SRC_DIR=''
TCL_TCLSH=''
_ACJNI_JAVAC=''
ac_ct_AR=''
ac_ct_CC=''
ac_ct_CCC=''
ac_ct_CXX=''
ac_ct_F77=''
ac_ct_RANLIB=''
ac_ct_STRIP=''
ac_ct_db_cv_path_ar='ar'
ac_ct_db_cv_path_chmod='chmod'
ac_ct_db_cv_path_cp='cp'
ac_ct_db_cv_path_kill=''
ac_ct_db_cv_path_ln='ln'
ac_ct_db_cv_path_mkdir='mkdir'
ac_ct_db_cv_path_rm='rm'
ac_ct_db_cv_path_rpm=''
ac_ct_path_ldconfig=''
ac_ct_path_ranlib='ranlib'
ac_ct_path_sh='sh'
ac_ct_path_strip='strip'
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnu'
build_alias=''
build_cpu='i686'
build_os='linux-gnu'
build_vendor='pc'
cxx_have_stdheaders=''
datadir='${prefix}/share'
db_align_t_decl=''
db_alignp_t_decl=''
db_cv_build_type='release'
db_cv_path_ar='ar'
db_cv_path_chmod='chmod'
db_cv_path_cp='cp'
db_cv_path_kill=''
db_cv_path_ldconfig=''
db_cv_path_ln='ln'
db_cv_path_mkdir='mkdir'
db_cv_path_ranlib='/usr/bin/ranlib'
db_cv_path_rm='rm'
db_cv_path_rpm=''
db_cv_path_rpm_archive='Not-configured-with-rpm=ARCHIVE'
db_cv_path_sh='/bin/sh'
db_cv_path_strip='/usr/bin/strip'
db_int_def=''
exec_prefix='NONE'
host='i686-pc-linux-gnu'
host_alias=''
host_cpu='i686'
host_os='linux-gnu'
host_vendor='pc'
includedir='${prefix}/include'
infodir='${prefix}/info'
int16_decl=''
int32_decl=''
inttypes_decl=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='${prefix}/man'
o=''
oldincludedir='/usr/include'
path_ldconfig=''
path_ranlib='ranlib'
path_sh='sh'
path_strip='strip'
prefix='NONE'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
ssize_t_decl=''
sysconfdir='${prefix}/etc'
target_alias=''
u_char_decl=''
u_int16_decl=''
u_int32_decl=''
u_int8_decl=''
u_int_decl=''
u_long_decl=''
u_short_decl=''
uudecode=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT "support@sleepycat.com"
#define PACKAGE_NAME "Berkeley DB"
#define PACKAGE_STRING "Berkeley DB 4.2.52"
#define PACKAGE_TARNAME "db-4.2.52"
#define PACKAGE_VERSION "4.2.52"
configure: exit 1




Pouvez-vous m'aider ?

Hors ligne

#3 03-06-2014 22:33:54

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation de BerkeleyDB sous Debian wheezy

Bonsoir,

Il semble que tu n'aies pas de compilateur C installé.
Que donne, par exemple :

apt-cache policy gcc


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 04-06-2014 07:21:01

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Installation de BerkeleyDB sous Debian wheezy

Salut

Je ne connais pas berkeley DB, mais il existe a priori le paquet db-util dans les dépôts. C'est une méthode préférable d'installer les paquets des dépôts plutôt que n'importe quelle autres.

J'en profite pour te signaler qu'il semble également exister un paquet pour installer un serveur ldap qui s'appelle sldap ( https://wiki.debian.org/LDAP/OpenLDAPSetup ) :)

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#5 04-06-2014 14:15:15

sultan225
Membre
Distrib. : Debian Wheezy 7
Noyau : linux 3.2.0-4-686-pae
(G)UI : xfce4
Inscription : 05-05-2014

Re : Installation de BerkeleyDB sous Debian wheezy

Bonjour Pascal,
la commande que tu me conseilles renvoit celà:

apt-cache policy gcc


gcc:
  Installé : (aucun)
  Candidat : 4:4.7.2-1
 Table de version :
    4:4.7.2-1 0
        500 cdrom://[Debian GNU/Linux 7.4.0 _Wheezy_ - Official i386 CD Binary-4 20140208-12:25]/ wheezy/main i386 Packages
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages

Hors ligne

#6 04-06-2014 14:27:41

sultan225
Membre
Distrib. : Debian Wheezy 7
Noyau : linux 3.2.0-4-686-pae
(G)UI : xfce4
Inscription : 05-05-2014

Re : Installation de BerkeleyDB sous Debian wheezy

Bonjour Mots des Rateurs,
Au début, j'ai fais comme tu as dis, en installant tout par "apt-get install slapd ldap-utils db-util" ! Mais j'avais des problèmes dans la configuration, et dans mes recherches j'ai vu une documentation de Openldap qui signalait des bugs dans la config, donc il valait mieux compiler manuellement BerkeleyDB en version .4.2 et openldap aussi en version 2.2.5 !! Raison pour laquelle je me met maintenant à l'installation par compilation, et non par "apt-get install <...>" !!
La documentation que je suis en parallèle de celles fournies par Openldap est:
http://www.espace-groupware.com/squid/a … .html#toc1
Mais Mais Mais j'aime bien votre lien, je me documente là dessus et je vous fais signe

Hors ligne

#7 04-06-2014 14:34:30

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation de BerkeleyDB sous Debian wheezy

Mettre à jour la base de donnée des paquets :

apt-get update


Puis installer le compilateur gcc :

apt-get install gcc

smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 04-06-2014 14:57:23

sultan225
Membre
Distrib. : Debian Wheezy 7
Noyau : linux 3.2.0-4-686-pae
(G)UI : xfce4
Inscription : 05-05-2014

Re : Installation de BerkeleyDB sous Debian wheezy

D'accord paskal,

le "apt-get update" c'est bien passé
le "apt-get install gcc" m'a rendu :

apt-get install gcc


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 clang : Dépend: libstdc++6-4.6-dev mais ne sera pas installé
 gcc : Dépend: gcc-4.7 (>= 4.7.2-1~) mais ne sera pas installé
 ghc : Dépend: libgmp-dev mais ne sera pas installé
       Dépend: libffi-dev mais ne sera pas installé
       Dépend: libbsd-dev mais ne sera pas installé
 llvm-3.0-dev : Dépend: libffi-dev (>= 3.0.9) mais ne sera pas installé
 llvm-3.0-runtime : Dépend: binfmt-support mais ne sera pas installé
 openjdk-7-jre : Dépend: libgif4 (>= 4.1.4) mais ne sera pas installé
                 Recommande: libgnome2-0 mais ne sera pas installé
                 Recommande: libgnomevfs2-0 mais ne sera pas installé
 openjdk-7-jre-headless : Dépend: java-common (>= 0.28) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


donc j'ai lancé le "apt-get if install" et il m'a proposé:

apt-get -f install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libarchive12 libcurl3
  libnettle4 libpython2.7 libssl-dev libssl-doc python2.7-dev
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  binfmt-support g++-4.6 gcc gcc-4.7 java-common libbsd-dev libffi-dev libgif4
  libgmp-dev libgmpxx4ldbl libitm1 libstdc++6-4.6-dev
Paquets suggérés :
  g++-4.6-multilib gcc-4.6-doc libstdc++6-4.6-dbg gcc-multilib manpages-dev
  autoconf automake1.9 libtool flex bison gdb gcc-4.7-multilib
  libmudflap0-4.7-dev gcc-4.7-locales libgcc1-dbg libgomp1-dbg libitm1-dbg
  libquadmath0-dbg libmudflap0-dbg libcloog-ppl0 libppl-c2 libppl7
  binutils-gold default-jre equivs libgmp10-doc libmpfr-dev libstdc++6-4.6-doc
Paquets recommandés :
  libstdc++-dev
Les NOUVEAUX paquets suivants seront installés :
  binfmt-support g++-4.6 gcc gcc-4.7 java-common libbsd-dev libffi-dev libgif4
  libgmp-dev libgmpxx4ldbl libitm1 libstdc++6-4.6-dev
0 mis à jour, 12 nouvellement installés, 0 à enlever et 19 non mis à jour.
47 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/17,8 Mo dans les archives.
Après cette opération, 44,8 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Ensuite il m'a demandé le Cd wheezy 2,
« Debian GNU/Linux 7.4.0 _Wheezy_ - Official i386 CD Binary-2 20140208-12:25 »
dans le lecteur « /media/cdrom/ » et appuyez sur la touche Entrée

Sélection du paquet java-common précédemment désélectionné.
(Lecture de la base de données... 65977 fichiers et répertoires déjà installés.)
Dépaquetage de java-common (à partir de .../java-common_0.47_all.deb) ...
Sélection du paquet libgif4 précédemment désélectionné.
Dépaquetage de libgif4 (à partir de .../libgif4_4.1.6-10_i386.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Changement de support : veuillez insérer le disque
 le Cd wheezy 5 !
« Debian GNU/Linux 7.4.0 _Wheezy_ - Official i386 CD Binary-5 20140208-12:25 »
dans le lecteur « /media/cdrom/ » et appuyez sur la touche Entrée

Sélection du paquet libgmpxx4ldbl:i386 précédemment désélectionné.
(Lecture de la base de données... 66037 fichiers et répertoires déjà installés.)
Dépaquetage de libgmpxx4ldbl:i386 (à partir de .../libgmpxx4ldbl_5.0.5+dfsg-2_i386.deb) ...
Sélection du paquet binfmt-support précédemment désélectionné.
Dépaquetage de binfmt-support (à partir de .../binfmt-support_2.0.12_i386.deb) ...

..
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de gcc-doc-base (4.7.2-2) ...
Paramétrage de gcc-4.7-doc (4.7.2-2) ...
Paramétrage de gcc-doc (5:4) ...
dpkg: des problèmes de dépendances empêchent la configuration de ghc :
 ghc dépend de gcc (>= 4:4.2) ; cependant :
  Le paquet gcc n'est pas installé.
 ghc dépend de libgmp-dev ; cependant :
  Le paquet libgmp-dev n'est pas installé.
 ghc dépend de libffi-dev ; cependant :
  Le paquet libffi-dev n'est pas installé.
 ghc dépend de libbsd-dev ; cependant :
  Le paquet libbsd-dev n'est pas installé.

dpkg: erreur de traitement de ghc (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de libllvm3.0:i386 (3.0-10) ...
dpkg: erreur de traitement de libffi-dev (--configure) :
 aucun paquet nommé « libffi-dev » n'est installé, configuration impossible
Paramétrage de binfmt-support (2.0.12) ...
[ ok ] Enabling additional executable binary formats: binfmt-support.
Paramétrage de llvm-3.0-runtime (3.0-10) ...
Paramétrage de llvm-3.0 (3.0-10) ...
dpkg: des problèmes de dépendances empêchent la configuration de llvm-3.0-dev :
 llvm-3.0-dev dépend de libffi-dev (>= 3.0.9) ; cependant :
  Le paquet libffi-dev n'est pas installé.

dpkg: erreur de traitement de llvm-3.0-dev (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de libclang-common-dev (1:3.0-6.2) ...
Paramétrage de gcc-4.6-base:i386 (4.6.3-14) ...
Paramétrage de cpp-4.6 (4.6.3-14) ...
Paramétrage de gcc-4.6 (4.6.3-14) ...
dpkg: erreur de traitement de g++-4.6 (--configure) :
 aucun paquet nommé « g++-4.6 » n'est installé, configuration impossible
dpkg: erreur de traitement de libstdc++6-4.6-dev (--configure) :
 aucun paquet nommé « libstdc++6-4.6-dev » n'est installé, configuration impossible
dpkg: des problèmes de dépendances empêchent la configuration de clang :
 clang dépend de libstdc++6-4.6-dev ; cependant :
  Le paquet libstdc++6-4.6-dev n'est pas installé.

dpkg: erreur de traitement de clang (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de libgnutls26:i386 (2.12.20-8+deb7u2) ...
Paramétrage de libgnutls-openssl27:i386 (2.12.20-8+deb7u2) ...
Paramétrage de libasyncns0:i386 (0.8-4) ...
Paramétrage de libatk-wrapper-java (0.30.4-3) ...
Paramétrage de libatk-wrapper-java-jni:i386 (0.30.4-3) ...
Paramétrage de libavahi-glib1:i386 (0.6.31-2) ...
Paramétrage de libflac8:i386 (1.2.1-6) ...
Paramétrage de libjson0:i386 (0.10-1.2) ...
Paramétrage de libsndfile1:i386 (1.0.25-5) ...
Paramétrage de libpulse0:i386 (2.0-6.1) ...
Paramétrage de libsmbclient:i386 (2:3.6.6-6+deb7u3) ...
Paramétrage de java-common (0.47) ...
Paramétrage de ttf-dejavu-extra (2.33-3) ...
Paramétrage de bin86 (0.16.17-3.1) ...
Paramétrage de bcc (0.16.17-3.1) ...
Paramétrage de libmilter1.0.1 (8.14.4-4) ...
Paramétrage de libbobcat3 (3.01.00-1+b1) ...
Paramétrage de bisonc++ (4.01.00-1) ...
Paramétrage de bisonc++-doc (4.01.00-1) ...
Paramétrage de ccache (3.1.7-1) ...
Updating symlinks in /usr/lib/ccache ...
Paramétrage de ccbuild (2.0.3-1+b1) ...
Paramétrage de elks-libc (0.16.17-3.1) ...
Paramétrage de fp-units-rtl-2.6.0 (2.6.0-9) ...
Paramétrage de fp-compiler-2.6.0 (2.6.0-9) ...
Warning: Could not find gcc. Unable to determine the gcclib path.
update-alternatives: utilisation de « /usr/bin/fpc-2.6.0 » pour fournir « /usr/bin/fpc » (fpc) en mode automatique
update-alternatives: utilisation de « /usr/bin/fpc-2.6.0 » pour fournir « /usr/bin/pc » (pc) en mode automatique
update-alternatives: utilisation de « /etc/fpc-2.6.0.cfg » pour fournir « /etc/fpc.cfg » (fpc.cfg) en mode automatique
Paramétrage de fp-compiler (2.6.0-9) ...
Paramétrage de fp-utils-2.6.0 (2.6.0-9) ...
update-alternatives: utilisation de « /usr/lib/fpc/2.6.0 » pour fournir « /usr/lib/fpc/default » (fp-utils) en mode automatique
Paramétrage de iasl (20100528-3) ...
Paramétrage de libgconf2-4:i386 (3.2.5-1+build1) ...
Paramétrage de libgif4 (4.1.6-10) ...
Paramétrage de tmake (1.8-1.1) ...
Paramétrage de dmake (1:4.12-2) ...
Paramétrage de openjdk-7-jre-headless:i386 (7u55-2.4.7-1~deb7u1) ...
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java » pour fournir « /usr/bin/java » (java) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/keytool » pour fournir « /usr/bin/keytool » (keytool) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/pack200 » pour fournir « /usr/bin/pack200 » (pack200) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/rmid » pour fournir « /usr/bin/rmid » (rmid) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/rmiregistry » pour fournir « /usr/bin/rmiregistry » (rmiregistry) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/unpack200 » pour fournir « /usr/bin/unpack200 » (unpack200) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/orbd » pour fournir « /usr/bin/orbd » (orbd) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/servertool » pour fournir « /usr/bin/servertool » (servertool) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/tnameserv » pour fournir « /usr/bin/tnameserv » (tnameserv) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/lib/jexec » pour fournir « /usr/bin/jexec » (jexec) en mode automatique
Paramétrage de openjdk-7-jre:i386 (7u55-2.4.7-1~deb7u1) ...
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/jre/bin/policytool » pour fournir « /usr/bin/policytool » (policytool) en mode automatique
Paramétrage de openjdk-7-jdk:i386 (7u55-2.4.7-1~deb7u1) ...
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/appletviewer » pour fournir « /usr/bin/appletviewer » (appletviewer) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/extcheck » pour fournir « /usr/bin/extcheck » (extcheck) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/idlj » pour fournir « /usr/bin/idlj » (idlj) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jar » pour fournir « /usr/bin/jar » (jar) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jarsigner » pour fournir « /usr/bin/jarsigner » (jarsigner) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/javac » pour fournir « /usr/bin/javac » (javac) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/javadoc » pour fournir « /usr/bin/javadoc » (javadoc) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/javah » pour fournir « /usr/bin/javah » (javah) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/javap » pour fournir « /usr/bin/javap » (javap) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jcmd » pour fournir « /usr/bin/jcmd » (jcmd) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jconsole » pour fournir « /usr/bin/jconsole » (jconsole) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jdb » pour fournir « /usr/bin/jdb » (jdb) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jhat » pour fournir « /usr/bin/jhat » (jhat) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jinfo » pour fournir « /usr/bin/jinfo » (jinfo) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jmap » pour fournir « /usr/bin/jmap » (jmap) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jps » pour fournir « /usr/bin/jps » (jps) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jrunscript » pour fournir « /usr/bin/jrunscript » (jrunscript) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jsadebugd » pour fournir « /usr/bin/jsadebugd » (jsadebugd) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jstack » pour fournir « /usr/bin/jstack » (jstack) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jstat » pour fournir « /usr/bin/jstat » (jstat) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/jstatd » pour fournir « /usr/bin/jstatd » (jstatd) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/native2ascii » pour fournir « /usr/bin/native2ascii » (native2ascii) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/rmic » pour fournir « /usr/bin/rmic » (rmic) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/schemagen » pour fournir « /usr/bin/schemagen » (schemagen) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/serialver » pour fournir « /usr/bin/serialver » (serialver) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/wsgen » pour fournir « /usr/bin/wsgen » (wsgen) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/wsimport » pour fournir « /usr/bin/wsimport » (wsimport) en mode automatique
update-alternatives: utilisation de « /usr/lib/jvm/java-7-openjdk-i386/bin/xjc » pour fournir « /usr/bin/xjc » (xjc) en mode automatique
Paramétrage de icedtea-7-jre-jamvm:i386 (7u55-2.4.7-1~deb7u1) ...
Paramétrage de ca-certificates-java (20121112+nmu2) ...
Adding debian:NetLock_Arany_=Class_Gold=_F?tanúsítvány.pem
Adding debian:Certum_Trusted_Network_CA.pem
Adding debian:A-Trust-nQual-03.pem
Adding debian:Starfield_Services_Root_Certificate_Authority_-_G2.pem
Adding debian:GlobalSign_Root_CA_-_R2.pem
Adding debian:thawte_Primary_Root_CA_-_G3.pem
Adding debian:TC_TrustCenter_Class_2_CA_II.pem
Adding debian:VeriSign_Class_3_Public_Primary_Certification_Authority_-_G5.pem
Adding debian:AddTrust_External_Root.pem
Adding debian:GlobalSign_Root_CA_-_R3.pem
Adding debian:Juur-SK.pem
Adding debian:SecureTrust_CA.pem
Adding debian:GeoTrust_Global_CA.pem
Adding debian:SecureSign_RootCA11.pem
Adding debian:Izenpe.com.pem
Adding debian:Digital_Signature_Trust_Co._Global_CA_1.pem
Adding debian:Buypass_Class_3_CA_1.pem
Adding debian:Equifax_Secure_Global_eBusiness_CA.pem
Adding debian:Buypass_Class_2_Root_CA.pem
Adding debian:TURKTRUST_Certificate_Services_Provider_Root_1.pem
Adding debian:TDC_Internet_Root_CA.pem
Adding debian:CA_Disig.pem
Adding debian:Microsec_e-Szigno_Root_CA.pem
Adding debian:EC-ACC.pem
Adding debian:Thawte_Server_CA.pem
Adding debian:EBG_Elektronik_Sertifika_Hizmet_Sa?lay?c?s?.pem
Adding debian:RSA_Security_2048_v3.pem
Adding debian:Verisign_Class_3_Public_Primary_Certification_Authority_-_G2.pem
Adding debian:TC_TrustCenter_Universal_CA_I.pem
Adding debian:Staat_der_Nederlanden_Root_CA_-_G2.pem
Adding debian:Certum_Root_CA.pem
Adding debian:Autoridad_de_Certificacion_Firmaprofesional_CIF_A62634068.pem
Adding debian:Secure_Global_CA.pem
Adding debian:certSIGN_ROOT_CA.pem
Adding debian:QuoVadis_Root_CA.pem
Adding debian:GeoTrust_Universal_CA.pem
Adding debian:QuoVadis_Root_CA_2.pem
Adding debian:Swisscom_Root_CA_1.pem
Adding debian:VeriSign_Universal_Root_Certification_Authority.pem
Adding debian:Global_Chambersign_Root_-_2008.pem
Adding debian:COMODO_ECC_Certification_Authority.pem
Adding debian:Staat_der_Nederlanden_Root_CA.pem
Adding debian:WellsSecure_Public_Root_Certificate_Authority.pem
Adding debian:DST_Root_CA_X3.pem
Adding debian:Go_Daddy_Root_Certificate_Authority_-_G2.pem
Adding debian:StartCom_Certification_Authority.pem
Adding debian:GTE_CyberTrust_Global_Root.pem
Adding debian:Certigna.pem
Adding debian:TDC_OCES_Root_CA.pem
Adding debian:Equifax_Secure_eBusiness_CA_2.pem
Adding debian:Comodo_Trusted_Services_root.pem
Adding debian:GeoTrust_Primary_Certification_Authority_-_G3.pem
Adding debian:S-TRUST_Authentication_and_Encryption_Root_CA_2005_PN.pem
Adding debian:America_Online_Root_Certification_Authority_2.pem
Adding debian:OISTE_WISeKey_Global_Root_GA_CA.pem
Adding debian:Network_Solutions_Certificate_Authority.pem
Adding debian:DigiCert_High_Assurance_EV_Root_CA.pem
Adding debian:Wells_Fargo_Root_CA.pem
Adding debian:E-Guven_Kok_Elektronik_Sertifika_Hizmet_Saglayicisi.pem
Adding debian:Comodo_AAA_Services_root.pem
Adding debian:Chambers_of_Commerce_Root_-_2008.pem
Adding debian:Entrust.net_Premium_2048_Secure_Server_CA.pem
Adding debian:VeriSign_Class_3_Public_Primary_Certification_Authority_-_G4.pem
Adding debian:thawte_Primary_Root_CA.pem
Adding debian:Verisign_Class_1_Public_Primary_Certification_Authority_-_G3.pem
Adding debian:Visa_eCommerce_Root.pem
Adding debian:Thawte_Premium_Server_CA.pem
Adding debian:NetLock_Notary_=Class_A=_Root.pem
Adding debian:ValiCert_Class_1_VA.pem
Adding debian:TURKTRUST_Certificate_Services_Provider_Root_2.pem
Adding debian:spi-ca-2003.pem
Adding debian:spi-cacert-2008.pem
Adding debian:DigiCert_Assured_ID_Root_CA.pem
Adding debian:Verisign_Class_2_Public_Primary_Certification_Authority_-_G2.pem
Adding debian:AffirmTrust_Networking.pem
Adding debian:Equifax_Secure_CA.pem
Adding debian:Security_Communication_EV_RootCA1.pem
Adding debian:COMODO_Certification_Authority.pem
Adding debian:Camerfirma_Global_Chambersign_Root.pem
Adding debian:Verisign_Class_3_Public_Primary_Certification_Authority_-_G3.pem
Adding debian:GeoTrust_Global_CA_2.pem
Adding debian:ca.pem
Adding debian:NetLock_Qualified_=Class_QA=_Root.pem
Adding debian:UTN_USERFirst_Email_Root_CA.pem
Adding debian:Go_Daddy_Class_2_CA.pem
Adding debian:Starfield_Class_2_CA.pem
Adding debian:Verisign_Class_1_Public_Primary_Certification_Authority.pem
Adding debian:UTN_DATACorp_SGC_Root_CA.pem
Adding debian:T-TeleSec_GlobalRoot_Class_3.pem
Adding debian:Sonera_Class_1_Root_CA.pem
Adding debian:ValiCert_Class_2_VA.pem
Adding debian:AffirmTrust_Commercial.pem
Adding debian:DigiCert_Global_Root_CA.pem
Adding debian:Deutsche_Telekom_Root_CA_2.pem
Adding debian:Trustis_FPS_Root_CA.pem
Adding debian:NetLock_Business_=Class_B=_Root.pem
Adding debian:Starfield_Root_Certificate_Authority_-_G2.pem
Adding debian:AddTrust_Low-Value_Services_Root.pem
Adding debian:SwissSign_Platinum_CA_-_G2.pem
Adding debian:Camerfirma_Chambers_of_Commerce_Root.pem
Adding debian:ComSign_Secured_CA.pem
Adding debian:Root_CA_Generalitat_Valenciana.pem
Adding debian:Baltimore_CyberTrust_Root.pem
Adding debian:IGC_A.pem
Adding debian:SwissSign_Silver_CA_-_G2.pem
Adding debian:CNNIC_ROOT.pem
Adding debian:ePKI_Root_Certification_Authority.pem
Adding debian:DST_ACES_CA_X6.pem
Adding debian:Sonera_Class_2_Root_CA.pem
Adding debian:Security_Communication_Root_CA.pem
Adding debian:AffirmTrust_Premium_ECC.pem
Adding debian:Verisign_Class_4_Public_Primary_Certification_Authority_-_G3.pem
Adding debian:Firmaprofesional_Root_CA.pem
Adding debian:GlobalSign_Root_CA.pem
Adding debian:SwissSign_Gold_CA_-_G2.pem
Adding debian:AC_Raíz_Certicámara_S.A..pem
Adding debian:NetLock_Express_=Class_C=_Root.pem
Adding debian:America_Online_Root_Certification_Authority_1.pem
Adding debian:StartCom_Certification_Authority_G2.pem
Adding debian:TC_TrustCenter_Class_3_CA_II.pem
Adding debian:ComSign_CA.pem
Adding debian:Buypass_Class_3_Root_CA.pem
Adding debian:Verisign_Class_2_Public_Primary_Certification_Authority_-_G3.pem
Adding debian:Verisign_Class_3_Public_Primary_Certification_Authority.pem
Adding debian:Taiwan_GRCA.pem
Adding debian:Entrust.net_Secure_Server_CA.pem
Adding debian:AffirmTrust_Premium.pem
Adding debian:Buypass_Class_2_CA_1.pem
Adding debian:QuoVadis_Root_CA_3.pem
Adding debian:EE_Certification_Centre_Root_CA.pem
Adding debian:Equifax_Secure_eBusiness_CA_1.pem
Adding debian:TC_TrustCenter_Universal_CA_III.pem
Adding debian:Digital_Signature_Trust_Co._Global_CA_3.pem
Adding debian:ApplicationCA_-_Japanese_Government.pem
Adding debian:TWCA_Root_Certification_Authority.pem
Adding debian:Hongkong_Post_Root_CA_1.pem
Adding debian:Verisign_Class_1_Public_Primary_Certification_Authority_-_G2.pem
Adding debian:XRamp_Global_CA_Root.pem
Adding debian:Hellenic_Academic_and_Research_Institutions_RootCA_2011.pem
Adding debian:Entrust_Root_Certification_Authority.pem
Adding debian:thawte_Primary_Root_CA_-_G2.pem
Adding debian:GeoTrust_Universal_CA_2.pem
Adding debian:GeoTrust_Primary_Certification_Authority.pem
Adding debian:AddTrust_Qualified_Certificates_Root.pem
Adding debian:Actalis_Authentication_Root_CA.pem
Adding debian:Certinomis_-_Autorité_Racine.pem
Adding debian:UTN_USERFirst_Hardware_Root_CA.pem
Adding debian:Microsec_e-Szigno_Root_CA_2009.pem
Adding debian:ACEDICOM_Root.pem
Adding debian:AddTrust_Public_Services_Root.pem
Adding debian:Comodo_Secure_Services_root.pem
Adding debian:GeoTrust_Primary_Certification_Authority_-_G2.pem
Adding debian:cacert.org.pem
Adding debian:Certplus_Class_2_Primary_CA.pem
Adding debian:RSA_Root_Certificate_1.pem
Adding debian:TÜB?TAK_UEKAE_Kök_Sertifika_Hizmet_Sa?lay?c?s?_-_Sürüm_3.pem
Adding debian:Cybertrust_Global_Root.pem
Adding debian:Security_Communication_RootCA2.pem
done.
Traitement des actions différées (« triggers ») pour « ca-certificates »...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....
done.
done.
Des erreurs ont été rencontrées pendant l'exécution :
 ghc
 libffi-dev
 llvm-3.0-dev
 g++-4.6
 libstdc++6-4.6-dev
 clang
E: Internal Error, No file name for gcc:i386
E: Internal Error, No file name for libgmp-dev:i386
E: Internal Error, No file name for libffi-dev:i386
E: Internal Error, No file name for libbsd-dev:i386
E: Internal Error, No file name for libstdc++6-4.6-dev:i386
E: Internal Error, No file name for g++-4.6:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)



Maintenant, je reprend les installations un à un de
ghc,  libffi-dev, llvm-3.0-dev,  g++-4.6, libstdc++6-4.6-dev et clang ???????
ou bien je vais un --purge de chacun ?

Hors ligne

#9 04-06-2014 15:08:38

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Installation de BerkeleyDB sous Debian wheezy

Argh ! désolé mad : j'ai tout simplement oublié de te faire configurer les sources.

Donc, avant tout, tu vas étudier le wiki, ici : https://debian-facile.org/doc:systeme:apt:sources.list

Et reviens demander éventuellement des précisions.  smile

Après tu pourras recommencer l'installation de gcc.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#10 04-06-2014 15:22:07

sultan225
Membre
Distrib. : Debian Wheezy 7
Noyau : linux 3.2.0-4-686-pae
(G)UI : xfce4
Inscription : 05-05-2014

Re : Installation de BerkeleyDB sous Debian wheezy

Hello paskal,
debrouillard que je suis, je me suis lancer dans l'installation un par un des paquets gcc, ghc, libffi-dev, llvm-3.0-dev, g++-4.6, libstdc++6-4.6-dev, clang ! Commençant seulement par gcc, j'ai suivi l'aide console en fesant le "apt-get -f install", puis il m'a demander encore des CD, je les ai introduit à tour de role, et l'installation a reussi ! Ma console affiche totalement:

apt-get install gcc


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 clang : Dépend: libstdc++6-4.6-dev mais ne sera pas installé
 gcc : Dépend: gcc-4.7 (>= 4.7.2-1~) mais ne sera pas installé
 ghc : Dépend: libgmp-dev mais ne sera pas installé
       Dépend: libffi-dev mais ne sera pas installé
       Dépend: libbsd-dev mais ne sera pas installé
 llvm-3.0-dev : Dépend: libffi-dev (>= 3.0.9) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


apt-get install gcc-4.7


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 clang : Dépend: libstdc++6-4.6-dev mais ne sera pas installé
 gcc-4.7 : Dépend: libitm1 (>= 4.7.2-5) mais ne sera pas installé
 ghc : Dépend: gcc (>= 4:4.2) mais ne sera pas installé
       Dépend: libgmp-dev mais ne sera pas installé
       Dépend: libffi-dev mais ne sera pas installé
       Dépend: libbsd-dev mais ne sera pas installé
 llvm-3.0-dev : Dépend: libffi-dev (>= 3.0.9) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


apt-get -f install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libarchive12 libcurl3
  libnettle4 libpython2.7 libssl-dev libssl-doc python2.7-dev
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  g++-4.6 gcc gcc-4.7 libbsd-dev libffi-dev libgmp-dev libitm1
  libstdc++6-4.6-dev
Paquets suggérés :
  g++-4.6-multilib gcc-4.6-doc libstdc++6-4.6-dbg gcc-multilib manpages-dev
  autoconf automake1.9 libtool flex bison gdb gcc-4.7-multilib
  libmudflap0-4.7-dev gcc-4.7-locales libgcc1-dbg libgomp1-dbg libitm1-dbg
  libquadmath0-dbg libmudflap0-dbg libcloog-ppl0 libppl-c2 libppl7
  binutils-gold libgmp10-doc libmpfr-dev libstdc++6-4.6-doc
Paquets recommandés :
  libstdc++-dev
Les NOUVEAUX paquets suivants seront installés :
  g++-4.6 gcc gcc-4.7 libbsd-dev libffi-dev libgmp-dev libitm1
  libstdc++6-4.6-dev
0 mis à jour, 8 nouvellement installés, 0 à enlever et 19 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/17,6 Mo dans les archives.
Après cette opération, 44,2 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Changement de support : veuillez insérer le disque
« Debian GNU/Linux 7.4.0 _Wheezy_ - Official i386 CD Binary-7 20140208-12:25 »
dans le lecteur « /media/cdrom/ » et appuyez sur la touche Entrée

Sélection du paquet g++-4.6 précédemment désélectionné.
(Lecture de la base de données... 66055 fichiers et répertoires déjà installés.)
Dépaquetage de g++-4.6 (à partir de .../g++-4.6_4.6.3-14_i386.deb) ...
Sélection du paquet libstdc++6-4.6-dev précédemment désélectionné.
Dépaquetage de libstdc++6-4.6-dev (à partir de .../libstdc++6-4.6-dev_4.6.3-14_i386.deb) ...
Sélection du paquet libffi-dev:i386 précédemment désélectionné.
Dépaquetage de libffi-dev:i386 (à partir de .../libffi-dev_3.0.10-3_i386.deb) ...
Sélection du paquet libgmp-dev:i386 précédemment désélectionné.
Dépaquetage de libgmp-dev:i386 (à partir de .../libgmp-dev_5.0.5+dfsg-2_i386.deb) ...
Traitement des actions différées (« triggers ») pour « ccache »...
Updating symlinks in /usr/lib/ccache ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « install-info »...
Changement de support : veuillez insérer le disque
« Debian GNU/Linux 7.4.0 _Wheezy_ - Official i386 CD Binary-4 20140208-12:25 »
dans le lecteur « /media/cdrom/ » et appuyez sur la touche Entrée

Sélection du paquet libitm1:i386 précédemment désélectionné.
(Lecture de la base de données... 66859 fichiers et répertoires déjà installés.)
Dépaquetage de libitm1:i386 (à partir de .../libitm1_4.7.2-5_i386.deb) ...
Sélection du paquet gcc-4.7 précédemment désélectionné.
Dépaquetage de gcc-4.7 (à partir de .../gcc-4.7_4.7.2-5_i386.deb) ...
Sélection du paquet gcc précédemment désélectionné.
Dépaquetage de gcc (à partir de .../gcc_4.7.2-1_i386.deb) ...
Traitement des actions différées (« triggers ») pour « ccache »...
Updating symlinks in /usr/lib/ccache ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libitm1:i386 (4.7.2-5) ...
Paramétrage de gcc-4.7 (4.7.2-5) ...
Paramétrage de gcc (4:4.7.2-1) ...
Paramétrage de libgmpxx4ldbl:i386 (2:5.0.5+dfsg-2) ...
Paramétrage de libgmp-dev:i386 (2:5.0.5+dfsg-2) ...
Paramétrage de libffi-dev:i386 (3.0.10-3) ...
dpkg: erreur de traitement de libbsd-dev (--configure) :
 aucun paquet nommé « libbsd-dev » n'est installé, configuration impossible
dpkg: des problèmes de dépendances empêchent la configuration de ghc :
 ghc dépend de libbsd-dev ; cependant :
  Le paquet libbsd-dev n'est pas installé.

dpkg: erreur de traitement de ghc (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de llvm-3.0-dev (3.0-10) ...
Paramétrage de g++-4.6 (4.6.3-14) ...
Paramétrage de libstdc++6-4.6-dev (4.6.3-14) ...
Paramétrage de clang (1:3.0-6.2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 libbsd-dev
 ghc
E: Internal Error, No file name for libbsd-dev:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)


apt-get install ghc


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
ghc est déjà la plus récente version disponible.
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
 ghc : Dépend: libbsd-dev mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


apt-get -f install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libarchive12 libcurl3
  libnettle4 libpython2.7 libssl-dev libssl-doc python2.7-dev
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libbsd-dev
Les NOUVEAUX paquets suivants seront installés :
  libbsd-dev
0 mis à jour, 1 nouvellement installés, 0 à enlever et 19 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/138 ko dans les archives.
Après cette opération, 350 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Changement de support : veuillez insérer le disque
« Debian GNU/Linux 7.4.0 _Wheezy_ - Official i386 CD Binary-8 20140208-12:25 »
dans le lecteur « /media/cdrom/ » et appuyez sur la touche Entrée

Sélection du paquet libbsd-dev précédemment désélectionné.
(Lecture de la base de données... 66977 fichiers et répertoires déjà installés.)
Dépaquetage de libbsd-dev (à partir de .../libbsd-dev_0.4.2-1_i386.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libbsd-dev (0.4.2-1) ...
Paramétrage de ghc (7.4.1-4) ...
update-alternatives: utilisation de « /usr/bin/runghc » pour fournir « /usr/bin/runhaskell » (runhaskell) en mode automatique
update-alternatives: utilisation de « /usr/bin/ghc » pour fournir « /usr/bin/haskell-compiler » (haskell-compiler) en mode automatique
root@serveur:/# apt-get install gcc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
gcc est déjà la plus récente version disponible.
gcc passé en « installé manuellement ».
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libarchive12 libcurl3
  libnettle4 libpython2.7 libssl-dev libssl-doc python2.7-dev
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 19 non mis à jour.



Après sa maintenant, j'ai continué ma compilation de BerkeleyDB, dans une autre console, j'ai finalement réussi. Cette console affiche:

cd build_unix/
../dist/configure


checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking if building in the top-level or dist directories... no
checking if --disable-cryptography option specified... no
checking if --disable-hash option specified... no
checking if --disable-queue option specified... no
checking if --disable-replication option specified... no
checking if --disable-verify option specified... no
checking if --enable-compat185 option specified... no
checking if --enable-cxx option specified... no
checking if --enable-debug option specified... no
checking if --enable-debug_rop option specified... no
checking if --enable-debug_wop option specified... no
checking if --enable-diagnostic option specified... no
checking if --enable-dump185 option specified... no
checking if --enable-java option specified... no
checking if --enable-mingw option specified... no
checking if --enable-posixmutexes option specified... no
checking if --enable-rpc option specified... no
checking if --enable-smallbuild option specified... no
checking if --enable-tcl option specified... no
checking if --enable-test option specified... no
checking if --enable-uimutexes option specified... no
checking if --enable-umrw option specified... no
checking if --with-mutex=MUTEX option specified... no
checking if --with-mutexalign=ALIGNMENT option specified... no
checking if --with-rpm=ARCHIVE option specified... no
checking if --with-tcl=DIR option specified... no
checking if --with-uniquename=NAME option specified... no
checking for ar... ar
checking for chmod... chmod
checking for cp... cp
checking for ln... ln
checking for mkdir... mkdir
checking for ranlib... ranlib
checking for ranlib... /usr/bin/ranlib
checking for rm... rm
checking for sh... sh
checking for sh... /bin/sh
checking for strip... strip
checking for strip... /usr/bin/strip
checking for a BSD-compatible install... /usr/bin/install -c
checking for cc... cc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking for an ANSI C-conforming const... yes
checking whether we are using gcc version 2.96... no
checking whether g++ requires -fhandle-exceptions... no
checking for a sed that does not truncate output... /bin/sed
checking for egrep... grep -E
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... cc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fl32... no
checking for af77... no
checking for fort77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for lf95... no
checking for g95... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc static flag  works... yes
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
appending configuration tag "F77" to libtool
checking SOSUFFIX from libtool... .so
checking MODSUFFIX from libtool... .so
checking JMODSUFFIX from libtool... .so
checking whether stat file-mode macros are broken... no
checking whether time.h and sys/time.h may both be included... yes
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking sys/fcntl.h usability... yes
checking sys/fcntl.h presence... yes
checking for sys/fcntl.h... yes
checking for struct stat.st_blksize... yes
checking for inttypes.h... (cached) yes
checking for char... yes
checking size of char... 1
checking for unsigned char... yes
checking size of unsigned char... 1
checking for short... yes
checking size of short... 2
checking for unsigned short... yes
checking size of unsigned short... 2
checking for int... yes
checking size of int... 4
checking for unsigned int... yes
checking size of unsigned int... 4
checking for long... yes
checking size of long... 4
checking for unsigned long... yes
checking size of unsigned long... 4
checking for size_t... yes
checking size of size_t... 4
checking for char *... yes
checking size of char *... 4
checking for off_t... yes
checking for size_t... (cached) yes
checking for u_char... yes
checking for u_short... yes
checking for u_int... yes
checking for u_long... yes
checking for u_int8_t... yes
checking for u_int16_t... yes
checking for int16_t... yes
checking for u_int32_t... yes
checking for int32_t... yes
checking for ssize_t... yes
checking for unsigned long long... yes
checking for ANSI C exit success/failure values... yes
checking for sched_yield... yes
checking for main in -lpthread... yes
checking for main in -lm... yes
checking for main in -lsocket... no
checking for main in -lnsl... yes
checking for mutexes... POSIX/pthreads/library
checking for getcwd... yes
checking for getopt... yes
checking for memcmp... yes
checking for memcpy... yes
checking for memmove... yes
checking for raise... yes
checking for snprintf... yes
checking for strcasecmp... yes
checking for strdup... yes
checking for strerror... yes
checking for vsnprintf... yes
checking for _fstati64... no
checking for clock_gettime... no
checking for directio... no
checking for getrusage... yes
checking for gettimeofday... yes
checking for getuid... yes
checking for pstat_getdynamic... no
checking for sched_yield... (cached) yes
checking for select... yes
checking for strtoul... yes
checking for sysconf... yes
checking for yield... no
checking for pread... yes
checking for pwrite... yes
checking for fcntl/F_SETFD... yes
checking for open/O_DIRECT... yes
configure: WARNING: O_DIRECT interface ignored on linux-gnu-pc.
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no
checking for mlock... yes
checking for munlock... yes
checking for mmap... yes
checking for munmap... yes
checking for shmget... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating db_cxx.h
config.status: creating db_int.h
config.status: creating include.tcl
config.status: creating db.h
config.status: creating db_config.h



Mais je ne crie pas victoire, car je suis toujours et toujours apprenant donc je m'atèle à lire conscienceusement ton Lien "https://debian-facile.org/doc:syst … urces.list" avant de continuer à compiler manuellement openldap !!

Hors ligne

#11 04-06-2014 16:20:18

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Installation de BerkeleyDB sous Debian wheezy

Salut sultan225,
J'ai édité tes messages pour les rendre plus lisibles. Je te laisse cliquer sur éditer sur tes messages pour voir quels mot-clés j'ai utilisé pour cela.
Voir le tuto : Le code, ça pique moins les yeux en couleur

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#12 04-06-2014 19:23:41

sultan225
Membre
Distrib. : Debian Wheezy 7
Noyau : linux 3.2.0-4-686-pae
(G)UI : xfce4
Inscription : 05-05-2014

Re : Installation de BerkeleyDB sous Debian wheezy

D'accord captnfab,
Je me demandais vraiment, comment rendre agréable ma discussion afin de motiver les membres du forums à intervenir ! Merci pour ton aide

Hors ligne

Pied de page des forums