Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-06-2014 14:38:54

Invité-5
Banni(e)

network.http.sendRefererHeader;2

Quand je mets cette valeur à 0 (zero) dans Iceweasel => about:config DF refuse de coopérer. Je puis me loger mais pour poster mission impossible.

citation a écrit :

Info
Mauvais HTTP_REFERER. Vous avez été renvoyé(e) vers cette page par une source inconnue ou interdite. Si le problème persiste, assurez-vous que le champ « URL de base » de la page Administration » Options est correctement renseigné et que vous vous rendez sur ces forums en utilisant cette URL. Vous pourrez trouver davantage d'informations dans la documentation de FluxBB.


Une solution peut-être ?

Dernière modification par Invité-5 (14-06-2014 14:51:34)

#2 13-06-2014 15:17:25

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : network.http.sendRefererHeader;2

Salut,

Le forum a besoin du referer par mesure de sécurité, d'où le message d'erreur.

La solution que j'ai adoptée est d'utiliser l'extension Smart Referer : le referer n'est désactivé que si tu changes de domaine (et est donc transmis si tu restes sur le domaine).

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#3 13-06-2014 18:02:51

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : network.http.sendRefererHeader;2

C'est effectivement une fonctionnalité du forum. Donc à part utiliser un plugin et définir une exception pour DF, pas vraiment de solution.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#4 13-06-2014 19:04:21

Invité-5
Banni(e)

Re : network.http.sendRefererHeader;2

Je me disais aussi. Merci. smile

#5 14-06-2014 14:57:38

Invité-5
Banni(e)

Re : network.http.sendRefererHeader;2

Momentanément, je me suis embrouillé tout seul avec

Since Firefox 28 there are three new items in about:config:

network.http.referer.XOriginPolicy: 0=always send, 1=send if base domains match, 2=send if hosts match
network.http.referer.spoofSource: false=real referer, true=spoof referer (use target URI as referer)
network.http.referer.trimmingPolicy: 0=send full URI, 1=scheme+host+port+path, 2=scheme+host+port

Referrer processing is done in this order. Thus, setting XOriginPolicy to 2 makes spoofSource and trimmingPolicy useless if going from a.example.com to b.example.com, since no referrer would be send anyway due to the XOriginPolicy.

If using the three new I'd suggest to set the old network.http.sendRefererHeader to 2 (default, always send referrer).

See https://bugzilla.mozilla.org/show_bug.cgi?id=822869


Une petite aide ne sera pas de trop parce-que Smart Referer n'a pas l'air de fonctionner.

Dernière modification par Invité-5 (14-06-2014 21:43:34)

#6 14-06-2014 15:25:29

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : network.http.sendRefererHeader;2

Perso j'utilise RefControl

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 14-06-2014 17:12:20

Invité-5
Banni(e)

Re : network.http.sendRefererHeader;2

Source => http://hal-9000.fr/article45/vie-privee … tp-referer

citation a écrit :

HTTP Referer : suppression, sauf…

Pour rappel, le HTTP Referer désigne une information transmise au serveur concernant l'origine du visiteur (c'est-à-dire l'URL de la page depuis laquelle le visiteur est venu). Par exemple, si vous avez cliqué sur le lien debian-facile.org, sans réglage particulier de votre part, le serveur de Debian Facile est « averti » que vous venez de Hal-9000 (et même, plus particulièrement, de cette page précise, là, que vous avez sous les yeux).

J'ai, durant plusieurs mois, opté pour une solution radicale : demander à Firefox de ne jamais transmettre cette information. Pour ce faire, il faut se rendre sur about:config (en tapant cette adresse dans sa barre d'adresse), puis chercher (ou créer ?) la clé Network.http.sendRefererHeader et lui assigner la valeur 0 (zéro). J'employais également un module, Disable HTTP Referer at Startup, qui s'assurait à chaque démarrage de Firefox que cette clé était bien à 0.

Problème : certains sites, pour des raisons légitimes de sécurité, vérifient le referer, et « bloquent » si ce dernier n'est pas renseigné. Concrètement, il m'était impossible de poster sur le forum de Debian Facile (décidément très cité dans ce billet). C'est là qu'intervient le module Smart Referer qui a la gentillesse de n'envoyer le referer que si l'on reste sur le même domaine. Aucune option particulière à administrer, le referer est bien effacé lorsqu'on passe d'un site à l'autre (comme on peut s'en assurer en visitant le site What is my Referer ? dont la capture ci-dessous est issue, site accédé depuis Google).


Ne fonctionne toujours pas. sad

Dernière modification par Invité-5 (14-06-2014 21:42:39)

#8 16-06-2014 11:05:45

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : network.http.sendRefererHeader;2

Je ne sais que te dire. Chez moi ça marche…

As-tu essayé de réactiver le referer dans about:config ?

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

Pied de page des forums