Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-12-2008 01:27:08

gnthibault
Membre
Inscription : 02-12-2008

Configurer vsftpd

Voilà, j'essaye depuis quelques temps d'installer un serveur ftp sur mon pc, mais je n'arrive pas à le configurer, je n'ai même pas d'accès en local, à chaque ofis j'ai l'erreur suivante:  500 OOPS: invalid pasv_address


J'ai trouvé un tuto pas mal:
http://www.andesi.org/admin:vsftpd-un-s … -et-simple
Mais apparament on ne peut utiliser libdb3-util ni db4-4 sous debian lenny (bug) pour configurer des comptes utilisateurs via PAM.

J'aimerai aussi à terme rendre mon ftp accessible depuis le net, auriez vous donc une idée pour le fichier de config, voilà mon vsftpd.conf actuel:



listen=YES

connect_from_port_20=YES
listen_port=21
anonymous_enable=NO
local_enable=YES

write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
guest_enable=NO
guest_username=virtual
ftpd_banner=Bienvenue
chroot_local_user=YES
setproctitle_enable=YES #voir la liste des utilisateurs avec  ps -aef | grep vsftpd
max_clients=10
max_per_ip=4
pasv_promiscuous=NO
pasv_enable=YES
pasv_min_port=40000
pasv_max_port=40100
pasv_address_resolv=YES
pasv_address= mon compte dyndns
port_promiscuous=NO
secure_chroot_dir=/var/run/vsftpd
rsa_cert_file=/etc/ssl/certs/vsftpd.pem






J'ai aussi du mal à comprendre ce que sont le mode standalone et/ou passif et quel est l'utilité des ports aléatoire désigné par pasv.

Hors ligne

#2 03-12-2008 14:12:05

cozo
Membre
Lieu : toulouse
Distrib. : lenny
Noyau : 2.6.25
(G)UI : Gnome
Inscription : 28-07-2008

Re : Configurer vsftpd

ben standalone c'est que le serveur tourne tout le temps , sinon il est gérer par inetd.
Pour du mode passif/actif en gros la com passe sur le port 21 et les donnée sur d'autre port ouvert soit sur le client soit sur le serveur si tu es en actif ou passif je crois.

Hors ligne

#3 03-12-2008 17:00:21

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Configurer vsftpd

500 OOPS: invalid pasv_address


Questions idiotes, mais tu as bien vérifer ceci:
pasv_address= mon compte dyndns

et tu as bien démarré le service ?


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#4 03-12-2008 19:14:02

gnthibault
Membre
Inscription : 02-12-2008

Re : Configurer vsftpd

Oui j'ai bien vérifié ce dernier paramètre et je reload le service à chaque fois, j'ai même éssayé de mettre en adresse celle de mon réseau locale (192.168.0.16), ou même la boucle locale pour voir, et pas moyen de me conecter dessus, j'ai toujours la même erreur ...

Hors ligne

#5 03-12-2008 22:38:58

gnthibault
Membre
Inscription : 02-12-2008

Re : Configurer vsftpd

Je ne comprend vraiment rien du tout, il doit y avoir un problème de socket ou je ne sais quoi....
En désactivant l'option pasv_address j'ai toujours une erreur de passv_address, pourtant je lit dans le man:

pasv_address
    Use this option to override the IP address that vsftpd will advertise in response to the PASV command. Provide a numeric IP address.

    Default: (none - the address is taken from the incoming connected socket)


Quel est donc l'utilité de c emode ? (je n'arrive même pas à me connecter en local)

Hors ligne

#6 03-12-2008 23:22:27

mister-lol
Membre
Distrib. : etch/linuxmint felicia
Noyau : 2.6.24.5/2.6.27.7
(G)UI : gnome
Inscription : 01-12-2008

Re : Configurer vsftpd

salut
Ton iptable est bien configuré ?
Si tu fait un nmap sur ton ip en local il trouve bien le port 21 ouvert en avec le service ftp ?

Hors ligne

#7 03-12-2008 23:53:14

gnthibault
Membre
Inscription : 02-12-2008

Re : Configurer vsftpd

Oui....

PORT     STATE SERVICE
21/tcp   open  ftp

Dernière modification par gnthibault (03-12-2008 23:53:33)

Hors ligne

#8 06-12-2008 18:58:54

gnthibault
Membre
Inscription : 02-12-2008

Re : Configurer vsftpd

Bon finalement j'ai désactivé le mode pasv, et tout marche, mon fichier de conf si jamais sa intéresse quelqun....

anonymous_enable=NO
local_enable=YES
chroot_local_user=YES
max_clients=10
max_per_ip=4
write_enable=NO
local_umask=022
dirmessage_enable=YES
vsftpd_log_file=/var/log/vsftpd.log
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
dual_log_enable=YES
ftpd_banner= Big Brother is watching you.
pam_service_name=vsftpd
userlist_enable=NO
listen=YES
tcp_wrappers=YES
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
guest_enable=YES
guest_username=ftp
secure_chroot_dir=/var/run/vsftpd
user_config_dir=/etc/vsftpd/vsftpd_user_conf
virtual_use_local_privs=NO

Hors ligne

#9 07-12-2008 19:33:50

KsmoinO
Modérateur
Distrib. : testing/sid
(G)UI : KDE
Inscription : 05-10-2007

Re : Configurer vsftpd

le mode pasv fonctionne bien sous lenny :

pasv_enable=YES
pasv_addr_resolve=YES
pasv_address=mon-adresse.no-ip.org
pasv_max_port=2048
pasv_min_port=1024

as tu bien veillé à pas mettre d'espace dans la ligne pasv_address= ?

Hors ligne

Pied de page des forums