Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-06-2014 03:53:14

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

[Resolu] probleme connexion ssh

Bonjour,

après un reboot de mon serveur (via ssh), ce dernier n'accepte plus mes connexion ssh. mais il les refuse pas vraiment non plus. Il ferme la connexion avant le login en fait.:
que je cherche à me connecter avec un user:

~$ ssh  toto@192.168.1.69
Connection closed by 192.168.1.69



ou en root:


~$ ssh  root@192.168.1.69
Connection closed by 192.168.1.69



comprend pas hmm

Dernière modification par bundy (27-06-2014 17:04:50)

Hors ligne

#2 23-06-2014 15:13:41

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Resolu] probleme connexion ssh

Salut,
Tu as configuré un pare-feu super efficace ? big_smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 23-06-2014 16:48:29

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Resolu] probleme connexion ssh

Ça tient de l'abri anti-atomique.  mad

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 23-06-2014 17:15:25

tatave
Membre
Lieu : France-Belgique
Distrib. : Debian 8.4x / Pfsense 2.3.x / esxi 5.5 / nas4free
Inscription : 23-06-2014
Site Web

Re : [Resolu] probleme connexion ssh

Salut salut

Cela sent le ttl sur la connexion ssh qui doit être trop courte ce qui est facilement gérable quand on a le serveur sous le coude mais plus coton quand on est à distance.
sinon un soucis sur le chemin de connexion de la carte réseau du serveur jusqu'au client ;
- La carte réseau serveur.
- Le câblage fatigué ou coupé.
- 1 Switch avec une prise qui vous lache si c'est pas le switch lui même.
- La carte réseau du client

Autre solution le client a une ip volé par un autre et ducoup le serveur drop les log sur cette ip la.

Beaucoup de possibilité en vue,

Éliminons étape par étape. en commençons par le matériel et finissons par le soft. en passant par le paramètre sur le réseau.

Bon courage.

Cordialement.

1 Cluster Pare-feu sous Pfsense 2.3.x (2wan,1wifi,1dmz,1lan)
1 Cluster Data center maison sous nas4free 10.3.x
2 Cluster Labo de Virtualisation 1 sous esxi et 1 sous hyper-v
----- vm prod debian, windows serveur 2012/2016, freebsd

En ligne

#5 23-06-2014 19:54:22

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

Salut tous,

captnfab a écrit :

Salut,
Tu as configuré un pare-feu super efficace ? big_smile


bah non, j'ia jamais eu ce probleme de connexion , c'est arrivé après un reboort du serveur. j'ai rien touché en plus

tatave a écrit :

Cela sent le ttl sur la connexion ssh qui doit être trop courte ce qui est facilement gérable quand on a le serveur sous le coude mais plus coton quand on est à distance.



Bon je vien de ressortir un ecran et un clavier pour le serveur, tu sais où est-ce qu'est logé le paramettre de configuration du temps de connexion ssh?

Hors ligne

#6 23-06-2014 19:57:18

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Resolu] probleme connexion ssh

NB : Un reboot, ça peut aussi réactiver des scripts d'init qui dormaient et avaient été désactivés à la main.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 24-06-2014 13:47:56

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

J'ai récement fait une mise à jour coté client. j me suis donc dit qu'il falait ptet fair une mise a jour coté serveur. ptet que ssh merdait à cause de ça.
mais quand j'ai voulu fair la mise à jour il me retorque ceci:


# aptitude update
0% [En cours] the methode hhtp has die unexpectedly!
E: le sous processus http a commis une violation d'accès mémoire



ça à surement un rapport avec mon probleme ssh non?
Ha et le pire, cette nuit il m'à fait un kernel panic.
Je précise que c'est un antique hp céleron qui a une quinzaine d'années:
Ça sent pas bon sad

Hors ligne

#8 24-06-2014 14:50:37

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Resolu] probleme connexion ssh

Ahem, ouais, dur…
Je ne sais pas si les problèmes sont liés.
« apt-get update » donne la même chose qu'aptitude ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 24-06-2014 14:59:54

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

oui, il y a autre chose aussi. maintenant quand je réessaye ssh . ça me met le meme message qu'avant mais il ne cherche plus, la connexion est fermée instantanement. On dirait que le serveur n'est meme plus interogé. je lance la commande dans le terminal, la reponse est instantanée.

Dernière modification par bundy (24-06-2014 15:03:51)

Hors ligne

#10 24-06-2014 17:47:56

tatave
Membre
Lieu : France-Belgique
Distrib. : Debian 8.4x / Pfsense 2.3.x / esxi 5.5 / nas4free
Inscription : 23-06-2014
Site Web

Re : [Resolu] probleme connexion ssh

salut salut

Petites question depuis une autre machine cela vous faite la même chose ? ou pas ?

Cordialement.

1 Cluster Pare-feu sous Pfsense 2.3.x (2wan,1wifi,1dmz,1lan)
1 Cluster Data center maison sous nas4free 10.3.x
2 Cluster Labo de Virtualisation 1 sous esxi et 1 sous hyper-v
----- vm prod debian, windows serveur 2012/2016, freebsd

En ligne

#11 24-06-2014 18:50:05

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

bonne question, je teste demain

Hors ligne

#12 25-06-2014 03:21:38

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

Oui meme avec un autre client cela me fait la même chose

Hors ligne

#13 25-06-2014 09:14:26

tatave
Membre
Lieu : France-Belgique
Distrib. : Debian 8.4x / Pfsense 2.3.x / esxi 5.5 / nas4free
Inscription : 23-06-2014
Site Web

Re : [Resolu] probleme connexion ssh

Salut salut

Heu autre question le client ssh est le même que sur le premier pc ?
Si oui cela ne permet pas de valider le soucis sur le serveur lui même.
L'idéal serait qu'il soit d'une version différente bien évidemment.

Cordialement.

1 Cluster Pare-feu sous Pfsense 2.3.x (2wan,1wifi,1dmz,1lan)
1 Cluster Data center maison sous nas4free 10.3.x
2 Cluster Labo de Virtualisation 1 sous esxi et 1 sous hyper-v
----- vm prod debian, windows serveur 2012/2016, freebsd

En ligne

#14 25-06-2014 10:48:22

tatave
Membre
Lieu : France-Belgique
Distrib. : Debian 8.4x / Pfsense 2.3.x / esxi 5.5 / nas4free
Inscription : 23-06-2014
Site Web

Re : [Resolu] probleme connexion ssh

Re salut salut

Je te donne deux fichier conf de ssh par défaut, ils sont dans /etc/ssh/ comme suit :

pour le ssh_config

# This is the ssh client system-wide configuration file.  See
# ssh_config(5) for more information.  This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
#  1. command line options
#  2. user-specific file
#  3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for some commonly used options.  For a comprehensive
# list of available options, their meanings and defaults, please see the
# ssh_config(5) man page.

Host *
#   ForwardAgent no
#   ForwardX11 no
#   ForwardX11Trusted yes
#   RhostsRSAAuthentication no
#   RSAAuthentication yes
#   PasswordAuthentication yes
#   HostbasedAuthentication no
#   GSSAPIAuthentication no
#   GSSAPIDelegateCredentials no
#   GSSAPIKeyExchange no
#   GSSAPITrustDNS no
#   BatchMode no
#   CheckHostIP yes
#   AddressFamily any
#   ConnectTimeout 0
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/identity
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   Port 22
#   Protocol 2,1
#   Cipher 3des
#   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
#   MACs hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160
#   EscapeChar ~
#   Tunnel no
#   TunnelDevice any:any
#   PermitLocalCommand no
#   VisualHostKey no
#   ProxyCommand ssh -q -W %h:%p gateway.example.com
    SendEnv LANG LC_*
    HashKnownHosts yes
    GSSAPIAuthentication yes
    GSSAPIDelegateCredentials no



pour le sshd_config

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile    %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes



regarde si il y des différences avec ta machine, pour info je suis sur une deb 7.5


1 Cluster Pare-feu sous Pfsense 2.3.x (2wan,1wifi,1dmz,1lan)
1 Cluster Data center maison sous nas4free 10.3.x
2 Cluster Labo de Virtualisation 1 sous esxi et 1 sous hyper-v
----- vm prod debian, windows serveur 2012/2016, freebsd

En ligne

#15 25-06-2014 17:36:59

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

bonjour,
je pense que l'on est dans la mauvaise direction avec ces histoires de conf ssh. je vien de m'appercevoire que le smtp, l'imap, ne fonctione plus; Le xmpp ne fonctionne plus qu'en local.!!!!!!!!!!!!!!!!!
Jamais eu ce genre de probleme avec mon ancien routeur. Je vien de passer chez OVH et j'utilise donc leur routeur. C'est depuis que j'ai fais ça que les merdes ont commencé. Je suis sûr que leur boxe pourie à du mal avec mon serveur qui impose son IP en static.
Le probleme est que mon ancien routeur ne dispose pas de port  le telephone en voip.

Hors ligne

#16 26-06-2014 00:18:34

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

Je viens de voir dans les kernel.log qu'en fait j'ai systematiquement un segfaut de lbresolv.2-13 à chaque fois que  le serveur utilise smtp, http et sshd .
Une barette memoire qui a fait son temps?  ou le proce ?

Hors ligne

#17 26-06-2014 01:00:31

tatave
Membre
Lieu : France-Belgique
Distrib. : Debian 8.4x / Pfsense 2.3.x / esxi 5.5 / nas4free
Inscription : 23-06-2014
Site Web

Re : [Resolu] probleme connexion ssh

Salut salut

Etrange de la part d'Ovh, ils sont plutot réacif et même proactif de ce coté là, si la machine est chez eux dans leur ferme, après ne connaissant pas ton archi réseau chez eux, dédié, cloude ou mutualiser.

j'ai eu un soucis hier avec un site web mutualisé ils sont intervenus assez rapidement sur la machine.

Cordialement.

1 Cluster Pare-feu sous Pfsense 2.3.x (2wan,1wifi,1dmz,1lan)
1 Cluster Data center maison sous nas4free 10.3.x
2 Cluster Labo de Virtualisation 1 sous esxi et 1 sous hyper-v
----- vm prod debian, windows serveur 2012/2016, freebsd

En ligne

#18 26-06-2014 14:36:25

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

Salut,
Ha non non on s'est mal compris, OVH est depuis peu mon FAI, et je me posais des questions sur le fait que ce soit leur box qui m'empêche d'atteindre mon serveur via ssh en local, chez moi. Le serveur est chez moi, pas chez OVH.

Hors ligne

#19 26-06-2014 18:25:35

tatave
Membre
Lieu : France-Belgique
Distrib. : Debian 8.4x / Pfsense 2.3.x / esxi 5.5 / nas4free
Inscription : 23-06-2014
Site Web

Re : [Resolu] probleme connexion ssh

Salut salut

Ha bien la c'est plus claire.
3 test à faire
- 1 - teste un log depuis chez vous sur votre machine
- 2 - du lieu de travail vers machine distante chez vous.
- 3 - du lieu site Y vers machine distante chez vous.

Si sur le test 1 ca passe pas, c'est soit la machine soit sur les liaisons que cela coince.
Si l'un des deux test 2/3 arrivent à ce loguer c'est que le soucis ne vient pas de la box chez vous, mais de la connexion du site appelant.
Si dans les deux test 2/3 cas vous n'avez pas de log sur la machine distante, c'est que le soucis pourrait bien venir de la box chez vous (matériel, config, ou plus haut cher votre fai)

c'est une façon de faire que j'applique pour vérifier si j'arrive a joindre des machines distantes, si cela peut vous aider.

Cordialement.

1 Cluster Pare-feu sous Pfsense 2.3.x (2wan,1wifi,1dmz,1lan)
1 Cluster Data center maison sous nas4free 10.3.x
2 Cluster Labo de Virtualisation 1 sous esxi et 1 sous hyper-v
----- vm prod debian, windows serveur 2012/2016, freebsd

En ligne

#20 27-06-2014 17:04:23

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : [Resolu] probleme connexion ssh

Bonjour,
en fait libresolv faisait un segfault à chaque fois que j'utilisais sshd, smtp, xmpp ou http. libresolv depend  du paquet libc6. J'ai réinstallé ce dernier et tout est rentré dans l'ordre. smile
Par contre je ne sais pas ce qui à corrompus libresolv.

merci à vous, big up à captnfab wink

Dernière modification par bundy (27-06-2014 17:05:46)

Hors ligne

#21 27-06-2014 17:08:59

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Resolu] probleme connexion ssh

\o/

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums