Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-07-2014 11:35:19

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

[resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

comment lui dire que yasm-1.2.0 est bien là ?
Bonjour,
pour installer HandBrake-0.9.9 sur Debian-7.5.0, j'ai essayé de compiler.
plein d'erreurs qui seraient liées à gtk.

je suis donc ça :
http://forums.debian.net/viewtopic.php? … 5&start=15

au moment du 'debuild' :


jlg@UL30A:~/handbrake-0.9.9$ debuild binary
dpkg-checkbuilddeps : dépendances de construction non trouvées : yasm (>= 1.1.0)
debuild: fatal error at line 1321:
You do not appear to have all build dependencies properly met.
You can use mk-build-deps to generate a dummy package which
Depends on all the required packages, or you can install them
manually using dpkg or apt using the error messages just above
this message.
jlg@UL30A:~/handbrake-0.9.9$ sudo mk-build-deps
mk-build-deps: Unable to find package name in control file `debian/control'
jlg@UL30A:~/handbrake-0.9.9$ sudo apt-get install yasm
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  yasm
0 mis à jour, 1 nouvellement installés, 0 à enlever et 2 non mis à jour.
Il est nécessaire de prendre 0 o/631 ko dans les archives.
Après cette opération, 1 753 ko d'espace disque supplémentaires seront utilisés.
Sélection du paquet yasm précédemment désélectionné.
(Lecture de la base de données... 171959 fichiers et répertoires déjà installés.)
Dépaquetage de yasm (à partir de .../yasm_1.1.0-1_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de yasm (1.1.0-1) ...



il me faut yasm-1.2.0.
dans les dépôts la version proposée est la 1.1.0.
je l'ai désinstallé et ai compilé la version 1.2.0.

jlg@UL30A:~/handbrake-0.9.9$ yasm --version
yasm 1.2.0
Compiled on Jul  7 2014.
Copyright (c) 2001-2011 Peter Johnson and other Yasm developers.
Run yasm --license for licensing overview and summary.
jlg@UL30A:~/handbrake-0.9.9$



nouvelle tentative de 'debuild' :


jlg@UL30A:~/handbrake-0.9.9$ debuild binary
dpkg-checkbuilddeps : dépendances de construction non trouvées : yasm (>= 1.1.0)
debuild: fatal error at line 1321:
You do not appear to have all build dependencies properly met.
You can use mk-build-deps to generate a dummy package which
Depends on all the required packages, or you can install them
manually using dpkg or apt using the error messages just above
this message.
jlg@UL30A:~/handbrake-0.9.9$



quelle la solution la plus simple pour indiquer au 'système' que yasm-1.2.0 est installée dans le cas présent dans '/home/jlg/yasm-1.2.0' puisque bien sûr cela n'apparaît pas, par exemple, dans les 'archives dpkg' ?

merci d'avance.
cordialement
debianux

Dernière modification par debianux (09-07-2014 16:20:03)

Hors ligne

#2 08-07-2014 11:48:32

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

yasm est là :

jlg@UL30A:/usr/local/bin$ ls
vsyasm  yasm  ytasm
jlg@UL30A:/usr/local/bin$
 

Hors ligne

#3 08-07-2014 12:54:55

Invité-5
Banni(e)

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Pourquoi faire simple, si on peut faire compliqué, n'est pas ? => Package: yasm (1.2.0-1~bpo70+1) dans wheezy-backports !

Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Il faut revoir le wiki => https://debian-facile.org/doc:systeme:a … -officiels

#4 08-07-2014 13:17:10

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@darien

merci, j'essaie la compilation avec yasm 1.2.0 des backports wink

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#5 08-07-2014 13:19:53

Invité-5
Banni(e)

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

smile

#6 08-07-2014 13:21:22

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Mais je pense que yasm ne sera pas le seul blocage, je pense aussi a GTK3 .... car Handbrake l'utilise maintenant car j'ai compilé une version (qui est passée allez savoir pourquoi) et maintenant avec les nouvelles sources .... NADA hmm


EDIT:

warning: implicit declaration of function ‘GTK_STACK’
make: *** [gtk.build] Erreur 2


C'est cuit coque smile

Une solution mais que je ne ferais pas :

http://forums.debian.net/viewtopic.php? … 05#p533226

Dernière modification par golgot200 (08-07-2014 13:27:11)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#7 08-07-2014 15:19:46

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@darien

Pourquoi faire simple, si on peut faire compliqué, n'est pas ?


sûrement pas pour le plaisir :-)

=> Package: yasm (1.2.0-1~bpo70+1) dans wheezy-backports !


merci!

Voir le tuto : Trop cool d'indiquer son installation dans son profil !


fait

Il faut revoir le wiki => https://debian-facile.org/doc:syst … -officiels


ok

@golgot200
http://forums.debian.net/viewtopic.php? … 05#p533226
oui, c'est celle citée dans le premier message et que j'essaye de suivre...

Une solution mais que je ne ferais pas


parce que ?...

finalement conseilles-tu de renoncer à installer HandBrake dans l'état actuel des choses ? :-)

Hors ligne

#8 08-07-2014 15:27:04

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

la question initiale reste :

comment lui dire que yasm-1.2.0 est bien là ?



cela se serait-il 'mal passé' au niveau d'un 'PATH quelconque mal ou non indiqué ?
rattrapable ?

Hors ligne

#9 08-07-2014 15:56:50

Invité-5
Banni(e)

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Tu peux vérifier en premier, s'il s'est bien installé :

apt-cache policy yasm

#10 08-07-2014 16:14:00

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

jlg@UL30A:~$ apt-cache policy yasm
yasm:
  Installé : (aucun)
  Candidat : 1.1.0-1
 Table de version :
     1.1.0-1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
jlg@UL30A:~$
 


mais :

jlg@UL30A:~$ yasm --version
yasm 1.2.0
Compiled on Jul  7 2014.
Copyright (c) 2001-2011 Peter Johnson and other Yasm developers.
Run yasm --license for licensing overview and summary.
jlg@UL30A:~$
 


et :

jlg@UL30A:~$ cd /usr/local/bin
jlg@UL30A:/usr/local/bin$ ls
vsyasm  yasm  ytasm
 


donc y serait là mais non installé ?

Hors ligne

#11 08-07-2014 16:20:31

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Salut,
Il ne faut pas installer les logiciels sans passer par le gestionnaire de paquet.
1) ils ne sont pas reconnus comme installés
2) ils sont installés n'importe où
3) ils ne sont pas désinstallables proprement

Ensuite, pour installer le paquet des backports, il te faut le dépôt des backports dans ton sources.list smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#12 08-07-2014 17:41:46

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

ok
je viens de modifier le sources.list.d comme indiqué dans le wiki smile

Hors ligne

#13 08-07-2014 18:13:33

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

mais je n'arrive pas à désinstaller :

jlg@UL30A:~$ cd /home/jlg/yasm-1.2.0
jlg@UL30A:~/yasm-1.2.0$ make uninstall
make: *** Pas de règle pour fabriquer la cible « uninstall ». Arrêt.
 


pas de bol sad

Si vous avez le message suivant c'est que les sources du programme ne prennent pas en charge la cible uninstall. (voir la F.A.Q. officiele de CMake).

make: *** Pas de règle pour fabriquer la cible « uninstall ». Arrêt.

Il faudra alors supprimer les fichiers manuellement avec l'aide du log d'installation install_manifest.txt créé dans le répertoire de la source du programme.

Hors ligne

#14 08-07-2014 18:16:58

Invité-5
Banni(e)

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

#15 08-07-2014 18:17:43

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

sauf que croyant bien faire j'ai fait un make clean et le 'manifest' ne se manifeste plus.
je recompile.

Hors ligne

#16 08-07-2014 18:24:16

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

bon j'ai supprimé les trois fichiers du /usr/local/bin

test -z "/usr/local/bin" || /bin/mkdir -p "/usr/local/bin"
  /usr/bin/install -c yasm ytasm vsyasm '/usr/local/bin'
/usr/bin/install: impossible de supprimer « /usr/local/bin/yasm »: Permission non accordée
/usr/bin/install: impossible de supprimer « /usr/local/bin/ytasm »: Permission non accordée
/usr/bin/install: impossible de supprimer « /usr/local/bin/vsyasm »: Permission non accordée
make[3]: *** [install-binPROGRAMS] Erreur 1
make[3]: quittant le répertoire « /home/jlg/yasm-1.2.0 »
make[2]: *** [install-am] Erreur 2
make[2]: quittant le répertoire « /home/jlg/yasm-1.2.0 »
make[1]: *** [install-recursive] Erreur 1
make[1]: quittant le répertoire « /home/jlg/yasm-1.2.0 »
make: *** [install] Erreur 2
jlg@UL30A:~/yasm-1.2.0$ sudo -i
[sudo] password for jlg:
root@UL30A:~# cd /usr/local
root@UL30A:/usr/local# cd bin
root@UL30A:/usr/local/bin# ls
vsyasm  yasm  ytasm
root@UL30A:/usr/local/bin# rm vsyasm yasm ytasm
root@UL30A:/usr/local/bin# ls
root@UL30A:/usr/local/bin#
 



peut-il y avoir autre chose à supprimer ?

Hors ligne

#17 08-07-2014 18:29:06

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@darien
malheureusement, comme ça n'a pas été installé ni avec apt, ni dpkg, il n'y a pas de paquet correspondant. (cf post #10)

Hors ligne

#18 08-07-2014 18:41:52

Invité-5
Banni(e)

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

As tu lus et appliqué tout ça en 1 minute. http://raphaelhertzog.fr/2011/09/14/gar … -a-debian/ Si oui, dis nous comment  ?

#19 08-07-2014 18:56:38

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

C'est bizarre, la version sur le site Handbrake et sur une Debian Wheezy stable se compile bien avec la version Yasm 1.1.0-1  hmm


patrick@debian:~$ apt-cache policy yasm
yasm:
  Installé : 1.1.0-1
  Candidat : 1.1.0-1
 Table de version :
 *** 1.1.0-1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status
patrick@debian:~$

 





-------------------------------------------------------------------------------
time end: Tue Jul  8 18:52:59 2014
duration: 11 minutes, 36 seconds (696.42s)
result: SUCCESS
-------------------------------------------------------------------------------
Build is finished!
You may now cd into ./build and examine the output.
patrick@debian:~/Téléchargements/HandBrake-0.9.9$
 



Handbrake.png


J'y comprend plus rien  smile
Et en plus l'interface est en GTK3

EDIT: C'est les SVN qui ne passent pas

Dernière modification par golgot200 (08-07-2014 19:08:35)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#20 08-07-2014 19:10:27

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@darien

jlg@UL30A:~$ aptitude search '~S ~i !~ODebian !~o'
jlg@UL30A:~$ aptitude search '?narrow(?installed, !?origin(Debian))!?obsolete'
jlg@UL30A:~$                                                              
 

Hors ligne

#21 08-07-2014 19:24:06

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

le sources.list.d a donc été modifié pour avoir le 'backport' :

jlg@UL30A:~$ sudo -i
root@UL30A:~# cd /etc/apt/sources.list.d
root@UL30A:/etc/apt/sources.list.d# ls
00debian-officiel.list   10debian-security.list
00debian-officiel.list~  10debian-security.list~
root@UL30A:/etc/apt/sources.list.d# cat 00debian-officiel.list

#deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140426-13:35]/ wheezy contrib main

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main contrib

# wheezy proposed updates
deb http://ftp.fr.debian.org/debian/ wheezy-proposed-updates main

# wheezy-backports
deb http://ftp.fr.debian.org/debian wheezy-backports main
root@UL30A:/etc/apt/sources.list.d#

 


ici j'ai le nom précis :
https://packages.debian.org/wheezy-back … m/download
là, le mode d'emploi :
https://debian-facile.org/doc:systeme:a … ions_types
j'essaye :

jlg@UL30A:~$ sudo apt-get -t wheezy-backports install yasm_1.2.0-1~bpo70+1_amd64.deb
[sudo] password for jlg:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet yasm_1.2.0-1~bpo70+1_amd64.deb
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « yasm_1.2.0-1~bpo70+1_amd64.deb »
 


?

Hors ligne

#22 08-07-2014 20:32:38

Invité-5
Banni(e)

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Vois le poste#19 avant tout. big_smile

sudo apt-get -t wheezy-backports install yasm

suffit. smile

Dernière modification par Invité-5 (08-07-2014 20:55:02)

#23 08-07-2014 21:09:03

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Et bien, après vérification de la "même" archive 0.9.9 téléchargée sur le site officiel mais à deux dates différentes dans le temps  =  une compilation avec une interface GTK2 et une autre avec GTK3 smile


EDIT:

la SVN avec un:


./configure --launch --disable-gtk
 



Ça passe. Donc pour moi sur Wheezy c'est au niveau des libs Gtk3 que ça coince. C'est trop OLD  big_smile



-------------------------------------------------------------------------------
time end: Tue Jul  8 21:52:52 2014
duration: 11 minutes, 29 seconds (689.72s)
result: SUCCESS
-------------------------------------------------------------------------------
Build is finished!
You may now cd into ./build and examine the output.
patrick@debian:~/hb-trunk$
 



Trouver un moyen de compiler les sources en activant GTK2 serait bien au lieu de GTK3 maintenant par défaut.
Pas besoin de se focaliser sur Yasm en 1.2 je pense. puisque ça passe bien sans majoration.

Dernière modification par golgot200 (08-07-2014 22:00:46)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#24 08-07-2014 23:01:36

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@darien

Vois le poste#19 avant tout. big_smile


je le regarde à nouveau et ne vois pas :

sudo apt-get -t wheezy-backports install yasm


mais j'avoue être fatigué...
en fait j'ai essayé de suivre les recommandations du post #3.

Hors ligne

#25 08-07-2014 23:05:35

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@golgot200
peut-être que c'est en partie ce qui est indiqué ici :
http://forums.debian.net/viewtopic.php? … 05#p533226

Re: Help building Handbrake from source

Postby stevepusser » 2014-03-11 02:42
It's included in devscripts. You also need dpkg-dev, but I think that gets pulled in automatically. The PPA package has a bug in that it leaves out both libgtk2.0-dev and libgtk-3-dev (>= 3.10) as build-depends, which is why I have you install it manually.

stevepusser
     
    Posts: 3626
    Joined: 2009-10-06 05:53

Hors ligne

Pied de page des forums