Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 08-07-2014 23:05:53

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@debianux

Au post 19

Dépots stable juste avec le Yasm 1.1.0-1 et le tarz 0.9.9 du site officiel.
Tu n'auras aucun problème de compilation + un checkinstall et tu te retrouveras avec ton paquet deb tout fait wink
Ne prend pas la subversion

EDIT: c'est tout à fait ça.

Dernière modification par golgot200 (08-07-2014 23:07:28)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#27 09-07-2014 12:09:39

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

ok, merci, je vais essayer :-)

Hors ligne

#28 09-07-2014 12:59:30

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

ça semble parfait smile

jlg@UL30A:~/HandBrake-0.9.9/build$ ls
build_20140709-1_amd64.deb  description-pak  gtk           libhb  project
contrib                     GNUmakefile      HandBrakeCLI  log    test
 



me reste une question : comment lance-t-on l'interface graphique ? smile

Hors ligne

#29 09-07-2014 13:57:42

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Tu as bien fait un :


./configure --launch
 



et non un ./configure --launch --disable-gtk


make
 




checkinstall
 



tu dois avoir le lanceur dans Multimédia ....

EDIT:


dpkg -i build_20140709-1_amd64.deb
 



Ton checkinstall, tu l'a fais en user ou en root ?
si c'est en user, ton deb est généré mais pas installé smile

Dernière modification par golgot200 (09-07-2014 14:05:58)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#30 09-07-2014 14:51:17

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

aïe, j'ai fait un './configure' seul
le checkinstall en root (pas tout faux :-))

faut-il recommencer ou y-aurait-il une astuce pour récupérer la "bourde" ? smile

Hors ligne

#31 09-07-2014 14:58:39

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Plop,
Au passage, je suppose qu'il faut donner au configure l'option --prefix=/usr pour qu'il n'installe pas dans /usr/local.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#32 09-07-2014 15:18:39

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

@golgot200

`--launch'
     All-in-one option which launches the build and logs output
     automatically.  Useful for novices and quick-start procedures.


je ne saisis pas le rapport avec le lanceur graphique

@captnfab
l'installation dans '/usr/local' présenterait quel(s) inconvénient(s) ?

Hors ligne

#33 09-07-2014 15:44:02

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

Ben, si le programme n'est pas prévu pour, il peut aller chercher dans /usr/local des fichiers qui sont dans /usr. De plus, je ne suis pas sûr que /usr/local/bin soit dans le PATH par défaut.

Installer dans /usr/local ou dans /opt me semble dans l'absolu plus propre pour les paquets faits à la main, non-officiels. Ça évite de faire des conflits avec le reste. Mais encore faut-il que le programme le permette.

Le Makefile me donne un mauvais a priori sur la robustesse du programme ^^"

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#34 09-07-2014 16:18:07

debianux
Membre
Distrib. : debian-jessie-8.6_LVM-chiffré_dual-boot-uefi-w10
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 19-05-2014

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

bon, infiniment désolé pour le dérangement : concentré sur le yasm je n'ai pas pensé à rechercher à propos de handbrake neutral

https://debian-facile.org/accueil?do=se … =handbrake

et merci pour tout smile

Hors ligne

#35 09-07-2014 16:20:51

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu] yasm-1.2.0 pour HandBrake: inutile au 09/07/14

smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums