Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-07-2014 23:46:30

jsaray
Membre
Inscription : 13-07-2014

[Résolu] la touche altgr ne marche pas

Bonjour,

Je viens d'installer Debian wheezy 7.0.5 / slim / xfce4, j'ai reussi la configuration de mon clavier sauf pour la touche alt-gr: j'essaie d'obtenir differents caracteres (tilde, arrobas etc) mais ca donne rien et en plus l'ordinateur fait un bruit assez dérangeant a chaque fois.
J'ai parcouru pas mal de forums déja, j'ai essaié nombreux solutions comme ajouter :

Keycode 108 = Multi_Key

a mon .Xmodmap et puis rajouter la commande :

xmodmap $HOME/.Xmodmap

a mon .xinitrc

Voici la configuration utilisé :

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="inspiron"
XKBLAYOUT="latam"
XKBVARIANT=""
XKBOPTIONS="lv3:ralt,compose:rctrl"

BACKSPACE="guess"

C'est la configuration du dernier essaie, mais j'ai essaié aussi beaucoup de combinations pour ce dernier fichier

Quelqun peut m'aider ?.

Merci,

Dernière modification par jsaray (03-08-2014 13:46:14)

Hors ligne

#2 14-07-2014 08:40:43

Invité-5
Banni(e)

Re : [Résolu] la touche altgr ne marche pas

#3 14-07-2014 10:25:05

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] la touche altgr ne marche pas


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 02-08-2014 17:46:25

jsaray
Membre
Inscription : 13-07-2014

Re : [Résolu] la touche altgr ne marche pas

Bonjour et merci de vos réponses.
J'ai essaié tout vos liens sans succes. :s .

Hors ligne

#5 02-08-2014 19:01:18

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Résolu] la touche altgr ne marche pas

salut,
tu as une réponse avec xev?
Chez moi, j'ai le retour suivant :

KeyPress event, serial 46, synthetic NO, window 0x2200001,
    root 0xb2, subw 0x0, time 26896526, (-687,751), root:(555,891),
    state 0x10, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False



Bon courage smile


<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#6 02-08-2014 20:12:49

jsaray
Membre
Inscription : 13-07-2014

Re : [Résolu] la touche altgr ne marche pas

Salut tout le monde !
Merci Laetitia pour ta proposition, je ne pensais trouver des gens si actives dans ce forum smile.

Après galerer plus d'une demi journée finalement j'ai trouvé la solution :

http://cosmolinux.no-ip.org/raconetlinu … heezy.html
(regarder numéro 5 : Keyboard issues writing foreign languages)

En gros il faut aller à Paramètres > Sessions et demarrage.
Puis clic dans Démarrage Automatique.
Clic Ajouter.
Mettre n'importe quel nombre et description.
Ajouter "setxkbmap -option compose:lwin" à la commande.

Je ne sais pas comment expliquer le fait que Altgr marche si lwin veut dire à mon avis "Left Windows" mais bon ca marche ! smile .

Merci de vos suggestions.

José.

Hors ligne

#7 02-08-2014 21:57:35

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Résolu] la touche altgr ne marche pas

super \o/ et merci pour le retour.
Dis voir, tu pourrais mettre le retour de la commande suivante, s'te plaît

setxkbmap -print


Tu as un clavier "exotique" ou un clavier tout ce qu'il y a de classique?

Peux-tu marquer ton sujet comme résolu Hé hé, c'est pour qui le point choco. Miam miam.


<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#8 03-08-2014 13:44:52

jsaray
Membre
Inscription : 13-07-2014

Re : [Résolu] la touche altgr ne marche pas

Salut !,

Oui, j'ai un clavier espagnol. Voici la sortie de la commande setxkbmap -print :

xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)"    };
    xkb_types     { include "complete"    };
    xkb_compat    { include "complete"    };
    xkb_symbols   { include "pc+latam(deadtilde)+inet(evdev)+compose(lwin)"};
    xkb_geometry  { include "pc(pc105)"    };
};

J'ai fait clic sur ton lien pour le marquer Resolu, ainsi que j'ai mis [Résolu] à gauche de mon premier post.
Est-ce que ca suffit?, je ne suis pas très habitué au forums.

José

Dernière modification par jsaray (03-08-2014 13:48:39)

Hors ligne

#9 03-08-2014 14:43:30

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Résolu] la touche altgr ne marche pas

Encore merci pour le retour, ça pourra en aider d'autre. smile
Parfait le résolu, c'est bien comme ça qu'il faut faire.

@ bientôt wink

<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

Pied de page des forums