Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-07-2014 10:51:55

minoltafan
Membre
Distrib. : Debian 8.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon 2.2.16
Inscription : 24-01-2014

[Résolu] problème partitions au démarrage

Bonjour tout le monde,
alors ça va vraiment vous sembler bizarre mais j'ai debian installé sur mon pc sur un disque dur. et j'ai deux autres disques durs (un avec windows 7 ) et l'autre (disque stockage) qui est juste partitionné en ntfs pour pouvoir accueilliir mes photos/vidéos.
ce qui se passe c'est qu'à chaque démarrage de debian le nom des partitions changent.
parfois le disque windows est sdb ou sdc ou sda  sad
du coup parfois je peux lire mes fichiers parfois non!
quelqu'un a t'il déjà eu ce problème? =/

voulez vous mon fstab qui est franchement moche!

Dernière modification par minoltafan (21-07-2014 23:43:11)


Steam sur linux! incroyable =p

Hors ligne

#2 17-07-2014 11:02:13

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] problème partitions au démarrage

Bonjour

minoltafan a écrit :

voulez vous mon fstab qui est franchement moche!

Ouiiii, refile le truc moche !  big_smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 17-07-2014 11:21:54

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] problème partitions au démarrage

âmes sensibles s'abstenir alors... wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 18-07-2014 09:24:17

minoltafan
Membre
Distrib. : Debian 8.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon 2.2.16
Inscription : 24-01-2014

Re : [Résolu] problème partitions au démarrage

Bonjour!
Merci pour vos réponse . voici mon fstab (ne vous moquez pas lol ) . J'aurais du faire install "/" + "/home" mais j'ai fait un truc compliqué que je ne comprends meme pas =p


cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/debian-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=d18dbcf1-54d6-4957-9917-1aa84319483e /boot           ext2    defaults        0       2
/dev/mapper/debian-home /home           ext4    defaults        0       2
/dev/mapper/debian-tmp /tmp            ext4    defaults        0       2
/dev/mapper/debian-usr /usr            ext4    defaults        0       2
/dev/mapper/debian-var /var            ext4    defaults        0       2
/dev/mapper/debian-swap_1 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
//freebox-server.local/Disque\040dur /media/freebox cifs _netdev,guest,directio,uid=1000,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
/dev/sdc1       /media/win1       ntfs-3g rw,user,auto,gid=100,uid=1000,nls=utf8,umask=002        0       0
/dev/sdc2       /media/win2       ntfs-3g rw,user,auto,gid=100,uid=1000,nls=utf8,umask=002        0       0
/dev/sdc3       /media/win3       ntfs-3g rw,user,auto,gid=100,uid=1000,nls=utf8,umask=002        0       0
/dev/sdc4       /media/win4       ntfs-3g rw,user,auto,gid=100,uid=1000,nls=utf8,umask=002        0       0
/dev/sda2       /media/BERLIN       ntfs-3g rw,user,auto,gid=100,uid=1000,nls=utf8,umask=002
/dev/sda3       /media/MIGUEL       ntfs-3g rw,user,auto,gid=100,uid=1000,nls=utf8,umask=002
/dev/sda6   /opt   ext4   defaults   1  0


 


faites pas attention aux noms des partitions hein lol


Steam sur linux! incroyable =p

Hors ligne

#5 18-07-2014 10:40:57

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] problème partitions au démarrage

minoltafan a écrit :

faites pas attention aux noms des partitions hein lol

Au contraire, c'est pas le plus moche ? tongue

Je pense que tu aurais intérêt à utiliser les UUID dans ton fstab.
Tu peux les trouver par blkid  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 19-07-2014 01:02:34

minoltafan
Membre
Distrib. : Debian 8.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon 2.2.16
Inscription : 24-01-2014

Re : [Résolu] problème partitions au démarrage

merci beaucoup paskal!
je vais regarder ça demain smile smile

Steam sur linux! incroyable =p

Hors ligne

#7 21-07-2014 23:42:07

minoltafan
Membre
Distrib. : Debian 8.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon 2.2.16
Inscription : 24-01-2014

Re : [Résolu] problème partitions au démarrage

Merci beaucoup pour blkid Paskal!!!
ça a marché !! je suis vraiment content big_smile
big_smile

Steam sur linux! incroyable =p

Hors ligne

#8 22-07-2014 08:49:50

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] problème partitions au démarrage

cool

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums