Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-07-2014 11:40:58

stephane-b
Membre
Inscription : 21-07-2014

Driver pour Mobility Radeon X2100

Bonjour,
Je viens d'installer Debian 7.4 sur mon PC portable Fujisu Siemens Amilo pi 2530. Tous est bon, le seul problème c'est le driver de la carte graphique. J'ai installé "firmware-linux-nonfree" et compiler le driver privateur d'AMD/ATI avec la commande :

apt-get install fglrx-modules-dkms fglrx-driver linux-headers-$(uname -r) fglrx-control
nux-headers-$(uname -r) fglrx-control
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Paquets suggérés :
  xvba-va-driver amd-opencl-icd
Paquets recommandés :
  libgl1-fglrx-glx-i386 fglrx-glx-ia32
Les NOUVEAUX paquets suivants seront installés :
  fglrx-control fglrx-driver fglrx-modules-dkms linux-headers-3.2.0-4-amd64
0 mis à jour, 4 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/15,0 Mo dans les archives.
Après cette opération, 45,1 Mo d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
Sélection du paquet fglrx-driver précédemment désélectionné.
(Lecture de la base de données... 145348 fichiers et répertoires déjà installés.)
Dépaquetage de fglrx-driver (à partir de .../fglrx-driver_1%3a12-6+point-3_amd64.deb) ...
Sélection du paquet linux-headers-3.2.0-4-amd64 précédemment désélectionné.
Dépaquetage de linux-headers-3.2.0-4-amd64 (à partir de .../linux-headers-3.2.0-4-amd64_3.2.60-1+deb7u1_amd64.deb) ...
Sélection du paquet fglrx-control précédemment désélectionné.
Dépaquetage de fglrx-control (à partir de .../fglrx-control_1%3a12-6+point-3_amd64.deb) ...
Sélection du paquet fglrx-modules-dkms précédemment désélectionné.
Dépaquetage de fglrx-modules-dkms (à partir de .../fglrx-modules-dkms_1%3a12-6+point-3_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « glx-alternative-fglrx »...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Paramétrage de fglrx-driver (1:12-6+point-3) ...
Paramétrage de linux-headers-3.2.0-4-amd64 (3.2.60-1+deb7u1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.2.0-4-amd64
Paramétrage de fglrx-control (1:12-6+point-3) ...
Paramétrage de fglrx-modules-dkms (1:12-6+point-3) ...
Loading new fglrx-12-6+point DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-4-amd64
Building initial module for 3.2.0-4-amd64
Done.

fglrx:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-amd64/updates/dkms/

depmod.......

DKMS: install completed.




Mais impossible de configurer x.org avec aticonfig :-(

aticonfig: No supported adapters detected



Pour info :

lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI M71 [Mobility Radeon X2100] [1002:7210] (rev ce)
 




Avez vous une solution ?

Dernière modification par stephane-b (21-07-2014 11:42:14)

Hors ligne

#2 21-07-2014 14:26:24

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Driver pour Mobility Radeon X2100

Bonjour,

stephane-b a écrit :

Avez vous une solution ?

Pas mieux que http://www.debian-fr.org/driver-pour-mo … 49109.html  neutral


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 21-07-2014 22:56:20

minoltafan
Membre
Distrib. : Debian 8.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon 2.2.16
Inscription : 24-01-2014

Re : Driver pour Mobility Radeon X2100

Bonjour Stephane-b,
pourquoi ne pas essayer de télécharger le driver du site et lancer les commandes que tu trouveras dans le fichier texte d'installation smile
dis nous si ça nne marche toujours pas!

Steam sur linux! incroyable =p

Hors ligne

#4 08-08-2014 14:45:02

stephane-b
Membre
Inscription : 21-07-2014

Re : Driver pour Mobility Radeon X2100

minoltafan a écrit :

Bonjour Stephane-b,
pourquoi ne pas essayer de télécharger le driver du site et lancer les commandes que tu trouveras dans le fichier texte d'installation smile
dis nous si ça nne marche toujours pas!



Bonjour, je n'est pas réagi plus vite car j'étais en vacance coupé d'internet ^^

Je viens d’essayer mais ça ne fonctionne pas :-/

pojwnc3sqz8lvjdl.png 

Dans /usr/share/ati/fglrx-install.log :

ninstalling any previously installed drivers.

Creating symlink /var/lib/dkms/fglrx/8.961/source ->
                 /usr/src/fglrx-8.961

DKMS: add completed.
[Error] Kernel Module : Failed to build fglrx-8.961 with DKMS
[Error] Kernel Module : Removing fglrx-8.961 from DKMS

------------------------------
Deleting module version: 8.961
completely from the DKMS tree.
------------------------------
Done.
[Reboot] Kernel Module : update-initramfs

 

Hors ligne

#5 09-08-2014 19:49:52

minoltafan
Membre
Distrib. : Debian 8.0
Noyau : Linux 3.16.0-4-amd64
(G)UI : Cinnamon 2.2.16
Inscription : 24-01-2014

Re : Driver pour Mobility Radeon X2100

ah mince alors sad sad

Steam sur linux! incroyable =p

Hors ligne

#6 22-08-2014 10:31:38

beuz666
Membre
Inscription : 16-07-2014

Re : Driver pour Mobility Radeon X2100

bonjour, pour ce type de "chipset graphique" ce n'est plus AMD qui gere l'affichage mais le pilote libre RADEON, je tourne avec ce type de carte (HD4100) et je n'ai aucun problème de 3D.

Hors ligne

Pied de page des forums