Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-07-2014 08:39:50

sechanbask
Membre
Inscription : 14-10-2009

SAMBA : connaître/vérifier la version du protocole SMB utilisé

Bonjour,

J'utilise le service samba

~# apt-cache policy samba
samba:
  Installé : 2:3.6.6-6+deb7u2
 



sur un serveur debian 7;

J'ai des soucis de connexion au démarrage avec des postes sous SEVEN SP1 OEM, je voudrais connaitre la version du protocole que mon serveur utilise afin de savoir si le problème vient d'une version trop vielle de ce service.

Comment faire pour savoir si j'utilise le SMB1, le SMB2, le SMB2.1 ?

Hors ligne

#2 22-07-2014 08:54:00

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : SAMBA : connaître/vérifier la version du protocole SMB utilisé

Bonjour,

Je peux me tromper mais il me semblait que c'était à configurer ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 22-07-2014 09:02:10

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : SAMBA : connaître/vérifier la version du protocole SMB utilisé


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 22-07-2014 11:09:28

sechanbask
Membre
Inscription : 14-10-2009

Re : SAMBA : connaître/vérifier la version du protocole SMB utilisé

Merci pour cet élément de réponse.

Je viens de modifier mon fichier de configuration avec les paramètres de la doc de SAMBA :

[global]
        workgroup = fredbet
        server string =
        #security = SHARE
        security = USER
        obey pam restrictions = Yes
        passdb backend = tdbsam
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        wins support = Yes
        default service = data
        panic action = /usr/share/samba/panic-action %d
        hide files = /lost+found/
        hide unreadable = yes
        server max protocol = SMB2_10
        server min protocol = SMB2_10

[data]
        path = /media/data
        read only = No
        guest ok = No
        force group = sambashare
        inherit permissions = Yes
        hide files = /media/data/lost+found/
        hide unreadable = yes
        veto files = /lost+found/
 



Mais le test n'est pas concluant

# testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Unknown parameter encountered: "server max protocol"
Ignoring unknown parameter "server max protocol"
Unknown parameter encountered: "server min protocol"
Ignoring unknown parameter "server min protocol"
Processing section "[data]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
 



J'ai l’impression que ce paramètre n'est pas adapté à ma version...

Je viens de lire le man de ma version et voici les paramètres à indiquer (expérimentaux) :

        max protocol = SMB2
        min protocol = SMB2
 



Je pense qu'il faudra que je change de version de samba pour supporter seven sp1, à mon ancien travail, je n'avais que XP et seven et je n'avais pas de problème.

Hors ligne

Pied de page des forums