Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-07-2014 23:23:11

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

[ Résolu ] Icône "Mettre en veille" absente du bureau.

Bonjour,
Je suis sous Gnome 3.12.2 et je n'ai rien trouvé dans du côté des extensions pour faire apparaître le bouton "Mettre en veille". Actuellement j'ai les boutons "redémarrer" et "Eteindre".
Donc je mets en veille avec""pm-suspend". Avez- vous trouvé une solution ?
Merci

Dernière modification par avinash (29-07-2014 15:01:33)

Hors ligne

#2 27-07-2014 23:42:12

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Salut,

Tu utilises bien systemd ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 27-07-2014 23:57:46

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Bonsoir,
Apparemment oui:

# apt-get install systemd systemd-sysv
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
systemd est déjà la plus récente version disponible.
systemd passé en « installé manuellement ».
systemd-sysv est déjà la plus récente version disponible.
systemd-sysv passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre#

Hors ligne

#4 28-07-2014 08:24:57

Invité-5
Banni(e)

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Des solutions, il y a toujours une. Ton fichiers /etc/apt/sources.list s'est présente comment ? testing seul ?   

aptitude versions upower

Paquet libupower-glib1 :
i   0.9.23-2+b2                                   testing                   500

Paquet upower :
i A 0.99.0-3                                      testing,unstable         500


aptitude install libupower-glib1

Installera la versions 0.9.23...Puis  http://snapshot.debian.org/archive/debi … _amd64.deb => enregistrer le fichier. Puis

# dpkg -i (le paquet.deb = le fichier enregistré préalablement)

Le paquet upower passera a la version inférieure (holder le paquet => voir le wiki) puisque au prochaine mise à jours il reviendra a la version initiale.

Dernière modification par Invité-5 (28-07-2014 09:40:12)

#5 28-07-2014 09:47:16

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Bonjour Damien,

Je te remercie de ton aide matinale.Je suis en testing seul.
En root le shell me renvoie les infos suivantes:

e# aptitude install libupower-glib1
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.



Le paquet libupower-glib1est donc déjà installé.

Dernière modification par avinash (28-07-2014 09:49:03)

Hors ligne

#6 28-07-2014 09:52:11

Invité-5
Banni(e)

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Il doit être installé déjà => aptitude search upower

#7 28-07-2014 10:48:22

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Donc il est installé:

# aptitude search upower
i A gir1.2-upowerglib-1.0           - GObject introspection data for upower     
p   libupower-glib-dev              - abstraction for power management - develop
i A libupower-glib1                 - couche d'abstraction pour la gestion de l'
i A libupower-glib2                 - couche d'abstraction pour la gestion de l'
i A upower                          - couche d'abstraction pour la gestion de l'
p   upower-doc                      - abstraction for power management - documen
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre#



Tu écris:

Installera la versions 0.9.23...Puis  http://snapshot.debian.org/archive/debi … _amd64.deb => enregistrer le fichier. Puis



Dois-je comprendre que je rajoute cette ligne dans mon sources.list ?

Dernière modification par avinash (28-07-2014 11:13:33)

Hors ligne

#8 28-07-2014 12:35:38

Invité-5
Banni(e)

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

avinash a écrit :

Dois-je comprendre que je rajoute cette ligne dans mon sources.list ?


Tu dois seulement enregistrer le fichier puis installer avec dpkg -i le paquet.deb Il ne faut pas non plus brûler les étapes. 

Courage et à bientôt. smile

#9 28-07-2014 14:16:46

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

avinash a écrit :

Bonjour,Je suis sous Gnome 3.12.2 et je n'ai rien trouvé dans du côté des extensions pour faire apparaître le bouton "Mettre en veille".



Ben si :

https://extensions.gnome.org/extension/ … nd-button/

Mais ce n'est pas moi qu'il faut remercier, c'est misaine.


CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#10 28-07-2014 15:19:17

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

J'ai bien "visité" cette page mais je n'ai rien su faire de concret à partir des informations, pour le moment en tout cas:P

Darien,

Damien a écrit:Tu dois seulement enregistrer le fichier puis installer avec dpkg -i le paquet.deb Il ne faut pas non plus brûler les étapes.



Peux-tu m'indiquer une page du Wiki par rapport à ce que tu me conseilles : "enregistrer" le fichier. Merci . Est-ce "enregistrer le fichier" ou "éditer" ?

Dernière modification par avinash (28-07-2014 17:49:44)

Hors ligne

#11 28-07-2014 18:18:03

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

avinash a écrit :

J'ai bien "visité" cette page mais je n'ai rien su faire de concret à partir des informations, pour le moment en tout cas:P


Ah ?

C'est pas compliqué, tu as en haut en dessous de "Extensions" et à gauche de "Suspend Button" le bouton On/Off qui permet d'installer et d'activer l'extension.

Suffit de le basculer sur On et elle s'installe.

Attention ça ne marche pas avec tous les navigateurs, Chromium par exemple, il faut Firefox ou dérivé libre tel que Iceweasel.

Parce que là vous êtes vraiment en train de chercher midi à quatorze heures, les amis.
Aucun besoin d'installer un paquet ou de modifier son sources.list .

Dernière modification par taureau89_9 (28-07-2014 18:20:16)


CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#12 28-07-2014 18:38:41

Invité-5
Banni(e)

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Salut, taureau89_9 je ne pratique pas de Gnome, je te laisse la parole, donc...

#13 28-07-2014 19:47:22

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

"We cannot detect a running copy of GNOME on this system, so some parts of the interface may be disabled. See our troubleshooting entry for more information."

Voila pourquoi je n'ai rien à gauche de" Suspend button".

Dernière modification par avinash (28-07-2014 19:48:40)

Hors ligne

#14 28-07-2014 20:11:10

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Voici l'écran : (clique pour agrandir)

captur10.png

Le message montre que tu utilises un navigateur qui ne supporte pas l'installation des plugins d'extensions pour Gnome Shell.
C'est ce que je disais plus haut !
Quel navigateur utilises-tu ?

L'extension est installée directement par le navigateur, à condition qu'il soit compatible.
Il faut prendre Firefox ou Iceweasel.

CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#15 28-07-2014 20:22:27

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Bonsoir taureau89_9,
J'ai Iceweasel: (je pensais que Iceweasel était une version ancienne de Firefox ?

~$ iceweasel

(process:6695): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
jean-pierre@jeanpierre-h67a-ud3h-b3:~$



# apt-get install iceweasel
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
iceweasel est déjà la plus récente version disponible.
iceweasel passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
root@jeanpierre-h67a-ud3h-b3:/home/jean-pierre#

Dernière modification par avinash (28-07-2014 20:27:09)

Hors ligne

#16 28-07-2014 20:36:41

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Iceweasel n'est pas une vieille version de Firefox. C'est bien Firefox, l'actuel. Le fait d'être en stable implique d'utiliser iceweasel 24.7, qui est le pendant de Firefox 24.7.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#17 28-07-2014 20:48:50

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Je ne suis pas en stable, mais sous Jessie. Donc il y a peut-être une solution pour avoir un Iceweasel plus "moderne". Est-ce possible d'installer Chromium sans que ça pose des problèmes?

Dernière modification par avinash (28-07-2014 20:49:31)

Hors ligne

#18 28-07-2014 20:57:13

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Sous Jessie, c'est la 30.0, sid la 31.0 et expérimental la 32.0  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#19 28-07-2014 21:04:55

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Comment savoir quelle version de Jessie j'ai ?
Je viens d'intaller Chromium mais ma version de Chromium ne supporte pas  l'installation des plugins d'extensions pour Gnome Shell.

chromium
[7386:7386:0728/205646:ERROR:component_loader.cc(138)] Failed to parse extension manifest.
ATTENTION: default value of option force_s3tc_enable overridden by environment.
l'installation des plugins d'extensions pour Gnome Shell.

Dernière modification par avinash (28-07-2014 21:13:49)

Hors ligne

#20 28-07-2014 21:16:00

michelh79
Membre
Lieu : Bressuire - 79
Distrib. : Debian sid
Noyau : Linux 3.14-amd64
(G)UI : Gnome 3.8.4
Inscription : 23-04-2010

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Je n'ai pas tout suivi , mais en passant , je suis sous Sid , Gnome , Iceweasel 31 et j'ai le même message ... ( We cannot detect a running copy of GNOME on this system ) ....  hmm

Je n'ai jamais été chaste à quoi sert d'être chaste ? Puisque même avec terreur tremblant de précautions nous aimer est tout ce qui nous reste. Zoe Valdès

Hors ligne

#21 28-07-2014 21:42:14

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Ma version actuelle:

~$ cat /etc/debian_version
jessie/sid
jean-pierre@jeanpierre-h67a-ud3h-b3:~$

Dernière modification par avinash (28-07-2014 21:42:49)

Hors ligne

#22 28-07-2014 21:47:43

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Il n'y a pas 36 Jessie, il y en a q'une seule smile Jessie est ta version de Debian, et donc tu utilises iceweasel 30 smile
Il y a sans-doute un module IW/Gnome là pour permettre l'installation des extensions ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#23 28-07-2014 22:15:11

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

On trouve dans Réglages les"Extensions" mais rien concernant la veille et l'hibernation. Donc je fais avec "pm-suspend.

Dernière modification par avinash (28-07-2014 22:15:41)

Hors ligne

#24 28-07-2014 22:53:41

taureau89_9
Adhérent(e)
Lieu : A proximité de LFLA
Distrib. : Debian Testing
Noyau : 4.7.0-1-amd64
(G)UI : Gnome 3.20+1 + gnome-shell 3.22.0-1
Inscription : 16-09-2011

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Je suis en testing, qui est pour l'instant équivalent à Jessie.

Avec Iceweasel 30.

Je pense qu'il faut aller dans Menu (en haut à droite) -> Modules (qui ouvre le gestionnaire de modules) -> Onglet Plugins -> et vérifier que le plugin Gnome Shell Integration est installé.

Si tu veux tu peux faire avec "pm-suspend", mais il n'y a aucune raison que ça ne marche pas chez toi, d'ailleurs on a la même configuration, je suis aussi en amd64.

Pareil pour toi, Michelh79.

Dernière modification par taureau89_9 (28-07-2014 22:55:25)


CM Asus Sabertooth 990FX, Proc FX 8350, 4 x 8Go DDR3 1866Mhz, GTX 750ti 2Go, DD 2 To Sata 3

Hors ligne

#25 29-07-2014 12:44:41

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : [ Résolu ] Icône "Mettre en veille" absente du bureau.

Salut taureau89_9,

Je suis sur Iceweasel mais pas certain que ce soit 30. Comment fais-tu pour savoir si c'est 30 ou autre chose ? A droite j'ai le bouton des paramètres mais pas une ombre de gestionnaire de modules.

Hors ligne

Pied de page des forums