Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-12-2008 15:39:23

amoule
Membre
Lieu : 78
Distrib. : Leeny 5.0.4 (Serveur)
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 07-12-2008
Site Web

Apache - Message d'erreur [Résolu]

bonjour a tous

je suis en train de me casser la tete pour la remontée d'info sur OCS

tous les tutos datent un peu et j'ai essayé de bidouller un peu les fichiers ssl

et j'ai du faire des conneries donc...

je vous post les messages au redémarrage d'apache sous Debian 4 Etch

debian:~# /etc/init.d/apache2 restart
Forcing reload of web server (apache2)...apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Fri Dec 12 14:12:04 2008] [error] VirtualHost *:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Fri Dec 12 14:12:04 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Fri Dec 12 14:12:04 2008] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Dec 12 14:12:04 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Fri Dec 12 14:12:07 2008] [error] VirtualHost *:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Fri Dec 12 14:12:07 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Fri Dec 12 14:12:07 2008] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Dec 12 14:12:07 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
.


si vous aviez l'amabilité de me dire quoi modifier...


fichiers dans /etc/apache2/sites-available/

default

NameVirtualHost *:80
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ /apache2-default/
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>


ocsssl

NameVirtualHost *:443
<VirtualHost *:443>
        ServerAdmin webmaster@localhost
        ServerName debian
SSLEngine On
SSLCertificateFile /etc/apache2/ssl/[b]apache.pem[/b]
ErrorLog /var/log/apache2/errorssl.log
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn
CustomLog /var/log/apache2/ocs443.log combined
ServerSignature Off
        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>


<Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
                # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ /apache2-default/
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                SSLOptions +StdEnvVars
        </Directory>

        ErrorLog /var/log/apache2/error.log
              RedirectMatch ^/$ /apache2-default/
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                SSLOptions +StdEnvVars
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On
   Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>


ssl

NameVirtualHost *
<VirtualHost *>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
                # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ /apache2-default/


                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ /apache2-default/
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn
     # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


Pour ceux qui connaissent ocs, comme je n'ai pas réussit a faire de fichier cacert.pem, j'ai utilisé celui généré et appelé apache.pem

bref, c'est la merde !! ça fait quelque jours que je n'arrive a faire remonté les infos et j'ai beau chercher, je ne comprend pas ce qui merdois

bref SOSsssssssssssssssss

et merci d'avance a ceux qui pourront me dépanner

petite precision, il n'y a qu'un site en soit, pas question de multi hebergement ou autre

le serveur est mis en place pour faire fonctionner OCS et glpi (non installé encore) et un forum phpbb3 (non installé encore)

avant de faire d'autres conneries, je prefere passer par vous ^^

et n'oublions pas : merci d'etre complet dans les reponses niveau manip, juste au cas où, je ne sache pas de quoi vous parliez big_smile:(

Edit :

ports.conf

Listen 80
Listen 443

Dernière modification par amoule (19-12-2008 21:17:46)

Hors ligne

#2 12-12-2008 19:02:37

amoule
Membre
Lieu : 78
Distrib. : Leeny 5.0.4 (Serveur)
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 07-12-2008
Site Web

Re : Apache - Message d'erreur [Résolu]

pour me detendre et me dire que je suis pas un gros nul, j'ai installé GLPI et ça marche impec big_smile:D:D:D:D:D

par contre toujours rien pour mon principal problème

je vois bien d'où peut venir le soucy mais pas comment le résoudre hélas, j'ai pas encore les connaissances pour

/etc/hosts

fichiers hosts

  GNU nano 2.0.2             Fichier : /etc/hosts                              
127.0.0.1 localhost debian
127.0.1.1 debian.cptaforpa.fr debian

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


on a un domaine sous 2003 serveur (cptaforpa donc), mais le debian n'est pas sur le domaine, juste il l'a vu à l'install et j'ai validé, p'tre j'aurais pas du mais je n'avais pas le probleme avant d'avoir touché a tout aujourd'hui ^^

Edit :

dans /etc/apache2/sites-available, j'ai :

default
ocsssl
ssl


je crois que j'ai ajouté ssl parce que dans la doc de ocs il en parlait

en revanche dans /var/www

je n'ai que apache2-default et un lien vers phpmyadmin

Dernière modification par amoule (12-12-2008 19:50:35)

Hors ligne

#3 13-12-2008 23:23:57

KsmoinO
Modérateur
Distrib. : testing/sid
(G)UI : KDE
Inscription : 05-10-2007

Re : Apache - Message d'erreur [Résolu]

a mon avis si tu désactive ton ssl tout cours ça devrai fonctionner
il te faudrai le fusionner avec ton ocsssl.

et ceux qui sont interessants son les sites que tu as dans /etc/apache2/sites-enabled

Hors ligne

#4 15-12-2008 21:37:08

amoule
Membre
Lieu : 78
Distrib. : Leeny 5.0.4 (Serveur)
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 07-12-2008
Site Web

Re : Apache - Message d'erreur [Résolu]

Salut merci pour la réponse

alors a priori, il faut le laisser sous peine de grave problème avec apache2 ^^ enfin a priori, c'est nécessaire pour ocs ;

ceci étant, j'ai résolu en parti le problème car j'ai réussi a générer le fichier cacert.pem comme indiqué par ocs et également réussit a trouver une dépendance perl manquante; comme un gros bourrin, j'ai rien noté ni sites ni manip.. mais ça fonctionne et ocs c'est réinstallé correctement

par contre, je galère toujours avec mon problème de virtualhost et/ou servername

j'ai un début de piste d'un autre fofo

rajouté dans hosts 10.0.0.200 qui est l'adresse du serveur avec un nom à coté, nom qui me pose problème

et pour le servername, je galere tous les tutos que je trouve parle de www.monsite.fr par exemple mais moi, le server n'a pas de nom de domaine "internet", il n'est pas accessible depuis l'extérieur donc je ne sais pas koi mettre, c'est con mais je bloque la dessus, quel nom pour le servername ? celui de la machine (debian), un nom au pif, p'tre ocsinventory-server qui apparait dans les fichiers de config d'OCS

volà, si vous avez des idées, je prend wink

merci d'avance

j'avance mais gentiment

sinon, bonne nouvelle, j'ai réussi a incorporer de manière manuel des PCs dans OCs et GLPI et c'est de la grosse boulette !!!!

j'ai hâte de réussir à le faire de manière automatique, là ça sera l'éclate totale !

Hors ligne

#5 16-12-2008 22:01:58

KsmoinO
Modérateur
Distrib. : testing/sid
(G)UI : KDE
Inscription : 05-10-2007

Re : Apache - Message d'erreur [Résolu]

pour le virtual host qui s'appelle * dans ta conf ssl c'est pas terrible
alors soit tu fait a2dissite ssl en root soit tu te débrouille pour qu'il n'entre pas en conflit avec les autres
à mon avis ton problème vien de là

Hors ligne

#6 19-12-2008 21:14:39

amoule
Membre
Lieu : 78
Distrib. : Leeny 5.0.4 (Serveur)
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 07-12-2008
Site Web

Re : Apache - Message d'erreur [Résolu]

Salut

j'ai finit par comprendre la pourquoi de mon erreur avec ocs, il manquait une dépendance perl que j'ai galéré a trouver, et je ne sais pourquoi mais j'ai réussi a généré le fichier cacert.pem alors que précédemment ça n'avait pas marché, bref

OCS et GLPI sont en place et les remontées se font bien automatiquement et c'est de la boulette !!

sinon, mes problemes apache2 sont résolus !! (grâce un autre forum "admin café")

/etc/apache2/sites-available/

NameVirtualHost

à la place *:80 et *.443, j'ai mis mon IP soit 10.0.0.200:80 et 10.0.0.200:443

et pour le fichiers hosts

/etc/hosts

127.0.0.1 localhost localhost
127.0.1.1 debian.cptaforpa.fr debian
10.0.0.200 debian
# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


soit rajout de 10.0.0.200 debian

et surtout 127.0.0.1 localhost localhost, n'ayant pas de nom de domaine externe type www.mon-site.fr, fallait "juste" remplacer par localhost

voili voilou

!!

Merci encore a vous pour le coup de main

Dernière modification par amoule (19-12-2008 21:20:11)

Hors ligne

Pied de page des forums