Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-08-2014 19:26:05

xdanes
Membre
Distrib. : Debian Wheezy 7.6
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3
Inscription : 27-02-2012

Problème de dépendances -- installation de gnome

Bonjour, je viens de réaliser une installation minimaliste toute fraîche de Debian 7.6 (sans environnement graphique). Je souhaite maintenant installer un environnement gnome minimal grâce au paquet gnome-core.
Seulement voilà lorsque j'essaie de l'installer avec aptitude j'ai cette dépendance non satisfaite :


0 paquets mis à jour, 614 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 376 Mo d'archives. Après dépaquetage, 1 072 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 python-aptdaemon.pkcompat : Est en conflit avec: packagekit mais 0.7.6-3 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

        Conserver les paquets suivants dans leur version actuelle :
1)        python-aptdaemon.pkcompat [Non installé]
 



Est-ce que ce paquet est important ? Si oui comment faire pour résoudre ce problème de dépendance ?

Merci de votre attention :-)

EDIT : j'avais essayé d'installer gnome-core avec aptitude. Je viens d'essayer avec apt-get, et il me fait ça sans broncher... Pourquoi donc ?

Dernière modification par xdanes (20-08-2014 19:46:13)

Hors ligne

#2 21-08-2014 12:25:20

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problème de dépendances -- installation de gnome

Salut,

Je pense qu'apt s'en fiche si certaines dépendances recommandées ne sont pas respectées. Et justement, la solution 1 que proposait aptitude est de ce type.

Reste que tu n'aurais pas du l'avoir quand même. Tu es en Wheezy pure ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 21-08-2014 12:34:17

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.11/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Problème de dépendances -- installation de gnome

packagekit, en voila un paquet que je vire direct dès que je le vois.....

PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#4 21-08-2014 13:14:03

xdanes
Membre
Distrib. : Debian Wheezy 7.6
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3
Inscription : 27-02-2012

Re : Problème de dépendances -- installation de gnome

Wheezy pure ? Oui, j'ai installé la 7.6 en netinstall (https://www.debian.org/distrib/netinst), et c'est la première chose que j'ai faite. J'avais eu le même problème avec la 7.5 sur une autre machine.

Hors ligne

#5 21-08-2014 13:54:26

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problème de dépendances -- installation de gnome

Mhh, ok, et tu avais bien les dépôts standards, wheezy, wheezy-updates et wheezy/updates (security) ?
Tu avais bien fait un

apt-get update

avant, et tu étais bien à jour ?

apt-get dist-upgrade

?

Normalement c'est le cas avec une netinst, mais suivant les cas, il est possible que non.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 21-08-2014 14:52:03

xdanes
Membre
Distrib. : Debian Wheezy 7.6
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3
Inscription : 27-02-2012

Re : Problème de dépendances -- installation de gnome

J'ai bien les dépôts wheezy, wheezy/updates et wheezy-updates. J'ai également deux dépôts liés à l'installation en netinst qui pointent vers le cdrom, que l'on peut je pense virer.

#

# deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140712-14:09]/ wheezy main

#deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 NETINST Binary-1 20140712-14:09]/ wheezy main

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main
 



J'ai réessayer une tentative d'installation en machine virtuelle. Je n'ai installé que les 'utilitaires usuels du système'. J'avais fait un aptitude update et aptitude upgrade mais pas de dist-upgrade. D'ailleurs petite question, sur un poste personnel, vaut-il mieux utiliser upgrade ou dist-upgrade pour une maintenance régulière ?

Dans tous les cas, j'ai donc essayer d'installer gnome-core avec aptitude après avoir lancer les commandes aptitude update, apt-get update, aptitude upgrade, apt-get upgrade, aptitude dist-upgrade et apt-get dist-upgrade, mais le système était bien à jour, donc aptitude trouve toujours cette dépendance non satisfaite..

Dernière modification par xdanes (21-08-2014 14:59:47)

Hors ligne

#7 21-08-2014 16:43:36

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Problème de dépendances -- installation de gnome

Salut,

Normalement, en stable, upgrade et dist-upgrade font la même chose parce que les dépôts sont cohérents et qu'il n'y a pas de conflits.

Pour ma part, que je sois en stable ou en testing/sid, je tente systématiquement un dist-upgrade en premier. Si je vois que cela cause des problèmes, je fais un upgrade simple.

Pour les dépôts cdrom, tu peux les virer sans problème puisqu'ils sont déjà commentés.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 21-08-2014 17:10:49

xdanes
Membre
Distrib. : Debian Wheezy 7.6
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3
Inscription : 27-02-2012

Re : Problème de dépendances -- installation de gnome

Ok merci pour les infos

Hors ligne

Pied de page des forums