Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-09-2014 10:24:03

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

[résolu]cups: http:localhost:631 plus de connexion possible

Bonjour,

j'ai un problème pour me connecter http:localhost:631 depuis le serveur.

La connexion a échoué
Firefox ne peut établir de connexion avec le serveur à l'adresse localhost:631.
 



Tout marchait parfaitement bien, après la configuration de l'imprimante à partager : page de test fonctionnelle depuis cups, de même depuis un hôte via l'hôte lui-même, l'imprimante était bien détectée par le gestionnaire d'impression.

J'avais configuré /etc/cups/cupsd.conf ainsi :


<Location /printers>
  Order Deny,Allow
  Deny from All
  BrowseAllow from 127.0.0.1
  BrowseAllow from 192.168.0.1/24
  BrowseAll from @LOCAL
  Allow from 127.0.0.1
  Allow from 192.168.0.1/24
  Allow from @LOCAL
</Location>
 



Le problème est survenu après modification depuis  http:localhost:631 -> cups -> adminstration -> Edit Configuration File

où j'ai voulu ajouter l'IP du serveur.

Après enregistrement il y a un message d'erreur. Mais les modifications ont été apportées au fichier /etc/cups/cupsd.conf.

Mais depuis quand je fais :

/etc/init.d/cups start



[....] Starting Common Unix Printing System: cupsd2014 Sep 15 10:10:59 debian-serveur Unable to read "/etc/cups/cupsd.conf" due to errors.
cupsd: Child exited with status 1
. ok



Et comme décrit plus haut, plus de connexion "http:localhost:631".

Enfin tous les clients du réseau ont leur gestionnaire d'imprimante vide.

Pourtant "http:localhost:631" est joignable depuis un poste client.

Quelqu'un sait-il comment trouver l'origine de ce problème voire même comment le régler ?

Merci d'avance smile

Dernière modification par Hypathie (17-09-2014 11:12:38)

Hors ligne

#2 15-09-2014 10:43:32

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

Salut,

Il te faut nous montrer le contenu du fichier /etc/cups/cupsd.conf smile

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#3 15-09-2014 12:01:16

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

Salut,

C'est normal que tu ne puisses plus te connecter car a priori le serveur cups ne démarre pas. A confirmer avec un:

service cups status


Il nous faudrait effectivement l'intégralité du fichier de conf car une erreur dans ce dernier semble empêcher cups de démarrer convenablement.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#4 15-09-2014 14:04:12

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]cups: http:localhost:631 plus de connexion possible

coucou, merci de vos réponses

En fait il était devenu impossible de démarrer le serveur cups.

J'ai réussi à réparer le problème au niveau du serveur en dé-installant cups et cups-client puis en les réinstallant.

Le seul problème qui persiste concerne les clients. Après avoir ajouter l'imprimante sur "http:localhost:631", l'imprimante apparaît bien dans le gestionnaire d'impression, mais impossible d'imprimer depuis un client. Bien qu'il soit possible d'imprimer depuis la machine sur laquelle est branché l'imprimante, et déclarée comme serveur.

Voilà le fichier /etc/cups/cupsd.conf :


#
# "$Id: cupsd.conf.in 9407 2010-12-09 21:24:51Z mike $"
#
# Sample configuration file for the CUPS scheduler.  See "man cupsd.conf" for a
# complete description of this file.
#

# Log general information in error_log - change "warn" to "debug"
# for troubleshooting...
LogLevel warn

# Deactivate CUPS' internal logrotating, as we provide a better one, especially
# LogLevel debug2 gets usable now
MaxLogSize 0

# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock
ServerName 192.168.0.14

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseLocalProtocols CUPS dnssd

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Web interface setting...
WebInterface Yes

# Restrict access to the server...
<Location />
  Order allow,deny
</Location>

# Restrict access to the admin pages...
<Location /admin>
  Order allow,deny
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  Order allow,deny
</Location>
<Location /printers>
  Order Deny,Allow
  Deny from All
  BrowseAll from @LOCAL
 Allow from @LOCAL
</Location>

# Set the default printer/job policies...
<Policy default>
  # Job/subscription privacy...
  JobPrivateAccess default
  JobPrivateValues default
  SubscriptionPrivateAccess default
  SubscriptionPrivateValues default

  # Job-related operations must be done by the owner or an administrator...
  <Limit Create-Job Print-Job Print-URI Validate-Job>
    Order deny,allow
  </Limit>

  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an administrator to authenticate...
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # All printer operations require a printer operator to authenticate...
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Acti
vate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

# Set the authenticated printer/job policies...
<Policy authenticated>
  # Job/subscription privacy...
  JobPrivateAccess default
  JobPrivateValues default
  SubscriptionPrivateAccess default
  SubscriptionPrivateValues default

  # Job-related operations must be done by the owner or an administrator...
  <Limit Create-Job Print-Job Print-URI Validate-Job>
    AuthType Default
    Order deny,allow
  </Limit>

  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    AuthType Default
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an administrator to authenticate...
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # All printer operations require a printer operator to authenticate...
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    AuthType Default
    Require user @OWNER @SYSTEM
   Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

#
# End of "$Id: cupsd.conf.in 9407 2010-12-09 21:24:51Z mike $".
#
 

Dernière modification par Hypathie (15-09-2014 14:07:16)

Hors ligne

#5 15-09-2014 14:22:59

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

As-tu un message d'erreur lorsque tu essayes d'imprimer depuis les clients? soit directement à l'écran, soit dans la catégorie "Jobs" de l'interface web?
Les pilotes de l'imprimante sont-il correctement installés sur les clients?

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#6 15-09-2014 15:06:00

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]cups: http:localhost:631 plus de connexion possible

mouais, j'avoue que j'ai choisi un peu au hasard le pilote. big_smile

Mais bon si ça fonctionne avec le serveur pour lequel j'ai choisi le même pilote, c'est bien qu'il doit aller, non?

Depuis le client :

lpstat -t



scheduler is running
system default destination: HP_Deskjet
device for HP_Deskjet: ipp://192.168.0.14:631/printers/HP_Deskjet_D2540_series
HP_Deskjet accepting requests since lun. 15 sept. 2014 14:48:16 CEST
printer HP_Deskjet now printing HP_Deskjet-7.  enabled since lun. 15 sept. 2014 14:48:16 CEST
  The printer is busy.
HP_Deskjet-7            hypathie          1024   lun. 15 sept. 2014 14:17:41 CEST



Les ports sont ouverts et vérifiables depuis le client  :

nmap -PN 192.168.0.14 -p631 -sS -sU



Starting Nmap 6.00 ( http://nmap.org ) at 2014-09-15 14:58 CEST
Nmap scan report for 192.168.0.14
Host is up (0.00017s latency).
PORT    STATE         SERVICE
631/tcp closed        ipp
631/udp open|filtered ipp
MAC Address: 00:50:DA:66:57:3B (3com)

Nmap done: 1 IP address (1 host up) scanned in 0.33 seconds



J'vois vraiment pas sad

Merci de ton aide, j'vais essayer de trouver le bon pilote...

Dernière modification par Hypathie (22-09-2014 05:16:34)

Hors ligne

#7 15-09-2014 17:02:51

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

Hum hum... tu as bien choisi le bon type de connexion lorsque tu as configuré tes clients?
Ton serveur est connecté comment à l'imprimante, usb? wi-fi? et tes clients?

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#8 15-09-2014 17:35:49

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]cups: http:localhost:631 plus de connexion possible

J'en peux plus tongue

Je viens de m'apercevoir que que côté serveur dans cups j'ai :


HP_Deskjet_2540_series (Innocupée, Accepte les tâches, Non Partagée)



Ce "Non Partagée" me laisse grrrrrrrrrr   big_smile

Pourtant j'ai bien cliqué sur "partagé" quand j'ai ajouté l'imprimante. De même après après le choix des drivers. j'ai bien sélectionné "partagé".

???

Sinon l'imprimante était détectée, j'ai choisi "usb avec le nom de mon imprimante".

Et pour les clients j'ai choisi ipp et j'ai mis

ipp://192.168.0.14:631/printers/HP_Deskjet_2540_series




smile

Hors ligne

#9 15-09-2014 17:58:51

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

Ha bah oui, mais là bon... lol
J'ai failli te poser la question tout à l'heure.
Tu peux toujours modifier ce paramètre via l'interface web côté serveur de toute façon mais théoriquement on devrait s'en foutre qu'elle le soit où non puisque tu as un poste serveur. L'imprimante ne devrait connaître que le serveur, c'est ce dernier qui gère les clients.
Ça fait un moment que je n'ai pas foutu le nez dans Cups je t'avoue...

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#10 15-09-2014 18:29:35

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]cups: http:localhost:631 plus de connexion possible

J'ai juste suivi ce wiki ...   tongue

Hors ligne

#11 15-09-2014 19:42:59

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

imprimante_partage_cups.txt · Dernière modification: 2014/05/09 18:55 (modification externe)


M'a pas l'air récent ton tuto smile
Je ne suis pas chez moi et je n'ai aucune imprimante sous la main aussi je préfère passer la main à d'autres qui te guideront mieux, mais de mémoire pour faire sensiblement la même chose je n'avais pas farfouillé dans les fichiers de config, tout en interface web.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#12 15-09-2014 20:17:41

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

sogalpunx a écrit :

imprimante_partage_cups.txt · Dernière modification: 2014/05/09 18:55 (modification externe)


M'a pas l'air récent ton tuto smile


Tu exagères un peu là tongue
Je ne pense pas que CUPS ait changé radicalement en même pas cinq mois…


Jouer sous Debian ? Facile !

Hors ligne

#13 15-09-2014 21:46:04

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [résolu]cups: http:localhost:631 plus de connexion possible

vv222 a écrit :

Tu exagères un peu là tongue
Je ne pense pas que CUPS ait changé radicalement en même pas cinq mois…


Ooops.... au temps pour moi, belle boulette, j'ai lu bien trop vite, j'ai pensé qu'il datait de 2009! tongue


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#14 16-09-2014 08:02:16

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]cups: http:localhost:631 plus de connexion possible

Bon pour résumer le problème wink

Une fois que tout fonctionne bien côté serveur.

Le problème se résumer ainsi pour le ou les clients : Comment se connecter à l'imprimante distante  ?

Selon certains wikis il faut simplement créer un fichier avec l'IP du serveur : /etc/cups/client.conf,

puis simplement passer par le gestionnaire graphique d'impression ou la ligne de commande.

-> mais ça ne fonctionne pas, il répond  :

FirewallD n'est pas lancé.
 Pour détecter des imprimantes réseau les services mdns ipp ipp-client
 et samba-client doivent être autorisé par le pare-feu.





Selon d'autres wikis, il faut contourner cela (qui est signalé comme étant un bug en allant, pour le client, configurer cups depuis le réseau.

-> Ce qui ne fonctionne pas, en tout cas en choisissant ipp + adresse IP du serveur.
Après avoir fait cela, le gestionnaire d'impression du client a bien accès à l'imprimante, mais l'imprimante n'imprime pas les tâches d'impression lancées par le client.

Voilà si quelqu'un a réussi à installer une imprimante  via cups sur un serveur d'impression et à la partager avec les autres ordinateurs debian du Lan, ce serait vraiment sympa d'indiquer comment faire pour le côté client.

smile

Dernière modification par Hypathie (16-09-2014 08:03:20)

Hors ligne

#15 17-09-2014 11:12:08

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]cups: http:localhost:631 plus de connexion possible

Résolu \o/

Origine du problème

Avec ces seuls ajouts (sans autre modification) dans /etc/cups/cupsd.conf :


NameServer ip-serveur

(...)

<Location /printers>
  Order Deny,Allow
  Deny from All
  BrowseAllow from 127.0.0.1
  BrowseAllow from 192.168.0.1/24
  BrowseAll from @LOCAL
  Allow from 127.0.0.1
  Allow from 192.168.0.1/24
  Allow from @LOCAL
</Location>



il était impossible sur la page http://localhost:631, avant de cliquer sur "Ajouter une imprimante", de modifier "les paramètres" après avoir sélectionner "Partager les imprimantes connectées à ce système".

Après le clic sur "modifier les paramètres",
cela entraînait l'impossibilité de se connecter à http://localhost:631, et au niveau du terminal le message d'erreur suivant apparaissait :

Message from syslogd@debian-pc1 at Sep 17 07:35:25 ...
 cupsd: Unable to read "/etc/cups/cupsd.conf" due to errors.




Solution côté serveur :

1) Suppression complète de cups et cups-client : apt-get --purge autoremove cups cups-client

2) Réinstallation : apt-get install cups cups-client
Ajout de :

apt-get install --install-recommends task-print-server



3) Ouverture tcp et udp pour le port 631 :

Voir http://debian-facile.org/atelier:chanti … e-partagee

4) Configuration de /etc/cups/cupsd.conf cette fois comme ceci :


Port 631
Listen /var/run/cups/cups.sock
ServerName 192.168.0.14
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseRemoteProtocols CUPS dnssd
BrowseAddress @LOCAL
BrowseLocalProtocols CUPS dnssd
DefaultAuthType Basic
WebInterface Yes


<Location />
  # Allow remote administration...
  Order allow,deny
  Allow all
</Location>
<Location /admin>
  # Allow remote administration...
  Order allow,deny
  Allow all
</Location>
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow all
</Location>
<Location /printers>
  AuthType None
  Order Deny,Allow
  Deny From None
  Allow From 192.168.0.*
  Allow From @LOCAL
</Location>
 



Puis redémarrage : /etc/init.d/cups start

5) Installation de nmap :

puis

nmap -PN 192.168.0.14 -p631 -sS -sU

Starting Nmap 6.00 ( http://nmap.org ) at 2014-09-17 07:57 CEST
Nmap scan report for 192.168.0.14
Host is up (0.00018s latency).
PORT    STATE         SERVICE
631/tcp closed        ipp
631/udp open|filtered ipp
MAC Address: xxxxxxxxx (3com)



6) Puis http://localhost:631

J'ai puis enfin "modifier" après avoir sélectionné "Partager les imprimantes connectées à ce système".


7) Enfin il faut aller au niveau du gestionnaire graphique d'impression : l'imprimante est là mais il faut la sélectionner "comme imprimante par défaut" (sur lxde il y a le choix entre imprimante système et "mon imprimante", choisir "mon imprimante")

Solution côté client :

1) Comme pour le serveur : ouverture tcp et udp pour le port 631

2) Éditer aussi /etc/cups/cupsd.conf :


# only listen for connections from local machine.
Listen 127.0.0.1:631
Listen /var/run/cups/cups.sock
Listen ip_du_serveur
 



Puis redémarrage : /etc/init.d/cups start

Puis aller sur http://localhost:631
Puis "Administration (avec seulement "Afficher les imprimantes partagées par d'autres systèmes") "Ajouter une imprimante" ->   choisir ipp -> Donner le nom exact de l'imprimante qui a été donné au serveur
Par exemple : ipp://192.168.0.22:631/printers/HP_Deskjet_2540_series
Nom : HP_Deskjet_2540_series
Description : ce qu'on veut
Emplacement : ce qu'on veut
inutile de cocher "partagée"
Enfin -> choisir les drivers

3) Aller dans le gestionnaire d'impression graphique, l'imprimante est là. Il faut l'ajouter comme "imprimante par défaut.

Faire de même pour tous les ordi clients.

Et voilà je peux imprimer depuis les clients ! smile

Dernière modification par Hypathie (06-11-2014 11:38:03)

Hors ligne

Pied de page des forums