Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-09-2014 13:06:13

yitianetie
Membre
Distrib. : Debian stretch/sid
Noyau : Linux 4.2.0-1-amd64
(G)UI : GNOME 3.18
Inscription : 06-08-2013

GRASS GIS 6.4.4 : la fonction i.class ne fonctionne pas

Bonjour,

Il s'agit d'un sujet que j'ai déjà posté sur le site de Géorezo pour lequel je n'ai pas encore eu de réponse. Je ne sais pas si le problème est lié à la version Debian de Grass GIS. C'est la raison pour laquelle j'ouvre un fil de discussion à ce sujet sur Debian-facile.org.

Je me suis initié au logiciel de traitement d'images satellite appelé GRASS GIS. J'ai réussi à importer des images landsat, à créer des compositions colorées avec différents canaux.
En revanche, je n'arrive pas à lancer le module "Entrée interactive pour une classification supervisée" (alias fonction i.class dans l'onglet imagerie). Je suppose que cette fonction permet d'extraire des signatures spectrales. En lançant ce module qui requiert Xterm et que j'ai déjà installé, le logiciel m'affiche le message suivant et s'arrête de charger :

=================================================================
If you wish to resize the X monitor, do so now. Window size is
locked while interactive modules are running.
=================================================================

/usr/lib/grass64/etc/grass-run.sh: 32: /usr/lib/grass64/etc/grass-run.sh: i.class: not found

ERROR: "i.class" exited abnormally. Press <enter> to continue.



Je ne sais pas d'où vient le problème, cela vient il de ma distribution linux ? J'ai installé le logiciel depuis les dépôts de Debian SID (version du noyau : linux 3.16.2) car je possède Debian avec le bureau XFCE qui dispose de Xterm intégré nativement.
Sinon, le problème viendrait il du logiciel en lui même ?

Y en a-t-il parmi vous qui ont eu affaire à ce problème et qui pourraient me venir en aide ?

Bien cordialement

Hors ligne

#2 23-09-2014 09:17:39

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : GRASS GIS 6.4.4 : la fonction i.class ne fonctionne pas

Bonjour

Je ne suis pas utilisateur de ce logiciel, mais il semble que ce problème ne soit  reporté, ni au niveau du paquet Debian, ni au niveau du paquet amont  hmm

Etant donné la relative confidentialité de ce programme (il ne doit pas y avoir une majorité d'utilisateur Debian qui l'installe wink ), il me semble que tu aurais tout intérêt à reporter ce bug afin qu'il soit corrigé.

Si tu as besoin d'aide pour cela, tu peux demander de l'aide dans la section du forum dédié à la contribution à Debian.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#3 23-09-2014 20:49:53

yitianetie
Membre
Distrib. : Debian stretch/sid
Noyau : Linux 4.2.0-1-amd64
(G)UI : GNOME 3.18
Inscription : 06-08-2013

Re : GRASS GIS 6.4.4 : la fonction i.class ne fonctionne pas

Bonsoir,

merci de m'avoir porté réponse. Mais en raison d'un bug du paquet libglib2.0-0 (version SID) le lancement de certains logiciels GTK dont Reportbug est impossible. Je n'arrive même pas à le lancer en commande (voir autre sujet que j'ai posté sur le forum à l'adresse : https://debian-facile.org/viewtopic.php?id=9728)

En bref, il m'est impossible de rapporter le bug à Debian. En attendant d'autres mises à jour des paquets défectueux, y aurait-il un moyen de rapporter ce bug directement sur le web via une interface en ligne ?

Hors ligne

Pied de page des forums