Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-10-2014 18:25:00

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

[Résolu] Disques non détectés RAID

Bonjour à tous,
Je viens de récupérer un IBM Eserver Xseries 206M de 2008 pour trois fois rien, j'ai donc voulu le passer sous Debian 7.6.0 (Il l'était apparemment avant mais les disques ont étaient reformatés), seulement durant l'installation en mode graphique, les premières étapes se déroulent très bien mais arrivé à la détection des disques, le message suivant apparait "Aucun disque dur n'a été trouvé [...] Choisir dans la liste.".
Je suis assez étonné de cette erreur puisque cette machine tournée déjà sous deb. sans aucun soucis.
C'est certainement du RAID, puisque ce sont des disques montés sur un support "Caddie" racktable ...
J'avoue que je suis un peu perdu sad .

Merci d'avance de vos réponses smile .

Cordialement,

McBuzz.

Dernière modification par McBuzz (04-10-2014 14:22:43)

Hors ligne

#2 03-10-2014 10:42:09

Invité-5
Banni(e)

Re : [Résolu] Disques non détectés RAID

Si toi même tu es perdu, nous encore plus. On ne peut pas non plus "dépanner" à distance ta vieille machine. Un coup de torchon sera souhaitable, désosses-là pour voir les branchements etc...

Courage.

#3 03-10-2014 11:28:50

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disques non détectés RAID

On peut quand même donner des conseils généraux pour faire avancer le sujet.

1) Aller voir dans le setup du BIOS RAID la configuration des disques et volumes. Si aucun volume RAID n'a été défini (ou s'ils ont été supprimés), c'est normal que l'installateur ne voie aucun disque.

2) Identifier le contrôleur RAID pour savoir s'il est pris en charge par le noyau de l'installateur Debian.
Dans le shell d'une des consoles de l'installateur accessibles par Ctrl+Alt+F2 ou F3, exécuter la commande suivante pour identifier les contrôleurs disques :

lspci -nn

Hors ligne

#4 03-10-2014 19:09:17

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

Merci bien pour ces infos "raleur" ^^,

Je viens d'executer dans le Shell d'installateur la commande :

lspci -nn

et voici le résultat :
"

*SCSI storage controller [0100] : Adaptec ASC-29320ALP U320 [9005:8017] (rev 10)
*Serial Attached SCSI controller [0107] : Adaptec AIC-9405W SAS (Razor-Lite ASIC non-raid) [9005:043e] (rev 08)

"

Je vais essayer de me renseigner plus amplement maintenant que j'ai ces infos smile

Hors ligne

#5 03-10-2014 19:26:43

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Disques non détectés RAID

raleur a écrit :

On peut quand même donner des conseils généraux pour faire avancer le sujet.

+1

Voilà pour les noyaux : http://cateee.net/lkddb/web-lkddb/SCSI_AIC94XX.html


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 03-10-2014 19:33:19

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

EDIT : Je viens de trouver un truc assez intéréssant : http://forums.debian.net/viewtopic.php?f=17&t=75425
D'après ce que je viens de lire, il me faudrait trouver e fichier aic94xx-seq.fw.

Dernière modification par McBuzz (03-10-2014 19:50:54)

Hors ligne

#7 03-10-2014 19:56:04

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

EDIT 2 :
Génial !!! Merci Paskal pour ce lien j'ai pu trouver le fichier tout marche Niquel ! Les quatres disques sont détectés !
Un grand merci.

big_smile

Dernière modification par McBuzz (03-10-2014 20:21:24)

Hors ligne

#8 03-10-2014 20:44:15

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Disques non détectés RAID

\o/
Bonne install.  big_smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 04-10-2014 09:18:36

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

Salut,
Je viens juste de m'apercevoir qu'il y'avait cependant "une couille dans le pâté" puisque pour démarrer correctement maintenant que Deb. est bien installé je dois cependant laisser la clef USB avec le fichier aic94xx-seq.fw connectée lors du démarrage sinon rien ne se passe hmm ...

Une idée pour résoudre ce problème ?

Hors ligne

#10 04-10-2014 09:24:07

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disques non détectés RAID

McBuzz, quel fichier manquait et comment l'as-tu trouvé à partir du lien fourni par Paskal ?
Est-ce le firmware aic94xx-seq.fw ?

Aussi, si tu vois les quatre disques individuels, cela signifie qu'ils ne sont pas en RAID. D'ailleurs d'après sa dénomination ce contrôleur "Adaptec AIC-9405W SAS (Razor-Lite ASIC non-raid)" ne fait pas de RAID. Tu peux quand même faire du RAID logiciel, mais je ne sais pas si la fonction hot-plug est disponible.

Hors ligne

#11 04-10-2014 09:29:27

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disques non détectés RAID

Que veux-tu dire par "rien ne se passe" ? grub ne démarre pas ? Dans ce cas tu as probablement installé l'amorce du chargeur par erreur sur la clé USB au lieu du disque de démarrage. Il faut réinstaller grub sur le(s) bon(s) disque(s) soit manuellement avec

grub-install /dev/sdX

(remplacer /dev/sdX par le disque à amorcer)
soit en sélectionnant les emplacements où grub doit être installé avec

dpkg-reconfigure grub-pc

(ou autre variante installée de grub : grub-efi-amd64, grub-legacy...)
Avantage : l'amorce sera automatiquement réinstallée dans ces emplacements si le paquet grub-* est mis à jour.

Dernière modification par raleur (04-10-2014 09:41:46)

Hors ligne

#12 04-10-2014 09:29:55

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Disques non détectés RAID

Quel est le retour de

uname -r


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#13 04-10-2014 10:01:49

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

Merci de répondre aussi vite wink
Alors oui je confirme, il ne s'agit pas de RAID puisque les quatre disques sont visibles depuis la vue Desktop, seul un contient tout les fichiers systèmes.
Lorsque la clef USB n'est pas insérée comme le dit raleur le GRUB n'apparait pas et l'écran reste sur un curseur clignotant.
Je pense que j'ai du faire la grosse bourde d'installer ce dernier sur la clef hmm
Le retour de la commande de Paskal en user donne ceci :

dunion@dunion-IBM-CORPORATION:~$ uname -r
3.2.0-4-686-pae



Merci d'avance.

Dernière modification par McBuzz (04-10-2014 10:04:55)

Hors ligne

#14 04-10-2014 10:07:45

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disques non détectés RAID

Merci d'avance pour quoi ? J'ai déjà fourni la méthode pour corriger le problème.
En complément, tu peux exécuter la commande suivante pour voir sur quel(s) périphérique(s) grub a été installé :

debconf-show grub-pc | grep install_devices:

Hors ligne

#15 04-10-2014 10:12:44

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

Non autant pour moi, le merci d'avance est une vieille habitude d'un temps ou je faisais du support client pour une boite de location de serveurs de jeux ... smile
Et bien vu raleur :

* grub-pc/install_devices: /dev/disk/by-id/usb-Intuix_DiskOnKey_0EF16750D3430A06-0:0

Dernière modification par McBuzz (04-10-2014 10:13:14)

Hors ligne

#16 04-10-2014 10:30:14

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Disques non détectés RAID

McBuzz a écrit :

Le retour de la commande de Paskal en user donne ceci :

dunion@dunion-IBM-CORPORATION:~$ uname -r
3.2.0-4-686-pae

Donc tu possèdes déjà le firmware : https://packages.debian.org/search?sear … e&arch=any
J'espère pour toi qu'il ne s'agit pas d'un bug.

Est-ce que les commandes suivantes répondent ?

rmmod aic94xx

suivie de

modprobe aic94xx


ça va pas être pratique comme ça, il vaudrait mieux que ton système soit sur un disque reconnu ou une clé, et te passer du fichier aic94xx-seq.fw


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#17 04-10-2014 10:36:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Disques non détectés RAID

Oups, désolé : je n'avais pas lu ton #13  sad , il s'agit vraisemblablement de l'install de grub, comme l'a dit raleur, confirmé par ton #15.  hmm

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#18 04-10-2014 10:39:00

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

Voila le résultat,

root@dunion-IBM-CORPORATION:/home/dunion# rmmod aic94xx
Error: Module aic94xx is in use
root@dunion-IBM-CORPORATION:/home/dunion# modprobe aic94xx


Je pense simplement qu'il faut que je réinstalle le Grub comme le dit raleur et tout sera réglé non ?
ps : aucun retour de la commande modprobe.

Dernière modification par McBuzz (04-10-2014 10:39:49)

Hors ligne

#19 04-10-2014 10:39:59

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Disques non détectés RAID

McBuzz a écrit :

Je pense simplement qu'il faut que je réinstalle le Grub comme le dit raleur et tout sera réglé non ?


Oui, sans problème.  cool


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 04-10-2014 13:49:37

McBuzz
Membre
Distrib. : wheezy 7.6
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE
Inscription : 02-10-2014

Re : [Résolu] Disques non détectés RAID

Sujet Résolu. Le secteur d'amorçage est déplacé, le Grub se charge correctement depuis /dev/sdb. cool
Merci à tous.

Dernière modification par McBuzz (04-10-2014 13:49:59)

Hors ligne

#21 04-10-2014 13:56:56

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Disques non détectés RAID


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums