Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-10-2014 06:03:46

maa
Membre
Distrib. : Debian GNU/Linux 6.0.10 (squeeze)
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : aucun (utilisation : serveur LAMP)
Inscription : 03-10-2014

pb pour installer un paquet

Bonjour,

Quequ'un sait-il comment résoudre ce problème s'il vous plaît :

Les paquets suivants contiennent des dépendances non satisfaites :
 php5-imap : Dépend: phpapi-20100525+lfs
             Dépend: php5-common (= 5.4.4-12~squeeze1) mais 5.3.3-7+squeeze19 devra être installé
 



Et m'expliquer  ce que signifie ce message d'erreur.

Des infos sur mon serveur :

cat /etc/debian_version
6.0.10

apt-cache policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://dl.google.com/linux/mod-pagespeed/deb/ stable/main i386 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main
     origin dl.google.com
 500 http://apt.izzysoft.de/ubuntu/ generic/universe i386 Packages
     release a=generic,c=universe
     origin apt.izzysoft.de
 500 http://www.tataranovich.com/debian/ squeeze/backports i386 Packages
     release o=IceMan,a=squeeze,n=squeeze,l=IceMan,c=backports
     origin www.tataranovich.com
 500 http://www.tataranovich.com/debian/ squeeze/main i386 Packages
     release o=IceMan,a=squeeze,n=squeeze,l=IceMan,c=main
     origin www.tataranovich.com
 500 http://hwraid.le-vert.net/debian/ squeeze/main i386 Packages
     release o=hwraid.le-vert.net,a=squeeze,l=hwraid.le-vert.net,c=main
     origin hwraid.le-vert.net
 500 http://security.debian.org/ squeeze/updates/non-free i386 Packages
     release v=6.0,o=Debian,a=oldstable,n=squeeze,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ squeeze/updates/contrib i386 Packages
     release v=6.0,o=Debian,a=oldstable,n=squeeze,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ squeeze/updates/main i386 Packages
     release v=6.0,o=Debian,a=oldstable,n=squeeze,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.fr.debian.org/debian/ squeeze/main Translation-fr
 500 http://ftp.fr.debian.org/debian/ squeeze/non-free i386 Packages
     release v=6.0.10,o=Debian,a=oldstable,n=squeeze,l=Debian,c=non-free
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ squeeze/contrib i386 Packages
     release v=6.0.10,o=Debian,a=oldstable,n=squeeze,l=Debian,c=contrib
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian/ squeeze/main i386 Packages
     release v=6.0.10,o=Debian,a=oldstable,n=squeeze,l=Debian,c=main
     origin ftp.fr.debian.org
Paquets étiquetés :




Merci.

Hors ligne

#2 03-10-2014 09:57:20

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : pb pour installer un paquet

Bonjour et Bienvenue smile

On manque un peu d'info sur ta distribution pour t'aider. Par ailleurs, il semblerait que ton sources.list soit assez exotique, ce qui ne va pas aider à la résolution d'un tel problème.

A ta place, je commencerais par mettre un sources.list pour Squeeze (puisqu'i semble que ça soit ta distribution) au carré (en commentant les entrées exotiques par exemple)


# squeeze
deb http://ftp.fr.debian.org/debian/ squeeze main
# squeeze updates  
deb http://security.debian.org/ squeeze/updates main
 


puis,

apt-get update
apt-get upgrade
apt-get dist-upgrade
 


Ensuite, tu pourras essayer d'installer à nouveau ton paquet.


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#3 03-10-2014 10:09:19

Invité-5
Banni(e)

Re : pb pour installer un paquet

+1 et puis jette un coup d’œil sur les versions => https://packages.debian.org/search?keyw … ection=all

#4 03-10-2014 10:13:10

maa
Membre
Distrib. : Debian GNU/Linux 6.0.10 (squeeze)
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : aucun (utilisation : serveur LAMP)
Inscription : 03-10-2014

Re : pb pour installer un paquet

Merci ! Voici le sources.list :

cat /etc/apt/sources.list
## Debian Squeeze sources.list

## Debian.org FR mirror
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free

## Debian security updates
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free

deb http://hwraid.le-vert.net/debian squeeze main

deb http://www.tataranovich.com/debian squeeze main backports
deb-src http://www.tataranovich.com/debian squeeze main backports

## monitorix
deb http://apt.izzysoft.de/ubuntu generic universe


Me conseillez-vous de mettre le sources.list que vous m'avez indiqué, ou le mien est-il bon ?

Hors ligne

#5 03-10-2014 10:15:39

maa
Membre
Distrib. : Debian GNU/Linux 6.0.10 (squeeze)
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : aucun (utilisation : serveur LAMP)
Inscription : 03-10-2014

Re : pb pour installer un paquet

Est-il mieux de passer à la version wheezy ? Ca apporte beaucoup de choses ? ou ça peut apporter des problèmes ?

Hors ligne

#6 03-10-2014 10:26:16

Invité-5
Banni(e)

Re : pb pour installer un paquet

Wheezy est stable est bien stable. Pourquoi s'attarder sous oldstable ?

#7 03-10-2014 10:32:23

maa
Membre
Distrib. : Debian GNU/Linux 6.0.10 (squeeze)
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : aucun (utilisation : serveur LAMP)
Inscription : 03-10-2014

Re : pb pour installer un paquet

Et il n'y pas de problèmes avec les scripts PHP, Perl, les logiciels Postfix, Mysql et autres ? Ou bien il peut y avoir des incompatibilités ? Vu que mon serveur est un serveur de production (rien de super critique non plus mais bon quand même), je n'aimerais pas prendre de risque.

Hors ligne

#8 03-10-2014 10:52:20

Invité-5
Banni(e)

Re : pb pour installer un paquet

Tout dépends de l’état physique de ton ordi. Il ne faut pas non plus demander la lune avec le matériel obsolète. smile

#9 03-10-2014 10:54:49

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : pb pour installer un paquet

Pour ma part, je n'ai (encore) jamais fait de migration d'un serveur. Ca doit cependant se faire. Voici la doc officielle pour ça smile

Sinon, Squeeze est une version Long term Support. Tu peux aussi regarder de ce coté là.

Quoiqu'il en soit, pour un serveur, je te conseille de te contenter du sources.list debian officiel. A ta place, je ferais ça

## Debian Squeeze sources.list

## Debian.org FR mirror
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free

## Debian security updates
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free

#deb http://hwraid.le-vert.net/debian squeeze main

#deb http://www.tataranovich.com/debian squeeze main backports
#deb-src http://www.tataranovich.com/debian squeeze main backports

## monitorix
#deb http://apt.izzysoft.de/ubuntu generic universe


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#10 03-10-2014 14:53:31

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : pb pour installer un paquet

Un article du wiki des voisins pour t’accompagner si tu comptes mettre ton système à jour vers Wheezy :
https://www.isalo.org/wiki.debian-fr/Mi … ers_Wheezy

Jouer sous Debian ? Facile !

Hors ligne

#11 04-10-2014 05:20:24

maa
Membre
Distrib. : Debian GNU/Linux 6.0.10 (squeeze)
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : aucun (utilisation : serveur LAMP)
Inscription : 03-10-2014

Re : pb pour installer un paquet

Merci les liens et pour tout big_smile Je vais essayer tout ça quand j'aurais un peu de temps.

Hors ligne

#12 04-10-2014 09:20:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : pb pour installer un paquet

Bonjour,

maa a écrit :

Et il n'y pas de problèmes avec les scripts PHP, Perl, les logiciels Postfix, Mysql et autres ? Ou bien il peut y avoir des incompatibilités ? Vu que mon serveur est un serveur de production (rien de super critique non plus mais bon quand même), je n'aimerais pas prendre de risque.

Migrer, c'est toujours une prise de risque, plus ou moins grande.
Cela dit, c'est souvent un passage obligé, même en production (et surtout en production : qui conserverait un serveur sous Sarge ?)

Alors ce qu'il convient de faire, pour minimiser ces risques, c'est de prévoir au mieux.
Et prévoir, c'est d'abord se documenter avec soin.

Voici un lien vers la procédure générale : Migrer, tu y trouveras les précautions à prendre et en particulier la sauvegarde.

Et j'attire ton attention sur la lecture des notes de publication, afin d'y déceler d'éventuelles actions à mener concernant tes scripts PHP, Perl et autres.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums