Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-10-2014 14:32:36

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Raccourci clavier

Bonjour,

depuis XCFE installé sur mon système, les raccourcis clavier de Gimp refusent de fonctionner ... de même que de nombreux autres raccourcis d'autres logiciels.   C'est généralement la touche "Ctrl" de gauche qui est affectée, mais je ne suis pas sûr que les dégâts se limitent à celle-ci.

Comment régler cela?

Merci.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 21-11-2014 17:29:23

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Raccourci clavier

Bonjour à tous,

Les raccourcis clavier jouent encore des tours!
Ils ne fonctionnent pas, pour la plupart d'entre eux.
En fait, seuls les raccourcis "par défaut" fonctionnent.

Il y eut un temps où tout allait bien, ce temps fut suffisamment long pour m'habituer et aimer ça.
Je fis quelques mis à jour (automatiques, rien d'extravagant).  Et oups ... les reccourcis ont été désactivés.  Ils sont bien là, visibles, mais inutilisables.
J'ai bien essayé de les supprimer pour le créer de nouveau mais sans plus de résultat.

Je suis passé à XFCE même si mon profil dit "gnome".

Merci de votre aide.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#3 21-11-2014 17:46:24

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Raccourci clavier

Bonjour,
Est-ce que les mises à jour ou autres manip auraient pu modifier la disposition du clavier?
Si tu as un portable, il se peut qu'un truc ésotérique soit arrivé. Cela m'est arrivé sur je-ne-sais-plus quel modèle: les touches Fn et Ctrl étaient inversées! yikes
J'ai du arrêter le portable, ôter la batterie quelques dizaines de secondes et au redémarrage le Ctrl était bien à sa place.

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#4 21-11-2014 17:59:06

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Raccourci clavier

Merci sogalpunx, mais non, je ne constate aucun changement dans mon clavier.
Oui, j'ai un ordinateur portatif (laptop).
J'ai redéfini mes raccourcis et les codes apparaissant à l'écran du gestionnaire de raccoucis corresondent bien aux touches choisies.

Je viens de tenter une autre modification, sans succès: passer du clavier générique 105 (intl) au clavier générique 104 touches.  Les raccoucis ne fonctionnent pas plus.  Je suis revenu au clavier générique 105 touches (intl) tel que reconnu automatiquement par le système lors de l'installation.  Les raccourcis ne fonctionnent pas encore plus.

Dernière modification par Patriboom (21-11-2014 18:03:23)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#5 21-11-2014 18:12:21

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Raccourci clavier

Et en essayant de supprimer (et purger) le paquet gérant les raccourcis XFCE puis en le réinstallant:

apt-get remove --purge xfce-keyboard-shortcuts


puis

apt-get install xfce-keyboard-shortcuts


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#6 21-11-2014 19:38:47

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Raccourci clavier

Salut,

merci pour la piste, mais il y a trop de paquets dépendants.  Je ne veux pas m'embarquer dans un tel capharnaüm.

J'ai plutòt fait

en root  
aptitude reinstall xfce-keyboard-shortcuts
et
aptitude reinstall xfce4-settings



Ça ne suffit pas encore.
J'ai changé tous les raccourcis sans plus de succès.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#7 21-11-2014 21:06:29

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Raccourci clavier

Je me rends compte que xfce4-goodies n'est pas installé.
Je tente de l'installer et vous renviendrai ensuite.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 21-11-2014 21:28:52

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : Raccourci clavier

Essaie de créer un nouvel utilisateur :

# adduser test



Puis connecte toi à une session xfce avec cet utilisateur. Si les raccourcis fonctionnent, alors, on saura que le problème vient des fichiers de configuration de xfce du premiers utilisateur (suite à une mise à jour?), et on pourra alors avancer.


YA3HGA-H

Hors ligne

#9 21-11-2014 21:35:35

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Raccourci clavier

J'ai installé xfce4-goodies sans meilleurs résultats.
Mais certains raccourcis nouveaux fonctionnent.

Je soupçonne maintenant que mes appels (commandes) ne soit pas bons.

Ainsi, lorsque je veux que le raccourci  ctrl-alt-g  ouvre gimp, j'écris simplement gimp dans la ligne de commande.   Devrais écrire  /bin/gimp ? ou quoi ?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#10 21-11-2014 21:39:11

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Raccourci clavier

Devrais-je suivre ce conseil  https://help.ubuntu.com/community/KeyboardShortcuts  et installer  xbindkeys

Text Entry Shortcuts

If you want to have quick access to lines of text by using a hotkey, for example to enter your email address in forms, then you can use xbindkeys. Xbindkeys has a GUI utility to allow easy settings of hotkeys, but be aware that it's a little more complicated than the default Ubuntu Shortcutkeys interface.

Install xbindkeys
sudo apt-get install xbindkeys

Create the default config file for xbindkeys
xbindkeys --defaults > /home/your-user-name/.xbindkeysrc

When thats done, install xbindkeys-config, the GUI for xbindkeys
sudo apt-get install xbindkeys-config

Now the utility that actually does the "typing"
sudo apt-get install xvkbd

Once each is installed, start both applications by bringing up "Run Application" with ALT -F2.
xbindkeys

and
xbindkeys-config


To keep the xbindkeys hotkeys active when you next start the computer you will have to add a new session, System --> Preferences --> Sessions. Put in the command "xbindkeys" into the command field (without the quotes).

You should be able to see the "Xbindkeys Config" window. Start a new hotkey. Hit "New" on the bottom row of buttons. Then use the edit area at the top right. Give the hotkey a name. Hit the "GetKey" button to set the keypress for a hotkey. Some hotkeys may conflict with other hotkeys on the system (a window will open or a compiz plugin will activate). If this happens then choose another combination like CTRL - ALT - F for example.

Now put the command to activate with that hotkey in the "Action" field. This can be anything, but to allow for the entry of a line of text into part of the GUI enter

xvkbd -xsendevent -text "myemail@server.com"

The example shows an email address but it can be any line of text. Now hit "Apply" and test the hotkey in a Firefox field, text editor, or anywhere that text can be entered. Please note that using "Run Action" will not be able to test the command in xbindkeys-config, you will have to test it somewhere else.


Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums