Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-10-2014 17:10:28

will7991
Membre
Distrib. : Stable et Testing, ça dépend de la machine :)
Inscription : 03-10-2014

Samba 3.6 en PDC et Windows 10 Technical Preview

Bonjour à tous,

Mon tout premier post chez debian-facile, ouais smile

Comme vous devez le savoir, Windows 10 est dispo en Technical Preview. Cela permet d'effectuer quelques tests, notamment d'interopérabilité avec nos outils Linux !
Malgré son manque d'innovation, je pense personnellement que cette dernière itération se généralisera par la force des choses. Windows 8/8.1, no pasaran ! Donc, ceux qui ont des clients XP comme dans mon cas devront à terme :
- soit passer à du 7, qui ne sera certainement plus commercialisé dès la mise en place de 10. Donc à faire rapidement...
- soit passer directement à 10
C'est pourquoi il est intéressant de le tester.

Sur mon LAN, j'ai un PDC sous Samba 3.6.6 (en Wheezy).
Il n'y a pas de LDAP, ni de serveur DNS interne.

Lorsque j'essaie de joindre le client W10 au domaine, j'ai cette erreur :

That domain couldn't be found. Check domain name and try again



Je ne comprends pas trop, car tous les types de Windows de mon réseau (XP, Vista, 7, 8) s'y connectent sans problème.

J'ai bien tenté de modifier la base de registre comme pour Windows 8, mais sans succès :

DNSNameResolutionRequire (0)
DomainComptibilityMode (1)



Le Windows 10 arrive pourtant à se connecter à un AD fonctionnant sous Windows 2008R2
Lorsque j'essaie de le connecter à un PDC Samba 4 que j'ai mis en test, le "contact" se fait bien (je n'ai pas l'erreur comme précédemment), mais je n'arrive pas à m'authentifier (ceci, je le garde pour un autre topic smile )

Voici un extrait de mon smb.conf :

======================= Global Settings =======================

[global]
   workgroup = MONDOMAINE
   netbios name = SERVEUR_SAMBA
   server string = Samba Server
   wins support = yes
   ;   wins server = w.x.y.z
   dns proxy = no
   name resolve order = lmhosts host wins bcast
   preferred master=true
   admin users = root

####### Authentication #######
   security = user
   encrypt passwords = true
   passdb backend = tdbsam:/var/lib/samba/mypassdb.tdb
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes

########## Domains ###########
   domain logons = yes



J'ignore s'il s'agit d'un pb coté OS client, si cela vient de ma version de Samba (migrer à la 4 ?) ou si ça vient d'un paramétrage ... ?

Merci à tous !

Hors ligne

#2 04-10-2014 18:03:31

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Samba 3.6 en PDC et Windows 10 Technical Preview

Bonjour et bienvenue sur le forum  smile,

Je ne sais pas si quelqu'un a eu l'occasion de faire cette manip en pointe mais c'est très intéressant.

Peut-être pourrais-tu confirmer qu'un autre Samba ne trouve le poste windows 10,
afin d'être sûr que le problème ne vient pas de là ?
On peut aussi imaginer que w10 ne souhaite pas répondre à Samba.  wink

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 04-10-2014 22:04:42

will7991
Membre
Distrib. : Stable et Testing, ça dépend de la machine :)
Inscription : 03-10-2014

Re : Samba 3.6 en PDC et Windows 10 Technical Preview

Salut paskal !

Qu'entends tu par

Peut-être pourrais-tu confirmer qu'un autre Samba ne trouve le poste windows 10, afin d'être sûr que le problème ne vient pas de là ?



Dans mon cas, c'est plutôt le w10 qui ne trouve pas le samba lorsque je fais "joindre au domaine"

Quelle manip me suggeres tu de faire ?

Merci !

Hors ligne

#4 05-10-2014 09:21:48

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Samba 3.6 en PDC et Windows 10 Technical Preview

Désolé, je n'avais pas compris "j'essaie de joindre le client W10"

will7991 a écrit :

Quelle manip me suggères tu de faire ?

À part comparer les configurations des 2 versions de Samba, 3.6 et 4, je ne vois pas pour l'instant.  sad


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 06-10-2014 12:00:38

will7991
Membre
Distrib. : Stable et Testing, ça dépend de la machine :)
Inscription : 03-10-2014

Re : Samba 3.6 en PDC et Windows 10 Technical Preview

Salut,

Pour être plus précis dans ce qui m'arrive :

1) Je fais joindre au domaine
2) Il me demande de m'identifier
3) Je saisi un user/password
4) Il me jette par le message

That domain couldn't be found. Check domain name and try again



Ce qui est très étrange, c'est que des fichiers de log correspondant à mon poste client sont bien créés. Mais ils sont désespérément vides ...

Par contre, quand j'essaie d'atteindre un partage du réseau par l'explorateur, ça marche bien  :

\\nom_netbios\partage

  puis saisie login/password -> la connexion se fait.

Je reste sans voix...

Hors ligne

Pied de page des forums