Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-10-2014 19:04:58

Invité-5
Banni(e)

apt en remplacement d'apt-get/aptitude

J'ai parcouru man apt qui me dit que la troisième commande doit être full-upgrade.

Vous confirmez ou pas ?

#2 10-10-2014 19:18:06

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : apt en remplacement d'apt-get/aptitude

Plop, smile

Déjà, je précise pour ceux qui ne connaissent pas que le binaire « apt » n'est présent qu'à partir de Jessie smile
Il ne dispose pas encore de toutes les fonctionnalités d'apt-get/apt-cache/aptitude, mais en fournit un paquets quand même.

apt full-upgrade et apt dist-upgrade semblent fonctionner tous les deux, mais le man indique effectivement full-upgrade.

Je n'en sais guère plus que ça. Le man indique que la commande « upgrade » sert à mettre à jour tout ce qui est mettable à jour sans retirer de paquets. Et que full-upgrade met tout à jour, quitte à retirer des paquets pour résoudre des conflits.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 10-10-2014 19:58:41

Invité-5
Banni(e)

Re : apt en remplacement d'apt-get/aptitude

Merci chef, je vous tiendrai au courant, car j'ai décidé d'utiliser dorénavant apt tout court.

#4 11-10-2014 11:31:07

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : apt en remplacement d'apt-get/aptitude

"apt upgrade" = "apt-get upgrade --with-new-pkgs"
"apt full-upgrade" = "apt-get dist-upgrade"

Jouer sous Debian ? Facile !

Hors ligne

#5 11-10-2014 23:26:38

avinash
Membre
Lieu : Rosnay 85320
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gestionnaire de fenêtres (xfwm4)
Inscription : 04-06-2013

Re : apt en remplacement d'apt-get/aptitude

Je viens de tester avec apt tout court: ça fonctionne.

Hors ligne

Pied de page des forums