Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-10-2014 13:49:27

enzocalzone
Membre
Inscription : 30-10-2014

Installation en Dual Boot ratée

Bonjour,

Suite à l'infection de ma machine tournant sous un XP "exotique". Je me suis mis en tête d'y installer Debian en Dual Boot avec un xp propre. C'est un Dell avec AMD Athlon 64 5000+ et 2G de Ram et une petite carte graphique Geforce je-sais-plus-quoi LE.
Un ami, Johnny, m'a repartitionné le disque dur et libéré 150G pour y installer un xp avec licence qui tournait sans problèmes (je souhaite garder xp pour de la MAO). Une autre partition de 100G devant recevoir Debian. (J'ai deux autres disques internes pour stocker mes données et documents)
Sur les conseils d'un autre ami, Johnny (c'est chié hien ?), je me suis rendu ici :
http://cdimage.debian.org/cdimage/weekl … -DVD-1.iso
J'y ai téléchargé l'iso du DVD 1. Puis j'ai téléchargé Unetbootin pour créer une clé USB d'installation.
Hier je me suis donc lancé dans l'instal de Debian. J'ai choisi la partition de 100G comme root, je n'ai pas fait de partition Swap. (J'ai remarqué qu'il y avait un dossier Dell sur cette partition, contenant quelques drivers qui ont donc été effacés lors de l'instal. j'avais copié ce dossier dans la partition windows pour ne pas le perdre complètement)
L'installation se termine et tout semble ok.

Problème, quand je choisis de booter xp avec Grub, j'obtiens un message d'erreur. Impossible de lancer Windows.
Debian semble se lancer correctement mais Freeze rapidement au bout de deux minutes maximum. (Freezes assez bourrins avec déformation de l'affichage)
Au démarrage j'ai remarque le message d'erreur suivant : bug 8254 timer not connected to io-apic

Conclusion : la loose totale. Je crois que ça ne pouvait pas plus mal se passer et je ne sais pas trop par où commencer sad

Toute aide sera la bienvenue. Merci d'avance !

Dernière modification par enzocalzone (30-10-2014 13:55:14)

Hors ligne

#2 30-10-2014 14:51:12

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

Salut,

Je ne connais pas ton niveau d'expérience avec Debian, mais par défaut j'aurais essayé d'installer la version stable (wheezy / 7) que tu peux récupérer ici: https://www.debian.org/.
Là tu as récupéré une image de la version testing (la future version de Debian en gros).

Ensuite pourquoi ne pas avoir créer de partition swap? C'est généralement recommandé par le système. Je te propose donc de tenter une réinstallation de Debian avec la version stable, avec le partionnement suivant: XP sur 150 Go, Debian / sur 96 Go et Debian swap sur 4 Go.
Le tutoriel suivant pourra t'aider lors du processus d'installation, je t'en conseille la lecture au préalable: http://debian-facile.org/doc:install:in … n-standard

Bon courage.

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 30-10-2014 16:04:10

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

salut solgalpunx et merci de me conseiller,

Je ne connais pas ton niveau d'expérience avec Debian


C'est simple mon niveau d'expérience est nul ! J'ai suivi les conseils d'un ami pro linux depuis longtemps. C'est lui qui m'a dirigé vers Jessie.

Penses-tu qu'il faille que je commence par réinstaller windows ? Par ce que si j'arrive à installer Debian mais que windows ne se lance pas, je vais être obligé de recommencer les deux install non ?
As-ton avis, pourquoi je n'arrive pas à booter XP depuis Grub (le message d'erreur que je reçoit concerne le disque dur) ?

Hors ligne

#4 30-10-2014 16:16:39

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

enzocalzone a écrit :


C'est simple mon niveau d'expérience est nul ! J'ai suivi les conseils d'un ami pro linux depuis longtemps. C'est lui qui m'a dirigé vers Jessie.


Ce n'est pas un choix que je recommanderai pour un débutant, il implique de comprendre un minimum le système de gestion des paquets et je ne pense pas que tu veuilles t'embêter avec ça pour l'instant smile

enzocalzone a écrit :

Penses-tu qu'il faille que je commence par réinstaller windows ? Par ce que si j'arrive à installer Debian mais que windows ne se lance pas, je vais être obligé de recommencer les deux install non ?


C'est possible mais s'il s'est correctement installé il devrait booter normalement.

enzocalzone a écrit :

As-ton avis, pourquoi je n'arrive pas à booter XP depuis Grub (le message d'erreur que je reçoit concerne le disque dur) ?


Avant de tout réinstaller, essayes de modifier les options de grub:
- lorsque son menu s'affiche appuie sur "e" pour éditer les options;
- trouve la ligne commençant par linux /boot...
- à la fin de celle-ci ajoute noapic
- puis appuie sur F10 pour booter


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#5 30-10-2014 16:54:50

aramis_qc
Membre
Lieu : Québec, Canada
Distrib. : JESSIE
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME 3.14.1
Inscription : 09-06-2007
Site Web

Re : Installation en Dual Boot ratée

Curieux tout cela yikes

J'avais un Win 7 en dual avec Ubuntu 14.04. J'ai ajouté une Debian JESSIE. Tout fonctionnait bien. Puis j'ai sauvegardé mes données et Debian. J'ai réorganisé mes partitions pour supprimer Ubuntu. Ensuite j'ai restauré Debian et apporté les modifications nécessaires à /etc/fstab de Debian pour avoir le portrait de mes partitions après réorganisation. La restauration terminée, j'ai réinstallé le GRUB et mis à jour le fichier de configuration. Tout fonctionne normalement. Je décris cette opération ici,

Hier en fin de journée, j'ai lancé l'installation d'une autre distribution, Funtoo. J'ai complété le tout ce matin sans installer GRUB de Funtoo. J'ai tout simplement redémarré sur Debian et j'ai mis le GRUB à jour. À nouveau tout fonctionne normalement.

Hors ligne

#6 30-10-2014 17:02:45

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

Dans Grub, j'ai ajouté noapic après quiet et tapé F10
Première tentative : je n'ai plus message d'erreur au démarrage mais je n'ai pas pu passer l'étape de l'identification :
Après avoir tapé mon mot de passe, le bureau ne s'est pas affiché - je pouvais quand même bouger la souris par contre.
Deuxième tentative : je passe l'étape identification je tente d'ouvrir Iceweasel et là Freeze. Plus rien ne bouge.

Hors ligne

#7 30-10-2014 17:11:52

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

concernant windows,
il s'était correctement installé et effectivement je ne comprends pas pourquoi depuis l'install de Debian et Grub je ne peut plus lancer XP.
La seule chose qui ait disparu depuis l'instal de Debian étant donc ce dossier Dell qui contenaient des drivers. Mais je sais pas trop à quoi ils servaient, possiblement des restants d'une première instal de xp avortée car commencée sur la mauvaise partition (celle qui reçoit Debian à l'heure actuelle)

Hors ligne

#8 30-10-2014 17:16:36

aramis_qc
Membre
Lieu : Québec, Canada
Distrib. : JESSIE
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME 3.14.1
Inscription : 09-06-2007
Site Web

Re : Installation en Dual Boot ratée

enzocalzone a écrit :

La seule chose qui ait disparu depuis l'instal de Debian étant donc ce dossier Dell qui contenaient des drivers.



Ce sont des pilotes spécifiques à Dell afin que toutes les fonctionnalités de ton PC soient supportées par Windows.

J'ai le même résultat en ce sens que j'ai supprimé cette partition spéciale lors de la réinstallation de Win 7. Plusieurs fonctions de mon portable ne sont plus prises en charge par Windows alors que tout est nickel dans Linux. Mais bon, cela je m'en fous éperdument. Win 7 est là pour une petite application multimédia qui ne tourne que sur Win et si j'arrive à la faire fonctionner en virtuel, je me débarrasserai de Win.

Hors ligne

#9 30-10-2014 17:17:28

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

Bon, c'est déjà encourageant smile
Indépendamment de ce freeze, est-ce que tu as pu booté XP?

Sinon, sous Debian, tu peux essayer de réinstaller grub:

- quand tu arrives sur l'écran de login, tu bascules en console avec la combinaison de touches Ctrl+Alt+F1
- login = root puis tu saisis le mot de passe root que tu as indiqué lors du processus d'installation (si tu as préféré utiliser sudo alors login = nom utilisateur puis tu passes root avec un sudo su)
- grub2-install /dev/sda

Ça va réinstaller grub sur le secteur de démarrage, on verra ce que ça donne. Lors de son installation grub va lister les systèmes trouvés vérifie que ton XP apparait.

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#10 30-10-2014 17:27:47

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

est-ce que tu as pu booté XP?


Dans Grub, je me place sur windows NT/2000/XP (loader) (sur /dev/sdb1) et tape entrée
Je reçoit le message habituel:
Windows n'a pu redémarrer en raison d'un problème de configuration matérielle d'un disque de l'ordinateur.
Impossible de lire à partir du disque de démarrage sélectionné. Vérifiez le chemin d'accès du démarrage et le lecteur de disque. etc.

tu peux essayer de réinstaller grub:


Je vais essayer ça oui !

Hors ligne

#11 30-10-2014 17:30:26

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

@aramis_qc

Salut,
donc si je te suis bien, selon toi la suppression de ce dossier n'est pas la raison pour laquelle windows ne veut plus démarrer. (c'est une bonne nouvelle)

Voilà ce que dit Microsoft à propos de ce message d'erreur :
http://support.microsoft.com/kb/314477/fr

Dernière modification par enzocalzone (30-10-2014 17:52:55)

Hors ligne

#12 30-10-2014 18:01:44

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

@sogalpunx

J'ai réussi à basculer en console,
à la ligne debian login: je tape =root puis entrée
à la ligne passord: qui s'affiche en dessous, mes touches ne répondent pas et je ne peux donc pas rentrer le mdp... étrange.

Dernière modification par enzocalzone (30-10-2014 18:03:13)

Hors ligne

#13 30-10-2014 18:06:24

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

enzocalzone a écrit :

à la ligne passord: qui s'affiche en dessous, mes touches ne répondent pas et je ne peux donc pas rentrer le mdp... étrange


Arf, j'ai oublié de te préciser: c'est NORMAL que rien ne soit renvoyé (affiché), c'est une méthode de sécurité pour éviter à un indiscret de compter les caractères etc...
Tu peux taper ton mot de passe en toute confiance et valider par Entrée wink


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#14 30-10-2014 18:07:45

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

oui c'est ce que je me suis dit !
j'ai donc tenté de taper le mot de passe mais il me répond login incorrect ...
Le clavier ne serait-il pas en qwerty ?

Edit : Non il n'est pas en Qwerty.

Je ne me souviens plus, lors de l'instal, il faut bien le taper deux fois non ce password ?
Si c'est le cas, je suis sur de ne pas me tromper

Edit2 : C'est bon j'ai réussi, pour le login il ne faut pas taper =root mais seulement root

Dernière modification par enzocalzone (30-10-2014 18:29:15)

Hors ligne

#15 30-10-2014 18:26:08

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

enzocalzone a écrit :


Edit2 : C'est bon j'ai réussi, il ne faut pas taper =root mais seulement root



smile en effet! petit astuce du même genre, quand on te donne des options ou des commandes etc... à taper et qu'elles sont encadrées par des "" (ex: "sudo su") il ne faut pas taper les guillemets , c'est un truc bête mais quand on sait pas il arrive de faire l'erreur smile

Dernière modification par sogal (30-10-2014 18:28:57)


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#16 30-10-2014 18:28:26

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

mais quand on sait pas il arrive de faire l'erreur


Effectivement ! Je suis un newbie total en la matière ! big_smile

Donc maintenant j'en suis là :

après root@debian: # j'ai tapé grub2-install/dev/sda
il me répond
-bash: grub2-install/dev/sda: aucun fichier ou dossier de ce type

Dernière modification par enzocalzone (30-10-2014 18:35:15)

Hors ligne

#17 30-10-2014 18:36:40

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

enzocalzone a écrit :


Effectivement ! Je suis un newbie total en la matière ! big_smile
J'ai fini par réussir à rentrer le login et le mdp.
il me répond
-bash: grub2-install/dev/sda: aucun fichier de ce type



Pas de soucis, on a tous commencé par là!

Il y a un espace:

grub2-install /dev/sda


Explications:
grub2-install => c'est la commande qui permet l'installation de grub (dans sa version 2)
/dev/sda => c'est le nom de ton disque principal tel qu'il est listé par le système.

Il y a toujours un espace entre la commande et l'objet sur lequel elle porte.

Tous les périphériques (clavier, souris, disque, etc...) sont représentés par des fichiers qui sont dans le dossier /dev et, en gros, les disques (internes et externes, clé usb) sont nommés sda, sdb, sdc...
A l'intérieur de chaque disque, les partitions sont numérotées:
ex: /dev/sda2 = 2ème partition du 1er disque
ex: /dev/sdc1 = 1ère partition du 3ème disque

Dernière modification par sogal (30-10-2014 18:37:39)


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#18 30-10-2014 18:41:21

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

Ah oui ! merci pour les explications claires.
Par contre il me répond commande introuvable maintenant

Bon je ne sais pas si c'est une bonne idée mais j'ai essayé avec grub-install au lieu de grub2
L'ordi à travaillé (installing for i386-PC platform) il me répond :
Installation terminée sans erreur

Dernière modification par enzocalzone (30-10-2014 18:51:31)

Hors ligne

#19 30-10-2014 18:57:21

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

enzocalzone a écrit :

Bon je ne sais pas si c'est une bonne idée mais j'ai essayé avec grub-install au lieu de grub2


Bon là, il s'agit peut-être d'une erreur de ma part, je suis sous stable (Wheezy) et j'ai tellement travaillé sous openSUSE qui a cette commande que j'ai pu confondre.

Et donc, verdict au redémarrage, il y a du mieux?


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#20 30-10-2014 19:03:56

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

y a-t-il un moyen de redémarrer sans forcer l'ordi à s'éteindre ? Avec une commande ?

Hors ligne

#21 30-10-2014 19:06:18

luxer
Membre
Distrib. : jessie/testing/sid--siduction
Noyau : 3.12-x-686-pae GCC4.8 (i686-linux-gnu)
(G)UI : xfce-4.10.0-5
Inscription : 12-02-2010

Re : Installation en Dual Boot ratée

sudo reboot

si tu as sudo sinon en terminal root

reboot

Dernière modification par luxer (30-10-2014 19:07:04)


Si Beethoven vivait encore il utiliserait lmms sur Debian

Hors ligne

#22 30-10-2014 19:07:40

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

bien sûr pardon:
Pour redémarrer:

reboot


Pour éteindre complétement

halt


ou

shutdown -h -P now


Explications:
shudown provoque l'arrêt du système, l'option -h provoque l'arrêt de la machine après ça, l'option -P facultative s'assure que le courant est coupé et now fait ça immédiatement.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#23 30-10-2014 19:25:16

yoshi
Membre
Lieu : Normandie
Distrib. : PCLinuxOS/Antix/Slackware
Noyau : 4.8.12/4.4.10/4.4.32
(G)UI : Plasma5/Fluxbox/KDE4/Trinity
Inscription : 05-03-2014

Re : Installation en Dual Boot ratée

NB* S'il est sur Jessie, c'est systemd et non sysvinit.

systemctl reboot


pour redémarrer.

 systemctl poweroff


pour arrêter le système.

Dernière modification par yoshi (30-10-2014 19:26:44)


PcLinuxOs KDE Plasma 5.8.4 / Slackware -current KDE 4.14.21 sur workstation bi-processeur AMD Opteron 4234 32 Go DDR-3
antiX 16 rox/fluxbox sur laptop Toshiba Satellite C-660-2D6 Intel core I3 8Go DDR-3
PcLinuxOs Trinity Desktop+Kodi sur media-center HP Intel Celeron 2Go DDR-3

Hors ligne

#24 30-10-2014 21:02:48

enzocalzone
Membre
Inscription : 30-10-2014

Re : Installation en Dual Boot ratée

Malheureusement ça n'a rien changé du tout.

Je me demandais,
est-il possible de simplement formater la partition avec Debian et voir si Windows repart ?
Dans ce cas je retenterai une install de Debian en suivant vos conseils.

Hors ligne

#25 30-10-2014 21:23:11

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : Installation en Dual Boot ratée

enzocalzone a écrit :

Malheureusement ça n'a rien changé du tout.
Je me demandais,
est-il possible de simplement formater la partition avec Debian et voir si Windows repart ?
Dans ce cas je retenterai une install de Debian en suivant vos conseils.


Supprimer ou formater la partition Debian ne changera rien s'il y a un problème avec le chargeur de démarrage et/ou le disque.
Si tu es sûr que ton disque est sain, que ton installation de Windows est correcte, je te dirais bien de réinstaller Debian (je te conseille à nouveau la version stable) proprement en suivant le tuto mentionné plus haut et en faisant bien attention lors du partionnement.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

Pied de page des forums