Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 15-06-2017 16:53:25

daufinsyd
Membre
Lieu : 68, 63, Karlsruhe
Distrib. : Manjaro + Debian Stable + Xubuntu
Noyau : Linux 4.9-amd64
(G)UI : Plasma 5.10
Inscription : 02-02-2013
Site Web

Re : Automatisation de CertBot

Tu as bien activé ssl sur apache et redémarré ce dernier ?


a2enmod ssl
a2ensite default-ssl
service apache2 reload
 



Sur le serveur vérifie que apache écoute bien sur le port 443 avec l'une ou l'autre de ces commandes

lsof -i :443
netstat -lpn | grep 443
 


Aspire V3-772G + SSD 850Evo
Intel i7-4790 - 12Go RAM - GTX460
Intel i7-6700 - 8Go RAM - AMD R9 280X 3Go - SSD 850Evo
Odroid C2, Raspberry Pi Zero

Hors ligne

#27 15-06-2017 16:59:15

hamzouz
Membre
Inscription : 08-06-2017

Re : Automatisation de CertBot

Oui, tout est activé.. J'ai activé tout les modules qui vont bien
Voilà ce que j'obtiens lorsque je tape la commande

root@CertBot:~# lsof -i :443
COMMAND   PID     USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
apache2 25541     root    6u  IPv6  53296      0t0  TCP *:https (LISTEN)
apache2 25624 www-data    6u  IPv6  53296      0t0  TCP *:https (LISTEN)
apache2 25625 www-data    6u  IPv6  53296      0t0  TCP *:https (LISTEN)

Hors ligne

#28 15-06-2017 17:03:27

hamzouz
Membre
Inscription : 08-06-2017

Re : Automatisation de CertBot

Je commence à penser sérieusement qu'il n'est pas possible de délivrer de certificats pour le site de l'entreprise, qu'en penses tu ?
Mise à part les pistes que tu m'as donné, j'ai tenté beaucoup de choses de mon côté et toujours rien pour ce p***n de HTTPS.....

Hors ligne

#29 15-06-2017 17:18:01

daufinsyd
Membre
Lieu : 68, 63, Karlsruhe
Distrib. : Manjaro + Debian Stable + Xubuntu
Noyau : Linux 4.9-amd64
(G)UI : Plasma 5.10
Inscription : 02-02-2013
Site Web

Re : Automatisation de CertBot

Tu arrives à faire tourner le serveur sur le port 80, avec ssl c'est semblable si ce n'est qu'il y a un échange des clefs en plus lors de l'établissement de la connexion entre le serveur et le client (et que la communication est chiffrée).

Peux tu poster le résultat de la deuxième commande (netstat)  ?


Essaye également de te connecter au serveur depuis celui-ci même
Si tu n'as pas d'interface graphique, tu peux installer links (un navigateur pour le terminal) ou bien utiliser la commande wget https://localhost

Aspire V3-772G + SSD 850Evo
Intel i7-4790 - 12Go RAM - GTX460
Intel i7-6700 - 8Go RAM - AMD R9 280X 3Go - SSD 850Evo
Odroid C2, Raspberry Pi Zero

Hors ligne

#30 15-06-2017 17:34:54

hamzouz
Membre
Inscription : 08-06-2017

Re : Automatisation de CertBot

A quel serveur veux tu que je me connecte ? J'ai pas tout saisi, tu veux que je me connecte au serveur hébergeant le site c'est bien ça ?


La commande demandée ci-dessous
root@CertBot:~# netstat -lpn | grep 443
tcp6       0      0 :::443                  :::*                    LISTEN      25541/apache2

Hors ligne

#31 16-06-2017 18:41:45

daufinsyd
Membre
Lieu : 68, 63, Karlsruhe
Distrib. : Manjaro + Debian Stable + Xubuntu
Noyau : Linux 4.9-amd64
(G)UI : Plasma 5.10
Inscription : 02-02-2013
Site Web

Re : Automatisation de CertBot

Celui qui fait tourner ton vhost.

Apache écoute bien sur le port 443 et n'est pas bloqué à l'interface interne (il accepte les connections extérieures à celles du serveur). Tu as dis qu'il n'y avait pas de pare-feu (ni sur le serveur même ni entre ce dernier et l'extérieur).

Vérifie à nouveau que le port 443 est bel et bien redirigé sur ton serveur et d'autre part tente de te connecter à celui-ci en étant à l'intérieur du réseau (en te connectant depuis ton serveur par exemple, sans devoir passer par l'adresse IP publique donc).

Note: en te connectant en ssh sur ton serveur tu peux aussi utiliser nmap

nmap -v -sS localhost -p 443



cette fois-ci il devrait indiquer que le port est ouvert.


Aspire V3-772G + SSD 850Evo
Intel i7-4790 - 12Go RAM - GTX460
Intel i7-6700 - 8Go RAM - AMD R9 280X 3Go - SSD 850Evo
Odroid C2, Raspberry Pi Zero

Hors ligne

Pied de page des forums