Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-07-2017 11:10:03

Philippine
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Xfce
Inscription : 03-12-2015

Problème de dépendances après mise à jour

Hello!

J'ai installé Dflinux il y a un peu plus d'un mois sur un Thinkpad X121. Or, cela ne marche pas si bien que cela: j'ai déjà parlé d'un problème (résolu) avec le trackpad.

Il y a quelques jours, j'ai voulu installer Deluge. J'ai sans doute commis l'erreur ne ne pas faire de mise à jour avant l'installation.
Deluge a désinstallé la moitié de mes applications préférées, et lorsque j'ai voulu les réinstaller la machine a refusé de le faire: "dépendances non satisfaites". J'ai modifié mon sources.list, et à coup de "apt-get update" "apt-get dist-upgrade" et "apt-get autoremove", ai enfin réussi à retrouver mes applications. Mais de nombreux problèmes persistent:

-Easytag a disparu, et je n'arrive pas à le réinstaller à cause de dépendances non satisfaites.

-Au démarrage, j'ai le message suivant, parfaitement incompréhensible:

[/lib/systemd/system/mpd.service:11] Failed to parse resource value, ignoring: -1



-La machine freeze de façon aléatoire, en général quand je suis en train de surfer ou lorsque j'ouvre un gestionnaire de fichiers (thunar). J'ai fait un memtest qui n'a rien montré d'anormal.

-La commande sudo systemctl hibernate, qui jusqu'à présent faisait hiberner la machine, la fait redémarrer après un long temps d'attente (pas de message d'erreur lorsque je la lance dans un terminal). Tout cela commence à faire beaucoup...

Voici le contenu du sources.list:

deb http://deb.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
deb http://www.deb-multimedia.org jessie main
deb http://deb.debian.org/debian jessie-backports main contrib non-free
 



Merci d'avance pour les pistes que vous pourrez me donner!

Edit à toto :
Les sources en couleur avec la balise Code du forum option : apt_sources dans la liste déroulante :

deb http://deb.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://deb.debian.org/debian/ jessie-updates main contrib non-free
deb http://www.deb-multimedia.org jessie main
deb http://deb.debian.org/debian jessie-backports main contrib non-free

Dernière modification par Philippine (03-07-2017 11:13:15)

Hors ligne

#2 03-07-2017 13:39:16

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Problème de dépendances après mise à jour

Bonjour smile
Peux tu nous donner le retour de

apt-cache policy deluge

Hors ligne

#3 03-07-2017 13:43:18

Philippine
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Xfce
Inscription : 03-12-2015

Re : Problème de dépendances après mise à jour

Salut smile

Voilà:

sudo apt-cache policy deluge
deluge:
  Installé : 1.3.13+git20161130.48cedf63-3
  Candidat : 1.3.13+git20161130.48cedf63-3
 Table de version :
 *** 1.3.13+git20161130.48cedf63-3 100
        100 /var/lib/dpkg/status
     1.3.10-3+deb8u1 500
        500 http://security.debian.org jessie/updates/main i386 Packages
     1.3.10-3 500
        500 http://deb.debian.org/debian jessie/main i386 Packages

Hors ligne

#4 03-07-2017 13:47:43

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Problème de dépendances après mise à jour

Et avec easytag maintenant

apt-cache policy easytag

Hors ligne

#5 03-07-2017 13:51:14

Philippine
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Xfce
Inscription : 03-12-2015

Re : Problème de dépendances après mise à jour

...j'ai essayé ceci:

sudo aptitude install easytag
[sudo] Mot de passe de philippine : 
Les NOUVEAUX paquets suivants vont être installés :    
  easytag libid3-3.8.3c2a{a} libopusfile0{a} libtag-extras1{a}
  libtag1-vanilla{a} libtag1c2a{a}
Les paquets suivants seront ENLEVÉS :
  deluge-common{u} deluge-gtk{u} fonts-freefont-ttf{u}
  libboost-chrono1.62.0{u} libboost-python1.62.0{u}
  libboost-random1.62.0{u} libsdl-image1.2{u} libsdl-mixer1.2{u}
  libsdl-ttf2.0-0{u} libsmpeg0{u} libtorrent-rasterbar9{u}
  musescore-soundfont-gm{u} python-attr{u} python-click{u}
  python-colorama{u} python-constantly{u} python-incremental{u}
  python-libtorrent{u} python-notify{u} python-pam{u}
  python-pyasn1-modules{u} python-pygame{u} python-serial{u}
  python-service-identity{u} python-twisted-bin{u} python-twisted-core{u}
  python-twisted-web{u} python-zope.interface{u} timgm6mb-soundfont{u}
0 paquets mis à jour, 6 nouvellement installés, 29 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1 259 ko d'archives. Après dépaquetage, 46,4 Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 libtag1v5 : Est en conflit avec: libtag1c2a but 1.9.1-2.1 is to be installed
 libtag1v5-vanilla : Casse: libtag1-vanilla but 1.9.1-2.1 is to be installed
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                              
1)      ario [1.5.1-1.3+b3 (now)]                                    
2)      gstreamer1.0-plugins-good [1.10.4-1 (now)]                  
3)      libtag1v5 [1.11.1+dfsg.1-0.1 (now)]                          
4)      libtag1v5-vanilla [1.11.1+dfsg.1-0.1 (now)]                  
5)      libtagc0 [1.11.1+dfsg.1-0.1 (now)]                          
6)      quodlibet [3.7.1-2 (now)]                                    
7)      soundconverter [3.0.0~alpha1+git20151209-1 (now)]            
8)      tellico [2.3.9+dfsg.1-1.1+b1 (now)]                          
9)      xcfa [5.0.2-1+b1 (now)]                                      

      Leave the following dependencies unresolved:                  
10)     ario-common recommande ario                                  
11)     tellico-doc recommande tellico                              
12)     libwebkit2gtk-4.0-37 recommande gstreamer1.0-plugins-good    
13)     tellico-data recommande tellico                              
14)     tellico-scripts recommande tellico                          
15)     phonon-backend-gstreamer recommande gstreamer1.0-plugins-good



Accepter cette solution ? [Y/n/q/?]



Super, il me propose de désinstaller des trucs que j'utilise tous les jours hmm

Hors ligne

#6 03-07-2017 13:52:46

Philippine
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Xfce
Inscription : 03-12-2015

Re : Problème de dépendances après mise à jour

...réponse au post #4:

sudo apt-cache policy easytag
easytag:
  Installé : (aucun)
  Candidat : 1:2.2.6-dmo1
 Table de version :
     1:2.2.6-dmo1 500
        500 http://www.deb-multimedia.org jessie/main i386 Packages
     2.4.3-1~bpo8+1 100
        100 http://deb.debian.org/debian jessie-backports/main i386 Packages
     2.2.4-1 500
        500 http://deb.debian.org/debian jessie/main i386 Packages
 

Hors ligne

#7 03-07-2017 14:07:59

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Problème de dépendances après mise à jour

Bon .... on a l'explication des logiciels qui ont disparu et ne veulent pas se réinstaller. Tu utilises le dépôt multimédia qui a des paquets qui sont parfois en commun avec Jessie mais en version plus élevée ce qui perturbe le fonctionnement du système. C'est ce qu'on nomme une frankendebian.
Pour un retour à un système stable il faudrait enlever ce qui provient des dépôts externes et installer des versions de Jessie si ce sont des paquets systèmes. Mais je ne saurais pas te guider sur ce coup.
D'un autre côté si ton PC est assez récent et moyennement bien pris en charge par  Jessie comme indiqué dans ton premier message, tu aurais peut-être intérêt à passer à stretch en refaisant une installation propre.

Hors ligne

#8 03-07-2017 14:34:48

Philippine
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Xfce
Inscription : 03-12-2015

Re : Problème de dépendances après mise à jour

Ah, merci de ton explication. Je ne savais pas qu'il existait une nouvelle version de Debian, je vais voir ça pour faire une installation propre.

Bonne journée

Hors ligne

Pied de page des forums