Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-09-2017 20:24:42

calixtus06
Membre
Distrib. : Librazik
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : mate
Inscription : 25-03-2016

message d'erreur lors de la mise à jour d'Handy linux

Bonjour, mon beau père a ce message d'erreur lors du déclenchement de la mise à jour :

"root@camille:~# dpkg --configure -a && apt-get -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" --yes --force-yes upgrade && apt-get -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" --yes --force-yes dist-upgrade && exit 0 || exit 1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
firefox-l10n-fr : Dépend: firefox (>= 47.0-1~bpo80+1) mais il n'est pas installé
                   Dépend: firefox (< 47.0-1~bpo80+1.1~) mais il n'est pas installé"

Comment résoudre ce problème.

Merci d'avance

Nico

Hors ligne

#2 13-09-2017 20:36:26

calixtus06
Membre
Distrib. : Librazik
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : message d'erreur lors de la mise à jour d'Handy linux

J'ai fait des apt update, des apt upgrade , des apt -f install mais j'ai des messages d'installation non faites :

apt  -f install



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  epiphany-browser-data libavahi-gobject0 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-4.0-18 libmozjs185-1.0 libvncserver0
  libwebkit2gtk-4.0-37 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common
  libxcb-icccm4 libxcb-image0 suckless-tools
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  firefox-l10n-fr
Les paquets suivants seront mis à jour :
  firefox-l10n-fr
1 mis à jour, 0 nouvellement installés, 0 à enlever et 97 non mis à jour.
Il est nécessaire de prendre 2 202 o dans les archives.
Après cette opération, 683 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] O
ATTENTION : les paquets suivants n'ont pas été authentifiés.
  firefox-l10n-fr
Faut-il installer ces paquets sans vérification ? [o/N] o
Err http://mozilla.debian.net/ jessie-backports/firefox-release firefox-l10n-fr all 52.0-1~bpo80+1
  404  Not Found [IP : 130.89.148.14 80]
E: Impossible de récupérer http://mozilla.debian.net/pool/firefox-release/f/firefox/firefox-l10n-fr_52.0-1~bpo80+1_all.deb  404  Not Found [IP : 130.89.148.14 80]

E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?



Voili si quelqu'un peut m'aider , merci d'avance

Hors ligne

#3 13-09-2017 20:56:07

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : message d'erreur lors de la mise à jour d'Handy linux

Bonjour,
Commence déjà par supprimer le dépôt mozilla qui n'existe plus pour jessie. Tu peux passer par Synaptic > Configuration > dépôts
Tu sélectionnes la lignes qui commences par http://mozilla.debian.net/ et tu cliques sur supprimer (ou enlever) puis tu valides et recharges les paquets.
Tu peux le faire avec le terminal :

sudo rm /etc/apt/sources.list.d/mozilla.list



Une fois supprimé, tu fais une mise à jour pour voir si les mises à jour passent

sudo apt-get update && sudo apt-get upgrade


Et si ça ne va pas, fais un copier coller du retour de la commande smile

Hors ligne

#4 14-09-2017 08:27:21

calixtus06
Membre
Distrib. : Librazik
Noyau : Linux 4.7.0-0.bpo.1-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : message d'erreur lors de la mise à jour d'Handy linux

Chalu !
J'ai décoché la ligne concernant mozilla dans les dépots ( basée sur jessie backport et non jessie ?)

et l'update me donne ça :
file-R6ed1185504eb2c7c7d6c1dd3026bad4e

https://debian-facile.org/images/file-R … d3026bad4e

Hors ligne

#5 14-09-2017 12:59:44

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : message d'erreur lors de la mise à jour d'Handy linux

Ok ça doit être l'adresse du dépôt handylinux qui a été modifiée. Il me semble m'en souvenir.
Je vais chercher mais si un membre de DF utilise Handylinux 2 à jour et nous donne sa liste dépôts, ça aidera smile

Edit : trouvé ici

##DEBIAN Jessie##
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie-updates main contrib non-free
#deb http://httpredir.debian.org/debian/ jessie-proposed-updates main contrib non-free
#deb-src http://httpredir.debian.org/debian/ jessie-proposed-updates main contrib non-free



## HandyLinux Jessie ##
deb http://lescahiersdudebutant.fr/handylinux/repo/debian jessie main
#deb-src http://lescahiersdudebutant.fr/handylinux/repo/debian jessie main


Vérifie que tu as les mêmes lignes actives, pas de non-free pour les dépôts handylinux seulement main.
Je pense que si tu fais

sudo apt-get update

et ensuite

sudo apt-get upgrade


Le Système se mettra à jour même si tu as des erreurs de dépôts
Les mises à jour se font sur les dépôts Debian principalement maintenant.

Hors ligne

Pied de page des forums