Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-09-2017 23:37:16

Pat'Atome
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
(G)UI : Gnome Version 3.22.2
Inscription : 13-09-2017

[Résolu] Problème d'installation de mise à jour

Salut après pusieurs tentative d'installation à cause d'une mauvaise connexion et près de presque une semaine sous debian, je me suis fais la remarque n'ayant pas eu une seul mise à jour, de savoir si javais pas un problème dans mon installation et aujourd'hui j'ai reçu une notification : quatre mises à jour en attente

bluetooth
bluez
bluez-obexd
libbluetooth3

En cliquant sur mettre à jour maintenant voici le message affiché : E: dpkg a été interrompu, il est nécessaire d'utiliser << dpkg --configure -a >> pour corriger le problème.

Que faut-il faire pour y remédier?
Y a t-il un moyen de tester le système entier avec une ligne de commande, et le cas échéant revoir si toutes les mises à jour lors de l'installation se sont bien installer?

Si qu'un qu'un répond merci de ne pas trop utiliser de termes technicotechnique kernal_panic.gif

Bien à vous ; )

Dernière modification par Pat'Atome (15-09-2017 00:12:42)

Hors ligne

#2 14-09-2017 06:42:31

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.11.0-2-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Problème d'installation de mise à jour

Salut,

Alors pour faire ce qu'il te dit : E: dpkg a été interrompu, il est nécessaire d'utiliser << dpkg --configure -a >> pour corriger le problème

tu ouvres un terminal,
tu dois être root pour que la commande dpkg --configure -a puisse fonctionner ( gestion des paquets est réservée à l'administrateur ( root ) ) ,
pour passer en root :

su


tu dois renseigner ton mot de passe root en aveugle, rien ne s'affiche quand tu le tapes pour raison de sécurité


dpkg --configure -a


si tout se passe bien, tu rafraichis la liste des paquets disponibles :

apt update


et tu fais tes mises à jour :

apt upgrade



Les pages du wiki qui expliquent :
root -> https://debian-facile.org/doc:systeme:superutilisateur
Gestion des paquets avec APT -> https://debian-facile.org/doc:systeme:apt:apt
smile

Dernière modification par nono47 (14-09-2017 06:50:03)

Hors ligne

#3 14-09-2017 10:36:00

Pat'Atome
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
(G)UI : Gnome Version 3.22.2
Inscription : 13-09-2017

Re : [Résolu] Problème d'installation de mise à jour

Super merci nono47 pour ton explication super d'avoir pris le temps de me répondre.
Je me suis même posé si j'avais posté sur la bonne rubrique?
Je me doute que ça doit pas être évident de répondre ainsi et se mettre au niveau d'un débutant wink Preuve d'humilité de ta part zen.gif
Donc ça a bien fonctionné, merci pour le lien, j'ai pas eu le reflex.
Mais il y a pas un gestionnaire de mise à jour?
J'ai installé un bouton de notification mais apparemment je peux pas les installer avec?

Hors ligne

#4 14-09-2017 12:03:04

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Problème d'installation de mise à jour

Pat'Atome a écrit :

J'ai installé un bouton de notification mais apparemment je peux pas les installer avec?


Ouvre un n'ôtre post pour ce problème et indique que celui d'ici est résolu comme chat :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

smile

Dernière modification par smolski (15-09-2017 05:57:53)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 15-09-2017 00:11:25

Pat'Atome
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
(G)UI : Gnome Version 3.22.2
Inscription : 13-09-2017

Re : [Résolu] Problème d'installation de mise à jour

Oups c'est fichu pour le chocolat sad

Dernière modification par Pat'Atome (15-09-2017 00:12:04)

Hors ligne

#6 15-09-2017 05:58:39

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] Problème d'installation de mise à jour

Non, rien ne se perd car c'est bibi qui colle le point chocodf dans sa besace !

smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#7 Hier 11:37:12

Pat'Atome
Membre
Distrib. : Debian GNU/Linux 9 (stretch) 64 bits
(G)UI : Gnome Version 3.22.2
Inscription : 13-09-2017

Re : [Résolu] Problème d'installation de mise à jour

lol

Hors ligne

Pied de page des forums