Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-09-2017 00:25:32

cdo
Membre
Distrib. : Debian 3.16.43-2+deb8u2
Noyau : Linux 3.16.0-4-686-pae
(G)UI : XFCE
Inscription : 25-03-2017

Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Bonjour,

Depuis hier, toute sauvegarde automatique est  impossible chez moi avec deja-dup qui me sort :

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1509, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1503, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1352, in main
    do_backup(action)
  File "/usr/bin/duplicity", line 1381, in do_backup
    sync_archive(decrypt)
  File "/usr/bin/duplicity", line 1112, in sync_archive
    remote_metafiles, ignored, rem_needpass = get_metafiles(remlist)
  File "/usr/bin/duplicity", line 1004, in get_metafiles
    pr = file_naming.parse(fn)
  File "/usr/lib/python2.7/dist-packages/duplicity/file_naming.py", line 396, in parse
    pr = check_full()
  File "/usr/lib/python2.7/dist-packages/duplicity/file_naming.py", line 315, in check_full
    t = str2time((m1 or m2).group("time"), short)
  File "/usr/lib/python2.7/dist-packages/duplicity/file_naming.py", line 288, in str2time
    t = dup_time.genstrtotime(timestr.upper())
  File "/usr/lib/python2.7/dist-packages/duplicity/dup_time.py", line 278, in genstrtotime
    return override_curtime - intstringtoseconds(timestr)
  File "/usr/lib/python2.7/dist-packages/duplicity/dup_time.py", line 190, in intstringtoseconds
    error()
  File "/usr/lib/python2.7/dist-packages/duplicity/dup_time.py", line 181, in error
    raise TimeException(bad_interval_string % interval_string)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xdd in position 15: ordinal not in range(128)



J'ai vu qu'il existe des versions plus récente de deja-dup (ex : 36.0) que j'utilise en 32.0.
Comme je me demande si mon problème ne serait pas résolu par une version plus récente du moteur duplicity (0.6.24 dans mon cas alors qu'il existe une 0.7.14) et donc de deja-dup qui l'utilise, je me demande pourquoi Jessie reste scotchée à la 32.0 (pas de mise à jour automatique). J'imagine qu'il y a une bonne raison, mais je n'ai pas trouvé laquelle dans mes recherches.
Quelqu'un a-t-il la réponse à cette question ainsi qu'une solution à mon problème ?

Edit à bendia : Voir le tuto : Le code, ça pique moins les yeux en couleur wink

Hors ligne

#2 13-09-2017 09:43:22

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Bonjour
La version de Jessie fonctionne très bien, vérifie que les répertoires sauvegardé et répertoires de destinations pour la sauvegarde soient bon
Il se peut qu'ils aient été déplacé , renommé, ou supprimé par erreur

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 14-09-2017 00:00:17

cdo
Membre
Distrib. : Debian 3.16.43-2+deb8u2
Noyau : Linux 3.16.0-4-686-pae
(G)UI : XFCE
Inscription : 25-03-2017

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Oui, pour moi aussi deja-dup 32.0 de Jessie fonctionnait très bien...jusqu'à avant hier ! :-)
J'ai vérifié que les répertoires sources et cibles n'ont pas bougé.
Ce problème semble assez classique : https://askubuntu.com/questions/901319/ … hon/902830.
Mais je ne sais pas comment savoir quel nom de fichier pose problème sinon je pourrais le renommer afin de ne pas utiliser de caractère UniCode.

Hors ligne

#4 14-09-2017 10:51:58

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Sur une semaine y'a peut être moyen de se souvenir quel fichiers pourraient poser problème
essai voir en listant les fichiers du répertoire que tu sauvegardes

ls -laR ~/Téléchargements | grep 2017 | grep sept


affiche les fichiers et fichiers caché de septembre 2017 du répertoire Téléchargements


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 15-09-2017 00:37:54

cdo
Membre
Distrib. : Debian 3.16.43-2+deb8u2
Noyau : Linux 3.16.0-4-686-pae
(G)UI : XFCE
Inscription : 25-03-2017

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Ouhhh, je sens une petite pointe d'ironie qui sonne comme un reproche dans ta première phrase. C'est vilain, ça ! smile
Ah mon tour : ben, tu te doutes bien que je l'ai déjà fait (en fait non, tu ne peux évidemment pas t'en douter puisque je ne l'avais pas encore dit et que tu n'es pas dans ma tête. Comme quoi les commentaires gratuits de ce genre sont inutiles ! :-))...

ls -alRt | grep "sept\. " | grep -v "sept. 13" | grep -v "sept. 12" | grep -v "sept.  6" | grep -v "sept.  5" | grep -v "sept.  4" | grep -v "sept.  3" | grep -v "sept.  2" | grep -v "sept.  1" | grep -v "20.." | more


...et que je n'ai pas trouvé, noyé dans les nombreux fichiers du genre :

-rw------- 1 christophe christophe    7552 sept. 14 00:57 B0DD8F2642431F609CEC68
AED30DC4CD2764DB9D
-rw------- 1 christophe christophe    2297 sept. 14 00:44 216D402DCF427E321F8919
3D3BFACFC4F55155FF
-rw------- 1 christophe christophe    2297 sept. 14 00:34 C3EBFD0C3934AD28B019EF
2D90722A6DC9CDAD82
-rw------- 1 christophe christophe    2297 sept. 14 00:32 40143FEAEAB6589352D9FD



D'autre part, j'ai exclu "Téléchargement" de la sauvegarde automatique.

Donc, tu ne me conseilles pas de passer "tout simplement" (je ne sais pas si c'est envisageable d'ailleurs) à deja-dup 36.0 ? A cause des dépendances que cette version tire ?

Hors ligne

#6 15-09-2017 05:49:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

cdo a écrit :

Ouhhh, je sens une petite pointe d'ironie qui sonne comme un reproche dans ta première phrase. C'est vilain, ça !


Une mesure de rétortion est d'ailleurs envisageable, peut-être la suppression d'un point choco df du membre df ?
Mais bon, il est probable que cela serait trop cruel...


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#7 15-09-2017 10:29:50

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Bonjour
J'avais pourtant changé ma phrase pour quelle ne paraisse pas ironique, bon ba c'est loupé pour le coup
--------------------------------------------------
Pour me faire pardonner une petite parenthèse:
Action personnalisé Thunar : Déja-dup pour choix du fichier à restaurer
Thunar , Edtion , configurer les actions personnalisées
Nom : restauration ancienne version
Description: restaure fichier(s) ou dossier(s) via Déja-dup
Commande: deja-dup --restore %F
utiliser la notification de démarrage
Onglet conditions d'apparition : tout cocher , motif de fichier *
Les dossiers ou fichiers doivent exister, si ils ont été effacé par erreur et qu'ils n'apparaissent pas dans la corbeille
Il faudra créer un vide avec un nom identique a celui de la sauvegarde ou passer par déja-dup et restaurer dans un répertoire dédié
y8cEGBtl5r6U.png9PjYhLkOQx4V.png
Sources:https://www.linuxliteos.com/forums/tuto … in-thunar/
-------------------------------------------------------------------------------
Je n'ai pas vu de version 36, au maximum 35.6 dans dépôt sid
Au pire tu peux tenter si tu ne trouve pas de fichiers suspect
Je regarde si il y aurait pas des notes sur les differentes version, souvent il y a mentionné les bugs corrigé
Edit rien de mieux dans les nouvelles version, du il me semble...dur à décrypter
http://metadata.ftp-master.debian.org/c … _changelog

Dernière modification par Croutons (15-09-2017 12:04:05)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 19-09-2017 02:14:03

cdo
Membre
Distrib. : Debian 3.16.43-2+deb8u2
Noyau : Linux 3.16.0-4-686-pae
(G)UI : XFCE
Inscription : 25-03-2017

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Désolé, mais je ne comprends pas pourquoi tu m'expliques comment effectuer une restauration alors que mon problème concerne le processus de sauvegarde...
J'ai vu la 36.1 ici : https://launchpad.net/deja-dup
et je vois que la 35.3 (https://launchpad.net/deja-dup/+announc … =5&start=5) contient des corrections relatives au UniCode.
Je testerai bien celle-là... ou carrément la dernière.

Hors ligne

#9 04-10-2017 00:57:57

cdo
Membre
Distrib. : Debian 3.16.43-2+deb8u2
Noyau : Linux 3.16.0-4-686-pae
(G)UI : XFCE
Inscription : 25-03-2017

Re : Jessie : erreur de sauvegarde avec deja-dup : UnicodeDecodeError

Bonjour,
J'ai repris le sujet....avant que mon disque dur interne ne crashe ! :-)
Après consultation des instructions du fichier HACKING et installation de "meson", la compil de la 35.3 est ko :

~/Téléchargements/deja-dup-35.3$ make
Error during basic setup:
[Errno 2] No such file or directory: '/home/christophe/Téléchargements/deja-dup-35.3/builddir'
Makefile:26: recipe for target 'builddir' failed
make: *** [builddir] Error 1


--> je crée le rép buildir pour voir :

~/Téléchargements/deja-dup-35.3$ make
ninja -C builddir
ninja: Entering directory `builddir'
ninja: error: loading 'build.ninja': No such file or directory
Makefile:20: recipe for target 'all' failed
make: *** [all] Error 1


et là, je sèche malgré le sujet prometteur https://answers.launchpad.net/deja-dup/+question/656820
Quelqu'un a-t-il déjà recompilé avec succès deja-dup ?

Dernière modification par cdo (09-10-2017 23:29:50)

Hors ligne

Pied de page des forums