Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-09-2017 15:14:33

minween
Membre
Inscription : 16-09-2017

[Résolu] Disque dur non détecté avec kernel 4.XX +

Bonjour,

Alors je fais fasse à un étrange problème.
Lorsque j'installe une distribution ou que je lance un OS via live usb, si la version du kernel est supérieur à 3.16 (donc 4.XX) mon disque dur n'est plus détecté uniquement les clés usb branché peuvent être détecté.

Je sais cela car j'ai déjà installé debian jessie (kernel 3.16) qui lui détecte mon disque dur.
Pareil pour un live gparted ( avec un kernel 3.16) mon disque est détecté et ubuntu aussi.

Mais si je souhaite installer un linux ou lancé un live usb avec une version récente les disques dur sont à nouveau plus détecté car le kernel est (4.XX).

Si quelqu'un aurais une idée d'ou pourrais venir ce problème.


Solution:

raleur a écrit :

Ah, le contrôleur SATA est en mode RAID. J'ai déjà vu passer ce genre de problème ailleurs. Le mode RAID n'a aucun intérêt, est-il possible mettre le contrôleur en mode SATA standard (AHCI) dans les réglages du BIOS/UEFI ?


minween a écrit :

Je suis allez sur le site du constructeur afin de regarder les mise a jour bios car je ne comprenais pas pourquoi je ne pouvais changer le mode RAID alors que dans le bios une option propose de le changer mais je pouvais choisir seulement le mode RAID.

J'ai donc effectué une mise a jour de bios, par la suite je pouvais changer en mode ahci et surprise les kernel 4.XX peuvent à nouveau détecter mon disque dur.

Edit: je viens de voir ton message, oui  @raleur c’était bien cela le problème merci de ton aide.

Dernière modification par minween (18-09-2017 15:16:32)

Hors ligne

#2 16-09-2017 19:27:46

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Quel est le modèle de disque dur et de contrôleur SATA ?
Tu peux identifier le contrôleur SATA et son pilote avec

lspci -k


Tu peux aussi comparer les messages du noyau relatifs aux disques ATA :

dmesg | egrep -i "ata|sd"

Hors ligne

#3 17-09-2017 14:55:21

minween
Membre
Inscription : 16-09-2017

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

raleur a écrit :

Quel est le modèle de disque dur et de contrôleur SATA ?
Tu peux identifier le contrôleur SATA et son pilote avec

lspci -k


Tu peux aussi comparer les messages du noyau relatifs aux disques ATA :

dmesg | egrep -i "ata|sd"



Je présume que ce que tu cherche est :
00:17.0 RAID bus controller: Intel Corporation 82801 SATA Controller [RAID mode] (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
  Kernel driver in use: ahci

PS: J'ai exec les commandes sur un kernel 3.16 qui detecte mes disks

Commandes:
@debian:~$

lspci -k


00:00.0 Host bridge: Intel Corporation Device 1910 (rev 07)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:01.0 PCI bridge: Intel Corporation Device 1901 (rev 07)
  Kernel driver in use: pcieport
00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 07)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:14.0 USB controller: Intel Corporation Device a12f (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 201f
  Kernel driver in use: xhci_hcd
00:14.2 Signal processing controller: Intel Corporation Device a131 (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:15.0 Signal processing controller: Intel Corporation Device a160 (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:15.1 Signal processing controller: Intel Corporation Device a161 (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:16.0 Communication controller: Intel Corporation Device a13a (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:17.0 RAID bus controller: Intel Corporation 82801 SATA Controller [RAID mode] (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
  Kernel driver in use: ahci
00:1c.0 PCI bridge: Intel Corporation Device a112 (rev f1)
  Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation Device a113 (rev f1)
  Kernel driver in use: pcieport
00:1c.4 PCI bridge: Intel Corporation Device a114 (rev f1)
  Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Device a150 (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:1f.2 Memory controller: Intel Corporation Device a121 (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
00:1f.3 Audio device: Intel Corporation Device a170 (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
  Kernel driver in use: snd_hda_intel
00:1f.4 SMBus: Intel Corporation Device a123 (rev 31)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1618 (rev a1)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
  Kernel driver in use: nvidia
01:00.1 Audio device: NVIDIA Corporation Device 0fbb (rev a1)
  Subsystem: ASUSTeK Computer Inc. Device 1ced
  Kernel driver in use: snd_hda_intel
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
  Subsystem: Intel Corporation Dual Band Wireless-AC 7265
  Kernel driver in use: iwlwifi
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
  Subsystem: ASUSTeK Computer Inc. Device 200f
  Kernel driver in use: r8169



@debian:~$

dmesg | egrep -i "ata|sd"


[    0.000000] ACPI: RSDP 0x0000000036D2E000 000024 (v02 _ASUS_)
[    0.000000] ACPI: XSDT 0x0000000036D2E0A8 0000D4 (v01 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: DSDT 0x0000000036D2E210 0290B7 (v02 _ASUS_ Notebook 01072009 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D575F8 000315 (v01 SataRe SataTabl 00001000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D57A70 000248 (v02 INTEL  sensrhub 00000000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D57D48 00337E (v02 DptfTa DptfTabl 00001000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D5B0C8 005741 (v02 SaSsdt SaSsdt   00003000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D60858 000E58 (v02 CpuRef CpuSsdt  00003000 INTL 20120913)
[    0.000000] ACPI: UEFI 0x0000000036D61768 00063A (v01 INTEL  RstSataE 00000000 ??   00000000)
[    0.000000] ACPI: UEFI 0x0000000036D61DA8 00005C (v01 INTEL  RstSataV 00000000 ??   00000000)
[    0.000000] ACPI: MSDM 0x0000000036188F18 000055 (v03 _ASUS_ Notebook 00000000 ASUS 00000001)
[    0.000000]   NODE_DATA [mem 0x4c67f7000-0x4c67fbfff]
[    0.000000] Memory: 16338500K/16714252K available (5244K kernel code, 948K rwdata, 1836K rodata, 1208K init, 840K bss, 375752K reserved)
[    0.403473] ACPI: SSDT 0xFFFF8804B51C3400 00037F (v02 PmRef  Cpu0Cst  00003001 INTL 20120913)
[    0.404386] ACPI: SSDT 0xFFFF8804B515B000 0005DC (v02 PmRef  Cpu0Ist  00003000 INTL 20120913)
[    0.431990] ACPI: SSDT 0xFFFF8804C583D800 0005AA (v02 PmRef  ApIst    00003000 INTL 20120913)
[    0.443464] ACPI: SSDT 0xFFFF8804B5159400 000119 (v02 PmRef  ApCst    00003000 INTL 20120913)
[    0.471009] _OSC request data:1 1f 0
[    0.510044] ACPI : EC: GPE = 0x23, I/O: command/status = 0x66, data = 0x62
[    0.767959] Write protecting the kernel read-only data: 8192k
[    0.801917] libata version 3.00 loaded.
[    0.805509] ahci 0000:00:17.0: flags: 64bit ncq pm led clo only pio slum part ems deso sadm sds apst
[    0.817897] ata1: SATA max UDMA/133 abar m524288@0xda100000 port 0xda100100 irq 16
[    0.817901] ata2: SATA max UDMA/133 abar m524288@0xda100000 port 0xda100180 irq 16
[    1.136628] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    1.136649] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    1.137767] ata1.00: ATA-8: HGST HTS721010A9E630, JB0OA3J0, max UDMA/133
[    1.137769] ata1.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    1.139001] ata1.00: configured for UDMA/133
[    1.139133] scsi 0:0:0:0: Direct-Access     ATA      HGST HTS721010A9 A3J0 PQ: 0 ANSI: 5
[    1.139647] ata2.00: ATAPI: MATSHITA DVD-RAM UJ8HC, 1.00, max UDMA/100
[    1.142087] ata2.00: configured for UDMA/100
[    1.157661] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[    1.157663] sd 0:0:0:0: [sda] 4096-byte physical blocks
[    1.157912] sd 0:0:0:0: [sda] Write Protect is off
[    1.157915] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.157994] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.173781] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    1.229584]  sda: sda1 sda2 sda3 sda4 sda5 sda6
[    1.230523] sd 0:0:0:0: [sda] Attached SCSI disk
[    1.904037] EXT4-fs (sda4): mounted filesystem with ordered data mode. Opts: (null)
[    3.669821] systemd[1]: Expecting device dev-sda5.device...
[    3.670151] systemd[1]: Starting Increase datagram queue length...
[    3.946654] systemd[1]: Started Increase datagram queue length.
[    5.919901] EXT4-fs (sda4): re-mounted. Opts: errors=remount-ro
[    7.590770] Adding 4414460k swap on /dev/sda5.  Priority:-1 extents:1 across:4414460k FS
[    7.758874] FAT-fs (sda3): utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[    8.747460] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[    9.943204] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
 



Edit à toto :

Les balises Commande du forum s'accompagnent automatiquement d'un bloc marqué à supprimer si il n'y a pas de retour où l'on colle le retour donné par la commande.
Mis les balises Commande user du post en conformité.

Hors ligne

#4 17-09-2017 15:07:58

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Ah, le contrôleur SATA est en mode RAID. J'ai déjà vu passer ce genre de problème ailleurs. Le mode RAID n'a aucun intérêt, est-il possible mettre le contrôleur en mode SATA standard (AHCI) dans les réglages du BIOS/UEFI ?

Et je voudrais aussi les mêmes informations avec un noyau qui ne détecte par le disque pour comparer.

Dernière modification par raleur (17-09-2017 15:08:11)

Hors ligne

#5 17-09-2017 16:43:17

minween
Membre
Inscription : 16-09-2017

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Dans les paramètres eufi d'asus il y'a bien une option pour modifier le contrôleur SATA mais etonnament je peut faire qu'un seul choix qui est le mode RAID. Je vais essayer de voir si c'est pas une secure ou autre  qui me force à 1 seul choix en attendant:




Commandes effectué sur un live Gparted kernel 4.XX :
@debian:~$

lspci -k



00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
    Subsystem: ASUSTeK Computer Inc. Skylake Host Bridge/DRAM Registers
    Kernel driver in use: skl_uncore
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 07)
    Subsystem: ASUSTeK Computer Inc. Skylake Processor Thermal Subsystem
    Kernel driver in use: proc_thermal
    Kernel modules: processor_thermal_device
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H USB 3.0 xHCI Controller
    Kernel driver in use: xhci_hcd
    Kernel modules: xhci_pci
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H Thermal subsystem
    Kernel driver in use: intel_pch_thermal
    Kernel modules: intel_pch_thermal
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H Serial IO I2C Controller
    Kernel driver in use: intel-lpss
    Kernel modules: intel_lpss_pci
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H Serial IO I2C Controller
    Kernel driver in use: intel-lpss
    Kernel modules: intel_lpss_pci
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H CSME HECI
    Kernel driver in use: mei_me
    Kernel modules: mei_me
00:17.0 RAID bus controller: Intel Corporation SATA Controller [RAID mode] (rev 31)
    Subsystem: ASUSTeK Computer Inc. SATA Controller [RAID mode]
    Kernel driver in use: ahci
    Kernel modules: ahci
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
    Kernel driver in use: pcieport
    Kernel modules: shpchp
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H LPC Controller
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H PMC
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H HD Audio
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
    Subsystem: ASUSTeK Computer Inc. Sunrise Point-H SMBus
    Kernel driver in use: i801_smbus
    Kernel modules: i2c_i801
01:00.0 VGA compatible controller: NVIDIA Corporation GM204M [GeForce GTX 970M] (rev a1)
    Subsystem: ASUSTeK Computer Inc. GM204M [GeForce GTX 970M]
    Kernel driver in use: nouveau
    Kernel modules: nouveau
01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)
    Subsystem: ASUSTeK Computer Inc. GM204 High Definition Audio Controller
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
    Subsystem: Intel Corporation Dual Band Wireless-AC 7265
    Kernel modules: iwlwifi
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
    Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    Kernel driver in use: r8169
    Kernel modules: r8169



@debian:~$

dmesg | egrep -i "ata|sd"


[    0.000000] ACPI: RSDP 0x0000000036D2E000 000024 (v02 _ASUS_)
[    0.000000] ACPI: XSDT 0x0000000036D2E0A8 0000D4 (v01 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: DSDT 0x0000000036D2E210 0290B7 (v02 _ASUS_ Notebook 01072009 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D575F8 000315 (v01 SataRe SataTabl 00001000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D57A70 000248 (v02 INTEL  sensrhub 00000000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D57D48 00337E (v02 DptfTa DptfTabl 00001000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D5B0C8 005741 (v02 SaSsdt SaSsdt   00003000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D60858 000E58 (v02 CpuRef CpuSsdt  00003000 INTL 20120913)
[    0.000000] ACPI: UEFI 0x0000000036D61768 00063A (v01 INTEL  RstSataE 00000000 ??   00000000)
[    0.000000] ACPI: UEFI 0x0000000036D61DA8 00005C (v01 INTEL  RstSataV 00000000 ??   00000000)
[    0.000000] ACPI: MSDM 0x0000000036188F18 000055 (v03 _ASUS_ Notebook 00000000 ASUS 00000001)
[    0.000000] NODE_DATA(0) allocated [mem 0x4c67fb000-0x4c67fffff]
[    0.000000] Memory: 16291100K/16714252K available (6464K kernel code, 1176K rwdata, 2788K rodata, 1436K init, 684K bss, 423152K reserved, 0K cma-reserved)
[    0.666062] ACPI: \: GPE=0x23, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.681360] ACPI: SSDT 0xFFFF965373597800 0005DC (v02 PmRef  Cpu0Ist  00003000 INTL 20120913)
[    0.682763] ACPI: SSDT 0xFFFF9653735B4800 00037F (v02 PmRef  Cpu0Cst  00003001 INTL 20120913)
[    0.682987] ACPI: SSDT 0xFFFF9653734E7180 00008E (v02 PmRef  Cpu0Hwp  00003000 INTL 20120913)
[    0.683136] ACPI: SSDT 0xFFFF9653734EC000 000130 (v02 PmRef  HwpLvt   00003000 INTL 20120913)
[    0.683913] ACPI: SSDT 0xFFFF965373597000 0005AA (v02 PmRef  ApIst    00003000 INTL 20120913)
[    0.684308] ACPI: SSDT 0xFFFF9653734EC800 000119 (v02 PmRef  ApHwp    00003000 INTL 20120913)
[    0.684530] ACPI: SSDT 0xFFFF9653734ECC00 000119 (v02 PmRef  ApCst    00003000 INTL 20120913)
[    0.689263] ACPI: \_SB_.PCI0.LPCB.EC0_: GPE=0x23, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.689264] ACPI: \_SB_.PCI0.LPCB.EC0_: Used as boot DSDT EC to handle transactions
[    0.749416] ACPI: \_SB_.PCI0.LPCB.EC0_: GPE=0x23, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.749417] ACPI: \_SB_.PCI0.LPCB.EC0_: Used as boot DSDT EC to handle transactions and events
[    2.605479] Write protecting the kernel read-only data: 12288k
[    2.684405] libata version 3.00 loaded.
[    2.689668] ahci 0000:00:17.0: flags: 64bit ncq pm led clo only pio slum part ems deso sadm sds apst
[    2.705267] ata1: SATA max UDMA/133 abar m524288@0xda100000 port 0xda100100 irq 315
[    2.705268] ata2: SATA max UDMA/133 abar m524288@0xda100000 port 0xda100180 irq 316
[    3.020842] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    3.020871] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    4.745812] sd 2:0:0:0: [sda] 3911680 512-byte logical blocks: (2.00 GB/1.87 GiB)
[    4.745980] sd 2:0:0:0: [sda] Write Protect is off
[    4.745983] sd 2:0:0:0: [sda] Mode Sense: 23 00 00 00
[    4.746145] sd 2:0:0:0: [sda] No Caching mode page found
[    4.746197] sd 2:0:0:0: [sda] Assuming drive cache: write through
[    4.749870]  sda: sda1
[    4.751277] sd 2:0:0:0: [sda] Attached SCSI removable disk
[    8.160402] ata1.00: qc timeout (cmd 0xef)
[    8.160410] ata1.00: failed to enable AA (error_mask=0x4)
[    8.160475] ata2.00: qc timeout (cmd 0xa1)
[    8.160482] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[    8.475335] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    8.475785] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    8.478824] ata1.00: ATA-8: HGST HTS721010A9E630, JB0OA3J0, max UDMA/133
[    8.478827] ata1.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 31/32)
[   18.656479] ata2.00: qc timeout (cmd 0xa1)
[   18.656487] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   18.656490] ata2: limiting SATA link speed to 1.5 Gbps
[   18.972056] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   24.032472] ata1.00: qc timeout (cmd 0x27)
[   24.032479] ata1.00: failed to read native max address (err_mask=0x4)
[   24.032480] ata1.00: HPA support seems broken, skipping HPA handling
[   24.032482] ata1.00: revalidation failed (errno=-5)
[   24.032532] ata1: limiting SATA link speed to 3.0 Gbps
[   24.032534] ata1.00: limiting speed to UDMA/133:PIO3
[   24.348065] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   39.392472] ata1.00: qc timeout (cmd 0xef)
[   39.392479] ata1.00: failed to set xfermode (err_mask=0x4)
[   39.392534] ata1.00: disabled
[   39.392546] ata1: hard resetting link
[   39.708065] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   39.708076] ata1: EH complete
[   50.144474] ata2.00: qc timeout (cmd 0xa1)
[   50.144481] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   50.460057] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   60.157874] sd 2:0:0:0: Attached scsi generic sg0 type 0
[   62.253260] nouveau 0000:01:00.0: firmware: direct-loading firmware nvidia/gm204/gr/fecs_data.bin
[   62.270577] nouveau 0000:01:00.0: firmware: direct-loading firmware nvidia/gm204/gr/gpccs_data.bin
[ 1156.944584] sd 2:0:0:0: [sda] tag#0 FAILED Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[ 1156.944589] sd 2:0:0:0: [sda] tag#0 CDB: Read(10) 28 00 00 07 28 40 00 00 f0 00
[ 1156.944592] blk_update_request: I/O error, dev sda, sector 469056
[ 1401.827774] SQUASHFS error: squashfs_read_data failed to read block 0xa1d8f1d
[ 1401.827775] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827778] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827780] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827782] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827783] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827785] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827787] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827788] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827790] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827793] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827795] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827796] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827798] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827799] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827801] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827803] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827804] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827806] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827808] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827809] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827811] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827812] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827814] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827817] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827818] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827820] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827821] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827823] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827825] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827826] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827828] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827830] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1401.827833] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
[ 1904.291247] SQUASHFS error: Unable to read data cache entry [a1d8f1d]
 

Hors ligne

#6 17-09-2017 22:17:54

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

On peut voir que le disque est bien détecté, mais la communication semble ne pas bien se faire, il y a des dépassements de délai (timeout).
Je ne sais pas d'où cela peut venir. Peut-être la prise en charge par les noyaux 4.x d'une fonctionnalité qui est buggée dans le contrôleur SATA ou le disque.
J'ai regardé les paramètres des modules impliqués (ahci, libahci, libata), mais rien ne m'inspire. A tout hasard tu peux désactiver l'utilisation de l'ACPI par le SATA en passant le paramètre "libata.noacpi=1" à la ligne de commande du noyau.

Hors ligne

#7 18-09-2017 12:39:53

minween
Membre
Inscription : 16-09-2017

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Oui en relisant les précédents logs le disque dur est bien détecté:
`[    8.475335] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    8.475785] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    8.478824] ata1.00: ATA-8: HGST HTS721010A9E630, JB0OA3J0, max UDMA/133
[    8.478827] ata1.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 31/32)`

J'ai désactivé l'acpi dans le grub, ça démarre mais en lancant gparted j'ai toujours que ma clé usb qui est affiché, le disque dur n'y est pas.

Les logs de dmesg on changé les erreurs de fin ne s'affiche plus.

dmesg | egrep -i "ata|sd"



[    0.000000] Command line: BOOT_IMAGE=/live/vmlinuz boot=live union=overlay username=user config components quiet noswap ip= net.ifnames=0 nosplash libata.noacpi=1
[    0.000000] ACPI: RSDP 0x0000000036D2E000 000024 (v02 _ASUS_)
[    0.000000] ACPI: XSDT 0x0000000036D2E0A8 0000D4 (v01 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: DSDT 0x0000000036D2E210 0290B7 (v02 _ASUS_ Notebook 01072009 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D575F8 000315 (v01 SataRe SataTabl 00001000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D57A70 000248 (v02 INTEL  sensrhub 00000000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D57D48 00337E (v02 DptfTa DptfTabl 00001000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D5B0C8 005741 (v02 SaSsdt SaSsdt   00003000 INTL 20120913)
[    0.000000] ACPI: SSDT 0x0000000036D60858 000E58 (v02 CpuRef CpuSsdt  00003000 INTL 20120913)
[    0.000000] ACPI: UEFI 0x0000000036D61768 00063A (v01 INTEL  RstSataE 00000000 ??   00000000)
[    0.000000] ACPI: UEFI 0x0000000036D61DA8 00005C (v01 INTEL  RstSataV 00000000 ??   00000000)
[    0.000000] ACPI: MSDM 0x0000000036188F18 000055 (v03 _ASUS_ Notebook 00000000 ASUS 00000001)
[    0.000000] NODE_DATA(0) allocated [mem 0x4c67fb000-0x4c67fffff]
[    0.000000] Kernel command line: BOOT_IMAGE=/live/vmlinuz boot=live union=overlay username=user config components quiet noswap ip= net.ifnames=0 nosplash libata.noacpi=1
[    0.000000] Memory: 16291100K/16714252K available (6464K kernel code, 1176K rwdata, 2788K rodata, 1436K init, 684K bss, 423152K reserved, 0K cma-reserved)
[    0.666024] ACPI: \: GPE=0x23, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.682089] ACPI: SSDT 0xFFFF9D71335B3000 0005DC (v02 PmRef  Cpu0Ist  00003000 INTL 20120913)
[    0.683516] ACPI: SSDT 0xFFFF9D71335D1C00 00037F (v02 PmRef  Cpu0Cst  00003001 INTL 20120913)
[    0.683745] ACPI: SSDT 0xFFFF9D71334E5300 00008E (v02 PmRef  Cpu0Hwp  00003000 INTL 20120913)
[    0.683895] ACPI: SSDT 0xFFFF9D71334E9600 000130 (v02 PmRef  HwpLvt   00003000 INTL 20120913)
[    0.684691] ACPI: SSDT 0xFFFF9D71335B3800 0005AA (v02 PmRef  ApIst    00003000 INTL 20120913)
[    0.685084] ACPI: SSDT 0xFFFF9D71334E9800 000119 (v02 PmRef  ApHwp    00003000 INTL 20120913)
[    0.685308] ACPI: SSDT 0xFFFF9D71334E9000 000119 (v02 PmRef  ApCst    00003000 INTL 20120913)
[    0.690081] ACPI: \_SB_.PCI0.LPCB.EC0_: GPE=0x23, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.690082] ACPI: \_SB_.PCI0.LPCB.EC0_: Used as boot DSDT EC to handle transactions
[    0.749608] ACPI: \_SB_.PCI0.LPCB.EC0_: GPE=0x23, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.749609] ACPI: \_SB_.PCI0.LPCB.EC0_: Used as boot DSDT EC to handle transactions and events
[    2.604883] Write protecting the kernel read-only data: 12288k
[    2.682118] libata version 3.00 loaded.
[    2.683669] ahci 0000:00:17.0: flags: 64bit ncq pm led clo only pio slum part ems deso sadm sds apst
[    2.699108] ata1: SATA max UDMA/133 abar m524288@0xda100000 port 0xda100100 irq 314
[    2.699109] ata2: SATA max UDMA/133 abar m524288@0xda100000 port 0xda100180 irq 315
[    3.015093] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    3.015122] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    4.771896] sd 2:0:0:0: [sda] 3911680 512-byte logical blocks: (2.00 GB/1.87 GiB)
[    4.772069] sd 2:0:0:0: [sda] Write Protect is off
[    4.772072] sd 2:0:0:0: [sda] Mode Sense: 23 00 00 00
[    4.772236] sd 2:0:0:0: [sda] No Caching mode page found
[    4.772288] sd 2:0:0:0: [sda] Assuming drive cache: write through
[    4.776189]  sda: sda1
[    4.777150] sd 2:0:0:0: [sda] Attached SCSI removable disk
[    8.158782] ata1.00: qc timeout (cmd 0xef)
[    8.158790] ata1.00: failed to enable AA (error_mask=0x4)
[    8.158858] ata2.00: qc timeout (cmd 0xa1)
[    8.158865] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[    8.474529] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    8.474554] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    8.477448] ata1.00: ATA-8: HGST HTS721010A9E630, JB0OA3J0, max UDMA/133
[    8.477452] ata1.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 31/32)
[   18.654808] ata2.00: qc timeout (cmd 0xa1)
[   18.654816] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   18.654819] ata2: limiting SATA link speed to 1.5 Gbps
[   18.970342] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   24.030777] ata1.00: qc timeout (cmd 0x27)
[   24.030784] ata1.00: failed to read native max address (err_mask=0x4)
[   24.030786] ata1.00: HPA support seems broken, skipping HPA handling
[   24.030788] ata1.00: revalidation failed (errno=-5)
[   24.030838] ata1: limiting SATA link speed to 3.0 Gbps
[   24.030840] ata1.00: limiting speed to UDMA/133:PIO3
[   24.346367] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   39.390779] ata1.00: qc timeout (cmd 0xef)
[   39.390786] ata1.00: failed to set xfermode (err_mask=0x4)
[   39.390839] ata1.00: disabled
[   39.390852] ata1: hard resetting link
[   39.706367] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   39.706378] ata1: EH complete
[   50.142794] ata2.00: qc timeout (cmd 0xa1)
[   50.142801] ata2.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[   50.458361] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[   53.725065] systemd[1]: Listening on LVM2 metadata daemon socket.
[   60.174899] sd 2:0:0:0: Attached scsi generic sg0 type 0
[   62.435116] nouveau 0000:01:00.0: firmware: direct-loading firmware nvidia/gm204/gr/fecs_data.bin
[   62.435170] nouveau 0000:01:00.0: firmware: direct-loading firmware nvidia/gm204/gr/gpccs_data.bin
user@debian:~$
 

Dernière modification par minween (18-09-2017 13:01:26)

Hors ligne

#8 18-09-2017 13:21:46

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Les erreurs SquashFS n'ont rien à voir avec le SATA. Les erreurs de timeout sont toujours là...

Hors ligne

#9 18-09-2017 14:00:54

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

D'après mes résultats de recherche, le passage en mode AHCI résoud le problème mais certains BIOS ne proposent que le mode RAID. Une mise à jour du BIOS est susceptible rendre le mode AHCI disponible.

Quel est le modèle de la machine ?
A-t-elle un SSD en plus du disque dur ? D'autres résultats suggèrent que débrancher le SSD permet au disque dur d'être détecté (en empêchant l'assemblage du RAID je suppose).

Hors ligne

#10 18-09-2017 14:40:51

minween
Membre
Inscription : 16-09-2017

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Je suis allez sur le site du constructeur afin de regarder les mise a jour bios car je ne comprenais pas pourquoi je ne pouvais changer le mode RAID alors que dans le bios une option propose de le changer mais je pouvais choisir seulement le mode RAID.

J'ai donc effectué une mise a jour de bios, par la suite je pouvais changer en mode ahci et surprise les kernel 4.XX peuvent à nouveau détecter mon disque dur.

Edit: je viens de voir ton message, oui  @raleur c’était bien cela le problème merci de ton aide.

Dernière modification par minween (18-09-2017 14:43:16)

Hors ligne

#11 18-09-2017 15:32:52

minween
Membre
Inscription : 16-09-2017

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Juste une dernière petite question.
Maintenant que le problème est corrigé, j’hésite entre dist-upgrade ma version de jessie vers skretch ou de re-installer un debian.
Le hic avec le dist-upgrade c'est que sur mon debian jessie (3.16 kernel) j'ai utilisé les backports pour installer les drivers nvidia ainsi que cuda donc je me demande si ça risque pas de casser apt ou autre de dist-upgrade sur skretch.

et le Hic avec une nouvelle install c'est que je dois reconfigurer tout l'interface graphique gnome que j'avais configurer sur l'ancienne installe.

Que conseillez vous ?

Hors ligne

#12 18-09-2017 16:03:54

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

Je pense que ça mérite un nouveau sujet.
Avec une partition /home séparée, les réglages de Gnome que tu avais faits dans ton profil utilisateur peuvent être conservés même lors d'une nouvelle installation si tu indiques de ne pas formater la partition /home.

Hors ligne

#13 18-09-2017 16:17:21

minween
Membre
Inscription : 16-09-2017

Re : [Résolu] Disque dur non détecté avec kernel 4.XX +

raleur a écrit :

Je pense que ça mérite un nouveau sujet.
Avec une partition /home séparée, les réglages de Gnome que tu avais faits dans ton profil utilisateur peuvent être conservés même lors d'une nouvelle installation si tu indiques de ne pas formater la partition /home.



Oui mais en disant configuration je visais à dire qu'il y'a + d'une dizaine d’extension de gnome que j'avais installé mais que je ne pense pas qu'il soit dans mon /home comme els fichiers de conf. Je pense que je vais dist-upgrade et si je vois que j'ai des problème avec apt ou autre je referais une nouvelle install en conservant ma partition /home.

Je te remercie pour ton aide @raleur.

Hors ligne

Pied de page des forums