Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-11-2017 21:41:18

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

[RESOLU] WebMin et Ufw

Bonsoir à tous smile

Webmin semble ne pas démarrer le pare-feu.
En l'installant, j'appelle systématiquement


ufw enable
 


Et l'OS me répond que le pare-feu est actif ET sera lancé au démarrage.

Or, sous WebMin, j'ai ceci :
eb5c2ffac665a143b2efd6890b97063cee3521bd.png

Même après la commande :


systemctl daemon-reload
 



Pourquoi ? scratchhead.gif

Dernière modification par Lupa (14-11-2017 16:12:43)

Hors ligne

#2 13-11-2017 21:46:20

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [RESOLU] WebMin et Ufw

Bonsoir,

Pourrais-tu poster le résultat de la commande

systemctl status ufw


Dell-Latitude D430

Hors ligne

#3 13-11-2017 22:29:47

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : [RESOLU] WebMin et Ufw

Voilà :


● ufw.service - LSB: start firewall
   Loaded: loaded (/etc/init.d/ufw)
   Active: active (exited) since lun. 2017-11-13 21:24:02 CET; 4min 5s ago
  Process: 308 ExecStart=/etc/init.d/ufw start (code=exited, status=0/SUCCESS)

nov. 13 21:24:02 deb-1155 systemd[1]: Starting LSB: start firewall...
nov. 13 21:24:02 deb-1155 ufw[308]: Starting firewall: ufw...Setting kernel...e.
nov. 13 21:24:02 deb-1155 systemd[1]: Started LSB: start firewall.
Hint: Some lines were ellipsized, use -l to show in full.
 



Apparemment, il est démarré, non ?

Hors ligne

#4 13-11-2017 22:33:53

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [RESOLU] WebMin et Ufw

Oui, il démarre et ensuite s'éteint mais c'est peut-être normal. Personnellement j'utilise iptable, mais cela  ne nécessite qu'une commande, le service ne tourne pas en permanence. Est-ce qu'après le démarrage les règles que tu as instaurées pour ufw sont effectives (si oui ça veut dire que tout fonctionne correctement) ?

Dell-Latitude D430

Hors ligne

#5 13-11-2017 22:50:28

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : [RESOLU] WebMin et Ufw

Les voilà :
667329469d535d092d21069f7310ebea7dea596f.png

En fait, actuellement, il n'y en n'a qu'une : l'autorisation à Webmin du loacalhost1000 .  Il faudrait d'ailleurs modifier cette adresse : trop connue, et donc dangereuse en root. Mais comment faire ? Je vais poster là-dessus.

Donc, elles sont effectives. Bizarre que WebMin me dise me contraire.

Hors ligne

#6 14-11-2017 15:38:11

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [RESOLU] WebMin et Ufw

Lupa a écrit :

Bizarre que WebMin me dise me contraire.


En fait Webmin ne te dit pas le contraire, c'est juste qu'il reflète l'état de Systemd. En gros, ton service ufw s'est lancé au démarrage, il a appliqué les changements (donc ici activer les règles du pare-feu), puis il s'est éteint car il n'avait plus rien à faire (une fois que les règles sont mises c'est fait jusqu'à extinction, pas besoin de le refaire toutes les secondes). Par contre, acpid a besoin de tourner en permanence, donc il te signale que ça a démarré au boot et que ça continue de fonctionner. En somme, tout est normal.

Du coup n'oublie pas de marquer le sujet comme résolu : Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. lol

Par ici les points choco, cette fois wink


Dell-Latitude D430

Hors ligne

#7 14-11-2017 16:12:14

Lupa
Membre
Distrib. : Debian Jessie
Noyau : Linux 4.9.0-3amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : [RESOLU] WebMin et Ufw

OK wink
Merci :hello:

Hors ligne

Pied de page des forums