Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 14-11-2017 16:21:16

snopgt
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux Snop 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2
(G)UI : Gnome
Inscription : 12-11-2017

Re : [Résolu] Pas de son :(

Voici le résulta

cat /etc/modprobe.d/alsa-base.conf


# Prevent abnormal drivers from grabbing index 0
#options bt87x index=-2
#options cx88_alsa index=-2
#options saa7134-alsa index=-2
#options snd-atiixp-modem index=-2
#options snd-intel8x0m index=-2
#options snd-via82xx-modem index=-2
#options snd-usb-audio index=-2
#options snd-usb-us122l index=-2
#options snd-usb-usx2y index=-2
#options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
#options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
#options snd-pcsp index=-2
# Ma config
options snd-hda-intel index=0
options snd-ice1712 index=1
options snd-usb-audio index=2,3
 

Hors ligne

#27 14-11-2017 16:33:50

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch
Noyau : linux-debian-4.9.0-7-amd64
(G)UI : env- i3-weechat-bépo
Inscription : 28-03-2012
Site Web

Re : [Résolu] Pas de son :(

bon, je vois que ça va toujours pas ??

tu as ouvert alsamixer en console

Celui qui ignore l’histoire se retrouvera sur une rive solitaire d’où il épiera en vain les lumières d’un bateau. Ce bateau ne viendra pas.
 
Adolph Rudnicki.

Hors ligne

#28 14-11-2017 17:17:47

snopgt
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux Snop 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2
(G)UI : Gnome
Inscription : 12-11-2017

Re : [Résolu] Pas de son :(

Oui il est sur pulsaudio

Hors ligne

#29 14-11-2017 17:20:43

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch
Noyau : linux-debian-4.9.0-7-amd64
(G)UI : env- i3-weechat-bépo
Inscription : 28-03-2012
Site Web

Re : [Résolu] Pas de son :(

t ovres une console et tu tapes  alsamixer
ça te donne ca


file-Refd5d9097d1cd1b641ce183e1fd2b89e

Celui qui ignore l’histoire se retrouvera sur une rive solitaire d’où il épiera en vain les lumières d’un bateau. Ce bateau ne viendra pas.
 
Adolph Rudnicki.

Hors ligne

#30 14-11-2017 17:44:53

snopgt
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux Snop 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2
(G)UI : Gnome
Inscription : 12-11-2017

Re : [Résolu] Pas de son :(

Oui c'est bien ça wink

Hors ligne

#31 14-11-2017 18:36:24

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Pas de son :(

Bonsoir à tou⋅te⋅s,

@snopgt : d'où sort le fichier alsa-base.conf ? ce fichier fourni par le paquet alsa-base jusqu'à Debian 7 Wheezy n'existe plus par défaut depuis Debian 8 Jessie... par ailleurs, que retourne la commande,

cat ~/.asoundrc


Le fichier ~/.asoundrc existe si tu as effectivement suivi le tuto cité au post #23, mais il n'est pas indispensable, puisque PulseAudio est installé (tu peux également installer pavucontrol, si ce n'est déjà fait) ; quoi qu'il en soit n'hésite pas à explorer l'interface AlsaMixer via la touche F6 !

Dernière modification par èfpé (14-11-2017 18:40:24)

Hors ligne

#32 14-11-2017 21:47:11

snopgt
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux Snop 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2
(G)UI : Gnome
Inscription : 12-11-2017

Re : [Résolu] Pas de son :(

Bonsoir
Alors pour la commande

cat ~/.asoundrc




Elle donne rien en user mais en root j'ai

cat ~/.asoundrc


defaults.ctl.!card 1
defaults.pcm.!card 1
defaults.pcm.!device 3
 



J'ai du faire une erreur lors de la création lol ,

Oui j'ai fait des essai avec alsamixer en modifiant le chois de la carte son mais pas de changement.

Hors ligne

#33 14-11-2017 22:14:24

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Pas de son :(

Re-,

OK ; effectivement cela ne risque pas de fonctionner, le fichier doit être créé en user et surtout adapté :

rm ~/.asoundrc


nano ~/.asoundrc

defaults.ctl.!card 1
defaults.pcm.!card 1


Me semblerait cohérent (inutile ici de préciser le périphérique) ; alternativement,

nano /etc/modprobe.d/alsa-base.conf

options snd-hda-intel id=SB index=0
options snd-hda-intel id=Generic index=1


Pourrait également fonctionner (mais je n'ai pas testé ces manips sous Debian 9 Stretch lol)

Hors ligne

#34 15-11-2017 12:13:46

snopgt
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux Snop 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2
(G)UI : Gnome
Inscription : 12-11-2017

Re : [Résolu] Pas de son :(

Merci a tous
J'ai corrigé et apparemment sa fonctionne a voir si ça dure wink
Je passe le poste en résolu pour le moment big_smile

Hors ligne

#35 15-11-2017 12:28:32

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : [Résolu] Pas de son :(

Bonjour
je n'ai aucun fichier de son dans mon /home/user (ou /home )  =>  ~/.asoundrc
ni de => /etc/modprobe.d/alsa-base.conf
j'ai du son pourtant
c'est fort d'etre obligé de triturer les fichiers de configuration , on est en 2017 tongue

nota : je sais pas ou est enregistrée la configuration en utilisant les outils graphiques du bureau pour l'audio roll  tongue

cool

Hors ligne

Pied de page des forums