Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-12-2017 17:17:33

fatpat
Membre
Distrib. : DF "Stretch" , MX 1.6, Mint 18
Noyau : 4.9.0-3-amd64, 4.7.0-0.bpo.1-amd64,4.10.0-40-gener
(G)UI : Xfce, XFCE, Mate
Inscription : 30-10-2017

Impossible de lancer Steam

Bonjour, tout est dans le titre malgré plusieurs installations et désinstallations des paquets ,Steam ne se lance pas! Comment pourrais-je voir ce qui cloche?

I 3 2102
DF os (Stetch)
cg :  GTX 660 Nvidia (MSI)
4go ram
SSD 60>>>240

Merci d'avance
Bonne journée

Hors ligne

#2 04-12-2017 18:52:13

pili36
Membre
Lieu : Lille
Distrib. : Debian stretch / Raspbian Jessie
Noyau : 4.9_amd64 / 3.16_armhf
(G)UI : Xfce / Lxde
Inscription : 03-11-2009

Re : Impossible de lancer Steam

Bonjour,

Pour voir l'erreur le plus simple est de lancer steam depuis le terminal.

steam



Ensuite faire un copier/coller du contenu ici (du texte va apparaître) voir si quelqu'un peu aider avec l'erreur.

Dernière modification par pili36 (04-12-2017 18:52:47)


Debian stretch amd64, Xfce, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Stretch amd64, (pour Steam), Xfce, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#3 04-12-2017 19:45:22

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : Impossible de lancer Steam

il nous faudra plus de détails pour pouvoir t'aider.
peux tu nous indiquer comment tu as installé steam ?

tu peux regarder sur le wiki:
https://debian-facile.org/doc:jeux:steam
https://wiki.debian.org/fr/Steam

Hors ligne

#4 04-12-2017 21:00:14

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Impossible de lancer Steam

Bonjour
le wiki officiel de debian (avec le paquet steam:i386 des dépots debian )  =>  https://wiki.debian.org/fr/Steam
préciser l'erreur que tu a (a l installation ou au lancement de steam )
la carte vidéo et le driver utilisé

steam fonctionne en i386 , debian amd64 doit avoir le multiarch activé et les paquets du driver vidéo i386 installé (driver libre ou propriétaire )

Hors ligne

#5 06-12-2017 22:58:34

fatpat
Membre
Distrib. : DF "Stretch" , MX 1.6, Mint 18
Noyau : 4.9.0-3-amd64, 4.7.0-0.bpo.1-amd64,4.10.0-40-gener
(G)UI : Xfce, XFCE, Mate
Inscription : 30-10-2017

Re : Impossible de lancer Steam

Salut à tous
@Pili
"Running Steam on debian 9 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

@niQntin
J'ai installé:
par le "handy menu" >>>désinstallation via Synaptic
par synaptic puis >>désinstallation via Synaptic
par gedebi en ayant téléchargé directement le paquet chez Steam

@Robert
GTX 660 2go ram MSI

"Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106 [GeForce GTX 660] [10de:11c0] (rev a1)

Checking card:  NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)
Your card is supported by the default drivers and legacy driver series 304.
It is recommended to install the nvidia-driver package."

Malgré avoir suivi le mode d'emploi pour l'installation du pilote nvidia et re boot, j'ai toujours la même réponse.

Bonne semaine

Dernière modification par fatpat (07-12-2017 19:02:50)

Hors ligne

#6 07-12-2017 19:07:18

fatpat
Membre
Distrib. : DF "Stretch" , MX 1.6, Mint 18
Noyau : 4.9.0-3-amd64, 4.7.0-0.bpo.1-amd64,4.10.0-40-gener
(G)UI : Xfce, XFCE, Mate
Inscription : 30-10-2017

Re : Impossible de lancer Steam

Quand je fais:

apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-driver



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
linux-headers-amd64 est déjà la plus récente version disponible.
nvidia-driver est déjà la plus récente version disponible.


Je ne comprends plus rien, le pilote est installé ou pas? Detect me dit "non" et l'installation "oui"
++ all et merci

Edit : ajout des balises codes pour rendre le message plus lisible : Voir le tuto : Le code, ça pique moins les yeux en couleur

FÉLICITATION POUR LE POINT "CHOCOLAT" hihihi

Dernière modification par fatpat (08-12-2017 01:42:30)

Hors ligne

#7 07-12-2017 22:59:35

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Impossible de lancer Steam

Bonjour
le driver de stretch


 The NVIDIA binary driver provides optimized hardware acceleration of OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server for graphics cards using NVIDIA chip sets.

Please see the nvidia-kernel-dkms or nvidia-kernel-source packages for building the kernel module required by this package. This will provide nvidia-kernel-375.82.

This version only supports GeForce, Quadro, NVS, Tesla, ... GPUs based on the Fermi, Kepler, Maxwell, or newer architectures. Look at the legacy packages for older cards.

See /usr/share/doc/nvidia-driver/README.txt.gz for a complete list of supported GPUs and PCI IDs.
 



la GTX660 est un gpu kepler qui est supporté par  le driver de stretch qui supporte les cartes de fermi a pascal.
tu change ce "distrib:windows10" qui me fait mal aux yeux sur ton profil et tu met quelle debian tu utilise

donc le 304 ne convient pas a ta carte , trop vieux , la version sera la "375.82"

la commande pour l installation est :


apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 



mais avant confirmer sur quelle debian l installation ( ex : stretch 9 amd64 ) et le bureau (gnome ou mate ou autre .......  )
nettoyer ce que tu a fait
bien désinstaller steam (y compris les fichiers dans ton /home ) certain sont caché exemple : ".steam"  (avec un point devant le nom )


apt-get remove --purge xserver-xorg-video-nvidia nvidia*
 


puis


apt-get autoremove --purge
 


puis


reboot
 


confirmé que tu a bien activé le multiarch et  le i386 sur ta debian amd64 (comme sur le wiki de steam ) => il faut le faire avant d installer le driver
lancer la commande ci dessus pour installer le driver


apt-get install nvidia-kernel-dkms nvidia-settings nvidia-driver linux-headers-$(uname -r)
 


un reboot
nota: normalement tu a des paquets amd64 et i386 installés , que tu peu vérifier par exemple avec synaptic =>recherche=>nvidia
si ton driver nvidia fonctionne bien , faire l installation de steam a partir du paquet de debian (pas celui officiel de steam )
(tu a le lien du wiki debian pour steam au dessus ) =>  https://wiki.debian.org/fr/Steam
au premier lancement il va se mettre a jour
puis l invite de connection a Steam

ps: si tout n'est pas correct ça ne fonctionnera pas (exemple des traces d une vieille installation de steam , ou un driver pas fonctionnel , ou l architecture i386 qui n'est pas activé sur ton OS 64bits )

Dernière modification par robert2a (07-12-2017 23:25:32)

Hors ligne

#8 09-12-2017 12:55:07

fatpat
Membre
Distrib. : DF "Stretch" , MX 1.6, Mint 18
Noyau : 4.9.0-3-amd64, 4.7.0-0.bpo.1-amd64,4.10.0-40-gener
(G)UI : Xfce, XFCE, Mate
Inscription : 30-10-2017

Re : Impossible de lancer Steam

Quand je lance Steam, voici sa réponse: absence de   libGL.so.1. et puis fatale erreur.
Le changement de pilote a été effectué.Chose importante , je pense : quand j'effectue

# dpkg --add-architecture i386
# aptitude update



Pour la première partie , il ne se passe rien mais rien du tout
Pour la seconde partie si je n'utilise pas "apt-get" à la place d "aptitude"  j'obtiens la réponse :commande inconnue.
Que de complications que moi, je qualifie d'inutiles lorsque je vois que l'installation sur Mint se fait en en 2 coups de cuillère à pot.

Dernière modification par fatpat (09-12-2017 18:14:24)

Hors ligne

#9 09-12-2017 14:32:16

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : Impossible de lancer Steam

aptitude n'est pas installé par défaut, tu peux l'installer avec:

apt-get install aptitude



le plus simple c'est de suivre le tuto pas à pas, tu ne devrais pas avoir de soucis: https://wiki.debian.org/fr/Steam#Syst.2 … 28amd64.29

ça ressemble à : https://debian-facile.org/viewtopic.php?id=8413

Hors ligne

#10 10-12-2017 00:15:15

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Impossible de lancer Steam

Bonjour
si ton driver nvidia (ou libre (nouveau)) est correctement configuré et installé  =>  https://packages.debian.org/stretch/amd … x/filelist

le multiarch  =>  https://wiki.debian.org/fr/Multiarch/HOWTO

pour "aptitude update" , l'équivalent est


apt update
 


ou


apt-get update
 



pour l update il ne se passe rien si tu n'a pas d installation de logiciel (ou drivers) qui ont besoin de paquet i386
l'activation du multiarch n installe pas tous les paquets en i386 pour ta stretch amd64   tongue
l installation du paquet "steam:i386" risque en dépendance d'installer des paquets i386  wink

Dernière modification par robert2a (10-12-2017 00:24:00)

Hors ligne

#11 10-12-2017 00:38:43

fatpat
Membre
Distrib. : DF "Stretch" , MX 1.6, Mint 18
Noyau : 4.9.0-3-amd64, 4.7.0-0.bpo.1-amd64,4.10.0-40-gener
(G)UI : Xfce, XFCE, Mate
Inscription : 30-10-2017

Re : Impossible de lancer Steam

Re coucou smile

Au lancement de Steam , voici sa réponse : Error, il manque la "library 32 bit : LibGL.so.1
Synaptic m'en montre une d'installée mais je pense que c'est du  64 bit
Je nettoie tout et je réinstalle Steam.
++ et merci pour l'aide

Dernière modification par fatpat (10-12-2017 00:49:52)

Hors ligne

#12 10-12-2017 01:33:14

fatpat
Membre
Distrib. : DF "Stretch" , MX 1.6, Mint 18
Noyau : 4.9.0-3-amd64, 4.7.0-0.bpo.1-amd64,4.10.0-40-gener
(G)UI : Xfce, XFCE, Mate
Inscription : 30-10-2017

Re : Impossible de lancer Steam

Re re,
Ca ne fonctionne pas , toujours la même erreur, ça me soûle.
@ Robert :Je ne comprends pas le 1/4 du 1/3 de ce qu'on raconte dans le multiarch how to, désolé mon job  c'est la ferraille et la soudure. Je ne sais déjà pas ce qu'est un "dpkg", alors le reste...
Debian facile , oui pour ceux qui connaissent , les autres cherchent plus simple ou reste chez winmachin. Pour attirer les jeunes ,ce n'est pas le bon système , ce qui les intéresse en premier lieu , ce sont les jeux! et la loi du moindre effort faisant, ils vont au plus facile. Les adultes aussi, il suffit de voir le retournement de situation à la ville de Munich qui repasse sous win , "à la demande de la majorité des fonctionnaires". Je peux te dire ,pour en avoir côtoyés pendant quelques années que certains ne connaissent même pas l'usage du clic droit et encore moins des raccourcis clavier.
Je vais essayer à nouveau.
++

Dernière modification par fatpat (10-12-2017 01:34:05)

Hors ligne

#13 10-12-2017 02:59:34

robert2a
Membre
Lieu : France
Distrib. : Buster 10
Noyau : Linux 4.14.0-1 4.14.2-1
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Impossible de lancer Steam

Bonjour
on reprend calmement smile
mon sources.list  dans /etc/apt/sources.list  (je suis sous Buster mais aucune importance le principe est le meme sous Stretch)
dans ton sources.list le mot buster sera remplacé par stretch


#buster 10
deb http://deb.debian.org/debian/ buster main contrib non-free
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
 



j'active la prise en charge du 32bits


dpkg --add-architecture i386
 



je fait un update du cache d apt


aptitude update
 



retour


Prendre :  1 http://deb.debian.org/debian buster InRelease [142 kB]
Prendre :  2 http://security.debian.org/debian-security buster/updates InRelease [25,5 kB]
Prendre :  3 http://deb.debian.org/debian buster-updates InRelease [46,0 kB]
Prendre :  4 http://deb.debian.org/debian buster/main amd64 Packages.diff/Index [27,9 kB]
Prendre :  5 http://deb.debian.org/debian buster/main i386 Packages.diff/Index [27,9 kB]
Prendre :  6 http://deb.debian.org/debian buster/main Translation-en.diff/Index [27,9 kB]
Prendre :  7 http://deb.debian.org/debian buster/main Translation-fr.diff/Index [27,8 kB]
Prendre :  8 http://deb.debian.org/debian buster/main amd64 Packages 2017-12-09-1506.09.pdiff [2 677 B]
Prendre :  9 http://deb.debian.org/debian buster/main i386 Packages 2017-12-09-1506.09.pdiff [2 674 B]
Prendre :  10 http://deb.debian.org/debian buster/main Translation-en 2017-12-09-1506.09.pdiff [229 B]
Prendre :  11 http://deb.debian.org/debian buster/main i386 Packages 2017-12-09-1506.09.pdiff [2 674 B]
Prendre :  12 http://deb.debian.org/debian buster/main amd64 Packages 2017-12-09-1506.09.pdiff [2 677 B]
Prendre :  13 http://deb.debian.org/debian buster/main Translation-en 2017-12-09-1506.09.pdiff [229 B]
Prendre :  14 http://deb.debian.org/debian buster/main Translation-fr 2017-12-09-1506.09.pdiff [5 040 B]          
Prendre :  15 http://deb.debian.org/debian buster/main Translation-fr 2017-12-09-1506.09.pdiff [5 040 B]                          
 336 ko téléchargés en 1s (238 ko/s)            
 


avec "apt" ou "apt-get" le résultat est le meme que avec aptitude
tu vois des lignes avec i386 dans le retour , donc ma debian amd64 prend en charge le 32 bits maintenant             
exemple:


Prendre :  5 http://deb.debian.org/debian buster/main i386 Packages.diff/Index [27,9 kB]
 




je me place en mode simulation avec l option "-s"


aptitude -s install steam
 


retour


Note: selecting "steam:i386" instead of the virtual package "steam"
Les NOUVEAUX paquets suivants vont être installés :
  libgl1-mesa-glx:i386{a} libgpg-error0:i386{a} libudev1:i386{a} libxinerama1:i386{a} libxss1:i386{a} steam:i386
0 paquets mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1 636 ko d'archives. Après dépaquetage, 5 061 ko seront utilisés.

Note: Using 'Simulate' mode.
Voulez-vous continuer ? [Y/n/?] n
Abandon.
 



tu vois que aptitude va installer steam:i386  et libgl1-mesa-glx:i386  , celui qui va fournir le fameux fichier qui te manque  "LibGL.so.1 "

je fais l'installation en vraie (sans l option "-s" )


aptitude install steam
 


retour


Note: selecting "steam:i386" instead of the virtual package "steam"
Les NOUVEAUX paquets suivants vont être installés :
  libgl1-mesa-glx:i386{a} libgpg-error0:i386{a} libudev1:i386{a} libxinerama1:i386{a} libxss1:i386{a} steam:i386
0 paquets mis à jour, 6 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1 636 ko d'archives. Après dépaquetage, 5 061 ko seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Prendre :  1 [url]http://deb.debian.org/debian[/url] buster/main i386 libudev1 i386 235-3 [129 kB]
Prendre :  2 [url]http://deb.debian.org/debian[/url] buster/main i386 libxinerama1 i386 2:1.1.3-1+b3 [16,9 kB]
Prendre :  3 [url]http://deb.debian.org/debian[/url] buster/main i386 libgl1-mesa-glx i386 17.2.5-1 [42,4 kB]
Prendre :  4 [url]http://deb.debian.org/debian[/url] buster/main i386 libgpg-error0 i386 1.27-5 [119 kB]
Prendre :  5 [url]http://deb.debian.org/debian[/url] buster/non-free i386 steam i386 1.0.0.54-2 [1 312 kB]
Prendre :  6 [url]http://deb.debian.org/debian[/url] buster/main i386 libxss1 i386 1:1.2.2-1+b2 [16,8 kB]
 1 636 ko téléchargés en 1s (1 309 ko/s)
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
bogues de gravité serious sur libgpg-error0:i386 (→ 1.27-5) <En attente de traitement>
 b1 - #872806 - libgpg-error0 packs runtime support files in shared library
Résumé :
 libgpg-error0:i386(1 bogue)
Êtes-vous certain(e) de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...]

Préconfiguration des paquets...
Sélection du paquet libudev1:i386 précédemment désélectionné.
(Lecture de la base de données... 218130 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-libudev1_235-3_i386.deb ...
Dépaquetage de libudev1:i386 (235-3) ...
Sélection du paquet libxinerama1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../1-libxinerama1_2%3a1.1.3-1+b3_i386.deb ...
Dépaquetage de libxinerama1:i386 (2:1.1.3-1+b3) ...
Sélection du paquet libgl1-mesa-glx:i386 précédemment désélectionné.
Préparation du dépaquetage de .../2-libgl1-mesa-glx_17.2.5-1_i386.deb ...
Dépaquetage de libgl1-mesa-glx:i386 (17.2.5-1) ...
Sélection du paquet libgpg-error0:i386 précédemment désélectionné.
Préparation du dépaquetage de .../3-libgpg-error0_1.27-5_i386.deb ...
Dépaquetage de libgpg-error0:i386 (1.27-5) ...
Sélection du paquet steam:i386 précédemment désélectionné.
Préparation du dépaquetage de .../4-steam_1.0.0.54-2_i386.deb ...
Dépaquetage de steam:i386 (1.0.0.54-2) ...
Sélection du paquet libxss1:i386 précédemment désélectionné.
Préparation du dépaquetage de .../5-libxss1_1%3a1.2.2-1+b2_i386.deb ...
Dépaquetage de libxss1:i386 (1:1.2.2-1+b2) ...
Paramétrage de libudev1:i386 (235-3) ...
Paramétrage de libxinerama1:i386 (2:1.1.3-1+b3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-2) ...
Paramétrage de libxss1:i386 (1:1.2.2-1+b2) ...
Paramétrage de libgpg-error0:i386 (1.27-5) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.25-3) ...
Paramétrage de libgl1-mesa-glx:i386 (17.2.5-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-4) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-1) ...
Paramétrage de steam:i386 (1.0.0.54-2) ...
 



j'accepte les conditions de steam  , et sur buster j'ai un bug sur un paquet , j'accepte son installation  => "libgpg-error0:i386(1 bogue)"

je lance steam dans la console  (en user (pas en root) )


/usr/games/steam %U
 


retour
il commence la mise a jour


ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2017-12-10 02:34:55] Startup - updater built Nov 23 2016 01:05:42
[2017-12-10 02:34:56] Verifying installation...
[2017-12-10 02:34:56] Unable to read and verify install manifest /root/.steam/package/steam_client_ubuntu12.installed
[2017-12-10 02:34:56] Verification complete
[2017-12-10 02:34:56] Downloading Update...
[2017-12-10 02:34:56] Checking for available update...
[2017-12-10 02:34:56] Package file tenfoot_misc_all.zip.008ed314d467eecacba58d188fdf082d23f264d2 missing or incorrect size
[2017-12-10 02:34:56] Package file tenfoot_dicts_all.zip.87bb49891925214df2d745e12a53518fd2ea86f0 missing or incorrect size
[2017-12-10 02:34:56] Package file tenfoot_fonts_all.zip.vz.7673e4cd32b6752bc621d8bc1a7118a9af19b64a_12077027 missing or incorrect size
[2017-12-10 02:34:56] Package file tenfoot_ambientsounds_all.zip.12963b9dbc3d331e26559cc2d323ca0661942b6b missing or incorrect size
[2017-12-10 02:34:56] Package file tenfoot_sounds_all.zip.vz.ffef2b2fc386819a842ea79484b966a937c2ca7e_1209792 missing or incorrect size
[2017-12-10 02:34:56] Package file tenfoot_images_all.zip.vz.af9493d21a929c0f80f5b990e845c8860019f604_29611905 missing or incorrect size
[2017-12-10 02:34:56] Package file tenfoot_all.zip.vz.6148bb93dac243fb98dd66578f034a1bddc8355d_2375893 missing or incorrect size
[2017-12-10 02:34:56] Package file resources_misc_all.zip.vz.6596f073f874e66a5af7a41ca94e54e1b091fcb7_2030550 missing or incorrect size
[2017-12-10 02:34:56] Package file resources_all.zip.vz.e4473120a4f4551fe56a1c0b4fb67259933019ea_5053566 missing or incorrect size
[2017-12-10 02:34:56] Package file strings_en_all.zip.vz.f108561de14d35522305117ad6499ada2d0b99f3_86720 missing or incorrect size
[2017-12-10 02:34:56] Package file strings_all.zip.vz.a0d3805c7e876aeee7d86289ce233f2c1bca02c5_2238961 missing or incorrect size
[2017-12-10 02:34:56] Package file public_all.zip.vz.0ac8e378249a1e5e9b61ad84a82675da61ad7c55_757036 missing or incorrect size
[2017-12-10 02:34:56] Package file bins_ubuntu12.zip.vz.f2fdb8c5bef63e932431ac155f479efcb5a16680_16903009 missing or incorrect size
[2017-12-10 02:34:56] Package file bins_pub_ubuntu12.zip.vz.fd539b6266620d4707eb2e40f6b2e2a8d9a6161f_9044108 missing or incorrect size
[2017-12-10 02:34:56] Package file bins_sdk_ubuntu12.zip.vz.2e1f31a51bfa6d3d337430a27732f82a724b606f_11263871 missing or incorrect size
[2017-12-10 02:34:56] Package file bins_codecs_ubuntu12.zip.vz.84b14918e1591ffd02e819b8f7fc79315dbedb03_1832666 missing or incorrect size
[2017-12-10 02:34:56] Package file bins_misc_ubuntu12.zip.8e1d5053d900bb59fd7b783e9419406130e55c36 missing or incorrect size
[2017-12-10 02:34:56] Package file webkit_ubuntu12.zip.vz.4110464c195117de17ad7ec996f7e78660045855_48820714 missing or incorrect size
[2017-12-10 02:34:56] Package file miles_ubuntu12.zip.vz.4fd048667c97ef6eb976f4c42ce5c18f8695ac9e_295483 missing or incorrect size
[2017-12-10 02:34:56] Package file sdl2_ubuntu12.zip.vz.25837fb8c170e7af5105ecc8f489951d273952d4_567301 missing or incorrect size
[2017-12-10 02:34:56] Package file steam_ubuntu12.zip.vz.565a6fcfca2293f9514737bb0a334f00b193b4f7_1478011 missing or incorrect size
[2017-12-10 02:34:56] Package file runtime_part0_ubuntu12.zip.21cdfb9681f90e30085f213f05a4a8f0105f0545 missing or incorrect size
[2017-12-10 02:34:56] Package file runtime_part1_ubuntu12.zip.ef8fcf287ada3c6eccabd9ee81f0405d74d2a77d missing or incorrect size
[2017-12-10 02:34:56] Downloading update (0 of 274 480 KB)...
[2017-12-10 02:34:57] Downloading update (54 of 274 480 KB)...
 



il finalise l installation et ouvre une fenètre graphique qui me propose de créer un compte ou d utiliser un compte existant


[2017-12-10 02:39:51] Downloading update (274 443 of 274 480 KB)...
[2017-12-10 02:39:51] Downloading update (274 480 of 274 480 KB)...
[2017-12-10 02:39:51] Download Complete.
[2017-12-10 02:39:51] uninstalled manifest found in /root/.steam/package/steam_client_ubuntu12 (1).
[2017-12-10 02:39:51] Extracting package...
[2017-12-10 02:39:57] Installing update...
[2017-12-10 02:39:58] Cleaning up...
[2017-12-10 02:39:58] Update complete, launching...
[2017-12-10 02:39:58] Shutdown
Running Steam on debian  64-bit
STEAM_RUNTIME is enabled automatically
Pins potentially out-of-date, rebuilding...
Found newer runtime version for 64-bit libdbusmenu-glib.so.4. Host: 4.0.12 Runtime: 4.0.13
Found newer runtime version for 64-bit libGLU.so.1. Host: 1.3.1 Runtime: 1.3.8004
[2017-12-10 02:40:16] Startup - updater built Oct 30 2017 19:09:32
[2017-12-10 02:40:16] Verifying installation...
[2017-12-10 02:40:16] Unable to read and verify install manifest /root/.steam/package/steam_client_ubuntu12.installed
[2017-12-10 02:40:16] Verification complete
[2017-12-10 02:40:16] Downloading update...
[2017-12-10 02:40:16] Checking for available updates...
[2017-12-10 02:40:16] Download complete.
[2017-12-10 02:40:16] uninstalled manifest found in /root/.steam/package/steam_client_ubuntu12 (1).
[2017-12-10 02:40:16] Extracting package...
[2017-12-10 02:40:22] Installing update...
[2017-12-10 02:40:26] Cleaning up...
[2017-12-10 02:40:26] Update complete, launching Steam...
[2017-12-10 02:40:26] Shutdown
Restarting Steam by request...
Running Steam on debian  64-bit
STEAM_RUNTIME has been set by the user to: /root/.steam/ubuntu12_32/steam-runtime
Pins up-to-date!
[2017-12-10 02:40:26] Startup - updater built Oct 30 2017 19:09:32
[2017-12-10 02:40:26] Verifying installation...
[2017-12-10 02:40:26] Verification complete
 



je vois aucune difficulté hmm
je suis vieux , pas très réactif roll hmm sad  tongue   et pourtant j'arrive a installer Steam  wink    cool

a toi de le faire maintenant et de le faire bien   wink

nota : j'ai mit plus de temps a faire ce post , que le temps qu a pris l'installation de Steam

PS: dans mon exemple au dessus j'ai lancé Steam en root , grosse erreur , j'aurai du passer en console user , je modifie en conséquence

un petit complément :
dans ton /home/user  afficher les dossiers caché
tu dois avoir un dossier "Steam"  et un dossier ".steam"
si tu refais une installation bien supprimer ces dossiers avant.

vérifier ton driver vidéo
installer le paquet mesa-utils


apt-get install mesa-utils
 


puis taper la commande en user


glxinfo -B
 


retour pour moi sur buster avec une GTX950 (sous stretch quelque  chose d'équivalent a part les versions )


name of display: :0
display: :0  screen: 0
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 950/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 384.98
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5.0 NVIDIA 384.98
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 384.98
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 



tu a la commande glxgears aussi , pour fermer tu click sur la croix de la fenetre ou les engrenages tournent

si tu passe ces deux tests c'est bon signe , ensuite pour lancer steam passe par le menu du bureau plutot qu en console (moi je l ai fait pour te montrer le retour des commandes )
par contre pour installer steam avec aptitude note (ou copier coller ) de ce que dit la console

nota : en plus d un éventuel problème de driver vidéo , j'ai peur que avec tous les tests que tu a fait , il reste des choses installé qui font planter Steam

Dernière modification par robert2a (10-12-2017 06:49:06)

Hors ligne

#14 14-12-2017 22:35:37

fatpat
Membre
Distrib. : DF "Stretch" , MX 1.6, Mint 18
Noyau : 4.9.0-3-amd64, 4.7.0-0.bpo.1-amd64,4.10.0-40-gener
(G)UI : Xfce, XFCE, Mate
Inscription : 30-10-2017

Re : Impossible de lancer Steam

Bon, commençons par le début : rajouter des sources listes , j'essaye par synaptic d'ajouter des dépots et .... impossible ... la première instruction et ellefoire !!!!
Merci quand même pour l'aide Robert smile

Hors ligne

#15 15-12-2017 00:36:29

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Impossible de lancer Steam

Pour modifier les sources, tu peux utiliser le terminal en mode superutilisateur :
Voir le lien : https://debian-facile.org/doc:systeme:superutilisateur
Puis, dans le terminal ouvrir et modifier les sources indiquées avec nano :
Lien des sources : https://debian-facile.org/doc:systeme:apt:sources.list
Lien de nano : https://debian-facile.org/doc:editeurs:nano
Lien des sources stable : https://debian-facile.org/doc:systeme:a … st:stretch
Lien des sources testing (du nom de buster actuellement) : https://debian-facile.org/doc:systeme:a … st:testing

Et tu y vas calmement.

Force et courage

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums