Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-01-2018 20:47:09

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.18.0-2-amd64 debian
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

[clos] i-nex et cpu-z

bonsoir tout le monde et bonne année à tous .

voilà , cherchant des programmes équivalents à cpu-z (w$) mais sous linux ,

j'ai trouvé ces deux là :

I-Nex
cpu-g

mais (il faut bien qu'il y en ait un) , cpu-g semble dédié à ubuntu ;

et I-Nex , lui , ne se compile pas sous debian . malgré les  consignes données

~$ git clone https://github.com/eloaders/I-Nex.git


Clonage dans 'I-Nex'...
remote: Counting objects: 10454, done.
remote: Total 10454 (delta 0), reused 0 (delta 0), pack-reused 10454
Réception d'objets: 100% (10454/10454), 14.16 MiB | 9.18 MiB/s, fait.
Résolution des deltas: 100% (6833/6833), fait.


là ça va ...

~$ cd ./I-Nex


~/I-Nex$


là aussi ...

~/I-Nex$ fakeroot debian/rules build


dh build --with autoreconf
   dh_update_autotools_config
   debian/rules override_dh_autoreconf
make[1] : on entre dans le répertoire « /home/alain-buster/I-Nex »
cd I-Nex && autoreconf -i
configure.ac:4: warning: AM_INIT_AUTOMAKE: two- and three-arguments forms are deprecated.  For more info, see:
configure.ac:4: http://www.gnu.org/software/automake/manual/automake.html#Modernize-AM_005fINIT_005fAUTOMAKE-invocation
configure.ac:4: installing './install-sh'
configure.ac:4: installing './missing'
make[1] : on quitte le répertoire « /home/alain-buster/I-Nex »
   debian/rules override_dh_auto_configure
make[1] : on entre dans le répertoire « /home/alain-buster/I-Nex »
dh_auto_configure --sourcedirectory=I-Nex
  cd I-Nex && ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=\${prefix}/include --mandir=\${prefix}/share/man --infodir=\${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=\${prefix}/lib/x86_64-linux-gnu --libexecdir=\${prefix}/lib/x86_64-linux-gnu --disable-maintainer-mode --disable-dependency-tracking
configure: WARNING: unrecognized options: --disable-maintainer-mode, --disable-dependency-tracking
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for gambas3 binaries... ./configure: line 2351: gbx3: command not found
No
./configure: line 409: test: check: integer expression expected
configure: error: your
./configure: line 298: return: check: numeric argument required
./configure: line 308: exit: check: numeric argument required
  cd I-Nex && tail -v -n \+0 config.log
==> config.log <==
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  $ ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=${prefix}/lib/x86_64-linux-gnu --libexecdir=${prefix}/lib/x86_64-linux-gnu --disable-maintainer-mode --disable-dependency-tracking

## --------- ##
## Platform. ##
## --------- ##

hostname = Alain-PC-BUSTER
uname -m = x86_64
uname -r = 4.14.12-amd64
uname -s = Linux
uname -v = #1 SMP Fri Jan 5 19:58:58 CET 2018

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/bin
PATH: /usr/bin
PATH: /bin
PATH: /usr/local/games
PATH: /usr/games


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1766: checking for a BSD-compatible install
configure:1834: result: /usr/bin/install -c
configure:1845: checking whether build environment is sane
configure:1900: result: yes
configure:2051: checking for a thread-safe mkdir -p
configure:2090: result: /bin/mkdir -p
configure:2097: checking for gawk
configure:2113: found /usr/bin/gawk
configure:2124: result: gawk
configure:2135: checking whether make sets $(MAKE)
configure:2157: result: yes
configure:2186: checking whether make supports nested variables
configure:2203: result: yes
configure:2349: checking for gambas3 binaries
configure:2353: result: No

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=x86_64-linux-gnu
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/usr/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_make_make_set=yes
am_cv_make_support_nested_variables=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/alain-buster/I-Nex/I-Nex/missing aclocal-1.15'
AMTAR='$${TAR-tar}'
AM_BACKSLASH='\'
AM_DEFAULT_V='$(AM_DEFAULT_VERBOSITY)'
AM_DEFAULT_VERBOSITY='1'
AM_V='$(V)'
AUTOCONF='${SHELL} /home/alain-buster/I-Nex/I-Nex/missing autoconf'
AUTOHEADER='${SHELL} /home/alain-buster/I-Nex/I-Nex/missing autoheader'
AUTOMAKE='${SHELL} /home/alain-buster/I-Nex/I-Nex/missing automake-1.15'
AWK='gawk'
COMPONENT_build=''
COMPONENT_name=''
CYGPATH_W='echo'
DEFS=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
GAMBAS_path='/bin'
GBCONTROL_path=''
GBINFO_path=''
GBLIBRARY_path=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LIBOBJS=''
LIBS=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /home/alain-buster/I-Nex/I-Nex/missing makeinfo'
MKDIR_P='/bin/mkdir -p'
PACKAGE='i-nex'
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_URL=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
SET_MAKE=''
SHELL='/bin/bash'
STRIP=''
VERSION='7.4.0'
am__isrc=''
am__leading_dot='.'
am__tar='$${TAR-tar} chof - "$$tardir"'
am__untar='$${TAR-tar} xf -'
bindir='${exec_prefix}/bin'
build_alias='x86_64-linux-gnu'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE}'
dvidir='${docdir}'
exec_prefix='NONE'
host_alias=''
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${prefix}/share/info'
install_sh='${SHELL} /home/alain-buster/I-Nex/I-Nex/install-sh'
libdir='${prefix}/lib/x86_64-linux-gnu'
libexecdir='${prefix}/lib/x86_64-linux-gnu'
localedir='${datarootdir}/locale'
localstatedir='/var'
mandir='${prefix}/share/man'
mkdir_p='$(MKDIR_P)'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/usr'
program_transform_name='s,x,x,'
psdir='${docdir}'
runstatedir='${localstatedir}/run'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE_URL ""
#define PACKAGE "i-nex"
#define VERSION "7.4.0"

configure: exit 2
dh_auto_configure: cd I-Nex && ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=\${prefix}/include --mandir=\${prefix}/share/man --infodir=\${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=\${prefix}/lib/x86_64-linux-gnu --libexecdir=\${prefix}/lib/x86_64-linux-gnu --disable-maintainer-mode --disable-dependency-tracking returned exit code 2
debian/rules:12 : la recette pour la cible « override_dh_auto_configure » a échouée
make[1]: *** [override_dh_auto_configure] Erreur 2
make[1] : on quitte le répertoire « /home/alain-buster/I-Nex »
debian/rules:18 : la recette pour la cible « build » a échouée
make: *** [build] Erreur 2


et là ça foire . première étape de la compilation ....

comprends plus , moi .

même ./configure ne fonctionne pas .

un p'tit coup de main ?

merci

en suivant ceci : https://www.debian.org/doc/manuals/main … ld.fr.html

j'ai fait :

~/I-Nex$ dpkg-buildpackage -us -uc


dpkg-buildpackage: info: paquet source i-nex
dpkg-buildpackage: info: version source 7.6.0
dpkg-buildpackage: info: distribution source stable
dpkg-buildpackage: info: source changé par eloaders <eloaders@linux.pl>
dpkg-buildpackage: info: architecture hôte amd64
 dpkg-source --before-build I-Nex
dpkg-checkbuilddeps: erreur: Unmet build dependencies: libcpuid14-dev gambas3-dev (>= 3.8.4) gambas3-gb-image (>= 3.8.4) gambas3-gb-qt5 (>= 3.8.4) gambas3-gb-form (>= 3.8.4) gambas3-gb-desktop (>= 3.8.4) gambas3-gb-desktop-x11 (>= 3.8.4)
dpkg-buildpackage: avertissement: dépendances de construction et conflits non satisfaits ; échec.
dpkg-buildpackage: avertissement: (Utilisez l'option -d pour forcer.)



~/I-Nex$ sudo apt install gambas


[sudo] Mot de passe de alain-buster : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet gambas



après installation de gambas3 , la compilation s'effectue sans accroc .

mais :

~$ sudo dpkg -i ./i-nex*.deb


Sélection du paquet i-nex précédemment désélectionné.
(Lecture de la base de données... 481276 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de ./i-nex_7.6.0_amd64.deb ...
Dépaquetage de i-nex (7.6.0) ...
Sélection du paquet i-nex-dbgsym précédemment désélectionné.
Préparation du dépaquetage de ./i-nex-dbgsym_7.6.0_amd64.deb ...
Dépaquetage de i-nex-dbgsym (7.6.0) ...
dpkg: des problèmes de dépendances empêchent la configuration de i-nex :
 i-nex dépend de libcpuid14 (>= 0.4) ; cependant :
  Le paquet libcpuid14 n'est pas installé.
 i-nex dépend de pastebinit (>= 1.4) ; cependant :
  Le paquet pastebinit n'est pas installé.

dpkg: erreur de traitement du paquet i-nex (--install) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de i-nex-dbgsym :
 i-nex-dbgsym dépend de i-nex (= 7.6.0) ; cependant :
 Le paquet i-nex n'est pas encore configuré.

dpkg: erreur de traitement du paquet i-nex-dbgsym (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour menu (2.1.47+b1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-2) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-4) ...
Des erreurs ont été rencontrées pendant l'exécution :
 i-nex
 i-nex-dbgsym



bon j'abandonne , i-nex utilise libcpuid en x86 , ,donc inutilisable sur ma plateforme (64 bits) .

j'efface les debs compilés ainsi que le dossier .

terminé .

Dernière modification par Debian Alain (07-01-2018 18:22:58)


1498812139.jpg    Antonio Vivaldi - Winter (Trance Remix) 
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

Pied de page des forums