Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-03-2018 20:25:42

Debion
Membre
Distrib. : Debian 9.4.0 Stretch
Noyau : Linux 4.9.0-6-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 24-02-2018

Problème Steam steamui.so

Bonjour,

J'ai installé Steam avec ce tutoriel : https://wiki.debian.org/fr/Steam

Je lance Steam, normal ça télécharge les données puis ça m'indique :

Fatal Error ; Failed to load steamui.so

Je ne sais pas d'où cela vient.

Merci d'avance !

Utilisateur de Linux ! Vive Linux !
Mon ordi : Asus K501LX / Intel Core i5 5200U / Nvidia Geforce GTX 950M 2 Go / 8 Go DDR3L
Debian 9.4.0 Stretch
Raspberry Pi 3 B+ / Raspberry Pi Zero W

Hors ligne

#2 06-03-2018 19:05:58

Privateer2
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome 3 au moins
Inscription : 04-09-2017

Re : Problème Steam steamui.so

J'essaye par ici, http://store.steampowered.com/about/
Le .deb est télécharger, mais pas moyen d'installer en ligne de commande

Bonjour et merci
(L'impression d'être dans un salon de lecture)

(Pourquoi 32 Go ? 16 Go pour l'usage , plus 16 Go pour une trentaine d'onglets/tuto ouverts en permanence smile)

Hors ligne

#3 06-03-2018 19:53:58

robert2a
Membre
Lieu : France
Distrib. : Stretch 9 , Buster 10 , Sid
Noyau : Linux 4.9 / 4.16.12 / 4.18-rc2
(G)UI : Mate/Gnome
Inscription : 15-11-2014

Re : Problème Steam steamui.so

@Debion

surement d'un problème vidéo , steam utilise le i386 , donc ton driver vidéo aussi ( plus de détail sur ta configuration et a tu installé le multiarch ? )

@Privateer2


dpkg -i "lenomdupaquet.deb"
 



avec gnome tu a un utilitaire => gdebi  pour installer les .deb
click droit sur le paquet et installer avec gdebi

il te manque peut etre des dépendances , et il te faut le multi-arch d'installé si tu est en amd64 (pour le i386 )

tu a un paquet sur debian pour steam
tu a testé :


aptitude install steam
 

Dernière modification par robert2a (06-03-2018 19:57:35)

Hors ligne

#4 06-03-2018 20:16:56

Debion
Membre
Distrib. : Debian 9.4.0 Stretch
Noyau : Linux 4.9.0-6-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 24-02-2018

Re : Problème Steam steamui.so

Bonsoir,

J'ai finalement arrêter d'essayer de résoudre le problème car j'ai regardé sur d'autres forums, le problème ne peut être résolu.

Merci d'avoir essayé de m'aider.

Utilisateur de Linux ! Vive Linux !
Mon ordi : Asus K501LX / Intel Core i5 5200U / Nvidia Geforce GTX 950M 2 Go / 8 Go DDR3L
Debian 9.4.0 Stretch
Raspberry Pi 3 B+ / Raspberry Pi Zero W

Hors ligne

#5 06-03-2018 20:29:23

Privateer2
Membre
Distrib. : Debian GNU/Linux 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome 3 au moins
Inscription : 04-09-2017

Re : Problème Steam steamui.so

Merci, j'essaye tout ça demain dans le calme

dpkg -i steam_latest.deb


Sélection du paquet steam-launcher précédemment désélectionné.
(Lecture de la base de données... 162948 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de steam_latest.deb ...
Dépaquetage de steam-launcher (1.0.0.54) ...
dpkg: des problèmes de dépendances empêchent la configuration de steam-launcher :
 steam-launcher dépend de curl ; cependant :
  Le paquet curl n'est pas installé.
 steam-launcher dépend de python-apt ; cependant :
  Le paquet python-apt n'est pas installé.

dpkg: erreur de traitement du paquet steam-launcher (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-9) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 steam-launcher

Dernière modification par Privateer2 (06-03-2018 20:35:01)


Bonjour et merci
(L'impression d'être dans un salon de lecture)

(Pourquoi 32 Go ? 16 Go pour l'usage , plus 16 Go pour une trentaine d'onglets/tuto ouverts en permanence smile)

Hors ligne

#6 08-03-2018 21:48:07

Slyfox
Membre
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Mate 1.16
Inscription : 15-12-2013

Re : Problème Steam steamui.so

Bonjour les ami(e)s smile

Voici ma méthode pour installer Steam:
Pour commencer j'ajoute le dépôt Steam:

# Steam for Linux
  deb [arch=i386] http://repo.steampowered.com/steam/ precise steam


Voici comment rajouter (si ce n'est pas déjà fait) le dépôt en ligne de commande:

echo -e "\n# Steam\n  deb [arch=i386] http://repo.steampowered.com/steam/ precise steam" >> /etc/apt/sources.list


Ensuite une séries de diverses commandes:

dpkg --add-architecture i386
apt-get update
apt-get upgrade


Selon ce lien: https://wiki.debian.org/fr/Steam#Installation
Pour les systèmes muni de cartes graphiques Nvidia :

apt-get  install libgl1-nvidia-glx:i386


Pour les systèmes muni de cartes graphiques ATI/AMD :

apt-get install libgl1-fglrx-glx:i386


Pour les systèmes muni de cartes graphiques AMDGPU : (testé sur stretch)

apt-get install xserver-xorg-video-amdgpu:i386 xorg-video-abi-23:i386 xserver-xorg-core:i386


Ensuite pour tous...

apt-get update
apt-get install steam



Lancer Steam et si il y a un problème, essayer cette commande qui indique les paquets manquants et à installer:

STEAM_RUNTIME=0 steam


Attention! Il faut installer les paquets manquants en 32 bits (i386).
Ci-dessous la liste des paquets que j'ai dû installer sur mon système:

apt-get install libxtst6:i386 libxrandr2:i386 libgl1-mesa-glx:i386 libglib2.0-0:i386 libgtk2.0-0:i386 libpulse0:i386 libgdk-pixbuf2.0-0:i386 libgl1-nvidia-glx:i386 libva1:i386 libvdpau1:i386 libbz2-1.0:i386


Lancer Steam et si ça ne fonctionne pas refaire (tant qu'il manque des paquets) la commande ci-dessous:

STEAM_RUNTIME=0 steam



Pour info... si on a cet avertissement:

Could not load module 'vgui2_s.so'.
For more information visit https://support.steampowered.com/kb_art … -OZVN-0660


Lancer Steam (normalement) via l’onglet "Jeu" ou voir ce lien: https://support.steampowered.com/kb_art … -OZVN-0660


cd /home/$USER/.steam/bin32
LD_LIBRARY_PATH=. ldd vgui2_s.so



Relancer Steam et normalement ça devrai fonctionner.

Liens:
https://debian-facile.org/doc:jeux:steam
http://store.steampowered.com/about/
https://www.debian-fr.org/t/steam-sous- … id/56701/2
https://forums.archlinux.fr/viewtopic.php?t=18139

Dernière modification par Slyfox (11-03-2018 10:54:19)

Hors ligne

Pied de page des forums