Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-05-2018 19:47:13

cocowin
Membre
Distrib. : Debian testing
Noyau : Linux 4.16.0-1-amd64
(G)UI : LXQt
Inscription : 05-05-2018

(résolu) Comment démarrer en mode graphique ? (problème avec sddm)

Alors je sais que ma question peut paraître évidente. Une simple recherche Google me donner des centaines de résultats. L'ennui, c'est qu'aucune de ces personnes n'a mon problème.

Enfin problème... Rien ne cloche, c'est juste moi qui ne sais pas comment faire une manip. lol

J'explique : je viens d'installer Debian testing, et j'ai sélectionné LXQt comme environnement de bureau.

Je redémarre, je me connecte en console, je fait startx et tout se lance parfaitement.

Ma question : comment démarrer directement en mode graphique ? Avec ce magnifique écran qui me demande mon mot de passe ?

J'ai essayé de désinstaller puis réinstaller sddm, mais le résultat est toujours le même.

Merci de votre aide ! merci.gif

Dernière modification par cocowin (06-05-2018 12:25:48)


Faisons un jeu : le premier qui dit "windobe" a perdu !

Hors ligne

#2 06-05-2018 10:10:58

lann
Membre
Distrib. : Debian Stretch
Noyau : 4.9.0-3-amd64
(G)UI : XFCE
Inscription : 28-04-2015

Re : (résolu) Comment démarrer en mode graphique ? (problème avec sddm)

Tu as un wiki : https://debian-facile.org/doc:environnements:kde:sddm
Sinon, tu dois certainement avoir des erreurs

Tu peux aussi essayer un autre gestionnaire d'affichage

Hors ligne

#3 06-05-2018 11:07:22

cocowin
Membre
Distrib. : Debian testing
Noyau : Linux 4.16.0-1-amd64
(G)UI : LXQt
Inscription : 05-05-2018

Re : (résolu) Comment démarrer en mode graphique ? (problème avec sddm)

Merci de la réponse, mais ce wiki ne m'aide pas. Il explique comment le configurer, l'installer... Mais pas comment le lancer automatiquement au démarrage.

J'ai quand même fait (en root) :

sddm --example-config > /etc/sddm.conf



Mais le résultat reste le même.

J'ai aussi essayé la commande sytemctl en root, voilà le résultat :

systemctl enable sddm


Synchronizing state of sddm.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable sddm
The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
   instance name specified.



Mais... je pige rien. crash.gif

Devrais-je essayer d'installer gdm ?

Dernière modification par cocowin (06-05-2018 11:08:41)


Faisons un jeu : le premier qui dit "windobe" a perdu !

Hors ligne

#4 06-05-2018 12:24:57

cocowin
Membre
Distrib. : Debian testing
Noyau : Linux 4.16.0-1-amd64
(G)UI : LXQt
Inscription : 05-05-2018

Re : (résolu) Comment démarrer en mode graphique ? (problème avec sddm)

Ok, j'ai du nouveau :

En désinstallant sddm, puis en installant lightdm, aucun problème, lightdm se lance.

Manip similiare avec lxdm, même résultat, 0 problèmes rencontrés.

Je réinstalle sddm, patatra, démarrage en mode console.

Le problème vient donc de sddm spécifiquement. Je vais donc juste espérer que cela soit corrigé dans les prochaines versions, et au pire j'utilise lxdm, c'est pas dramatique.

Faisons un jeu : le premier qui dit "windobe" a perdu !

Hors ligne

#5 06-05-2018 14:38:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : (résolu) Comment démarrer en mode graphique ? (problème avec sddm)

Que donne tes sources ?
Les commandes :

cat /etc/apt/sources.list


et :

ls /etc/apt/sources.list.d


Nous en diront plus sur ce wingobe là !
Même pas que j'ai perdu ! wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 06-05-2018 15:31:27

cocowin
Membre
Distrib. : Debian testing
Noyau : Linux 4.16.0-1-amd64
(G)UI : LXQt
Inscription : 05-05-2018

Re : (résolu) Comment démarrer en mode graphique ? (problème avec sddm)

smolski a écrit :

Que donne tes sources ?
Les commandes :

cat /etc/apt/sources.list


et :

ls /etc/apt/sources.list.d


Nous en diront plus sur ce wingobe là !
Même pas que j'ai perdu ! wink


Le fichier sources.list :

deb http://ftp.ch.debian.org/debian/ buster main
deb-src http://ftp.ch.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free



Et le dossier sources.list.d est vide.

Une installation standard, quoi. smile


Faisons un jeu : le premier qui dit "windobe" a perdu !

Hors ligne

#7 06-05-2018 16:58:47

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : (résolu) Comment démarrer en mode graphique ? (problème avec sddm)

Je t'engage à consulter le wiki concernant testing :
https://debian-facile.org/doc:systeme:a … st:testing

Il peut être avantageux de le compléter avec sid et expérimental sous un pinning comme indiqué dans le tuto afin de récupérer ou préserver au mieux une configuration fonctionnelle. cool

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums