Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-05-2018 10:22:15

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

[clos] localhost et mon site

bonjour  big_smile

j'observe , depuis un petit bout de temps  , maintenant ,

que localhost/ m'envoie sur mon site internet

localhost/wp-admin/ m'envoie sur mon word press local , ça c'est bien .

mais comment modifier le comportement  de localhost/  ?

pour qu'il me renvoie sur mon site local  ?

merci

j'ai trouvé çà  :  https://www.wistee.fr/configuration-nom … hosts.html

$ ls /etc/host*.*



host.conf  hosts.allow  hosts.deny
 



$ cat host.conf


multi on



alain@Alain-PC:~$ cat /etc/hosts.allow


# /etc/hosts.allow: list of hosts that are allowed to access the system.
#                   See the manual pages hosts_access(5) and hosts_options(5).
#
# Example:    ALL: LOCAL @some_netgroup
#             ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
#
# If you're going to protect the portmapper use the name "rpcbind" for the
# daemon name. See rpcbind(8) and rpc.mountd(8) for further information.
#
 



~$ cat /etc/hosts.deny


# /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
#                  See the manual pages hosts_access(5) and hosts_options(5).
#
# Example:    ALL: some.host.name, .some.domain
#             ALL EXCEPT in.fingerd: other.host.name, .other.domain
#
# If you're going to protect the portmapper use the name "rpcbind" for the
# daemon name. See rpcbind(8) and rpc.mountd(8) for further information.
#
# The PARANOID wildcard matches any host whose name does not match its
# address.
#
# You may wish to enable this to ensure any programs that don't
# validate looked up hostnames still leave understandable logs. In past
# versions of Debian this has been the default.
# ALL: PARANOID
 

Dernière modification par Debian Alain (20-07-2018 13:12:21)


1498812139.jpg TEXAS - SUMMER SUN (2017)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#2 31-05-2018 11:23:06

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : [clos] localhost et mon site

j'ai trouvé un début de solution  .

ça s'appelerait  : le forward automatique .

mais j'en sais pas plus : pas de renseignement  sur google .

1498812139.jpg TEXAS - SUMMER SUN (2017)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#3 31-05-2018 14:09:32

Artheriom
Membre
Lieu : Clermont-Ferrand
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-5-amd64
(G)UI : Gnome3
Inscription : 29-01-2018
Site Web

Re : [clos] localhost et mon site

Coucou,

Que veux-tu faire précisément, que localhost/ renvoie toujours sur localhost/wp-admin/ ?

Étudiant en Master à l'Institut Informatique d'Auvergne.
Parfois je fais des trucs sur le Oueb", et généralement ça fonctionne. Fondateur de Goldheim https://goldheim.fr/
Linuxien convaincu depuis 2010. Adepte de Debian, CentOS, Mandrake, Ubuntu, SolusOS. Mandravia, c'était pas si mal.

Hors ligne

#4 31-05-2018 14:23:10

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [clos] localhost et mon site

Tu mets un "index.php" dans ta racine contenant un

header("Location: http://example.com/myOtherPage.php");
die();



Sinon plus élégant c'est d'adapter ta config apache, mais pour ça faut connaître apache un peu, ce qui est pas mon cas.

Dernière modification par otyugh (31-05-2018 14:23:57)


Agenda du libre : dépannage par des bénévoles pour tout le monde !
Arzano Informatique : dépannage gagne-pain.
Liste de balados (aussi dit "podcast") : emissions audio pro/amateur

Hors ligne

#5 31-05-2018 14:44:50

raleur
Membre
Inscription : 03-10-2014

Re : [clos] localhost et mon site

Debian Alain a écrit :

j'observe , depuis un petit bout de temps  , maintenant ,
que localhost/ m'envoie sur mon site internet
localhost/wp-admin/ m'envoie sur mon word press local , ça c'est bien .
mais comment modifier le comportement  de localhost/  ?
pour qu'il me renvoie sur mon site local  ?


Ce serait bien si tu pouvais être plus clair et plus explicite dans tes explications. Nous ne sommes pas dans ta tête, ni dans ton ordinateur, ni devant ton écran. Devoir jouer aux devinettes ne fait pas gagner du temps.

Si je comprends bien, tu as un serveur web local sur ton ordinateur hébergeant un site auquel tu accèdes par des URL http://localhost/... ?
Quel est le logiciel serveur web utilisé ? Apache, autre ?
Que veux-tu dire exactement par "m'envoie sur mon site internet" ? Où ce site est-il hébergé ? Sur le serveur local aussi ? Ce "renvoi" occasionne-t-il un changement d'URL ?
Qu'appelles-tu "mon site local" ? Où est-il stocké ?

Debian Alain a écrit :

j'ai trouvé çà  :  https://www.wistee.fr/configuration-nom … hosts.html


On ne touche pas à la résolution de nom de localhost.

Debian Alain a écrit :

ls /etc/host*.*


Qu'est-ce que ces fichiers ont à voir avec la résolution de localhost ? C'est le fichier /etc/hosts qui contient les noms définis localement. L'expression hosts*.* n'englobe pas le fichier "hosts" car le nom de ce dernier ne contient pas de point.

Hors ligne

#6 31-05-2018 16:56:14

Debian Alain
Adhérent(e)
Lieu : BREST
Distrib. : W$10 / stable / ubuntu / testing
Noyau : Linux 4.17.0-1 debian
(G)UI : Gnome classic / Gdm3
Inscription : 11-03-2017
Site Web

Re : [clos] localhost et mon site

arf ! oui , j'ai pas été clair .

bon ,  alors , récapitulatif  :

configuration debian testing sur ssd 500 go

serveur L.A.M.P.

Linux debian testing kernel 4.16.0-2
Apache2 (2.4.33-3)
Mysql (15.1 distrib 10.1.29 MariaDB)
PHP 7.2 (7.2+61)

wordpress 4.9.6

WP installé sur mon serveur L.A.M.P.

site créé en local . tout fonctionne parfaitement . y compris les banières .

en local , donc , le site ne fonctionne que dans :  localhost/wp-admin/customize.php



en distant : sur mon site web :
le site fonctionne  (mal)  sur 

https://alain-bellec.000webhostapp.com


( voir mon profil )

le but du jeu est d'accéder à mon site en local sans avoir à rentrer dans 

localhost/wp-admin/customize.php



simplement en tapant

localhost

.

or , cela me renvoie sur mon site internet en https://....

 $ ls /etc/h*



/etc/hddtemp.db   /etc/host.conf  /etc/hosts        /etc/hosts.deny
/etc/hdparm.conf  /etc/hostname   /etc/hosts.allow

/etc/hotplug:
usb

/etc/hp:
hplip.conf

 



hosts est totalement vide

$ ls -la /etc/hosts



-rw-r--r-- 1 root root 201 mai   11 12:40 /etc/hosts
 

Dernière modification par Debian Alain (31-05-2018 17:04:54)


1498812139.jpg TEXAS - SUMMER SUN (2017)
RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON PULSE RX 550 4GB DDR5 OC UEFI - CORSAIR RM750X - SSD crucial MX500 500GB

Hors ligne

#7 01-06-2018 14:49:54

raleur
Membre
Inscription : 03-10-2014

Re : [clos] localhost et mon site

Ton site semble hébergé chez Amazon ou un truc du genre, pas sur ton serveur.
Donc si le navigateur te renvoie de http://localhost à l'URL de ton site, cela veut dire qu'il y a une redirection dans la page d'accueil du site (virtualhost) par défaut du serveur local.
Cette redirection peut être dans la déclaration du site par défaut (cf. /etc/apache/sites-enabled ou approchant), dans un fichier .htaccess, index.html, index.php... à la racine du site (définie dans la déclaration du site), par exemple /var/www, /srv/www.

Désolé pour les approximations mais je n'ai pas touché à Apache depuis très longtemps.

Edit : /etc/hosts n'est pas vide, il pèse 201 octets. Mais peu importe, c'est hors sujet.

Dernière modification par raleur (01-06-2018 14:50:55)

Hors ligne

Pied de page des forums