Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-07-2018 14:21:49

Micka260
Membre
Inscription : 12-07-2018

[Resolu] Virtualbox - Kernel driver not installed

Bonjour,

J'ai un ordinateur NAS sous openmediavault, qui tourne lui même sous débian stretch ... donc on peu dire que je suis sous débian stretch sans interface graphique.
Je souhaite utiliser Virtualbox, j'ai donc dans un premier temps j'ai installer une interface graphique légère : LXDE que je ne lancerai que lorsque je veux utiliser Virtualbox.

Pour l'installation j'ai suivie plusieurs tuto sur le net, avec lesquelles j'ai installé virtualbox depuis un fichier .deb téléchargé sur le site officiel de virtualbox.

Le logiciel se lance bien, mais lorsque je veux démarrer ma machine virtuelle j'ai ce message d'erreur :
Capture_d_e_cran_2018_07_11_a_20_52_47.png

Pouvez vous m'aider ?

Merci,

Dernière modification par Micka260 (17-07-2018 18:32:48)

Hors ligne

#2 12-07-2018 19:36:23

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Resolu] Virtualbox - Kernel driver not installed

Bonjour
Tu as la réponse a ta question dans ta copie d'écran
Mais avant il te faut installer quelques paquets puis lancer le script vboxconfig

2.3.2 Le module noyau de VirtualBox
VirtualBox utilise un module spécial du noyau appelé vboxdrv pour effectuer des affectations de
mémoire physique et contrôler le processeur pour exécuter les systèmes invités. Sans ce mod-
ule du noyau, vous pouvez utiliser le gestionnaire de VirtualBox pour configurer des machines
virtuelles mais elles ne démarreront pas. En outre, existe des modules noyau vboxnetflt et
vboxnetadp requis pour les fonctionnalités réseau plus avancées de VirtualBox.
Le module noyau de VirtualBox est automatiquement installé sur votre système quand vous
installez VirtualBox. Pour le maintenir avec les futures mises à jour du noyau, pour les distri-
butions Linux qui le permettent – la plupart de celles actuelles – nous recommandons d’installer
Dynamic Kernel Module Support (DKMS) 2 . Cet environnement vous aide à construire et à mettre
à jour les modules du noyau.
Si DKMS n’est pas déjà installé, exécutez une des procédures suivantes :

apt get install dkms


Si DKMS est disponible et installé, le module du noyau VirtualBox devrait toujours fonctionner
automatiquement et il sera automatiquement reconstruit si vous mettez à jour le noyau de votre
hôte.
Sinon, il n’y a que deux situations où vous devrez vous préoccuper du module noyau :
1. L’installation échoue dès le départ. Cela signifie probablement que votre système Linux
n’est pas prêt à construire des modules noyau externes.
La plupart des distributions Linux peuvent être paramétrées simplement en installant les
bons paquets - en principe il s’agit du compilateur GNU (GCC), GNU Make (make) et des
paquets contenant les fichiers d’en-tête de votre noyau - et en s’assurant que toutes les
mises à jour du système sont installées et que le système exécute le noyau le plus récent
proposé par la distribution. Les numéros de version des paquets des fichiers d’en-tête doivent
être les mêmes que celui du noyau que vous utilisez.
vous devez installer la bonne version de
linux-headers et s’il existe, le paquet linux-kbuild .
La par contre il te faut installer la version qui correspond au noyau installé et a la bonne architecture

uname -a


te renseignera

apt search linux-headers


apt search linux-kbuild


Normalement si tu es sous Debian stable tu devrais avoir le noyau 4.9
donc
installes le meta-package

apt install linux-headers-4.9.0-6-all linux-kbuild-4.9



Une fois installé tu pourras lancer le script de configuration

/sbin/vboxconfig

Dernière modification par Croutons (12-07-2018 19:37:43)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 12-07-2018 20:25:16

Micka260
Membre
Inscription : 12-07-2018

Re : [Resolu] Virtualbox - Kernel driver not installed

Merci pour ta réponse, mais cela ne semble toujours pas fonctionner.
Voici les réponses Shell à tes lignes de commande :

root@Micka-NAS:~# sudo apt-get install dkms
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
dkms is already the newest version (2.3-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 40 non mis à jour.



root@Micka-NAS:~# uname -a
Linux Micka-NAS 4.16.0-0.bpo.1-amd64 #1 SMP Debian 4.16.5-1~bpo9+1 (2018-05-06) x86_64 GNU/Linux



root@Micka-NAS:~# apt search linux-headers
En train de trier... Fait
Recherche en texte intégral... Fait
aufs-dkms/stable 4.9+20161219-1 amd64
  DKMS files to build and install aufs

linux-headers-4.16.0-0.bpo.2-all/stretch-backports 4.16.16-2~bpo9+1 amd64
  All header files for Linux 4.16 (meta-package)

linux-headers-4.16.0-0.bpo.2-all-amd64/stretch-backports 4.16.16-2~bpo9+1 amd64
  All header files for Linux 4.16 (meta-package)

linux-headers-4.16.0-0.bpo.2-amd64/stretch-backports 4.16.16-2~bpo9+1 amd64
  Header files for Linux 4.16.0-0.bpo.2-amd64

linux-headers-4.16.0-0.bpo.2-cloud-amd64/stretch-backports 4.16.16-2~bpo9+1 amd64
  Header files for Linux 4.16.0-0.bpo.2-cloud-amd64

linux-headers-4.16.0-0.bpo.2-common/stretch-backports 4.16.16-2~bpo9+1 all
  Common header files for Linux 4.16.0-0.bpo.2

linux-headers-4.16.0-0.bpo.2-common-rt/stretch-backports 4.16.16-2~bpo9+1 all
  Common header files for Linux 4.16.0-0.bpo.2-rt

linux-headers-4.16.0-0.bpo.2-rt-amd64/stretch-backports 4.16.16-2~bpo9+1 amd64
  Header files for Linux 4.16.0-0.bpo.2-rt-amd64

linux-headers-4.9.0-3-all/stable 4.9.30-2+deb9u5 amd64
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-3-all-amd64/stable 4.9.30-2+deb9u5 amd64
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-3-amd64/stable 4.9.30-2+deb9u5 amd64
  Header files for Linux 4.9.0-3-amd64

linux-headers-4.9.0-3-common/stable 4.9.30-2+deb9u5 all
  Common header files for Linux 4.9.0-3

linux-headers-4.9.0-3-common-rt/stable 4.9.30-2+deb9u5 all
  Common header files for Linux 4.9.0-3-rt

linux-headers-4.9.0-3-rt-amd64/stable 4.9.30-2+deb9u5 amd64
  Header files for Linux 4.9.0-3-rt-amd64

linux-headers-4.9.0-4-all/stable,now 4.9.65-3+deb9u1 amd64  [installé]
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-4-all-amd64/stable,now 4.9.65-3+deb9u1 amd64  [installé, automatique]
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-4-amd64/stable,now 4.9.65-3+deb9u1 amd64  [installé]
  Header files for Linux 4.9.0-4-amd64

linux-headers-4.9.0-4-common/stable,now 4.9.65-3+deb9u1 all  [installé, automatique]
  Common header files for Linux 4.9.0-4

linux-headers-4.9.0-4-common-grsec/stretch-backports 4.9.65-2+grsecunoff1~bpo9+1 all
  Common header files for Linux 4.9.0-4-grsec

linux-headers-4.9.0-4-common-rt/stable,now 4.9.65-3+deb9u1 all  [installé, automatique]
  Common header files for Linux 4.9.0-4-rt

linux-headers-4.9.0-4-grsec-amd64/stretch-backports 4.9.65-2+grsecunoff1~bpo9+1 amd64
  Header files for Linux 4.9.0-4-grsec-amd64

linux-headers-4.9.0-4-rt-amd64/stable,now 4.9.65-3+deb9u1 amd64  [installé, automatique]
  Header files for Linux 4.9.0-4-rt-amd64

linux-headers-4.9.0-5-all/stable 4.9.65-3+deb9u2 amd64
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-5-all-amd64/stable 4.9.65-3+deb9u2 amd64
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-5-amd64/stable 4.9.65-3+deb9u2 amd64
  Header files for Linux 4.9.0-5-amd64

linux-headers-4.9.0-5-common/stable 4.9.65-3+deb9u2 all
  Common header files for Linux 4.9.0-5

linux-headers-4.9.0-5-common-rt/stable 4.9.65-3+deb9u2 all
  Common header files for Linux 4.9.0-5-rt

linux-headers-4.9.0-5-rt-amd64/stable 4.9.65-3+deb9u2 amd64
  Header files for Linux 4.9.0-5-rt-amd64

linux-headers-4.9.0-6-all/stable,now 4.9.88-1+deb9u1 amd64  [installé]
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-6-all-amd64/stable,now 4.9.88-1+deb9u1 amd64  [installé, automatique]
  All header files for Linux 4.9 (meta-package)

linux-headers-4.9.0-6-amd64/stable,now 4.9.88-1+deb9u1 amd64  [installé, automatique]
  Header files for Linux 4.9.0-6-amd64

linux-headers-4.9.0-6-common/stable,now 4.9.88-1+deb9u1 all  [installé, automatique]
  Common header files for Linux 4.9.0-6

linux-headers-4.9.0-6-common-rt/stable,now 4.9.88-1+deb9u1 all  [installé, automatique]
  Common header files for Linux 4.9.0-6-rt

linux-headers-4.9.0-6-rt-amd64/stable,now 4.9.88-1+deb9u1 amd64  [installé, automatique]
  Header files for Linux 4.9.0-6-rt-amd64

linux-headers-amd64/stretch-backports 4.16+94~bpo9+1 amd64
  Header files for Linux amd64 configuration (meta-package)

linux-headers-cloud-amd64/stretch-backports 4.16+94~bpo9+1 amd64
  Header files for Linux cloud-amd64 configuration (meta-package)

linux-headers-grsec-amd64/stretch-backports 13~bpo9+1 amd64
  Header files for Linux amd64 configuration, grsec featureset (meta-package)

linux-headers-rt-amd64/stretch-backports 4.16+94~bpo9+1 amd64
  Header files for Linux rt-amd64 configuration (meta-package)

linux-libc-dev-alpha-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-arm64-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-armel-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-armhf-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-hppa-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-m68k-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mips-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mips64-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mips64el-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-mipsel-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-powerpc-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-powerpcspe-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-ppc64-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-ppc64el-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-s390x-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-sh4-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)

linux-libc-dev-sparc64-cross/stable 4.9.25-1cross1 all
  Linux Kernel Headers for development (for cross-compiling)



root@Micka-NAS:~# apt search linux-kbuild
En train de trier... Fait
Recherche en texte intégral... Fait
linux-kbuild-4.16/stretch-backports 4.16.16-2~bpo9+1 amd64
  Kbuild infrastructure for Linux 4.16

linux-kbuild-4.9/stable,now 4.9.88-1+deb9u1 amd64  [installé]
  Kbuild infrastructure for Linux 4.9



root@Micka-NAS:~# sudo apt install linux-headers-4.9.0-6-all linux-kbuild-4.9
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
linux-headers-4.9.0-6-all is already the newest version (4.9.88-1+deb9u1).
linux-kbuild-4.9 is already the newest version (4.9.88-1+deb9u1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 40 non mis à jour



root@Micka-NAS:~# sudo /sbin/vboxconfig
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.
The distribution packages containing the headers are probably:
    linux-headers-amd64 linux-headers-4.16.0-0.bpo.1-amd64
This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.
The distribution packages containing the headers are probably:
    linux-headers-amd64 linux-headers-4.16.0-0.bpo.1-amd64

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.
 




Du coup je pense avoir compris qu'il faut que j'installe linux-headers-amd64 linux-headers-4.16.0-0.bpo.1-amd64

root@Micka-NAS:~# sudo apt install linux-headers-amd64 linux-headers-4.16.0-0.bpo.1-amd64
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
E: Impossible de trouver le paquet linux-headers-4.16.0-0.bpo.1-amd64
E: Couldn't find any package by glob 'linux-headers-4.16.0-0.bpo.1-amd64'
E: Impossible de trouver de paquet correspondant à l'
expression rationnelle « linux-headers-4.16.0-0.bpo.1-amd64 »



Cela ne fonctionne toujours pas mais je pense que c'est normal vue la situation, mais je ne sais pas comment résoudre la situation ...

Dernière modification par Micka260 (12-07-2018 20:25:52)

Hors ligne

#4 12-07-2018 21:18:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Resolu] Virtualbox - Kernel driver not installed

Bonsoir, et bienvenue donc,

Micka260 a écrit :

il faut que j'installe linux-headers-amd64 linux-headers-4.16.0-0.bpo.1-amd64

Non la version candidate de linux-headers est 4.16.0-0.bpo.2 ; elle doit « matcher » avec le noyau.

apt -t stretch-backports install linux-headers-amd64 linux-image-amd64


Cette commande installera les métapaquets (et dépendances) rétroportés et mettra le noyau à jour.

apt -s -t stretch-backports install linux-headers-amd64 linux-image-amd64


La commande précédente, agrémentée de l'option -s/--simulate, permet d'effectuer une simulation.

Hors ligne

#5 12-07-2018 22:58:59

Micka260
Membre
Inscription : 12-07-2018

Re : [Resolu] Virtualbox - Kernel driver not installed

Merci pour cette réponse.

Je viens de suivre tes conseils voici le résultat :

root@Micka-NAS:~# apt -t stretch-backports install linux-headers-amd64 linux-image-amd64
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'
état... Fait
The following additional packages will be installed:
  linux-compiler-gcc-6-x86 linux-headers-4.16.0-0.bpo.2-amd64
  linux-headers-4.16.0-0.bpo.2-common linux-image-4.16.0-0.bpo.2-amd64
  linux-kbuild-4.16
Paquets suggérés :
  linux-doc-4.16 debian-kernel-handbook
Paquets recommandés :
  irqbalance apparmor
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-4.16.0-0.bpo.2-amd64 linux-headers-4.16.0-0.bpo.2-common
  linux-headers-amd64 linux-image-4.16.0-0.bpo.2-amd64 linux-kbuild-4.16
Les paquets suivants seront mis à jour :
  linux-compiler-gcc-6-x86 linux-image-amd64
2 mis à jour, 5 nouvellement installés, 0 à enlever et 98 non mis à jour.
Il est nécessaire de prendre 10,1 Mo/55,7 Mo dans les archives.
Après cette opération, 314 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://cdn-fastly.deb.debian.org/debian stretch-backports/main amd64 linux-compiler-gcc-6-x86 amd64 4.16.16-2~bpo9+1 [576 kB]
Réception de:2 http://cdn-fastly.deb.debian.org/debian stretch-backports/main amd64 linux-headers-4.16.0-0.bpo.2-common all 4.16.16-2~bpo9+1 [8 274 kB]
Réception de:3 http://cdn-fastly.deb.debian.org/debian stretch-backports/main amd64 linux-kbuild-4.16 amd64 4.16.16-2~bpo9+1 [815 kB]
Réception de:4 http://cdn-fastly.deb.debian.org/debian stretch-backports/main amd64 linux-headers-4.16.0-0.bpo.2-amd64 amd64 4.16.16-2~bpo9+1 [478 kB]
Réception de:5 http://cdn-fastly.deb.debian.org/debian stretch-backports/main amd64 linux-headers-amd64 amd64 4.16+94~bpo9+1 [6 570 B]
10,1 Mo réceptionnés en 7s (1 319 ko/s)                                        
(Lecture de la base de données... 123832 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-linux-compiler-gcc-6-x86_4.16.16-2~bpo9+1_amd64.deb ...
Dépaquetage de linux-compiler-gcc-6-x86 (4.16.16-2~bpo9+1) sur (4.9.88-1+deb9u1) ...
Sélection du paquet linux-headers-4.16.0-0.bpo.2-common précédemment désélectionné.
Préparation du dépaquetage de .../1-linux-headers-4.16.0-0.bpo.2-common_4.16.16-2~bpo9+1_all.deb ...
Dépaquetage de linux-headers-4.16.0-0.bpo.2-common (4.16.16-2~bpo9+1) ...
Sélection du paquet linux-kbuild-4.16 précédemment désélectionné.
Préparation du dépaquetage de .../2-linux-kbuild-4.16_4.16.16-2~bpo9+1_amd64.deb ...
Dépaquetage de linux-kbuild-4.16 (4.16.16-2~bpo9+1) ...
Sélection du paquet linux-headers-4.16.0-0.bpo.2-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../3-linux-headers-4.16.0-0.bpo.2-amd64_4.16.16-2~bpo9+1_amd64.deb ...
Dépaquetage de linux-headers-4.16.0-0.bpo.2-amd64 (4.16.16-2~bpo9+1) ...
Sélection du paquet linux-headers-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../4-linux-headers-amd64_4.16+94~bpo9+1_amd64.deb ...
Dépaquetage de linux-headers-amd64 (4.16+94~bpo9+1) ...
Sélection du paquet linux-image-4.16.0-0.bpo.2-amd64 précédemment désélectionné.
Préparation du dépaquetage de .../5-linux-image-4.16.0-0.bpo.2-amd64_4.16.16-2~bpo9+1_amd64.deb ...
Dépaquetage de linux-image-4.16.0-0.bpo.2-amd64 (4.16.16-2~bpo9+1) ...
Préparation du dépaquetage de .../6-linux-image-amd64_4.16+94~bpo9+1_amd64.deb ...
Dépaquetage de linux-image-amd64 (4.16+94~bpo9+1) sur (4.16+93~bpo9+1) ...
Paramétrage de linux-image-4.16.0-0.bpo.2-amd64 (4.16.16-2~bpo9+1) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-4.16.0-0.bpo.1-amd64
I: /initrd.img.old is now a symlink to boot/initrd.img-4.16.0-0.bpo.1-amd64
I: /vmlinuz is now a symlink to boot/vmlinuz-4.16.0-0.bpo.2-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.16.0-0.bpo.2-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.16.0-0.bpo.2-amd64
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
/etc/kernel/postinst.d/zz-update-grub:
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.16.0-0.bpo.2-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.16.0-0.bpo.2-amd64
Image Linux trouvée : /boot/vmlinuz-4.16.0-0.bpo.1-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.16.0-0.bpo.1-amd64
Image Linux trouvée : /boot/vmlinuz-4.14.0-0.bpo.3-amd64
Image mémoire initiale trouvée : /boot/initrd.img-4.14.0-0.bpo.3-amd64
fait
Paramétrage de linux-compiler-gcc-6-x86 (4.16.16-2~bpo9+1) ...
Paramétrage de linux-image-amd64 (4.16+94~bpo9+1) ...
Paramétrage de linux-headers-4.16.0-0.bpo.2-common (4.16.16-2~bpo9+1) ...
Paramétrage de linux-kbuild-4.16 (4.16.16-2~bpo9+1) ...
Paramétrage de linux-headers-4.16.0-0.bpo.2-amd64 (4.16.16-2~bpo9+1) ...
Paramétrage de linux-headers-amd64 (4.16+94~bpo9+1) ...
root@Micka-NAS:~# apt -s -t stretch-backports install linux-headers-amd64 linux-image-amd64
Lecture des listes de paquets... Fait
Construction de l'
arbre des dépendances      
Lecture des informations d'état... Fait
linux-headers-amd64 is already the newest version (4.16+94~bpo9+1).
linux-image-amd64 is already the newest version (4.16+94~bpo9+1).
Le paquet suivant a été installé automatiquement et n'
est plus nécessaire :
  linux-image-4.14.0-0.bpo.3-amd64
Veuillez utiliser « apt autoremove » pour le supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 98 non mis à jour.
root@Micka-NAS:~#
 


bloc à supprimer si la commande n’affiche rien



Cela ne fonctionne toujours pas ...

Hors ligne

#6 12-07-2018 23:08:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Resolu] Virtualbox - Kernel driver not installed

Re-,

Micka260 a écrit :

Cela ne fonctionne toujours pas...

As-tu redémarré la machine après la mise à jour du noyau ? DKMS devrait construire les modules...

Hors ligne

#7 13-07-2018 11:40:55

Micka260
Membre
Inscription : 12-07-2018

Re : [Resolu] Virtualbox - Kernel driver not installed

Super, après redémarrage cela fonctionne parfaitement smile

Hors ligne

#8 13-07-2018 11:42:51

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [Resolu] Virtualbox - Kernel driver not installed

cool
Il te reste plus qu'a passer le poste en résolu en éditant ton premier message


    \o/
    Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums