Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 12-07-2018 13:13:15

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Problème pendant l'execution de apt-get update

Donc deux informations contradictoires, Laquelle prendre en compte ?

Trisquel 8 64bits  Ordi.: Thinkpad T400
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#27 12-07-2018 13:22:03

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Problème pendant l'execution de apt-get update

perso je me baserais plus sur le retour des commandes que sur le profil (qui n'est pas forcément mis à jour régulièrement) smile

enfin, ça dépasse mes connaissances, revenir à une distribution stable en partant de ce mélange de dépôts, ça doit être possible, pas simple, mais possible (faire la liste des paquets installé, leur provenance (dépôts), les réinstaller en stable, jouer avec le pinning pour commencer avant la suppression des dépôts tiers...) je ne sais pas par où commencer et si je suis capable de régler l'ensemble des soucis qui risque d'apparaître neutral

Hors ligne

#28 12-07-2018 14:13:52

phreg
Membre
Distrib. : MX Ubuntu LMDE Manjaro
Noyau : 4.9 à 4.19
(G)UI : Xfce Mate
Inscription : 02-04-2011

Re : Problème pendant l'execution de apt-get update

Jean-Pierre Pinson a écrit :

Si vous savez lire justinien4all Dispose bien d'une distribution stretch :
Membre
Distrib. : Debian Stretch 9.3
Noyau : Linux 4.9.0-6-amd64
(G)UI : kde
Inscription : 09-07-2018


Non, ça c'est ce qu'il croit.
Ce que montre Severian (Debian GNU/Linux stable-updates (sid)) me semble dépassé par tout ce que Justinien4all a bricolé.
N'oubliez pas les PPA Ubuntu Xenial (2016), Bionic (2018) et Cosmic (même pas encore en beta) puis les dépôts Google et Microsoft. Ça doit laisser de sacrées traces.
Si je dois réparer ça, je n'hésite pas :
- récupération des données si pas de home séparé
- réinstallation avec formatage de la partition système
En gros 20 à 60 mn pour arriver à une vraie version Debian plutôt qu'un truc où il resterait peut-être des traces.

Hors ligne

#29 12-07-2018 14:23:02

Invité-X
Invité

Re : Problème pendant l'execution de apt-get update

vim /etc/apt/preferences

Package: *
Pin: release o=Debian,a=stable,n=stretch
Pin-Priority: 1001

Package: *
Pin: release o=Debian,a=stable-updates,n=stretch-updates
Pin-Priority: 1001

--
apt update
apt dist-upgrade -y



Ca va remetre les paquets de stretch

si il utilise un source.list

#stable
deb http://ftp.fr.debian.org/debian/ stretch main
#deb-src http://ftp.fr.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
#deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ stretch-updates main
#deb-src http://ftp.fr.debian.org/debian/ stretch-updates main

deb http://ftp.debian.org/debian stretch-backports main contrib non-free
#deb-src http://ftp.debian.org/debian stretch-backports main contrib non-free

#30 12-07-2018 14:54:34

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : Problème pendant l'execution de apt-get update

Ça, ça a pas mal de risque de casser, Debian n'etant pas prévu pour un downgrad général. Ça se tente pour le fun après avoir sauvegardé ses données et si on a potentiellement un peu de temps à perdre (si ça marche par contre, c'est tout benef) wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#31 12-07-2018 14:56:13

Invité-X
Invité

Re : Problème pendant l'execution de apt-get update

Faut aimer le risque tongue

#32 12-07-2018 15:19:26

Severian
Membre
Distrib. : Debian GNU/Linux 9.4 (stretch)
Noyau : Linux 4.14.0-0.bpo.3-amd64
(G)UI : Openbox 3.6.1-4
Inscription : 13-12-2014

Re : Problème pendant l'execution de apt-get update

avant de vouloir faire revenir / installer stretch à justinien4all, il faut qu'il définisse ses besoins comme le souligne phreg dans son message #13

je ne crois pas que l'on installe des dépôts php, skype, microsoft... pour le fun, c'est qu'il doit y avoir un besoin quelque part smile

et le "vrai" soucis n'est pas "comment revenir sur debian stable" mais "Problème pendant l'execution de apt-get update" (entre les dépôts qui ne sont plus en ligne et le soucis des clés d'authentifications)

Hors ligne

#33 12-07-2018 15:50:44

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : Problème pendant l'execution de apt-get update

Je notais juste que la manip de downgrade générale était risquée, et nécessitait donc une sauvegarde préalable, et qu'elle n'était pas.nécessairement plus rapide qu'une réinstallation wink

Ensuite, il ne me semble pas inutile de pointer la cause primaire du souci. Si quelqu'un te demande comment coller la rustine sur sa chambre à air et que tu t'appercois qu'il est au milieu d'un champ de ronce, et que ça risque de se reproduire, c'est utile de le prévenir tongue

Ceci-dit, définir les besoins permet effectivement de savoir si Debian est l'outil le plus adapté smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#34 13-07-2018 08:11:43

phreg
Membre
Distrib. : MX Ubuntu LMDE Manjaro
Noyau : 4.9 à 4.19
(G)UI : Xfce Mate
Inscription : 02-04-2011

Re : Problème pendant l'execution de apt-get update

bendia a écrit :

Je notais juste que la manip de downgrade générale était risquée, et nécessitait donc une sauvegarde préalable, et qu'elle n'était pas.nécessairement plus rapide qu'une réinstallation wink
Ensuite, il ne me semble pas inutile de pointer la cause primaire du souci. Si quelqu'un te demande comment coller la rustine sur sa chambre à air et que tu t'appercois qu'il est au milieu d'un champ de ronce, et que ça risque de se reproduire, c'est utile de le prévenir tongue
Ceci-dit, définir les besoins permet effectivement de savoir si Debian est l'outil le plus adapté smile

Simple et je pense que tout est dit !

Hors ligne

Pied de page des forums