Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-09-2018 20:46:56

Deewens
Membre
Inscription : 04-09-2018

Problème configuration d'un VPN sur VPS

Bonjour,

Etant Etudiant, et ayant besoin d'internet, je me connecte au réseau fournit par RENATER : eduroam. Cependant, ce réseau est assez limitatif, il bloque pas mal de protocole comme le RTC, le P2P, et d'autres dont je n'ai pas pu tester, mais ceux là suffisent déjà à me limiter, je ne peux même pas utiliser le service vocal de discord...

J'ai donc voulu voir si un VPN suffisait à régler le problème, j'ai donc testé vite fait les VPN gratuit et effectivement, je peux enfin tout faire, j'ai donc décidé de louer un VPS pour y installer un VPN (et d'autres trucs plus tard, c'est pour ça que j'ai pris un VPS pour le faire moi même et non un service VPN en qui je ne sais pas si je peux avoir confiance e plus)

Je connais Linux depuis quelques mois maintenant, mais je suis toujours qu'un simple bidouilleur amateur qui essaye tant bien que mal de suivre les tutos sur le net pour m'améliorer, mais je n'ai jamais eu à configurer mon propre serveur. J'ai donc suivit quelques tutos, en particulier celui-ci :

https://korben.info/installer-openvpn.html

J'ai tout bien fait, j'ai juste un problème vers la fin, j'ai donc créer mon utilisateur qui sera utilisé exclusivement pour le vpn et l'ai ajouté dans le "User Permission" du OpenVPN AS. J'ai ensuite voulu me connecter sur l'ip "client" pour récupérer le logiciel pour mon windows ainsi que le "client.ovpn", or l'utilisateur que je me suis crée ne fonctionne pas, je suis obligé d'utiliser le compte admin d'OpenVPN, celui crée par défaut à l'installation du paquet. J'ai récupéré les logiciels, me disant que je verrai ça plus tard, j'ai ensuite cliquer sur "start server" dans la partit admin de mon serveur. Or, gros problème, ca fait planter toute la connexion SSH, et gros message d'erreur incompréhensible...

http://prntscr.com/kqlhll

J'ai tout de même essayé de me connecter à mon VPN, mais évidemment, ça ne marche pas, en plus de ça il ne reconnait que les identifiants admin d'openVPN et pas ceux que j'ai fait.

Enfin voilà, pourriez-vous m'aider s'il vous plait?
Merci!

Dernière modification par Deewens (04-09-2018 20:47:18)

Hors ligne

#2 04-09-2018 20:52:22

raleur
Membre
Inscription : 03-10-2014

Re : Problème configuration d'un VPN sur VPS

Le VPS ne serait-il pas un "conteneur" (LXC, OpenVZ...) qui partage le noyau du système hôte, et non une vraie machine virtuelle avec son propre noyau ?

Hors ligne

#3 04-09-2018 20:57:04

Deewens
Membre
Inscription : 04-09-2018

Re : Problème configuration d'un VPN sur VPS

Oui, c'est un LXC, je ne savais pas que ça avait de l'importance en prenant le VPS, j'ai voulu prendre au moins cher.
Ca change quoi?

Hors ligne

#4 04-09-2018 21:02:05

raleur
Membre
Inscription : 03-10-2014

Re : Problème configuration d'un VPN sur VPS

OpenVPN dépend du module du noyau "tun" qui gère les interfaces réseau virtuelles TUN/TAP par l'intermédiaire de /dev/net/tun. Or le noyau et les modules actifs d'un conteneur LXC sont ceux du système hôte, donc tu ne peux pas charger les modules que tu veux. Le module doit être activé au niveau du système hôte. C'est un inconvénient de ce type de virtualisation qui est plutôt de l'isolation.

Dernière modification par raleur (04-09-2018 21:04:21)

Hors ligne

#5 04-09-2018 21:06:49

Deewens
Membre
Inscription : 04-09-2018

Re : Problème configuration d'un VPN sur VPS

Ca veut dire que j'ai acheté le serveur pour rien ? Ou y'a t'il un moyen de faire autrement pour configurer un VPN là dessus?

Hors ligne

#6 04-09-2018 21:08:56

raleur
Membre
Inscription : 03-10-2014

Re : Problème configuration d'un VPN sur VPS

Il faut voir avec l'hébergeur s'il est possible d'activer le module tun sur ton VPS.

Hors ligne

#7 04-09-2018 21:25:50

Deewens
Membre
Inscription : 04-09-2018

Re : Problème configuration d'un VPN sur VPS

d'acc, je vais voir ça, j’espère que oui hmm !

Hors ligne

#8 04-09-2018 22:08:36

Deewens
Membre
Inscription : 04-09-2018

Re : Problème configuration d'un VPN sur VPS

Merci à toi de l'info', du coup ils m'ont activé TUN/TAP.
J'essaie de régler un autre soucis avant de ré-essayer mon VPN, c'est cette histoire de compte utilisateur qui doit servir à utiliser le VPN. Je l'ai crée avec adduser tout ça, et l'ai ajouté ici :

http://prntscr.com/kqmetj

Cependant, lorsque je rentre le login et le mdp sur la page client d'openVPN, j'ai un login failed :

http://prntscr.com/kqmg0k

C'est bien ce compte que je dois utiliser pour me connecter au client, non? Ca me semble pas très sécure d'y aller avec le compte admin d'openVPN.

EDIT : bon, j'ai quand même essayé, je pense que pour que ça fonctionne il faudrait déjà pouvoir démarrer le serveur, mais j'ai exactement la même erreur qu'en haut avec TUN/TAP, et pourtant ils m'ont dit l'avoir activé. Je me renseigne sur internet pour savoir comment faire pour installer un VPN dans un conteneur, mais pour l'instant, rien ne fonctionne hmm.

Dernière modification par Deewens (04-09-2018 22:45:40)

Hors ligne

#9 05-09-2018 08:28:34

celp
Membre
Lieu : Chartres
Distrib. : Debian Stable
Noyau : Linux 4.9.0 amd64
(G)UI : i3wm
Inscription : 14-09-2016

Re : Problème configuration d'un VPN sur VPS

Pour les vpns
j'installe ce script : https://github.com/angristan/openvpn-install

ça marche tout le temps.

Par contre pour avoir travailler dans l'education nationale, eduroam est blindé en sortie.

--

Hors ligne

#10 05-09-2018 19:14:41

Deewens
Membre
Inscription : 04-09-2018

Re : Problème configuration d'un VPN sur VPS

A priori, depuis cette nuit ça fonctionne sans interruption, je suis connecté dessus sans soucis, le truc c'est que à chaque fois que je fais un "reboot" du VPS, je suis obligé de faire un dpkg reconfigure pour openVPN pour que ça refonctionne, j'ai l'impression qu'a chaque reboot, il supprime les fichiers qui doivent travailler avec TUN. Comment ça se fait? Pour l'instant, je le reboot pas, mais j'aimerais bien régler le problème.

Ben, a priori Eduroam, il suffit d'un VPN pour tout débloquer, je peux tout faire là lol.

Hors ligne

#11 05-09-2018 21:02:43

raleur
Membre
Inscription : 03-10-2014

Re : Problème configuration d'un VPN sur VPS

Peut-être qu'openvpn n'est pas démarré automatiquement au démarrage du serveur ?

Hors ligne

#12 08-09-2018 17:38:16

Deewens
Membre
Inscription : 04-09-2018

Re : Problème configuration d'un VPN sur VPS

C'est ce que je me suis dit, mais logiquement non, puisque à chaque fois que je redémarre le serveur, je peux quand même accéder au panel de gestion du VPN quand je tape son IP dans ma barre d'URL. Pour le moment ça fonctionne en tout cas tant que je reboot pas, et si je dois reboot je fais un dpkg-reconfigure d'openvpn. Du coup c'est cool, mais j'aimerais bien quand même pouvoir régler ce soucis...

Si c'est bien une histoire de démarrage automatique au boot du serv', je suis censé faire comment pour le démarrer automatiquement openvpn ? J'ai déjà cherché sur internet, mais je tombe sur des solutions complexes qui n'ont pas forcément quelque chose à voir avec ce que je voudrais, où bien sur des tutos pour savoir comment démarrer son PC en se connectant directement à son VPN automatiquement, mais rien de bien précis pour un serveur.

D'ailleurs, en même temps, j'ai une petite question, est-il possible de scinder le serveur en plusieurs partit, si par exemple je veux y mettre un serveur de jeu entre pote vite fait, et un serveur web en plus de ce VPN ?

Hors ligne

Pied de page des forums