Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-12-2018 12:49:14

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Finaliser la communication SSH

Bonjour,

Je vais dans le terminal de l'ordi client ( boulot) me mets en root ( su et mot de passe)
Je tape ensuite ssh <nom d'utilisateur>@<adresse publique> -p<numéro de port indiqué par mon ip.com>
et j'attends j'attends ....

Message:

connect to host xx.xxx.xxx.xx port xxxxx: Connection timed out.



Est-ce que c'est parce que l'ordi est en veille ? qu'il faudrait fournir l'adresse de la machine voire mon adresse ip interne à la place de mon nom d'utilisateur?? Est-ce que le numéro de port n'est pas celui fourni par le site  mon-ip.com ??

Merci d'avance

Nico

Dernière modification par calixtus06 (04-12-2018 12:51:02)


Il n'y a pas de mauvaises questions...

Hors ligne

#2 04-12-2018 12:58:57

Freemaster
Membre
Lieu : Nord
Distrib. : Debian amd64
Inscription : 31-07-2018
Site Web

Re : Finaliser la communication SSH

bonjour,

<numéro de port indiqué par mon ip.com> correspond à quoi ?

cela devrait être le port que tu as routé depuis ta box, vers le port de ton ssh local

Hors ligne

#3 04-12-2018 16:25:36

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

Freemaster a écrit :

Bonjour,

cela devrait être le port que tu as routé depuis ta box, vers le port de ton ssh local

  Depuis le fichier de config d'openssh ? 


((Sur l'ordi de mon boulot j'ai regardé ce fichier de config et j'ai le port 22 . Peut être qu'à la maison j'ai indiqué un autre numéro que 22 ( ??) ))


Freemaster a écrit :

cela devrait être le port que tu as routé depuis ta box, vers le port de ton ssh local

   Faut il que je regarde dans les paramètres de la freebox ?

((Quand je vais sur http://www.mon-ip.com/ j'obtiens mon adresse publique ( externe ou publique d'ailleurs ?? puisqu'on n'est pas sensé la communiquer)  et le numéro de port ( A quoi correspond il ?)  ))


Il n'y a pas de mauvaises questions...

Hors ligne

#4 04-12-2018 17:42:58

Freemaster
Membre
Lieu : Nord
Distrib. : Debian amd64
Inscription : 31-07-2018
Site Web

Re : Finaliser la communication SSH

quand tu vas sur mon-ip.com, depuis ton poste de chez toi, tu vois ton adresse publique, c'est cette adresse que tu dois utiliser à distance au bureau
le port afficher c'est le port qui a servi ton pc à communiquer avec le site mon-ip.com, si tu appuies sur la touche F5 il doit changer
donc tu n'as pas à tenir compte de ce port

par contre au niveau de ta freebox, tu dois rajouter une redirection de port (22 ou autre) vers l'ip du serveur (poste concerné) et le port du serveur ssh (22 si pas changé)

Hors ligne

#5 04-12-2018 19:50:05

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

Je  suis dans les paramètres de la freeebox et découvre que mon pc a deux ip ( ??)

https://debian-facile.org/images/file-R … 52d3b96643

https://debian-facile.org/images/file-R … a58a45946d

https://debian-facile.org/images/file-R … e3dbc6fb93

Sur la dernière image j'avoue ne pas savoir quoi mettre et où ? Qu'est ce que le port de début celui de fin et le port de destination ??

Bon j'ai rajouté une redirection et indiqué le port 22 (sur le modèle du port 10010)

Je vais sur l'ordi de ma femme:

nicolas@karin-K73BR ~ $ ssh 192.168.0.20@xx.xxx.xxx.xx -p22
ssh: connect to host xx.xxx.xxx.xx port 22: Connection refused
nicolas@karin-K73BR ~ $ ssh 192.168.0.20@xx.xxx.xxx.xx -p10010
The authenticity of host '[xx.xxx.xxx.xx]:10010 ([xx.xxx.xxx.xx]:10010)' can't be established.
ECDSA key fingerprint is 04:10:f2:2c:be:12:e2:d2:82:3c:94:88:ad:69:2f:66.
Are you sure you want to continue connecting (yes/no)? y
Please type 'yes' or 'no': yes
Warning: Permanently added '[xx.xxx.xxx.xx]:10010' (ECDSA) to the list of known hosts.
Permission denied (publickey).
 

Dernière modification par calixtus06 (04-12-2018 20:09:44)


Il n'y a pas de mauvaises questions...

Hors ligne

#6 04-12-2018 21:50:19

Freemaster
Membre
Lieu : Nord
Distrib. : Debian amd64
Inscription : 31-07-2018
Site Web

Re : Finaliser la communication SSH

si l'ordi de ta femme est sur ton réseau local, c'est normal que cela ne marche pas !
par contre 192.168.0.20 c'est l'ip local du serveur, c'est aussi le nom de ton user ? smile

Hors ligne

#7 05-12-2018 00:06:42

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

Freemaster a écrit :

si l'ordi de ta femme est sur ton réseau local, c'est normal que cela ne marche pas !
par contre 192.168.0.20 c'est l'ip local du serveur, c'est aussi le nom de ton user ? smile




ok

192.168.0.20 c'est l'adresse ip mais pas le nom de mon user . Peut être que je devrais vérifier le nom de mon user....

le terminal dit ça :

nicolas@LibraZiK2-studio-audio:~$



du coup je devrais essayer de joindre le pc de mon domicile  en écrivant

ssh LibraZiK2-studio-audio@xx.xxx.xxx.xx -p10010



?


Il n'y a pas de mauvaises questions...

Hors ligne

#8 05-12-2018 05:47:22

Freemaster
Membre
Lieu : Nord
Distrib. : Debian amd64
Inscription : 31-07-2018
Site Web

Re : Finaliser la communication SSH

ssh root@xx.xxx.xxx.xx -p10010


ou encore

ssh nicolas@xx.xxx.xxx.xx -p10010

Hors ligne

#9 06-12-2018 17:32:56

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

je viens d'essayer depuis le boulot :

nicolas@NICOLASDEBIAN:~$ su
Mot de passe :
root@NICOLASDEBIAN:/home/nicolas# ssh 192.168.0.20@adresse publique de ma freebox -p10010
ssh: connect to host  [adresse publique freebox] port 10010: Connection timed out
root@NICOLASDEBIAN:/home/nicolas#  



root@NICOLASDEBIAN:/home/nicolas# ssh nicolas@adresse publique de ma freebox -p10010
ssh: connect to host [adresse publique freebox]  port 10010: Connection timed out




root@NICOLASDEBIAN:/home/nicolas# ssh root@ [adresse publique freebox] -p10010
ssh: connect to host  [adresse publique freebox] port 10010: Connection timed out
root@NICOLASDEBIAN:/home/nicolas#
 



Si vous pouvez m'éclairer ...


Il n'y a pas de mauvaises questions...

Hors ligne

#10 06-12-2018 20:19:20

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : Finaliser la communication SSH

Pour se connecter en root c'est pas su mais

su -



Ne pas oublier l'espace entre su et le tiré

Dernière modification par Jean-Pierre Pinson (06-12-2018 20:20:23)


Trisquel 8 64bits  Ordi.: Thinkpad T400
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

En ligne

#11 06-12-2018 20:50:09

Freemaster
Membre
Lieu : Nord
Distrib. : Debian amd64
Inscription : 31-07-2018
Site Web

Re : Finaliser la communication SSH

ssh: connect to host [adresse publique freebox]  port 10010: Connection timed out


le port 10010 n'est pas :
soit routé dans ta freebox
soit le port est bloqué par le réseau entreprise du boulot

mais aussi soit la machine qui est sensé répondre, est éteint... ou le service associé est arreté

Hors ligne

#12 10-12-2018 09:37:15

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

Jean-Pierre Pinson a écrit :

Pour se connecter en root c'est pas su mais

su -



Ne pas oublier l'espace entre su et le tiré



je ne connais pas cette option. On s'en sert pour quoi ?


Il n'y a pas de mauvaises questions...

Hors ligne

#13 10-12-2018 09:39:57

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

Freemaster a écrit :

ssh: connect to host [adresse publique freebox]  port 10010: Connection timed out


le port 10010 n'est pas :
soit routé dans ta freebox
soit le port est bloqué par le réseau entreprise du boulot

mais aussi soit la machine qui est sensé répondre, est éteint... ou le service associé est arreté



c'est dans l'espace de paramètrage de ma freebox ( à la maison) que j'ai lu ce port de redirection. Sérieusement mon boulot pourrait empêcher l'accès à des ports sur des box à l'extérieur ??


Il n'y a pas de mauvaises questions...

Hors ligne

#14 10-12-2018 10:11:38

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch
Noyau : linux-debian-amd64 4.9.130-2
(G)UI : env- CLI- i3-weechat-bépo
Inscription : 28-03-2012
Site Web

Re : Finaliser la communication SSH

il ne faut pas se connecter en root à ssh

ssh LibraZiK2-studio-audio@xx.xxx.xxx.xx -p10010




le port se change dans  /etc/ssh/sshd_config


si tu veux verifier le port ssh utilisé

netstat -tnplv | grep ssh



ssh -p xxxxx  nicolas@xxxxxxx



parfois c'est bien de nettoyer le known_hosts

cd .ssh
rm -rf   known_hosts
cd
et re essayer la connexion ssh

si tu utilises une clé rsa ou autre, regarde que la clé publique  soit bien dans l'ordi distant aussi

regarde aussi si openssh est bien tout installé


dpkg -l | grep ssh



il te faut les 2

openssh-client   et  openssh-server

Dernière modification par lagrenouille (10-12-2018 10:15:23)


In Girum Imus Nocte Et Consumimur Igni

En ligne

#15 10-12-2018 11:28:51

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

c'est donc le port 10010 qui est spécifié

root@LibraZiK2-studio-audio:/home/nicolas# netstat -tnplv | grep ssh
tcp        0      0 0.0.0.0:10010           0.0.0.0:*               LISTEN      872/sshd            
tcp6       0      0 :::10010                :::*                    LISTEN      872/sshd            
root@LibraZiK2-studio-audio:/home/nicolas#
 



La commande suivante se fait en utilisateur simple depuis un pc à l'extérieur du réseau ? Est ce possible depuis le réseau local car depuis l'ordi de ma femme ( mint) ça ne fonctionne pas ( permission denied publickey)

Problème de clef publique ??

je ne sais pas si j'utilises une clef publique ou pas.

Par contre quand je fais des essais depuis l'ordi de ma femme pour joindre ma debian il m'est indiqué qu'au port 22 la connexion est refusée puis avec le port 10010 que la permission est "denied (publickey)"


Il n'y a pas de mauvaises questions...

Hors ligne

#16 10-12-2018 12:24:28

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch
Noyau : linux-debian-amd64 4.9.130-2
(G)UI : env- CLI- i3-weechat-bépo
Inscription : 28-03-2012
Site Web

Re : Finaliser la communication SSH

l'ordi de ta femme a openssh-client   et  openssh-server  installé aussi

permission denied publickey



tu as mis la clé publique dans le .ssh des ordis que tu veux joindre  (id_rsa.pub)


In Girum Imus Nocte Et Consumimur Igni

En ligne

#17 10-12-2018 19:49:12

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

Comment identifier cette clef et l'utiliser ?

Au boulot (l'un des futurs ordis client) J'ai trouvé 3 fichiers dans /etc/ssh avec l'extension .pub. J'imagine qu'il faut faire du ménage et utiliser une clef publique qui serait la même que sur l'ordi serveur ??

Dernière modification par calixtus06 (10-12-2018 19:58:15)


Il n'y a pas de mauvaises questions...

Hors ligne

#18 10-12-2018 20:15:09

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : Finaliser la communication SSH

Le ssh a un tuto qui pourra peut-être t'aider :
Tout commence là : https://debian-facile.org/doc:reseau:ssh smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#19 10-12-2018 20:46:23

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch
Noyau : linux-debian-amd64 4.9.130-2
(G)UI : env- CLI- i3-weechat-bépo
Inscription : 28-03-2012
Site Web

Re : Finaliser la communication SSH

tu nettoies rien  de cis clés publiques, si tu sais pas, par contre tu peux rajouter la tienne, a la création, pour que tu la reconnaisse fais une id_rsa2, et ta clé publique sera probablement id_rsa2.pub

In Girum Imus Nocte Et Consumimur Igni

En ligne

#20 11-12-2018 16:40:01

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

smolski a écrit :

Le ssh a un tuto qui pourra peut-être t'aider :
Tout commence là : https://debian-facile.org/doc:reseau:ssh smile



J'ai commenté en gras ce que je ne comprenais pas sur cette fiche. Elle ne m'est vraiment pas claire.


Il n'y a pas de mauvaises questions...

Hors ligne

#21 11-12-2018 16:51:58

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

lagrenouille a écrit :

tu nettoies rien  de cis clés publiques, si tu sais pas, par contre tu peux rajouter la tienne, a la création, pour que tu la reconnaisse fais une id_rsa2, et ta clé publique sera probablement id_rsa2.pub



"rajouter la tienne" ? la clef rsa.pub fournie par le ssh de mon serveur ?  et si ta réponse est oui je la colle où ?

"fais une id_rsa2" c'est une commande ? et si oui sur quel ordi le faire ?

Dernière modification par calixtus06 (11-12-2018 16:53:11)


Il n'y a pas de mauvaises questions...

Hors ligne

#22 11-12-2018 19:26:45

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

lagrenouille a écrit :


si tu utilises une clé rsa ou autre, regarde que la clé publique  soit bien dans l'ordi distant aussi



Lorsque je tape ssh nomdela machine @ adressepublique -p numéro de port
le curseur clignote un moment mais ne me propose pas d'inscrire une clef ou un mot de passe...
Il finit par me rendre connection timed out


Il n'y a pas de mauvaises questions...

Hors ligne

#23 11-12-2018 19:36:55

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch
Noyau : linux-debian-amd64 4.9.130-2
(G)UI : env- CLI- i3-weechat-bépo
Inscription : 28-03-2012
Site Web

Re : Finaliser la communication SSH


In Girum Imus Nocte Et Consumimur Igni

En ligne

#24 11-12-2018 19:55:37

Freemaster
Membre
Lieu : Nord
Distrib. : Debian amd64
Inscription : 31-07-2018
Site Web

Re : Finaliser la communication SSH

calixtus06 a écrit :

Lorsque je tape ssh nomdela machine @ adressepublique -p numéro de port


mais t'as lu ça où ?
ssh -p 1234 jojo@coincoin
jojo c'est le nom de l'utilisateur
coincoin est le nom de la machine, qui est à remplacer par l'ip publique, ou encore le dyndns associé...

maintenant ton timeout indique que tu n'as pas accès au port spécifié...
routage freebox, port bloqué par entreprise, etc.

Hors ligne

#25 Hier 00:50:57

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Finaliser la communication SSH

lagrenouille a écrit :



En commençant à lire cette doc  je me suis arrêté sur ça:

https://debian-facile.org/images/file-R … 12cd09ec4a

ssh user@ip publique



Désolé je ne comprends pas :pour moi à la place de "user" il devrait y avoir l'adresse ip interne de la machine serveur . Qu'entends tu par user ?? habituellement c'est le nom d'utilisateur d'une session sur un ordi, non ?


Il n'y a pas de mauvaises questions...

Hors ligne

Pied de page des forums