Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-01-2019 15:50:25

netfab
Membre
Inscription : 09-01-2019

[résolu][interf chaise-clavier] org.bluez.Error.AuthenticationRejected

Bonjour,

Deux jours que je me casse les dents sur ce problème, j'ai tout essayé.
Je ne suis pas du tout spécialiste de debian, ni du bluetooth.
À la base je suis sur stretch. Pour tenter de régler le problème, j'ai upgradé en testing (buster). En vain.

Le casque audio que j'essaie d'appairer : Pioneer SE-MS9BN
Ci-dessous le log :

$ bluetoothctl
Agent registered
[bluetooth]# agent on
Agent is already registered
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# devices
[bluetooth]# scan on
Discovery started
[CHG] Controller 00:15:83:F4:9B:64 Discovering: yes
[NEW] Device F4:0E:11:75:E0:0B LE-Pioneer SE-MS9BN
[CHG] Device F4:0E:11:75:E0:0B RSSI: -56
[CHG] Device F4:0E:11:75:E0:0B RSSI: -65
[CHG] Device F4:0E:11:75:E0:0B RSSI: -60
[CHG] Device F4:0E:11:75:E0:0B RSSI: -61
[CHG] Device F4:0E:11:75:E0:0B RSSI: -70
[CHG] Device F4:0E:11:75:E0:0B RSSI: -62
[CHG] Device F4:0E:11:75:E0:0B RSSI: -73
[CHG] Device F4:0E:11:75:E0:0B RSSI: -69
[CHG] Device F4:0E:11:75:E0:0B RSSI: -57
[CHG] Device F4:0E:11:75:E0:0B RSSI: -56
[CHG] Device F4:0E:11:75:E0:0B RSSI: -65
[CHG] Device F4:0E:11:75:E0:0B RSSI: -56
[CHG] Device F4:0E:11:75:E0:0B RSSI: -69
[CHG] Device F4:0E:11:75:E0:0B RSSI: -60
[CHG] Device F4:0E:11:75:E0:0B RSSI: -69
[CHG] Device F4:0E:11:75:E0:0B RSSI: -61
[CHG] Device F4:0E:11:75:E0:0B RSSI: -58
[CHG] Device F4:0E:11:75:E0:0B RSSI: -58
[CHG] Device F4:0E:11:75:E0:0B RSSI: -71
[CHG] Device F4:0E:11:75:E0:0B RSSI: -61
[CHG] Device F4:0E:11:75:E0:0B RSSI: -58
[CHG] Device F4:0E:11:75:E0:0B RSSI: -53
[CHG] Device F4:0E:11:75:E0:0B RSSI: -64
[bluetooth]# trust F4:0E:11:75:E0:0B
[CHG] Device F4:0E:11:75:E0:0B Trusted: yes
Changing F4:0E:11:75:E0:0B trust succeeded
[CHG] Device F4:0E:11:75:E0:0B RSSI: -74
[CHG] Device F4:0E:11:75:E0:0B RSSI: -61
[CHG] Device F4:0E:11:75:E0:0B RSSI: -60
[CHG] Device F4:0E:11:75:E0:0B RSSI: -69
[CHG] Device F4:0E:11:75:E0:0B RSSI: -60
[CHG] Device F4:0E:11:75:E0:0B RSSI: -60
[CHG] Device F4:0E:11:75:E0:0B RSSI: -60
[CHG] Device F4:0E:11:75:E0:0B RSSI: -67
[CHG] Device F4:0E:11:75:E0:0B RSSI: -59
[CHG] Device F4:0E:11:75:E0:0B RSSI: -59
[CHG] Device F4:0E:11:75:E0:0B RSSI: -68
[CHG] Device F4:0E:11:75:E0:0B RSSI: -55
[CHG] Device F4:0E:11:75:E0:0B RSSI: -63
[CHG] Device F4:0E:11:75:E0:0B RSSI: -66
[CHG] Device F4:0E:11:75:E0:0B RSSI: -54
[CHG] Device F4:0E:11:75:E0:0B RSSI: -63
[bluetooth]# pair F4:0E:11:75:E0:0B
Attempting to pair with F4:0E:11:75:E0:0B
[CHG] Device F4:0E:11:75:E0:0B Connected: yes
[CHG] Device F4:0E:11:75:E0:0B Name: Pioneer SE-MS9BN
[CHG] Device F4:0E:11:75:E0:0B Alias: Pioneer SE-MS9BN
Failed to pair: org.bluez.Error.AuthenticationRejected
[CHG] Device F4:0E:11:75:E0:0B Connected: no
[CHG] Device F4:0E:11:75:E0:0B Name: LE-Pioneer SE-MS9BN
[CHG] Device F4:0E:11:75:E0:0B Alias: LE-Pioneer SE-MS9BN
[CHG] Device F4:0E:11:75:E0:0B RSSI: -74
[CHG] Device F4:0E:11:75:E0:0B RSSI: -64
[CHG] Device F4:0E:11:75:E0:0B RSSI: -65



Je suis sous Xfce. J'utilise blueman et bluez. J'ai installé pulseaudio-module-bluetooth.

Là où çà devient intéressant, c'est que le même casque, avec la même clef, avec les mêmes logiciels fonctionnent sous Gentoo presque instantanément.
Donc c'est forcément un problème de configuration, mais je sèche totalement. J'ai dû passer à côté de quelque chose. Un coup de main serait fortement apprécié smile
Merci.

Dernière modification par netfab (09-01-2019 20:06:58)

Hors ligne

#2 09-01-2019 19:16:27

phreg
Membre
Distrib. : MX Ubuntu LMDE Manjaro
Noyau : 4.9 à 4.20
(G)UI : Xfce Mate
Inscription : 02-04-2011

Re : [résolu][interf chaise-clavier] org.bluez.Error.AuthenticationRejected

Bonjour,
Juste pour limiter les recherches, as tu déjà réussi à apparier un autre device sous la même Debian ?

Hors ligne

#3 09-01-2019 20:04:40

netfab
Membre
Inscription : 09-01-2019

Re : [résolu][interf chaise-clavier] org.bluez.Error.AuthenticationRejected

Oui, un contrôleur PS3 qui fonctionne.

Mais en fait, j'ai résolu le mystère : il n'y a strictement aucun problème.
Enfin, si. Mais pas du côté de debian. Juste un problème d'interface chaise-clavier.
La manipulation que j'effectuais sur le casque n'était tout simplement pas la bonne pour faire entrer le casque en mode appairage.
Le casque réagissait à la manipulation que j'effectuais, et je croyais à tort qu'il entrait en mode appairage, sauf que non.
La question qui reste en suspens : comment diable ai-je réussi à appairer ce satané casque la première fois ? big_smile

Merci tout de même.

Dernière modification par netfab (09-01-2019 20:08:25)

Hors ligne

Pied de page des forums