Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-05-2018 19:03:32

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

xfce >déconnexion >redémarrer

Sous xfce, >déconnexion >redémarrer ne redémarre pas mon ordinateur, je suis obligé de l'éteindre, et de le démarrer à nouveau.

Quelqu'un aurait il une explication ? scratchhead.gif

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#2 02-05-2018 20:17:03

Antic Bomber
CA Debian-Facile
Lieu : P.O. 66
Distrib. : stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : xfce
Inscription : 10-08-2014

Re : xfce >déconnexion >redémarrer

Salut JPP, je suis sous xfce et je n'ai jamais rencontré ce problème, je vais tester ! wink

La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.  Albert Einstein
https://framacarte.org/en/map/debian-fa … 160/2.8606

Hors ligne

#3 02-05-2018 20:28:47

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s Stretch + bpo
Noyau : linux 4.9.0-8-amd64
(G)UI : fluxbox par arnault
Inscription : 15-02-2015

Re : xfce >déconnexion >redémarrer

L'explication, non, mais la solution est simple :

reboot

big_smile


HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#4 02-05-2018 21:01:47

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

La commande

reboot



ne fonctionne pas


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#5 02-05-2018 21:03:36

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

J'ai l'impression, mais je n'en suis pas sûr, que mon BIOS n'est pas à jour, Peut-être que ça viendrait de ça ?

Dernière modification par Jean-Pierre Pinson (07-05-2018 21:20:01)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#6 03-05-2018 09:28:07

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : xfce >déconnexion >redémarrer

Bonjour,
Tu as un retour pour la commande reboot qui ne fonctionne pas ?

Hors ligne

#7 03-05-2018 10:02:04

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : xfce >déconnexion >redémarrer

Bonjour,

Suite à la commande reboot (ou un clic sur le menu correspondant), peux-tu nous fournir le retour de la commande

dmesg |tail -50



Merci à toi smile

Hors ligne

#8 05-05-2018 18:01:54

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

j'ai mis à jour le bios, mais ce n'a rien changé

root@jpp:/home/jpp# dmesg |tail -50
[   19.704128] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   19.704583] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   19.704674] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   19.813646] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   19.814135] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   19.814229] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   19.848012] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   20.450324] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   50.262764] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   50.263222] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   50.263309] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   50.373840] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   50.374297] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   50.374384] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   50.408071] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   50.444223] wlp3s0: authenticate with 00:19:70:42:ee:ee
[   50.449755] wlp3s0: send auth to 00:19:70:42:ee:ee (try 1/3)
[   50.556044] wlp3s0: send auth to 00:19:70:42:ee:ee (try 2/3)
[   50.560591] wlp3s0: authenticated
[   50.564064] wlp3s0: associate with 00:19:70:42:ee:ee (try 1/3)
[   50.568197] wlp3s0: RX AssocResp from 00:19:70:42:ee:ee (capab=0x431 status=0 aid=4)
[   50.579694] wlp3s0: associated
[   50.684262] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[ 3184.778099] wlp3s0: authenticate with 00:19:70:42:ee:ee
[ 3184.787199] wlp3s0: send auth to 00:19:70:42:ee:ee (try 1/3)
[ 3184.924135] wlp3s0: send auth to 00:19:70:42:ee:ee (try 2/3)
[ 3184.929957] wlp3s0: authenticated
[ 3184.932043] wlp3s0: associate with 00:19:70:42:ee:ee (try 1/3)
[ 3184.938403] wlp3s0: RX AssocResp from 00:19:70:42:ee:ee (capab=0x431 status=0 aid=4)
[ 3184.964386] wlp3s0: associated
[ 4182.307286] wlp3s0: authenticate with 00:19:70:42:ee:ee
[ 4182.315145] wlp3s0: send auth to 00:19:70:42:ee:ee (try 1/3)
[ 4182.424078] wlp3s0: send auth to 00:19:70:42:ee:ee (try 2/3)
[ 4182.431316] wlp3s0: authenticated
[ 4182.432140] wlp3s0: associate with 00:19:70:42:ee:ee (try 1/3)
[ 4182.443000] wlp3s0: RX AssocResp from 00:19:70:42:ee:ee (capab=0x431 status=0 aid=4)
[ 4182.446369] wlp3s0: associated
[ 5178.116362] [drm:i965_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 5214.420896] perf: interrupt took too long (2515 > 2500), lowering kernel.perf_event_max_sample_rate to 79500
[ 5346.773251] perf: interrupt took too long (3149 > 3143), lowering kernel.perf_event_max_sample_rate to 63500
[ 7043.259651] wlp3s0: authenticate with 00:19:70:42:ee:ee
[ 7043.267688] wlp3s0: send auth to 00:19:70:42:ee:ee (try 1/3)
[ 7043.372088] wlp3s0: send auth to 00:19:70:42:ee:ee (try 2/3)
[ 7043.376034] wlp3s0: authenticated
[ 7043.380594] wlp3s0: associate with 00:19:70:42:ee:ee (try 1/3)
[ 7043.384726] wlp3s0: RX AssocResp from 00:19:70:42:ee:ee (capab=0x431 status=0 aid=4)
[ 7043.389991] wlp3s0: associated
[17511.804128] perf: interrupt took too long (3950 > 3936), lowering kernel.perf_event_max_sample_rate to 50500
[21890.274761] perf: interrupt took too long (4939 > 4937), lowering kernel.perf_event_max_sample_rate to 40250
[34019.594003] perf: interrupt took too long (6192 > 6173), lowering kernel.perf_event_max_sample_rate to 32250
root@jpp:/home/jpp#
 


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#9 05-05-2018 18:17:02

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

chalu, quand je reboot je quitte bien ma cession, mais au reboot l'ordinateur reste bloqué sur un écran noir, alors que quand je l'éteins et je le rallume je n'est pas de problèmes pour retrouver ma cession. donc je n'est pas de retour pour la commande reboot qui ne fonctionne pas.

Dernière modification par Jean-Pierre Pinson (05-05-2018 18:20:01)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#10 07-05-2018 08:24:01

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : xfce >déconnexion >redémarrer

Hum, rien dans tes logs.

Et la commande :

systemctl reboot


fonctionne-t-elle ?

Hors ligne

#11 07-05-2018 08:44:26

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

systemctl reboot

ne fonctionne pas non plus


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#12 07-05-2018 08:45:57

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : xfce >déconnexion >redémarrer

Le log dmesg c'était bien après avoir tenté un reboot ?

Sinon je passe la main.. Désolé de ne pas pouvoir t'aider.

Hors ligne

#13 07-05-2018 08:51:25

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

après avoir tenté un reboot, je n'est pas de console, mon écran est complètement noir.

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#14 07-05-2018 09:32:14

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : xfce >déconnexion >redémarrer

Tu as eu accès à grub ou bien c'est arrivé avant? Auquel cas, ton update de BIOS pourrait-être en cause.

Si tu as accès au mode rescue depuis grub, nous dire si tu as un message quelconque.

T'as pas eu de message d'erreur du Bios? Ton disque dur est récent?

Hors ligne

#15 07-05-2018 09:56:08

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

pas de message d'erreur du bios et mon DD fonctionne bien, il n'y a que quand je fais redémarrer que je n'est pas accès a grub ni au bios d'ailleur.

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#16 07-05-2018 10:00:27

LeDub
Adhérent(e)
Lieu : Orry-la-Ville (60)
(G)UI : XFCE
Inscription : 18-02-2014

Re : xfce >déconnexion >redémarrer

Bonjour JPP,

J'aimerais comprendre ton problème. Quand tu dis :

Sous xfce, >déconnexion >redémarrer ne redémarre pas mon ordinateur, je suis obligé de l'éteindre, et de le démarrer à nouveau.


veux-tu dire que l'option "redémarrer" est inaccessible ou inefficace ?
Est-ce que le compte que tu utilises est celui qui a été créé pendant l'installation ?
As-tu essayé la même manipulation avec le compte administrateur ?
Ne serait-ce pas un problème de droits ?
Que donne un "id" depuis ce compte ?

LeDub qui comme d'habitude pose toujours autant de questions !

Hors ligne

#17 07-05-2018 10:08:48

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : xfce >déconnexion >redémarrer

Jean-Pierre Pinson a écrit :

Il n'y a que quand je fais redémarrer que je n'est pas accès a grub ni au bios d'ailleur.



Si t'as pas accès au bios c'est que t'as un souci avec le BIOS en question. Peut-être une table ACPI incompatible. ça fonctionnait avant le reboot ou c'est depuis un kernel particulier?

Tu peux essayer de modifier le lancement du kernel via grub (touche e sur le menu de lancement) et modifier la ligne :
GRUB_CMDLINE_LINUX_DEFAULT en y ajoutant

acpi_osi=Linux acpi_backlight=vendor



Si ça me fonctionne pas, c'est un souci de BIOS et c'est en dehors de mes compétences.

Hors ligne

#18 07-05-2018 12:25:20

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

j'avais le même problème avent que je mette à jours le bios !

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#19 07-05-2018 16:39:14

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

J'ai bien accès au BIOS Quand je démarre avec le bouton power, C'est seulement quand je reboot que ça se passe mal, l'ordinateur reste bien allumé, puisque le voyant, est toujours allumé, mais il ne redémarre pas. Je suis obligé de l'éteindre, Et de l'allumer, pour pouvoir booter, et avoir accès à grub.

Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#20 11-02-2019 18:36:12

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

J'ai ce message au redémarrage:

watchdog: watchdog0:watchdog did not stop
reboot: Restarting system



Mais ça ne redémarre pas

Dernière modification par Jean-Pierre Pinson (11-02-2019 18:36:55)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#21 11-02-2019 18:41:23

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

Je précise que Ce n'est pas sur l'ordinateur libreboot En revanche C'est bien un T400 avec debian stretch et xfce

Dernière modification par Jean-Pierre Pinson (11-02-2019 18:42:29)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#22 12-02-2019 17:03:21

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 10
Noyau : Linux 4.19.0-2-amd64
(G)UI : gnome 1:3.22+12
Inscription : 15-02-2016

Re : xfce >déconnexion >redémarrer

Bonjour, as-tu essayé :

shutdown -r now

Hors ligne

#23 12-02-2019 17:58:23

robert2a
Membre
Lieu : France
Inscription : 15-11-2014

Re : xfce >déconnexion >redémarrer

Jean-Pierre Pinson a écrit :

après avoir tenté un reboot, je n'est pas de console, mon écran est complètement noir.



cela fait un peu comme si l'ACPI dans le bios était désactivé .
pour la commande shutdown


shutdown --help
 



shutdown [OPTIONS...] [TIME] [WALL...]

Shut down the system.

     --help      Show this help
  -H --halt      Halt the machine
  -P --poweroff  Power-off the machine
  -r --reboot    Reboot the machine
  -h             Equivalent to --poweroff, overridden by --halt
  -k             Don't halt/power-off/reboot, just send warnings
     --no-wall   Don't send wall message before halt/power-off/reboot
  -c             Cancel a pending shutdown

See the shutdown(8) man page for details.
 



tu peu tester les deux ,  l'option -r (reboot)  ou -h (éteindre au bout d'un certain temps )
l'option -c permet d'annuler l'arret
now (maintenant) correspond a la valeur [TIME] qui donne un reboot ou arret immédiat
si rien ne fonctionne c'est pas cool  roll

soit sur l'arret quelque chose bloque , soit l'acpi est inactif sur ton bios (la machine effectue un arret  du système mais pas de l'alimentation )
il me semble que avec shutdown -h , il affiche la fermeture des processus au bout d un certain temps (time par défaut )

tu peu tester a partir du bureau (console graphique)
ou a partir d une console pure (Ctrl+Alt+F2 a partir de l'invite de connexion)
voir si le comportement est identique

tu peu aussi indiquer si lors d un arret sauvage (bouton alimentation a partir de l'écran noir) le démarrage suivant a des fichiers orphelins ou pas  (le démontage des partitions a été correct ou pas )
tu peu aussi indiquer si le clavier est éteint , voyant num verr éteint , le passage de minuscule a majuscule idem le voyant reste éteint (le clavier est inactif)

en fonction de tes retours peut être que quelqu'un aura une solution  roll

Hors ligne

#24 12-02-2019 18:58:51

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

Merci robert2a et --gilles--

Je teste les commandes et je reviens vers vous

Dernière modification par Jean-Pierre Pinson (12-02-2019 19:09:57)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#25 12-02-2019 19:20:25

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Trisquel 8 64bits Ordi.: Thinkpad T400
Noyau : 4.4.0-64-generic x86_64
(G)UI : xfce
Inscription : 04-03-2017

Re : xfce >déconnexion >redémarrer

Bons alors la comande

shutdown -r now

Ne donne rien de nouveau, à savoir j'ai toujours le même message:

watchdog: watchdog0:watchdog did not stop
reboot: Restarting system



a partir d une console pure ça ne redémarre pas non plus

Sinon je ne suis pas sûr d'avoir très bien compris ta question: le passage de minuscule a majuscule fonctionne ainsi que le voyant !

Pour le démontage des partitions je n'ai vu aucun problème

Dernière modification par Jean-Pierre Pinson (12-02-2019 20:19:24)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

Pied de page des forums