Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-10-2019 15:28:39

paul-riluma
Membre
Distrib. : debian perso
Noyau : oulala
(G)UI : pleinpartout
Inscription : 22-09-2019
Site Web

scanne des mails dans claws mail par clamav-daemon

bonjour tout le monde

n'ayant pas trouvé de discussion quant aux configurations de versions récentes du plugin de claws mail permettant de faire scanner les mails par clamav-daemon

n'ayant pas trouvé d'indications fonctionnant avec les versions récentes installées sur Debian9
sur les machines installées avec Debien8 je ne rencontre pas de problème

je propose cette annonce

le problème rencontré depuis Debian9 se présente comme ça dans une fenêtre d'alerte :
Erreur lors de la vérification :
~/.claws-mail/mimetmp/00000000.mimetmp: lstat() failed: Permission denied. ERROR

bon, alors en courant dans les log, on n'est pas mieux renseigné, il y a effectivement un problème de droit d'accès...
donc, j'ai d'abord bidouillé diverses solutions de permissions sur les dossiers concernés, puis d'ajout de groupe et d'utilisateur en fouillant dans le /etc/group et les man de scripts...

ben ça résiste

y'a aussi une recommandation qui traînait sur bon nombre d'échanges autour de cette question :
j'en site une ici, ayant le même principe et la même résolution
Making tests over the new server I have seen that ClamAV is not
operating fine due to permission problems:
[...]
MailScanner[15458]: Virus and Content Scanning: Starting
MailScanner[15458]: Clamd::ERROR:: UNKNOWN CLAMD RETURN ./lstat()
failed: Permission denied. ERROR :: /var/spool/MailScanner/incoming/15458
MailScanner[15458]: Virus Scanning: Clamd found 1 infections
MailScanner[15458]: Virus Scanning: Found 1 viruses
[...]

I have solved the problem modifying the configuration parameter
AllowSupplementaryGroups from false to true in the file:
/etc/clamav/clamd.conf
...
ben, les nouvelles versions de clamav ne prennent pas en compte cet directive AllowSupplementaryGroups
qui n'apparaît pas dans le man...

donc voilà. j'ai pas installé de machine avec Debian 10, donc je ne sais pas si ce truc, qui n'empèche pas de recevoir le mail hein, a été ou pas résolu quelque part.

vais peut-être voir si je peux pas bricoler quelque chose avec p3scan comme ça se faisait il y a longtemps...
mais bon

si quelqu'un a trouvé une astuce, ça servira à d'autres...

Hors ligne

Pied de page des forums