Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-12-2019 12:24:06

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Je veux installer un nouveau noyau, lequel choisir ?

Bonjour je suis sous Librazik 2 ( stretch) et son noyau ne permet pas l'utilisation de vmware.
Du coup je me renseigne et tombe sur une commande qui me propose pas mal de noyaux mais lequel choisir et quel risque et précaution dois je prendre ?

Il y a des linux-headers, des rt, des bpo ....

apt-cache search linux-image



linux-image-amd64 - Linux pour les ordinateurs 64 bits (métapaquet)
linux-image-rt-amd64 - Linux pour les ordinateurs 64 bits (métapaquet) avec PREEMPT_RT
linux-headers-4.9.0-11-amd64 - Header files for Linux 4.9.0-11-amd64
linux-headers-4.9.0-11-rt-amd64 - Header files for Linux 4.9.0-11-rt-amd64
linux-image-4.9.0-11-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-11-amd64-dbg - Debug symbols for linux-image-4.9.0-11-amd64
linux-image-4.9.0-11-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-11-rt-amd64-dbg - Debug symbols for linux-image-4.9.0-11-rt-amd64
linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package)
linux-headers-5.3.0-0.bpo.2-amd64 - Header files for Linux 5.3.0-0.bpo.2-amd64
linux-headers-5.3.0-0.bpo.2-cloud-amd64 - Header files for Linux 5.3.0-0.bpo.2-cloud-amd64
linux-image-5.3.0-0.bpo.2-amd64-dbg - Debug symbols for linux-image-5.3.0-0.bpo.2-amd64
linux-image-5.3.0-0.bpo.2-amd64-unsigned - Linux 5.3 for 64-bit PCs
linux-image-5.3.0-0.bpo.2-cloud-amd64-dbg - Debug symbols for linux-image-5.3.0-0.bpo.2-cloud-amd64
linux-image-5.3.0-0.bpo.2-cloud-amd64-unsigned - Linux 5.3 for x86-64 cloud
linux-image-amd64-signed-template - Template for signed linux-image packages for amd64
linux-image-cloud-amd64-dbg - Debugging symbols for Linux cloud-amd64 configuration (meta-package)
linux-image-5.3.0-0.bpo.2-amd64 - Linux 5.3 for 64-bit PCs (signed)
linux-image-5.3.0-0.bpo.2-cloud-amd64 - Linux 5.3 for x86-64 cloud (signed)
linux-image-cloud-amd64 - Linux for x86-64 cloud (meta-package)
linux-headers-4.9.0-6-amd64 - Header files for Linux 4.9.0-6-amd64
linux-headers-4.9.0-8-amd64 - Header files for Linux 4.9.0-8-amd64
linux-headers-4.9.0-4-amd64 - Header files for Linux 4.9.0-4-amd64
linux-image-4.9.0-8-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-4-amd64 - Linux 4.9 for 64-bit PCs
linux-headers-4.9.0-9-amd64 - Header files for Linux 4.9.0-9-amd64
linux-image-4.9.0-9-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-6-amd64 - Linux 4.9 for 64-bit PCs
nicolas@NICOLASDEBIAN:~$
 



merci de vos éclairages


Il n'y a pas de mauvaises questions...

Hors ligne

#2 03-12-2019 12:46:55

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

je connais les noyaux classiques :

- amd64 (classique)
- bpo (backports)
mais ceux là : ?
- rt : noyau temps réel (mais qu'est ce que c'est : mystère)
-cloud : noyau cloud (dans le nuage je pense)

CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#3 03-12-2019 13:36:57

phreg
Membre
Distrib. : MX Ubuntu LMDE Manjaro
Noyau : 4.9 à 4.20
(G)UI : Xfce Mate
Inscription : 02-04-2011

Re : Je veux installer un nouveau noyau, lequel choisir ?

Bonjour,
j'imagine que librazik utilise un noyau RT (real time) qui n'est pas optimisé pour faire de la bureautique ou des gérer des machines virtuelles.
Installe un noyau classique (amd64).
Tu pourras de toute manière choisir avec grub lequel utiliser.

En ligne

#4 03-12-2019 13:55:34

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

je crains que librazik n'utilise un noyau bien à lui .

installer un autre noyau (amd64 , bpo , rt ou cloud) ne fera que "recréer " une autre distribution puisque un autre noyau
(c'est pas exact mais c' est plus compréhensible comme çà)

tu aura donc , dans grub , à choisir sur quel noyau tu démarre (options avancées) et donc ,
de ce fait , tu ne sera plus sous librazik en choisissant un autre noyau .


je pense .

je vais monter une V.M. pour vérifier ...

Dernière modification par Debian Alain (03-12-2019 15:56:36)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#5 03-12-2019 13:57:39

melissa6969
Membre
Lieu : Lyon Métropole
Distrib. : Sid Xfce minimal
Inscription : 30-11-2016
Site Web

Re : Je veux installer un nouveau noyau, lequel choisir ?

Si librazik porte bien son nom et est orientée création musicale, alors il faut un noyau en temps réel, ce qui permet une latence minimale et une meilleure fluidité pour la création musicale.
C'est d'ailleurs son seul but à ce kernel, avoir des temps de latence extrêmement court pour chaque appel, ce qui permet justement pour la création musicale où on utilise énormément de tampons, que ça soit très réactif et permette une expérience optimale.

Faire de la création musicale avec un kernel normal ça devient vite galère et on remarque vite les désagréments.

Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#6 03-12-2019 15:40:26

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

je viens rectifier mon post .
avec librazik 2 , si on veut installer un autre noyau , on peut .
en restant sous stretch , la distribution par défaut , j'ai pu installer un noyau rt sans problème apparent sur le fonctionnement de la distribution .

j'ai réussi à mettre en place les sources de buster et à faire du pinning , mais ,
l'installation d'un noyau 4.19 en lieu et place du noyau officiel 4.9 pose problème .

cela demande la mise à jour de gcc entre autres .
ne voulant pas casser ma machine , je me suis arrêté là .
donc , à première vue , installation d'un noyau buster dans librazik 2 stretch : impossible .

et je ne sais pas si librazik existe en version buster , je crois pas .

Dernière modification par Debian Alain (03-12-2019 15:44:57)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#7 03-12-2019 16:08:55

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Hello tout le monde, je ne veux pas remplacer mon noyau mais en ajouter un que je pourrais sélectionner dans grub. Quel est la marche à suivre ? Faut il ajouter le linux-headers ?

Il n'y a pas de mauvaises questions...

Hors ligne

#8 03-12-2019 16:31:49

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

les mêta - paquets "linux-image-amd64" et "linux-headers-amd64" , d'après ce que j'ai vu , sont installés par défaut dans librazik .

ils servent à la mise à jour automatique du noyau quand celle - ci à lieu .
leur présence est donc nécessaire et recommandée .

tu peux rajouter presque tous les noyaux que tu veux tant que ce sont des noyaux de stretch .

pour avoir la liste tu peux faire ceci :

liste des noyaux "image" :

apt search linux-image


liste des noyaux "headers" : (fichiers d'en têtes du noyau , parfois nécessaires)

apt search linux-headers


et pour installer :

apt install linux-image-xxxxx-amd64 linux-headers-xxxxx-amd64


remplacer xxxxx par le no du kernel .
cette ligne prends par exemple les noyaux 64  bits mais tu peux faire pareil avec les noyaux rt-amd64 , cloud , etc...
suffit de recopier le nom des kernels  qui t'intéressent .

mon post présent , parle d'installation (d'ajout si tu préfères) , pas de remplacement .
tu aura donc à choisir à la main ton kernel au démarrage .
pour remplacer , il faut installer le kernel désiré et supprimer (donc à la main) celui ou ceux dont on ne veut plus .
de façon à forcer le systeme à booter sur le kernel choisi .
je crois qu'il y a aussi , dans grub , une option pour démarrer automatiquement sur un kernel choisi ,
mais çà fait tellement longtemps et c'est tellement rare que je ne sais plus comment on fait .
c'est simple , pourtant , je crois .
trouvé : https://www.blog-libre.org/2019/03/15/d … hain-boot/
suffit de modifier la variable "GRUB_DEFAULT=0" dans /etc/default/grub

par contre , librazik a besoin des kernels image et headers .
si tu installes la moitié , y a des chances que çà fonctionne pas .

n.b.: les noyaux de oldstable (stretch) sont des noyaux 4.9.xxxx
ceux de stable (buster) , sont des noyaux 4.19.xxxx
et ceux de testing (bullseye) , sont des noyaux 5.3.xxxxx

Dernière modification par Debian Alain (03-12-2019 17:14:16)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#9 03-12-2019 17:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Bonjour calixtus06,

calixtus06 a écrit :

Faut-il ajouter le [paquet] linux-headers* ?


Non, un paquet linux-headers* ne fournit pas le noyau mais les fichiers d'en-têtes du noyau donné.
Oui si le paquet linux-headers* est installé pour le noyau actuel. Non dans le cas contraire bien sûr.

Le dépôt stretch-backports fournit un noyau 4.19 RT mais il n'est pas installable (cf. backport.pref).

apt-cache policy

Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://download.tuxfamily.org/librazik/decepas LZK-DCP-users/contrib amd64 Packages
     release v=all,o=LibraZiK,n=LZK-DCP-users,l=LibraZiK-DCP-users,c=contrib,b=amd64
     origin download.tuxfamily.org
 500 http://download.tuxfamily.org/librazik/decepas LZK-DCP-users/main amd64 Packages
     release v=all,o=LibraZiK,n=LZK-DCP-users,l=LibraZiK-DCP-users,c=main,b=amd64
     origin download.tuxfamily.org
 500 http://deb.debian.org/debian stretch-backports/contrib amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch-backports/main amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=oldstable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian-security stretch/updates/contrib amd64 Packages
     release v=9,o=Debian,a=oldstable,n=stretch,l=Debian-Security,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian-security stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=oldstable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch/contrib amd64 Packages
     release v=9.11,o=Debian,a=oldstable,n=stretch,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch/main amd64 Packages
     release v=9.11,o=Debian,a=oldstable,n=stretch,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
     linux-image-4.19.0-0.bpo.6-amd64-unsigned -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-rt-amd64-dbg -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-4.9.0-4-grsec-amd64 -> 4.9.65-2+grsecunoff1~bpo9+1 with priority -10
     linux-image-cloud-amd64 -> 4.19+105+deb10u1~bpo9+1 with priority -10
     linux-image-amd64-signed-template -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-rt-amd64-dbg -> 4.19+105+deb10u1~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-cloud-amd64-dbg -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-cloud-amd64-unsigned -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-rt-amd64-unsigned -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-cloud-amd64 -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-amd64 -> 4.19+105+deb10u1~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-rt-amd64 -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-cloud-amd64-dbg -> 4.19+105+deb10u1~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-amd64 -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-4.19.0-0.bpo.6-amd64-dbg -> 4.19.67-2+deb10u2~bpo9+1 with priority -10
     linux-image-grsec-amd64 -> 13~bpo9+1 with priority -10
     linux-image-amd64-dbg -> 4.19+105+deb10u1~bpo9+1 with priority -10
     linux-image-rt-amd64 -> 4.19+105+deb10u1~bpo9+1 with priority -10
 


Mais d'où sortent les paquets linux-image-5.3.0-0.bpo.2* ? Probablement pas des dépôts librazik !

apt-cache search linux-image

linux-image-amd64 - Linux pour les ordinateurs 64 bits (métapaquet)
linux-image-rt-amd64 - Linux pour les ordinateurs 64 bits (métapaquet) avec PREEMPT_RT
linux-headers-4.9.0-11-amd64 - Header files for Linux 4.9.0-11-amd64
linux-headers-4.9.0-11-rt-amd64 - Header files for Linux 4.9.0-11-rt-amd64
linux-image-4.9.0-11-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-11-amd64-dbg - Debug symbols for linux-image-4.9.0-11-amd64
linux-image-4.9.0-11-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-11-rt-amd64-dbg - Debug symbols for linux-image-4.9.0-11-rt-amd64
linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package)
linux-headers-4.19.0-0.bpo.6-amd64 - Header files for Linux 4.19.0-0.bpo.6-amd64
linux-headers-4.19.0-0.bpo.6-cloud-amd64 - Header files for Linux 4.19.0-0.bpo.6-cloud-amd64
linux-headers-4.19.0-0.bpo.6-rt-amd64 - Header files for Linux 4.19.0-0.bpo.6-rt-amd64
linux-headers-4.9.0-4-grsec-amd64 - Header files for Linux 4.9.0-4-grsec-amd64
linux-headers-4.9.0-3-lzk-bl-amd64 - Header files for Linux 4.9.0-3-lzk-bl-amd64
linux-headers-4.9.0-3-lzk-rt-amd64 - Header files for Linux 4.9.0-3-lzk-rt-amd64
linux-headers-4.9.0-4-lzk-bl-amd64 - Header files for Linux 4.9.0-4-lzk-bl-amd64
linux-headers-4.9.0-4-lzk-rt-amd64 - Header files for Linux 4.9.0-4-lzk-rt-amd64
linux-headers-4.9.0-5-lzk-bl-amd64 - Header files for Linux 4.9.0-5-lzk-bl-amd64
linux-headers-4.9.0-5-lzk-rt-amd64 - Header files for Linux 4.9.0-5-lzk-rt-amd64
linux-headers-4.9.0-6-lzk-bl-amd64 - Header files for Linux 4.9.0-6-lzk-bl-amd64
linux-headers-4.9.0-6-lzk-rt-amd64 - Header files for Linux 4.9.0-6-lzk-rt-amd64
linux-headers-4.9.0-7-lzk-bl-amd64 - Header files for Linux 4.9.0-7-lzk-bl-amd64
linux-headers-4.9.0-7-lzk-rt-amd64 - Header files for Linux 4.9.0-7-lzk-rt-amd64
linux-headers-4.9.0-8-lzk-bl-amd64 - Header files for Linux 4.9.0-8-lzk-bl-amd64
linux-headers-4.9.0-8-lzk-rt-amd64 - Header files for Linux 4.9.0-8-lzk-rt-amd64
linux-headers-4.9.0-9-lzk-bl-amd64 - Header files for Linux 4.9.0-9-lzk-bl-amd64
linux-headers-4.9.0-9-lzk-rt-amd64 - Header files for Linux 4.9.0-9-lzk-rt-amd64
linux-image-4.9.0-3-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-3-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-4-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-4-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-5-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-5-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-6-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-6-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-7-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-7-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-8-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-8-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-9-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-9-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-9-amd64 - Linux 4.9 for 64-bit PCs
 


Par défaut, c'est un noyau basse latence qui est utilisé. Il y a une bonne doc... et un forum adapté.

Dernière modification par èfpé (05-12-2019 22:04:42)

Hors ligne

#10 03-12-2019 17:40:08

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

èfpé a écrit :

B
Mais d'où sortent les paquets linux-image-5.3.0-0.bpo.2* ? Probablement pas des dépôts librazik !




Désolé j'ai fait la commande depuis l'ordi du boulot : debian stretch ! Honte à moi !


Il n'y a pas de mauvaises questions...

Hors ligne

#11 03-12-2019 17:42:00

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Debian Alain a écrit :

pour installer :

apt install linux-image-xxxxx-amd64 linux-headers-xxxxx-amd64


remplacer xxxxx par le no du kernel .



Salut , il faut mettre le && au milieu de la commande , j'imagine ?


Il n'y a pas de mauvaises questions...

Hors ligne

#12 03-12-2019 17:42:49

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

éfpè a écrit :


  calixtus  a écrit :

Faut-il [installer un paquet] linux-headers* ?


Non



tu es sûr efpé ?

retire les headers de librazik et dis moi si çà fonctionne aussi bien .
et surtout , essaies de les remettre (dis moi si tu y arrive (et comment) ou non)

s'il les a installés par défaut , y a une raison , non ?


calixtus  a écrit :

Debian Alain a écrit :


pour installer :

apt install linux-image-xxxxx-amd64 linux-headers-xxxxx-amd64



remplacer xxxxx par le no du kernel .



Salut , il faut mettre le && au milieu de la commande , j'imagine ?



non , avec apt install tu peux procéder paquet par paquet ou en les mettant tous  à suivre séparés par un espace .

apt install <paquet 1>
apt install <paquet 2>
apt install <paquet 3>


reviennent au même que

apt install <paquet 1> <paquet 2> <paquet 3>

Dernière modification par Debian Alain (03-12-2019 17:50:27)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#13 03-12-2019 18:11:01

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Bonjour calixtus06
Librazik a corrigé le problème des headers qui n’existaient pas pour son noyau
https://librazik.tuxfamily.org/dotclear … -améliorés
Tu dois trouver ce qui va bien avec le noyau de librazik, pas besoin d’installer celui de debìan.

Grâce à la pugnacité et aux tests de Julien (jujudusud), ainsi qu'aux recherches de Jean-Pierre (jpcima), j'ai pu reconstruire la série de noyaux LibraZiK-2 actuels (4.9.0-9) ainsi que ces paquets complémentaires linux-headers-XXXX-common. Ceci permet donc aux utilisateurs de ces noyaux de pouvoir construire des modules-noyau additionnels comme le pilote nvidia propriétaire, ou d'autres modules avec DMKS comme le module wifi broadcom (bc43228), le module virtualbox-guest-dkms pour virtualbox, le module v4l2loopback par exemple, ou l'installation du module broadcom-sta,...etc et probablement des tas d'autres modules-noyau additionnels.


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

En ligne

#14 03-12-2019 19:02:37

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

merci chalu .

-- page des noyaux de librazik (mémorandum) --

liste des noyaux officiels recommandés (basse latence) :

apt search linux-image-4.9.*-lzk-bl-amd64


En train de trier... Fait
Recherche en texte intégral... Fait
linux-headers-4.9.0-3-lzk-bl-amd64/unknown 4.9.30-1 amd64
  Header files for Linux 4.9.0-3-lzk-bl-amd64

linux-headers-4.9.0-4-lzk-bl-amd64/unknown 4.9.65-3+deb9u1 amd64
  Header files for Linux 4.9.0-4-lzk-bl-amd64

linux-headers-4.9.0-5-lzk-bl-amd64/unknown 4.9.65-3+deb9u2 amd64
  Header files for Linux 4.9.0-5-lzk-bl-amd64

linux-headers-4.9.0-6-lzk-bl-amd64/unknown 4.9.88-1+deb9u1 amd64
  Header files for Linux 4.9.0-6-lzk-bl-amd64

linux-headers-4.9.0-7-lzk-bl-amd64/unknown 4.9.110-3+deb9u2 amd64
  Header files for Linux 4.9.0-7-lzk-bl-amd64

linux-headers-4.9.0-8-lzk-bl-amd64/unknown 4.9.110-3+deb9u5 amd64
  Header files for Linux 4.9.0-8-lzk-bl-amd64

linux-headers-4.9.0-9-lzk-bl-amd64/unknown 4.9.168-1 amd64
  Header files for Linux 4.9.0-9-lzk-bl-amd64

linux-image-4.9.0-3-lzk-bl-amd64/unknown 4.9.30-1 amd64
  Linux 4.9 for 64-bit PCs

linux-image-4.9.0-4-lzk-bl-amd64/unknown 4.9.65-3+deb9u1 amd64
  Linux 4.9 for 64-bit PCs

linux-image-4.9.0-5-lzk-bl-amd64/unknown 4.9.65-3+deb9u2 amd64
  Linux 4.9 for 64-bit PCs

linux-image-4.9.0-6-lzk-bl-amd64/unknown 4.9.88-1+deb9u1 amd64
  Linux 4.9 for 64-bit PCs

linux-image-4.9.0-7-lzk-bl-amd64/unknown 4.9.110-3+deb9u2 amd64
  Linux 4.9 for 64-bit PCs

linux-image-4.9.0-8-lzk-bl-amd64/unknown 4.9.110-3+deb9u5 amd64
  Linux 4.9 for 64-bit PCs

linux-image-4.9.0-9-lzk-bl-amd64/unknown 4.9.168-1 amd64
  Linux 4.9 for 64-bit PCs
 


liste des noyaux "temps réel" librazik

apt search linux-image-4.9.*-lzk-rt-amd64


En train de trier... Fait
Recherche en texte intégral... Fait
linux-headers-4.9.0-3-lzk-rt-amd64/unknown 4.9.30-1 amd64
  Header files for Linux 4.9.0-3-lzk-rt-amd64

linux-headers-4.9.0-4-lzk-rt-amd64/unknown 4.9.65-3+deb9u1 amd64
  Header files for Linux 4.9.0-4-lzk-rt-amd64

linux-headers-4.9.0-5-lzk-rt-amd64/unknown 4.9.65-3+deb9u2 amd64
  Header files for Linux 4.9.0-5-lzk-rt-amd64

linux-headers-4.9.0-6-lzk-rt-amd64/unknown 4.9.88-1+deb9u1 amd64
  Header files for Linux 4.9.0-6-lzk-rt-amd64

linux-headers-4.9.0-7-lzk-rt-amd64/unknown 4.9.110-3+deb9u2 amd64
  Header files for Linux 4.9.0-7-lzk-rt-amd64

linux-headers-4.9.0-8-lzk-rt-amd64/unknown 4.9.110-3+deb9u5 amd64
  Header files for Linux 4.9.0-8-lzk-rt-amd64

linux-headers-4.9.0-9-lzk-rt-amd64/unknown 4.9.168-1 amd64
  Header files for Linux 4.9.0-9-lzk-rt-amd64

linux-image-4.9.0-3-lzk-rt-amd64/unknown 4.9.30-1 amd64
  Linux 4.9 for 64-bit PCs, PREEMPT_RT

linux-image-4.9.0-4-lzk-rt-amd64/unknown 4.9.65-3+deb9u1 amd64
  Linux 4.9 for 64-bit PCs, PREEMPT_RT

linux-image-4.9.0-5-lzk-rt-amd64/unknown 4.9.65-3+deb9u2 amd64
  Linux 4.9 for 64-bit PCs, PREEMPT_RT

linux-image-4.9.0-6-lzk-rt-amd64/unknown 4.9.88-1+deb9u1 amd64
  Linux 4.9 for 64-bit PCs, PREEMPT_RT

linux-image-4.9.0-7-lzk-rt-amd64/unknown 4.9.110-3+deb9u2 amd64
  Linux 4.9 for 64-bit PCs, PREEMPT_RT

linux-image-4.9.0-8-lzk-rt-amd64/unknown 4.9.110-3+deb9u5 amd64
  Linux 4.9 for 64-bit PCs, PREEMPT_RT

linux-image-4.9.0-9-lzk-rt-amd64/unknown 4.9.168-1 amd64
  Linux 4.9 for 64-bit PCs, PREEMPT_RT
 



curieusement , avec une stretch à jour :

dpkg -l | grep -iE "linux-image-|linux-headers-"


ii  linux-headers-4.9.0-11-amd64            4.9.189-3+deb9u2                               amd64        Header files for Linux 4.9.0-11-amd64
ii  linux-headers-4.9.0-11-common           4.9.189-3+deb9u2                               all          Common header files for Linux 4.9.0-11
ii  linux-headers-4.9.0-9-lzk-bl-amd64      4.9.168-1                                      amd64        Header files for Linux 4.9.0-9-lzk-bl-amd64
ii  linux-headers-4.9.0-9-lzk-bl-common     4.9.168-1                                      all          Common header files for Linux 4.9.0-9-lzk-bl
ii  linux-headers-amd64                     4.9+80+deb9u9                                  amd64        Header files for Linux amd64 configuration (meta-package)
ii  linux-image-4.9.0-11-amd64              4.9.189-3+deb9u2                               amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-4.9.0-9-amd64               4.9.168-1                                      amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-4.9.0-9-lzk-bl-amd64        4.9.168-1                                      amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-amd64                       4.9+80+deb9u9                                  amd64        Linux for 64-bit PCs (meta-package)
 



uname -a


Linux jessie 4.9.0-9-lzk-bl-amd64 #1 SMP PREEMPT Debian 4.9.168-1 (2019-04-12) x86_64 GNU/Linux


et

Linux jessie 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64 GNU/Linux



pas de lézard , tout roule .


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#15 03-12-2019 21:15:04

melissa6969
Membre
Lieu : Lyon Métropole
Distrib. : Sid Xfce minimal
Inscription : 30-11-2016
Site Web

Re : Je veux installer un nouveau noyau, lequel choisir ?

y a abus de langage parfois.

c'est pas un vrai kernel rt, quand le kernel est compilé  avec "Processor type and features" -> "Preemption Model" -> "Preemptible Kernel" (Low-Latency Desktop)
ça devient un low latency, et le résultat attendu peut être déçevant.

pour les vrai kernel rt (kernel vanilla + le patch), compil via "Processor type and features" -> "Preemption Model" -> "Fully Preemptible Kernel (RT)"

Faut donc bien choisir le bon sinon on risque d'être deçu.

et on peut ne pas installer les headers, c'est utile qu'en cas de build via dkms (pilote nvidia, virtualbox par exemple)

Dernière modification par melissa6969 (03-12-2019 21:16:36)


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#16 04-12-2019 00:38:42

èfpé
Membre
Inscription : 10-07-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Re-,

calixtus06 a écrit :

Désolé j'ai fait la commande depuis l'ordinateur du boulot : Debian Stretch !


Debian Stretch... ou Debian Buster avec le dépôt buster-backports activé ? (cf. Debian Alain en #8).

Debian Alain a écrit :

Curieusement, avec une Stretch à jour :
[...]

uname -srv

Linux 4.9.0-9-lzk-bl-amd64 #1 SMP PREEMPT Debian 4.9.168-1 (2019-04-12)

[puis]

Linux 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u2 (2019-11-11)


Le noyau 4.9.0-11-lzk-* stagne dans le dépôt LZK-DCP-testers, or linux-image-amd64 est installé :

apt list --installed linux-image-* linux-headers-*

En train de lister... Fait
linux-image-4.9.0-9-amd64/now 4.9.168-1+deb9u3 amd64  [installé, local]
linux-image-4.9.0-9-lzk-bl-amd64/unknown,now 4.9.168-1 amd64  [installé]
linux-image-amd64/now 4.9+80+deb9u7 amd64 [installed,upgradable to: 4.9+80+deb9u9]


Donc, sur une LibraZiK 2 à jour c'est le noyau 4.9.0-11 dit basique qui est actif (chargé par défaut).

Dernière modification par èfpé (04-12-2019 11:08:42)

Hors ligne

#17 04-12-2019 10:51:45

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

éfpè  a écrit :

Debian Stretch... ou Debian Buster avec le dépôt buster-backports activé ? (cf. Debian Alain en #8).


euh ... non .

mais je sais plus si j'ai fait l'installation des mêta-paquets sous stretch à la main ou si çà c'est fait automatiquement .

apt policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 100 http://deb.debian.org/debian stretch-backports/contrib amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=contrib,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
     release o=Debian Backports,a=stretch-backports,n=stretch-backports,l=Debian Backports,c=main,b=amd64
     origin deb.debian.org
 500 http://download.tuxfamily.org/librazik/decepas LZK-DCP-users/contrib amd64 Packages
     release v=all,o=LibraZiK,n=LZK-DCP-users,l=LibraZiK-DCP-users,c=contrib,b=amd64
     origin download.tuxfamily.org
 500 http://download.tuxfamily.org/librazik/decepas LZK-DCP-users/main amd64 Packages
     release v=all,o=LibraZiK,n=LZK-DCP-users,l=LibraZiK-DCP-users,c=main,b=amd64
     origin download.tuxfamily.org
 100 http://deb.debian.org/debian stable/non-free amd64 Packages
     release v=10.2,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian stable/contrib amd64 Packages
     release v=10.2,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 100 http://deb.debian.org/debian stable/main amd64 Packages
     release v=10.2,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=oldstable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=oldstable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian stretch/main amd64 Packages
     release v=9.11,o=Debian,a=oldstable,n=stretch,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :


 apt policy linux-image-amd64 linux-headers-amd64


linux-image-amd64:
  Installé : 4.9+80+deb9u9
  Candidat : 4.9+80+deb9u9
 Table de version :
     4.19+105+deb10u1 100
        100 http://deb.debian.org/debian stable/main amd64 Packages
     4.19+105+deb10u1~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 4.9+80+deb9u9 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     4.9+80+deb9u6 500
        500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
linux-headers-amd64:
  Installé : 4.9+80+deb9u9
  Candidat : 4.9+80+deb9u9
 Table de version :
     4.19+105+deb10u1 100
        100 http://deb.debian.org/debian stable/main amd64 Packages
     4.19+105+deb10u1~bpo9+1 100
        100 http://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 4.9+80+deb9u9 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     4.9+80+deb9u6 500
        500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
 


où l'on voit que les mêta - paquets sont installés depuis stretch/main

*** 4.9+80+deb9u9 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#18 04-12-2019 11:04:43

èfpé
Membre
Inscription : 10-07-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Bonjour Debian Alain,

Debian Alain a écrit :

Euh... non.


Euh... je m'adressais à calixtus06. Quant au post #1, à part un mélange stretch/stable-backports...

Hors ligne

#19 04-12-2019 16:08:16

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

melissa  a écrit :

... / ... les headers, c'est utile qu'en cas de build via dkms (pilote nvidia, virtualbox par exemple)



pour virtualbox , je savais , je m'en sers facilement ;
pour les pilotes propriétaires Nvidia , j'ai découvert , en effet ;
pour dkms , je savais pas . pourtant , je m'en suis déjà servi .

merci melissa et pardon à éfpè , je crois que j'ai dû me tromper (posts #8 et #9) .

Dernière modification par Debian Alain (04-12-2019 16:10:45)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#20 04-12-2019 19:49:36

melissa6969
Membre
Lieu : Lyon Métropole
Distrib. : Sid Xfce minimal
Inscription : 30-11-2016
Site Web

Re : Je veux installer un nouveau noyau, lequel choisir ?

Debian Alain a écrit :

melissa  a écrit :

... / ... les headers, c'est utile qu'en cas de build via dkms (pilote nvidia, virtualbox par exemple)



pour virtualbox , je savais , je m'en sers facilement ;
pour les pilotes propriétaires Nvidia , j'ai découvert , en effet ;
pour dkms , je savais pas . pourtant , je m'en suis déjà servi .

merci melissa et pardon à éfpè , je crois que j'ai dû me tromper (posts #8 et #9) .


En faite les headers sontvraiment nécessaire juste pour éviter de tout recompiler à la main, même si dkms recompile en quelque sorte, mais c'est automatique et rapide.

Sur le pc de ma mère par exemple, les headers sont pas installés, elle a juste un pilote pour sa carte ethernet et c'est grâce à l'initramfs qu'il est builder en quelque sorte.
Dans ce contexte les headers lui sont totalement inutiles, même si au fond ils dérangent pas tant que ça les entêtes du kernel.


Quamdiu est spes est, Est vitae.
Fiet in posterum melius

Hors ligne

#21 05-12-2019 00:17:51

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

J'ai lancé un fil à part pour justement savoir si je pouvais rajouter un dépôt de buster dans ma stretch pour obtenir musescore 3 et ses mises à jour plutôt que de prendre juste un .deb..

Pour en revenir au noyau à ajouter. J'ai tenté la manoeuvre , planté l'ordi, ré installé librazik..
Est ce que je peux télécharger au pif ou presque ( 4.19, 5.xx) un noyau et son header sans rien risquer ??

Il n'y a pas de mauvaises questions...

Hors ligne

#22 05-12-2019 01:28:42

èfpé
Membre
Inscription : 10-07-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Bonne nuit calixtus06,

calixtus06 a écrit :

J'ai tenté la manœuvre, planté [le système], réinstallé LibraZiK...


Quelle manœuvre ? Quelle commande ? Pour installer quel noyau ? De quel dépôt, exotique ou non ?

calixtus06 a écrit :

Est-ce que je peux télécharger un noyau [...] au pif ou presque (4.19, 5.xx) sans rien risquer ?


Non bien sûr. Tu viens de l'expérimenter. LibraZiK ne bride pas le dépôt stretch-backports pour rien.

Hors ligne

#23 05-12-2019 18:00:01

calixtus06
Membre
Distrib. : Librazik2
Noyau : Linux version 4.9.0-6-lzk-bl-amd64
(G)UI : mate
Inscription : 25-03-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

Hello,

En résumé les noyaux installés sur mon pc:


linux-image-4.9.0-9-lzk-bl-amd64  4.9.168-1         amd64
linux-image-4.9.0-9-amd64         4.9.168-1+deb9u3  amd64
linux-image-4.9.0-11-amd64        4.9.189-3+deb9u2  amd64
linux-image-amd64                 4.9+80+deb9u9     amd64
 



Celui qui est utilisé :

4.9.0-11-amd64 x86_64
 



Bizarre , théoriquement je devrais avoir celui de librazik ...(?)

apt-cache search linux-image



linux-headers-4.9.0-11-686 - Header files for Linux 4.9.0-11-686
linux-headers-4.9.0-11-686-pae - Header files for Linux 4.9.0-11-686-pae
[b]linux-headers-4.9.0-11-amd64 - Header files for Linux 4.9.0-11-amd64[/b]
linux-headers-4.9.0-11-rt-686-pae - Header files for Linux 4.9.0-11-rt-686-pae
linux-headers-4.9.0-11-rt-amd64 - Header files for Linux 4.9.0-11-rt-amd64
linux-image-4.9.0-11-686 - Linux 4.9 for older PCs
linux-image-4.9.0-11-686-dbg - Debug symbols for linux-image-4.9.0-11-686
linux-image-4.9.0-11-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-11-686-pae-dbg - Debug symbols for linux-image-4.9.0-11-686-pae
[b]linux-image-4.9.0-11-amd64 - Linux 4.9 for 64-bit PCs[/b]
linux-image-4.9.0-11-amd64-dbg - Debug symbols for linux-image-4.9.0-11-amd64
linux-image-4.9.0-11-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-11-rt-686-pae-dbg - Debug symbols for linux-image-4.9.0-11-rt-686-pae
linux-image-4.9.0-11-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-11-rt-amd64-dbg - Debug symbols for linux-image-4.9.0-11-rt-amd64
linux-image-686-dbg - Debugging symbols for Linux 686 configuration (meta-package)
linux-image-686-pae-dbg - Debugging symbols for Linux 686-pae configuration (meta-package)
linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
linux-image-rt-686-pae-dbg - Debugging symbols for Linux rt-686-pae configuration (meta-package)
linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package)
linux-image-586 - Linux pour les anciens ordinateurs (paquet factice)
linux-image-686 - Linux pour les anciens ordinateurs (métapaquet)
linux-image-amd64 - Linux pour les ordinateurs 64 bits (métapaquet)
linux-image-rt-686-pae - Linux pour les ordinateurs récents avec PREEMPT_RT (méta-paquet)
linux-image-rt-amd64 - Linux pour les ordinateurs 64 bits (métapaquet) avec PREEMPT_RT
linux-headers-4.9.0-3-lzk-bl-amd64 - Header files for Linux 4.9.0-3-lzk-bl-amd64
linux-headers-4.9.0-3-lzk-rt-amd64 - Header files for Linux 4.9.0-3-lzk-rt-amd64
linux-headers-4.9.0-4-lzk-bl-amd64 - Header files for Linux 4.9.0-4-lzk-bl-amd64
linux-headers-4.9.0-4-lzk-rt-amd64 - Header files for Linux 4.9.0-4-lzk-rt-amd64
linux-headers-4.9.0-5-lzk-bl-amd64 - Header files for Linux 4.9.0-5-lzk-bl-amd64
linux-headers-4.9.0-5-lzk-rt-amd64 - Header files for Linux 4.9.0-5-lzk-rt-amd64
linux-headers-4.9.0-6-lzk-bl-amd64 - Header files for Linux 4.9.0-6-lzk-bl-amd64
linux-headers-4.9.0-6-lzk-rt-amd64 - Header files for Linux 4.9.0-6-lzk-rt-amd64
linux-headers-4.9.0-7-lzk-bl-amd64 - Header files for Linux 4.9.0-7-lzk-bl-amd64
linux-headers-4.9.0-7-lzk-rt-amd64 - Header files for Linux 4.9.0-7-lzk-rt-amd64
linux-headers-4.9.0-8-lzk-bl-amd64 - Header files for Linux 4.9.0-8-lzk-bl-amd64
linux-headers-4.9.0-8-lzk-rt-amd64 - Header files for Linux 4.9.0-8-lzk-rt-amd64
linux-headers-4.9.0-9-lzk-bl-amd64 - Header files for Linux 4.9.0-9-lzk-bl-amd64
linux-headers-4.9.0-9-lzk-rt-amd64 - Header files for Linux 4.9.0-9-lzk-rt-amd64
linux-image-4.9.0-3-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-3-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-4-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-4-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-5-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-5-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-6-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-6-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-7-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-7-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-8-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-8-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-9-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-9-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-headers-4.9.0-3-lzk-bl-686-pae - Header files for Linux 4.9.0-3-lzk-bl-686-pae
linux-headers-4.9.0-3-lzk-rt-686-pae - Header files for Linux 4.9.0-3-lzk-rt-686-pae
linux-headers-4.9.0-4-lzk-bl-686-pae - Header files for Linux 4.9.0-4-lzk-bl-686-pae
linux-headers-4.9.0-4-lzk-rt-686-pae - Header files for Linux 4.9.0-4-lzk-rt-686-pae
linux-headers-4.9.0-5-lzk-bl-686-pae - Header files for Linux 4.9.0-5-lzk-bl-686-pae
linux-headers-4.9.0-5-lzk-rt-686-pae - Header files for Linux 4.9.0-5-lzk-rt-686-pae
linux-headers-4.9.0-6-lzk-bl-686-pae - Header files for Linux 4.9.0-6-lzk-bl-686-pae
linux-headers-4.9.0-6-lzk-rt-686-pae - Header files for Linux 4.9.0-6-lzk-rt-686-pae
linux-headers-4.9.0-7-lzk-bl-686-pae - Header files for Linux 4.9.0-7-lzk-bl-686-pae
linux-headers-4.9.0-7-lzk-rt-686-pae - Header files for Linux 4.9.0-7-lzk-rt-686-pae
linux-headers-4.9.0-8-lzk-bl-686-pae - Header files for Linux 4.9.0-8-lzk-bl-686-pae
linux-headers-4.9.0-8-lzk-rt-686-pae - Header files for Linux 4.9.0-8-lzk-rt-686-pae
linux-headers-4.9.0-9-lzk-bl-686-pae - Header files for Linux 4.9.0-9-lzk-bl-686-pae
linux-headers-4.9.0-9-lzk-rt-686-pae - Header files for Linux 4.9.0-9-lzk-rt-686-pae
linux-image-4.9.0-3-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-3-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-4-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-4-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-5-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-5-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-6-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-6-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-7-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-7-lzk-rt-686-pae - Linux 4.bloc à supprimer si la commande n’affiche rien9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-8-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-8-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-9-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-9-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-headers-4.19.0-0.bpo.6-686 - Header files for Linux 4.19.0-0.bpo.6-686
linux-headers-4.19.0-0.bpo.6-686-pae - Header files for Linux 4.19.0-0.bpo.6-686-pae
[b]linux-headers-4.19.0-0.bpo.6-amd64 - Header files for Linux 4.19.0-0.bpo.6-amd64[/b]
linux-headers-4.19.0-0.bpo.6-cloud-amd64 - Header files for Linux 4.19.0-0.bpo.6-cloud-amd64
linux-headers-4.19.0-0.bpo.6-rt-686-pae - Header files for Linux 4.19.0-0.bpo.6-rt-686-pae
linux-headers-4.19.0-0.bpo.6-rt-amd64 - Header files for Linux 4.19.0-0.bpo.6-rt-amd64
linux-image-4.19.0-0.bpo.6-686-dbg - Debug symbols for linux-image-4.19.0-0.bpo.6-686
linux-image-4.19.0-0.bpo.6-686-pae-dbg - Debug symbols for linux-image-4.19.0-0.bpo.6-686-pae
linux-image-4.19.0-0.bpo.6-686-pae-unsigned - Linux 4.19 for modern PCs
linux-image-4.19.0-0.bpo.6-686-unsigned - Linux 4.19 for older PCs
linux-image-4.19.0-0.bpo.6-rt-686-pae-dbg - Debug symbols for linux-image-4.19.0-0.bpo.6-rt-686-pae
linux-image-4.19.0-0.bpo.6-rt-686-pae-unsigned - Linux 4.19 for modern PCs, PREEMPT_RT
linux-image-i386-signed-template - Template for signed linux-image packages for i386
linux-headers-4.9.0-4-grsec-686-pae - Header files for Linux 4.9.0-4-grsec-686-pae
linux-headers-4.9.0-4-grsec-amd64 - Header files for Linux 4.9.0-4-grsec-amd64
linux-image-4.9.0-4-grsec-686-pae - Linux 4.9 for modern PCs, Grsecurity protection (unofficial patch)
linux-image-grsec-686-pae - Linux image meta-package, grsec featureset
linux-image-grsec-i386 - Linux image meta-package, grsec featureset (transition package)
linux-image-686-pae - Linux for modern PCs (meta-package)
linux-image-4.19.0-0.bpo.6-686 - Linux 4.19 for older PCs (signed)
linux-image-4.19.0-0.bpo.6-686-pae - Linux 4.19 for modern PCs (signed)
linux-image-4.19.0-0.bpo.6-rt-686-pae - Linux 4.19 for modern PCs, PREEMPT_RT (signed)
[b]linux-image-4.9.0-9-amd64 - Linux 4.9 for 64-bit PCs[/b]
nicolas@LibraZiK2-studio-audio:~$
 



Bizarre aussi que le linux-header de mon noyau librazik ne soit pas installé...

Est ce que ce qui est mis en gras peut être installé pour avoir un choix supplémentaire dans grub ?

Merci de votre patience


Il n'y a pas de mauvaises questions...

Hors ligne

#24 05-12-2019 18:14:45

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.3.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Je veux installer un nouveau noyau, lequel choisir ?

calixtus06  a écrit :

Bizarre , théoriquement je devrais avoir celui de librazik ...(?)


ben , tu l'as .

installé :

linux-image-4.9.0-9-lzk-bl-amd64  4.9.168-1         amd64
... / ...



http://librazik.tuxfamily.org/doc2/manuel/noyau?s

les noyaux (et les headers) *-lzk-* , ce sont les noyaux librazik .
tu n'avais pas compris ?   big_smile

doc officielle librazik  a écrit :

Le noyau linux “basique” est un noyau “de base”. Sur LibraZiK-2, les noyaux “basiques” sont directement fournis par debian.

Ces noyaux “basiques” ne sont pas fait pour être performants en terme de MAO (bien qu'ils puissent être suffisant selon la tâche MAO effectuée). LibraZiK-2 fourni donc deux autres types de noyaux


les noyaux *-lzk-bl-* , ce sont les noyaux librazik "basse latence" (recommandés dans la doc officielle)

doc officielle librazik  a écrit :

Les noyaux linux “basse-latence” (bl) fournis par LibraZiK-2 sont conçus pour avoir des temps de latence réduits permettant le travail audio-numérique. Ce sont ceux que vous voudrez utiliser dans la grande majorité des cas pour un contexte de production audio-numérique.


les noyaux *-lzk-rt-* , ce sont des noyaux "temps réel" , pour les cas particuliers (toujours d'après la doc officielle).

doc officielle librazik  a écrit :

Les noyaux linux “temps-réel” (rt) fournis par LibraZiK-2 sont encore plus optimisés pour les latences basses. Ceci dit, ils peuvent avoir des problèmes de compatibilité notamment avec certains pilotes pour carte graphique.

Il est à noter que dans 95% des cas, vous n'avez pas besoin d'un noyau “temps-réel”, le noyau basse-latence étant largement suffisant. Le problème étant de se dire que “oh bah oui, mais moi je fais partie des 5% qui en ont besoin”. Non. Vous n'êtes certainement pas si spécial que ça. Navré de vous le dire sèchement ici :-D . Utilisez un noyau basse-latence, ça suffira bien largement et vous éviterez d'autres soucis.

Vous ne devriez utiliser un RT que si vous savez réellement et sérieusement pourquoi vous en avez besoin,


apt-cache search linux-image

ce sont là les noyaux librazik officiels disponnibles
dans ton listing original , ils sont mélangés avec les noyaux "classiques" et les noyaux "p.a.e."

... / ...
linux-headers-4.9.0-3-lzk-bl-amd64 - Header files for Linux 4.9.0-3-lzk-bl-amd64
linux-headers-4.9.0-3-lzk-rt-amd64 - Header files for Linux 4.9.0-3-lzk-rt-amd64
linux-headers-4.9.0-4-lzk-bl-amd64 - Header files for Linux 4.9.0-4-lzk-bl-amd64
linux-headers-4.9.0-4-lzk-rt-amd64 - Header files for Linux 4.9.0-4-lzk-rt-amd64
linux-headers-4.9.0-5-lzk-bl-amd64 - Header files for Linux 4.9.0-5-lzk-bl-amd64
linux-headers-4.9.0-5-lzk-rt-amd64 - Header files for Linux 4.9.0-5-lzk-rt-amd64
linux-headers-4.9.0-6-lzk-bl-amd64 - Header files for Linux 4.9.0-6-lzk-bl-amd64
linux-headers-4.9.0-6-lzk-rt-amd64 - Header files for Linux 4.9.0-6-lzk-rt-amd64
linux-headers-4.9.0-7-lzk-bl-amd64 - Header files for Linux 4.9.0-7-lzk-bl-amd64
linux-headers-4.9.0-7-lzk-rt-amd64 - Header files for Linux 4.9.0-7-lzk-rt-amd64
linux-headers-4.9.0-8-lzk-bl-amd64 - Header files for Linux 4.9.0-8-lzk-bl-amd64
linux-headers-4.9.0-8-lzk-rt-amd64 - Header files for Linux 4.9.0-8-lzk-rt-amd64
linux-headers-4.9.0-9-lzk-bl-amd64 - Header files for Linux 4.9.0-9-lzk-bl-amd64
linux-headers-4.9.0-9-lzk-rt-amd64 - Header files for Linux 4.9.0-9-lzk-rt-amd64
linux-image-4.9.0-3-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-3-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-4-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-4-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-5-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-5-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-6-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-6-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-7-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-7-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-8-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-8-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-9-lzk-bl-amd64 - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-9-lzk-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-headers-4.9.0-3-lzk-bl-686-pae - Header files for Linux 4.9.0-3-lzk-bl-686-pae
linux-headers-4.9.0-3-lzk-rt-686-pae - Header files for Linux 4.9.0-3-lzk-rt-686-pae
linux-headers-4.9.0-4-lzk-bl-686-pae - Header files for Linux 4.9.0-4-lzk-bl-686-pae
linux-headers-4.9.0-4-lzk-rt-686-pae - Header files for Linux 4.9.0-4-lzk-rt-686-pae
linux-headers-4.9.0-5-lzk-bl-686-pae - Header files for Linux 4.9.0-5-lzk-bl-686-pae
linux-headers-4.9.0-5-lzk-rt-686-pae - Header files for Linux 4.9.0-5-lzk-rt-686-pae
linux-headers-4.9.0-6-lzk-bl-686-pae - Header files for Linux 4.9.0-6-lzk-bl-686-pae
linux-headers-4.9.0-6-lzk-rt-686-pae - Header files for Linux 4.9.0-6-lzk-rt-686-pae
linux-headers-4.9.0-7-lzk-bl-686-pae - Header files for Linux 4.9.0-7-lzk-bl-686-pae
linux-headers-4.9.0-7-lzk-rt-686-pae - Header files for Linux 4.9.0-7-lzk-rt-686-pae
linux-headers-4.9.0-8-lzk-bl-686-pae - Header files for Linux 4.9.0-8-lzk-bl-686-pae
linux-headers-4.9.0-8-lzk-rt-686-pae - Header files for Linux 4.9.0-8-lzk-rt-686-pae
linux-headers-4.9.0-9-lzk-bl-686-pae - Header files for Linux 4.9.0-9-lzk-bl-686-pae
linux-headers-4.9.0-9-lzk-rt-686-pae - Header files for Linux 4.9.0-9-lzk-rt-686-pae
linux-image-4.9.0-3-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-3-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-4-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-4-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-5-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-5-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-6-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-6-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-7-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-7-lzk-rt-686-pae - Linux 4.bloc à supprimer si la commande n’affiche rien9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-8-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-8-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
linux-image-4.9.0-9-lzk-bl-686-pae - Linux 4.9 for modern PCs
linux-image-4.9.0-9-lzk-rt-686-pae - Linux 4.9 for modern PCs, PREEMPT_RT
... / ...



si tout fonctionne comme çà , ne touche pas aux headers pour l'instant .
en attendant que tu comprennes et que tu t'y habitues , laisse les de côté pour le moment .
tu verra plus tard .

Dernière modification par Debian Alain (05-12-2019 19:16:00)


CelKilt / Petit Papa Noël cover / Official video

RYZEN7 1700X - PRIME X370 PRO - 16 Go DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB

En ligne

#25 05-12-2019 19:13:47

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Je veux installer un nouveau noyau, lequel choisir ?

calixtus06 : tu devrais t’inscrire sur le forum de librazik pour lui signaler qu’il y a un noyau plus récent sur Debian stretch et qu’il doit mettre à jour celui de librazik.
De mémoire il me semble qu’il y a un seul développeur et un (ou deux ou plus ) testeurs.
un des testeurs est trebmuth, il est inscrit sur le forum, tu peux aussi lui envoyé un MP pour lui parler de la version du noyau

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

En ligne

Pied de page des forums