Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-03-2020 18:16:05

BauHax
Membre
Inscription : 23-03-2020

Problème de connections internet wifi

Bonjour, je suis actuellement newbie sur Linux et j'ai chercher la solution en vain, c'est pourquoi je viens demander de l'aide ici.
J'ai passé mon pc portable Asus sous debian 10 LXQt avec le fameux connman pour gérer le wifi. Je réussi à me connecter aux wifi mais au moment de lancer un navigateur celui ne parvient pas à charger la moindre page. Or je n'ai pas ce problème avec les wifi auquel je me connectais auparavant lorsque l'ordi étais encore sous w10. Voilà voilà...
Network controller [ 0280] Qualcomm Atheros QCA9565 / AR9565 wireless network adapter [168c:0036] (rdv 01)
Merci d'avance pour votre aide

Hors ligne

#2 25-03-2020 10:03:57

Renart_frambivore
Membre
Distrib. : Debian GNU/Linux buster
Noyau : 4.19.0-8-amd64
(G)UI : XFCE4
Inscription : 07-09-2018

Re : Problème de connections internet wifi

Salut,
peux tu donner le retour de :

rfkill


et de :

ifconfig


Ifconfig va te donner le nom de tes interfaces.
Le nom d'une interface wifi ressemble à : wlpXsX .
Aprés, tu n'as qu'à utiliser la commande :

ifup "ton_interface_wifi"


disposes tu du paquet : firmware-atheros  ?
Sinon, tu peux essayer de l'installer.

apt-get update && apt-get install firmware-atheros


Il faudra bien sur te brancher en ethernet ou utiliser ton téléphone comme modem USB.
Si la commande précédente ne trouves pas le paquet firmware-atheros, tu devras modifier ton fichier : /etc/apt/sources.list afin d'ajouter les dépots "contrib" et "non-free"
Il y a beaucoup de tuto sur le net, ce n'est vraiment pas compliqué, tu veras.

Dernière modification par Renart_frambivore (25-03-2020 10:13:10)


Maître Renart, par l'odeur alléché, Lui tint à peu près ce langage : "sudo apt-get update && sudo apt-get upgrade && sudo apt-get autoremove && sudo reboot"

Hors ligne

#3 25-03-2020 11:53:21

raleur
Membre
Inscription : 03-10-2014

Re : Problème de connections internet wifi

1) rfkill seul ne va pas afficher grand-chose d'intéressant. Plutôt

rfkill list


Mais j'ose espérer que si l'interface wifi est effectivement associée à un point d'accès, la radio n'est pas bloquée.

2) ifconfig n'est plus forcément installé par défaut. Il vaut mieux utiliser son remplaçant ip :

ip addr
ip route



3) ifup ne fonctionne qu'avec une interface configurée dans /etc/network/interfaces. Rien à voir avec connman a priori.

Hors ligne

#4 25-03-2020 14:27:13

Renart_frambivore
Membre
Distrib. : Debian GNU/Linux buster
Noyau : 4.19.0-8-amd64
(G)UI : XFCE4
Inscription : 07-09-2018

Re : Problème de connections internet wifi

perso j'utilise toujours rfkill seul qui me renvoi les infos que je souhaite, mais ca n'a pas d'importance.

rfkill


ID TYPE      DEVICE     SOFT     HARD
 0 wlan      phy0   débloqué débloqué
 1 bluetooth hci0     bloqué débloqué



Mais j'ose espérer que si l'interface wifi est effectivement associée à un point d'accès, la radio n'est pas bloquée.


En effet, j'avais mal lu...

Et pour le firmware-atheros, qu'est ce que tu en dis?


Maître Renart, par l'odeur alléché, Lui tint à peu près ce langage : "sudo apt-get update && sudo apt-get upgrade && sudo apt-get autoremove && sudo reboot"

Hors ligne

#5 25-03-2020 15:13:07

raleur
Membre
Inscription : 03-10-2014

Re : Problème de connections internet wifi

Renart_frambivore a écrit :

perso j'utilise toujours rfkill seul


Autant pour moi, ça a changé depuis buster et j'utilise encore une ancienne version.

Renart_frambivore a écrit :

Et pour le firmware-atheros, qu'est ce que tu en dis?


Pareil, je ne vois pas comment l'association avec le point d'accès pourrait se faire sans les firmwares nécessaires.

Hors ligne

#6 26-03-2020 17:18:51

BauHax
Membre
Inscription : 23-03-2020

Re : Problème de connections internet wifi

Bonjour merci pour vos réponses, bon petite précision lors du démarage du PC il m'écrit nottament "failed to raised Network interface". Je vous met la réponse de ip addr et de ip route mais ifconfig n'est pas installé et rfkill non plus. Mes tentatives restent vaines pour mettre le débian en connection ethernet et pour le partage de connection par usb, j'ai donc téléchargé sur un autre ordi net-tools.60-6+b1_amd.deb ; rfkill_0.5-1_amd64.deb et firmware-atheros_20190717-2_ll.deb. J'installe les trois avec Gdebi il me répond que l'installation a été effectuée mais non lorsque j'utilises les commandes rfkill ou ifconfig pas de retour donc je sais pas .. j'ai l'impression d'etre un cassos à galérer comme ça pour installer un pilote de carte wifi mais pour le coup je galere vraiment.
merci pour votre aide, voici les retours commandes

linux@LINUX:~$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0f2: <NO-CARRIER,BROADCAST,MULTICAST,DYNAMIC,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 38:2c:4a:82:a1:78 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc noqueue master tether state UP group default qlen 1000
    link/ether 40:e2:30:49:72:39 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::42e2:30ff:fe49:7239/64 scope link
       valid_lft forever preferred_lft forever
4: tether: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 40:e2:30:49:72:39 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.1/24 brd 192.168.0.255 scope global tether
       valid_lft forever preferred_lft forever
    inet6 fe80::8c61:66ff:fe5a:b646/64 scope link
       valid_lft forever preferred_lft forever
linux@LINUX:~$ ip route
192.168.0.0/24 dev tether proto kernel scope link src 192.168.0.1


bloc à supprimer si la commande n’affiche rien

Hors ligne

Pied de page des forums