Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).


L'icône rouge permet de télécharger chaque page du wiki visitée au format PDF et la grise au format ODT → ODT PDF Export

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
doc:media:obs-studio [15/03/2016 09:03]
nazmi [Utilisation]
doc:media:obs-studio [20/02/2019 14:51] (Version actuelle)
kao [Introduction] retrait de la mention qu'il n'y a pas de paquet Debian
Ligne 8: Ligne 8:
     * Création par [[user>​nazmi]] 10/03/2016     * Création par [[user>​nazmi]] 10/03/2016
     * Testé par <...> le <...> FIXME     * Testé par <...> le <...> FIXME
-  * Commentaires sur le forum : [[https://​debian-facile.org/​viewtopic.php?​id=13693 | Lien vers le forum concernant ce tuto]]((N'​hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !))+  * Commentaires sur le forum : [[https://​debian-facile.org/​viewtopic.php?​id=13692 | Lien vers le forum concernant ce tuto]]((N'​hésitez pas à y faire part de vos remarques, succès, améliorations ou échecs !))
  
 ===== Introduction ===== ===== Introduction =====
Ligne 22: Ligne 22:
 Cependant un projet nommé OBS-Studio a démarré (par la même équipe), ayant pour objectif d'​être multiplate-forme,​ encore plus complet, et à terme de remplacer l'​OBS original. ​ Cependant un projet nommé OBS-Studio a démarré (par la même équipe), ayant pour objectif d'​être multiplate-forme,​ encore plus complet, et à terme de remplacer l'​OBS original. ​
  
-Parmi les systèmes supportés figure Debian et bien qu'il n'y ait pas de paquet disponible pour l'​instant (Mars 2016), il est possible de le compiler à partir des sources en une petite demi-heure de travail. ​ 
  
 <note tip>Des instructions (en anglais) sont disponibles sur le github mais elles seront ci-après reprises et expliquées dans un Français compréhensible pour un utilisateur averti (enfin pas forcément besoin mais ça aide ^_^ ).</​note>​ <note tip>Des instructions (en anglais) sont disponibles sur le github mais elles seront ci-après reprises et expliquées dans un Français compréhensible pour un utilisateur averti (enfin pas forcément besoin mais ça aide ^_^ ).</​note>​
  
 <note tip>Un bémol cependant: la majorité de la communauté utilisant OBS, et vu qu'​OBS-Studio est encore à une version peu avancée, une grande partie des plugins et fonctionnalités disponibles pour le premier ne le sont pas pour le dernier.</​note>​ <note tip>Un bémol cependant: la majorité de la communauté utilisant OBS, et vu qu'​OBS-Studio est encore à une version peu avancée, une grande partie des plugins et fonctionnalités disponibles pour le premier ne le sont pas pour le dernier.</​note>​
 +
 +===== Prérequis =====
 +Tout d'​abord,​ il faut vérifier votre version d'​opengl avec la commande glxinfo: ​
 +<code root>apt install mesa-utils</​code>​
 +<code user>​glxinfo | grep "​OpenGL"</​code> ​
 +si au niveau de core profile version, c'est supérieur à 3.2, c'est bon, exemple : <​code>​OpenGL core profile version string: 4.10</​code>​
  
 ===== Installation ===== ===== Installation =====
 +Le paquet obs-studio est disponible dans les dépôts depuis Debian Stretch:
 +<code root>apt install obs-studio</​code>​
 +
 +
 +==== Compiler Obs-studio pour Debian Jessie ====
 +
 +<note tip>La documentation ci-dessous vous propose de compiler OBS. Vous pouvez aussi utiliser une AppImage, très facile à installer (télécharger,​ clic droit, onglet permission, autoriser l’exécution de ce programme, double clic et c'est lancé) et ne présente pas de conflits de librairies [[https://​obsproject.com/​forum/​threads/​appimage-for-most-linux-distributions.62418/​]]</​note>​
  
 <note tip>issu de: [[https://​github.com/​jp9000/​obs-studio/​wiki/​Install-Instructions#​manually-compiling-on-debian-based-distros]]</​note>​ <note tip>issu de: [[https://​github.com/​jp9000/​obs-studio/​wiki/​Install-Instructions#​manually-compiling-on-debian-based-distros]]</​note>​
  
-  - Tout d'​abord,​ il faut vérifier votre version d'​opengl avec : <code user>​glxinfo | grep "​OpenGL"</​code>​ si au niveau de core profile version, c'est supérieur à 3.2, c'est bon, exemple : <​code>​OpenGL core profile version string: 4.10</​code>​+
   -    - 
-    -Ensuite, installez/vérifiez que sont installés les paquets qui vont être nécessaires pour installer et faire tourner (dépendances) OBS-Studio : <code root>​apt-get install build-essential pkg-config cmake git checkinstall libx11-dev libgl1-mesa-dev libpulse-dev libxcomposite-dev libxinerama-dev libv4l-dev libudev-dev libfreetype6-dev libfontconfig-dev qtbase5-dev libqt5x11extras5-dev libx264-dev libxcb-xinerama0-dev libxcb-shm0-dev libjack-jackd2-dev libcurl4-openssl-dev libavcodec-dev libavfilter-dev libavdevice-dev ffmpeg</​code>​+    -Installez/vérifiez que sont installés les paquets qui vont être nécessaires pour installer et faire tourner (dépendances) OBS-Studio : <code root>​apt-get install build-essential pkg-config cmake git checkinstall libx11-dev libgl1-mesa-dev libpulse-dev libxcomposite-dev libxinerama-dev libv4l-dev libudev-dev libfreetype6-dev libfontconfig-dev qtbase5-dev libqt5x11extras5-dev libx264-dev libxcb-xinerama0-dev libxcb-shm0-dev libjack-jackd2-dev libcurl4-openssl-dev libavcodec-dev libavfilter-dev libavdevice-dev ffmpeg</​code>​
     - Si vous n'​êtes pas un militant du logiciel libre (honte sur vous et votre famille sur 16 générations) et voulez avoir le support du codec audio aac (pas du tout nécessaire pour pouvoir streamer), faites aussi :<code root>​apt-get install libfdk-aac-dev</​code>​     - Si vous n'​êtes pas un militant du logiciel libre (honte sur vous et votre famille sur 16 générations) et voulez avoir le support du codec audio aac (pas du tout nécessaire pour pouvoir streamer), faites aussi :<code root>​apt-get install libfdk-aac-dev</​code>​
   - Il faut maintenant installer un paquet de backports, parce-que sinon ça ne compilera pas, (libswresample-dev) avec :<code root>​apt-get -t jessie-backports install libswresample-dev</​code>​   - Il faut maintenant installer un paquet de backports, parce-que sinon ça ne compilera pas, (libswresample-dev) avec :<code root>​apt-get -t jessie-backports install libswresample-dev</​code>​
doc/media/obs-studio.1458047000.txt.gz · Dernière modification: 15/03/2016 09:03 par nazmi

Pied de page des forums

Propulsé par FluxBB