Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Système » [Résolu] Faire un Gost pour changer de disque » 07-02-2021 14:34:11

Coucou.

J'utilise Manjaro Xfce en live usb (qui intègre Clonezilla d'office).
En cas de soucis, sur une seule clé, le système live (Manjaro) pour récupérer mes données en cas de plantage de mon pc, et de remettre en place la dernière image système effectuée via Clonezilla.
Et sur une autre clé usb, j'ai l'installateur de Debian pour m'en servir en cas de besoin de réparation (via le mode rescue de l'installateur).

Pour le moment, je ne me sers que de Manjaro en live pour cloner mon système.

Comme ce matin, grosse mise à jour (de 10.7 à 10.8) et comme toujours par précaution (on n'est jamais trop prudente dans la vie) un backup via Clonezilla.

#3 Re : Matériel » [Abandon] Grésillements avec la prise jack » 04-02-2021 22:31:08

J'ai fais un test à l'arrache.
En branchant mon Dac Micromega en usb, lui-même relié à mon ampli Harman Kardon via un câble rca, sur lequel est branché des enceintes Elipson, plus aucun grésillements comme attendu puisque j'outrepasse la prise jack pour obtenir du son.
Le tout est relié via un câble usb en plaqué or, câble rca en plaqué or, et câbles d'enceintes en cuivre OFC de 4 mm² en bi-câblage.

Mais dans cette configuration, quand je branche le casque sur la jack du pc, plus aucun grésillement, pourtant le Dac n'est pas actif dans ces moments, donc le mystère reste entier.

Ce petit pc je voulais m'en servir pour l'amener dans le train pour m'occuper, mais je vais pas amener tout le matériel Hi-Fi de l'appart dans le train !
Du coup ce petit Asus me servira juste en cas de soucis avec mon laptop principal.

On peut clore le sujet, merci à tous.

#4 Re : Matériel » [Abandon] Grésillements avec la prise jack » 14-01-2021 09:46:36

Huuum je vais y réfléchir à plusieurs fois, je n'ai jamais mis à jour un bios, alors vu ma malchance légendaire tongue

#5 Re : Matériel » [Abandon] Grésillements avec la prise jack » 13-01-2021 10:54:42

Bonjour.

Je laisse ici le retour de dmesg |grep i2c

[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.9.0-5-amd64 root=UUID=fd2fbeef-4b96-431d-a1ac-0549db4ddb11 ro modprobe.blacklist=hci_uart modprobe.blacklist=btsdio modprobe.blacklist=snd_hdmi_lpe_audio quiet
[    0.037883] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.9.0-5-amd64 root=UUID=fd2fbeef-4b96-431d-a1ac-0549db4ddb11 ro modprobe.blacklist=hci_uart modprobe.blacklist=btsdio modprobe.blacklist=snd_hdmi_lpe_audio quiet
[    1.739273] i2c_designware 80860F41:04: I2C bus managed by PUNIT
[    2.334099] i2c_hid i2c-PDEC3393:00: supply vdd not found, using dummy regulator
[    2.334188] i2c_hid i2c-PDEC3393:00: supply vddl not found, using dummy regulator
[    2.524346] i2c_hid i2c-ELAN0100:00: supply vdd not found, using dummy regulator
[    2.524446] i2c_hid i2c-ELAN0100:00: supply vddl not found, using dummy regulator
[    2.650981] input: PDEC3393:00 0B05:8585 as /devices/platform/80860F41:00/i2c-0/i2c-PDEC3393:00/0018:0B05:8585.0001/input/input0
[    2.651601] asus 0018:0B05:8585.0001: input,hidraw0: I2C HID v1.00 Keyboard [PDEC3393:00 0B05:8585] on i2c-PDEC3393:00
[    5.960622] rt5645 i2c-10EC5648:00: supply avdd not found, using dummy regulator
[    5.960723] rt5645 i2c-10EC5648:00: supply cpvdd not found, using dummy regulator
[   53.215590] elan_i2c i2c-ELAN0100:00: supply vcc not found, using dummy regulator
[   53.382429] elan_i2c i2c-ELAN0100:00: Elan Touchpad: Module ID: 0x0026, Firmware: 0x000a, Sample: 0x0001, IAP: 0x0007
[   53.386267] input: Elan Touchpad as /devices/platform/80860F41:03/i2c-3/i2c-ELAN0100:00/input/input12



Pour jouer avec bus i2c, ça me paraît trop complexe pour moi.
J'ai testé le blacklistage des modules i2c un par un, mais aucun changement.
En même temps il y en a pas beaucoup, le retour de lsmod |grep i2c

elan_i2c               53248  0
i2c_algo_bit           16384  1 i915
i2c_hid                32768  0
hid                   147456  4 i2c_hid,usbhid,hid_generic,hid_asus



Pour le bios une MAJ de 2019 est disponible.
https://www.asus.com/us/Laptops/ASUS_Ee … Desk_BIOS/
Mais je ne sais pas comment on fait !
J'ai décompressé le .zip et dedans il y a un fichier inconnu de 5 Mo.
à mettre dans une clé usb tel un iso ? Je suis perdue.

Edit, le retour de lspci -nnk pour beta-pictoris.

00:00.0 Host bridge [0600]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register [8086:0f00] (rev 0f)
  Subsystem: ASUSTeK Computer Inc. Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register [1043:18cd]
  Kernel driver in use: iosf_mbi_pci
00:02.0 VGA compatible controller [0300]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display [8086:0f31] (rev 0f)
  Subsystem: ASUSTeK Computer Inc. Atom Processor Z36xxx/Z37xxx Series Graphics & Display [1043:18cd]
  Kernel driver in use: i915
  Kernel modules: i915
00:14.0 USB controller [0c03]: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI [8086:0f35] (rev 0f)
  Subsystem: ASUSTeK Computer Inc. Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI [1043:182d]
  Kernel driver in use: xhci_hcd
  Kernel modules: xhci_pci
00:1a.0 Encryption controller [1080]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine [8086:0f18] (rev 0f)
  Subsystem: ASUSTeK Computer Inc. Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine [1043:182d]
00:1f.0 ISA bridge [0601]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit [8086:0f1c] (rev 0f)
  Subsystem: ASUSTeK Computer Inc. Atom Processor Z36xxx/Z37xxx Series Power Control Unit [1043:182d]
  Kernel driver in use: lpc_ich
  Kernel modules: lpc_ich

#6 Re : Matériel » [Abandon] Grésillements avec la prise jack » 10-01-2021 14:23:16

Jpt, je ne connaissais pas ce mot, chez moi on dit un teuteu.
Je me coucherais moins idiote cette nuit smile

#7 Re : Matériel » [Abandon] Grésillements avec la prise jack » 09-01-2021 23:24:04

Je remets un paste pour le dmesg i2c ?
Je ne sais même pas pourquoi il a expiré, je regarderai mieux pour le prochain ?

C'est quoi un bitoniau ?

#8 Re : Matériel » [Abandon] Grésillements avec la prise jack » 08-01-2021 21:11:46

alsamixer
Capture-d-cran-2021-01-08-21-07-16.png

Le retour de lspci -nnk |grep -iA3 audio est vide, c'est pas très normal ?

J'ai testé en ligne de commande avec cvlc en tty2 avant de me logger, grissellement toujours d'actualité (avec mes 2 casques)...
Pour l'hdmi j'ai pas d'écran avec HP intégrés, ni de casque bluetooth...

#9 Re : Matériel » [Abandon] Grésillements avec la prise jack » 07-01-2021 21:15:45

Tyzef, j'essaie Puppy ce week-end quand j'aurais du temps devant moi.
Oui j'ai 2 casques, mais le problème est identique avec les 2, et même avec mon petit système 2.1

Pour l'histoire des prises et côtes, j'ai essayé en retirant doucement mais rien ne change, ça grésille, et quand la prise est trop retirée, plus de son au casque..
Je pense que c'est peine perdue pour ce petit pc.

#10 Re : Matériel » [Abandon] Grésillements avec la prise jack » 07-01-2021 11:01:07

Coucou.

Blacklistage du module hdmi via le fichier de conf de grub effectué, mais le son grésille autant au casque (en essayant comme depuis le début, via audacious, vlc, firefox)..
J'ai vérifié avec lsmod, plus rien en rapport avec l'hdmi.

Pour syslog.log, et kern.log, quand je checke avec tail -f, pas de remplissage rapide (juste une erreur récurrente par rapport au module wifi, erreur qui se retrouve aussi avec journalctl, et dmesg).
Pour dmesg -w, c'est le calme plat, aucun message d'alerte ou autre qui défile.

#11 Re : Matériel » [Abandon] Grésillements avec la prise jack » 06-01-2021 09:35:20

Quand je fais la commande, on me dit

modprobe: FATAL: Module snd_hdmi_lpe_audio is in use.



Ha mais je suis nouille, les log sont inaccessibles parce que j'ai la mauvaise habitude de mettre /var/log en tmpfs quand le disque est petit (je sais, très mauvaise façon de faire)

#12 Re : Matériel » [Abandon] Grésillements avec la prise jack » 05-01-2021 10:15:54

Re,

Efpé, même si le pc meurt sous peu, j'aurais eu le réflexe de tenter de lui donner une 2e vie.

Tyzef, ce soir j'essaie puppylinux.

beta-pictoris, le retour de pactl list cards

Carte #0
  Nom : alsa_card.pci-0000_00_02.0-platform-hdmi-lpe-audio
  Pilote : module-alsa-card.c
  Module propriétaire : 6
  Propriétés :
    alsa.card = "1"
    alsa.card_name = "Intel HDMI/DP LPE Audio"
    alsa.long_card_name = "Intel HDMI/DP LPE Audio"
    alsa.driver_name = "snd_hdmi_lpe_audio"
    device.bus_path = "pci-0000:00:02.0-platform-hdmi-lpe-audio"
    sysfs.path = "/devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card1"
    device.bus = "pci"
    device.vendor.id = "8086"
    device.vendor.name = "Intel Corporation"
    device.product.id = "0f31"
    device.product.name = "Atom Processor Z36xxx/Z37xxx Series Graphics & Display"
    device.string = "1"
    device.description = "Atom Processor Z36xxx/Z37xxx Series Graphics & Display"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card-pci"
  Profils :
    output:hdmi-stereo: Sortie Digital Stereo (HDMI) (sinks: 1, sources: 0, priority: 5900, available: non)
    output:hdmi-surround: Sortie Digital Surround 5.1 (HDMI) (sinks: 1, sources: 0, priority: 800, available: non)
    output:hdmi-surround71: Sortie Digital Surround 7.1 (HDMI) (sinks: 1, sources: 0, priority: 800, available: non)
    output:hdmi-stereo-extra1: Sortie Digital Stereo (HDMI 2) (sinks: 1, sources: 0, priority: 5700, available: non)
    output:hdmi-surround-extra1: Sortie Digital Surround 5.1 (HDMI 2) (sinks: 1, sources: 0, priority: 600, available: non)
    output:hdmi-surround71-extra1: Sortie Digital Surround 7.1 (HDMI 2) (sinks: 1, sources: 0, priority: 600, available: non)
    off: Éteint (sinks: 0, sources: 0, priority: 0, available: oui)
  Profil actif : off
  Ports :
    hdmi-output-0: HDMI / DisplayPort (priority: 5900, latency offset: 0 usec, not available)
      Propriétés :
        device.icon_name = "video-display"
      Partie du(des) profil(s) : output:hdmi-stereo, output:hdmi-surround, output:hdmi-surround71
    hdmi-output-1: HDMI / DisplayPort 2 (priority: 5800, latency offset: 0 usec, not available)
      Propriétés :
        device.icon_name = "video-display"
      Partie du(des) profil(s) : output:hdmi-stereo-extra1, output:hdmi-surround-extra1, output:hdmi-surround71-extra1

Carte #1
  Nom : alsa_card.platform-cht-bsw-rt5645
  Pilote : module-alsa-card.c
  Module propriétaire : 7
  Propriétés :
    alsa.card = "0"
    alsa.card_name = "chtrt5645"
    alsa.long_card_name = "ASUSTeKCOMPUTERINC.-X205TA-1.0"
    alsa.driver_name = "snd_soc_sst_cht_bsw_rt5645"
    device.bus_path = "platform-cht-bsw-rt5645"
    sysfs.path = "/devices/platform/80860F28:00/cht-bsw-rt5645/sound/card0"
    device.form_factor = "internal"
    device.string = "0"
    device.description = "Audio interne"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card"
  Profils :
    HiFi: Default (sinks: 1, sources: 1, priority: 8000, available: oui)
    off: Éteint (sinks: 0, sources: 0, priority: 0, available: oui)
  Profil actif : HiFi
  Ports :
    [Out] Headphones: Headphones (priority: 200, latency offset: 0 usec, not available)
      Partie du(des) profil(s) : HiFi
    [Out] Speaker: Speaker (priority: 100, latency offset: 0 usec)
      Partie du(des) profil(s) : HiFi
    [In] Headset: Headset Microphone (priority: 200, latency offset: 0 usec, not available)
      Partie du(des) profil(s) : HiFi
    [In] Mic: Internal Analog Microphone (priority: 100, latency offset: 0 usec)
      Partie du(des) profil(s) : HiFi



Quand je fais les 2 commandes en root, avec su -
J'ai ce retour

tail: impossible d'ouvrir '/var/log/syslog et kern.log aussi' en lecture: Aucun fichier ou dossier de ce type
tail: aucun fichier restant

#13 Re : Matériel » [Abandon] Grésillements avec la prise jack » 03-01-2021 19:04:46

Re efpé.

En faite les problèmes listés étaient présents sur windows 8.1, d'où le faite que l'ancienne propriétaire a voulu s'en débarrasser.
Mais le grésillement est propre à Linux.

Je vais tester cette histoire de script.

Ha... je pensais avoir dis que j'étais sur Xfce 4.16, mea culpa.
J'ai testé une debian 9 en premier lieu, mais la prise jack est tout bonnement non reconnue, quoi que je branchais dessus, il se passait rien, et pavucontrol me mentionnait une entrée factice...
Et la wifi n'était pas fonctionnelle d'ailleurs.

#14 Re : Matériel » [Abandon] Grésillements avec la prise jack » 03-01-2021 11:13:28

C'est constant, dès que je branche casque ou système 2.1, un petit grésillement apparaît, et dès qu'un son est joué (internet, vidéo avec vlc, audacious, ou molotov) le grésillement devient vraiment audible est désagréable (ça fait un peu le bruit d'un gros coup de vent qui souffle dans les arbres dénudés avec un chrac permanent et qui prend le dessus du son joué)

Et si je bouge la prise jack aucune différence, ni d'effets dans le casque.

#15 Re : Matériel » [Abandon] Grésillements avec la prise jack » 03-01-2021 08:35:26

Dans alsamixer oui j'ai tout coupé pour ne garder que le son des H.P et du casque .

Sur secteur comme sur batterie, ça grésille.
Avec une souris branchée ou sans, ça grésille aussi.

Je viens de faire la manipulation  reboot, mais pas de changements notables en terme d'utilisation cpu (vérifié avec htop), et ça grésille toujours.

#16 Re : Matériel » [clos] Avis sur différents portables pour achat » 02-01-2021 21:45:17

Les Lenovo Thinkpads, et Dell Vostro sont super d'occasion, c'est des pc solides.
Mon thinkpad a chuté du bureau écran ouvert, aucune séquelle.
Mon Vostro est tombé de la table à mangé du balcon après que mon chien (65 kg de muscles) ait glissé sur le carrelage, résultat le pc a rebondit sur la balustrade du balcon et est tombé écran ouvert sur le rail de la porte fenêtre, aucune séquelle à déplorer.

En plus ils ont de bonnes configurations même si ancienne, ils sont gros, lourds, carrés, et un peu moche, mais c'est du bon vieux matériel qu'on ne trouve plus aujourd'hui..

Là j'ai un asus que j'essaye de refaire vivre, autant dire que c'est une sacrée bouse moderne qui vaut rien..

#17 Re : Matériel » [Abandon] Grésillements avec la prise jack » 02-01-2021 21:34:36

Petit état des lieux.
Fedora 33 kernel 5.8, son aux haut parleurs ok, mais grésillements avec la prise jack.
Manjaro, kernel 5.10, son aux haut parleurs ok, mais grésillements avec la prise jack.
Ubuntu 20.04, je n'ai pas réussi à démarrer le live usb...

Ce qui devient inquiétant, c'est que sur 4 distributions, 3 ont le soucis de grésillements quand même..

Soit c'est logiciel, soit matériel..

J'ai réduis la partition de debian en vue de réinstaller le windows 8.1 bing natif, mais une fois sur l'iso de windows, le touchpad, clavier ne fonctionnent pas, et les ports usb sont inopérants..
Je doute de plus en plus sur l'état de santé matériel de ce petit pc, ça expliquerait aussi les touches du clavier très lente lors de la frappe, les ports usb fonctionnels une fois sur deux, la lenteur complète du pc, le touchpad au contrôle hasardeux, et la batterie qui se vide vitesse grand V, ou qui passe brutalement de 96% à 70%, ou qui se vide même pc éteint..

Mon but était de lui offrir une 2e vie, mais ça sent le sapin un peu..

#18 Re : Matériel » [Abandon] Grésillements avec la prise jack » 02-01-2021 15:00:56

Y a donc moyen de faire quelque chose avec ce fichier de conf
https://github.com/plbossart/UCM/blob/m … /HiFi.conf ?
Si oui ça serait a placer où exactement ?

Pas dans /usr/share/alsa/ucm/chtrt5645/chtrt5645.conf je suppose ?

Ce soir en rentrant du taf, je m'occupe de télécharger les iso live de Ubuntu, Manjaro, et Fedora, et je teste pour voir si ce problème de grésillement existe aussi.

#19 Re : Matériel » [Abandon] Grésillements avec la prise jack » 02-01-2021 10:19:03

Efpé, en effet je n'avais pas vu ce soucis d'IRQ.
Tu as raison, Je vais tester ubuntu en live, puis dans la foulée manjaro et fedora, ça permettra d'avoir des bases pour faire un diagnostic, par contre avec cet uefi hybride, ça va être compliqué de réussir à démarrer sur les lives hmm

Kawer, sur ce pc le problème de grésillement à la prise jack n'existait pas sous windows 8, l'ancienne propriétaire me l'a confirmé.
Mais comme je dis à efpé, je vais tester plusieurs familles de distributions linux, ça me permettra d'avoir plusieurs expériences.
Et si le problème vient de debian (ce qui serait dommage, j'aime bien cette distribution) alors j'en installerais une autre.

Macisa, l'uefi est en 32 bits, mais le cpu en 64 bits, un uefi bâtard, mal foutu et inutile qui emmerde le monde, probablement une volonté de brider ces petits pc..

#20 Re : Matériel » [Abandon] Grésillements avec la prise jack » 01-01-2021 20:42:00

j'ai fais le pastebinit complet de dmesg

https://paste.debian.net/1179300/

à partir de la ligne 645 il y a des "call traces", des points d'interrogation, mais je suis nulle pour interprétée les messages !

#21 Re : Matériel » [Abandon] Grésillements avec la prise jack » 01-01-2021 11:35:59

Efpé en effet le quirck ne change rien..

Et le module i2c concerne bien le touchpad Elan, je viens de vérifier..

#22 Re : Matériel » [Abandon] Grésillements avec la prise jack » 01-01-2021 09:50:13

Hello, et bonne année et surtout la santé à tous.

Croûtons, le résultat je l'ai déjà posté hier soir comme demandé, du coup je remets le lien.
http://alsa-project.org/db/?f=5e733d3b7 … 3429bc720e

#23 Re : Matériel » [Abandon] Grésillements avec la prise jack » 31-12-2020 22:02:02

macisa, l'uefi est en 32 bits mais le CPU supporte du 64 bits sans soucis.

Pour les soucis de grésillement certes ce n'est pas important, ni essentiel, mais bien pratique pour écouter de la musique tranquillement dans notre bulle sans être dérangé par les bruits extérieurs, surtout pour un notebook transportable.

Vu que sous Windows 8 ça ne grésillait pas, le soucis vient probablement du driver Linux.

#25 Re : Matériel » [Abandon] Grésillements avec la prise jack » 31-12-2020 18:28:26

croûtons, le retour de lsmod |grep snd_hdmi_lpe_audio me donne ceci

snd_hdmi_lpe_audio     32768  1
snd_pcm               135168  6 snd_compress,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_soc_rt5645,snd_soc_sst_cht_bsw_rt5645
snd                   110592  12 snd_timer,snd_compress,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm



j'ai essayé avec moprobe -r de désactiver le module, mais impossible, modprobe: FATAL: Module snd_hdmi_lpe_audio is in use.

macisa, j'ai déjà lu tous ces liens, mais ça ne m'a pas aidé hélas hmm

Pied de page des forums

Propulsé par FluxBB