Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Multimédia » Configuration ALSA 5.1 et vidéos internet » 07-05-2011 13:06:26

spz
Re

Désolé, mais avec ton lien, je n'ai pas de 5.1 quand je lis un film/musique sous Linux, mais j'ai du son sous Youtube.

Comment faire pour trouver la bonne configuration entre son youtube et 5.1 sous Linux ?

#2 Re : Multimédia » Configuration ALSA 5.1 et vidéos internet » 07-05-2011 00:45:34

spz
Bonsoir Darien

Merci pour ton lien, maintenant j'ai du son sur Youtube ET sur Linux smile. Mais bon, ce n'est pas en 5.1, mais c'est mieux que rien smile.

Je vais chercher sur le net pour voir si c'est possible, si je ne trouve pas c'est pas grave, l'essentiel est d'avoir du son wink je vous tiendrai au courant, promis.

@+

#3 Multimédia » Configuration ALSA 5.1 et vidéos internet » 05-05-2011 08:20:16

spz
Réponses : 5
Bonjour à tous,

Suite au topic concernant flashplayer (résolu ICI), il s'avère que cela ne venait pas de lui (les sites en flash s'affichent très bien).

En effet, j'ai configuré ALSA en 5.1 pour pouvoir regarder des films et écouter de la musique en 5.1 sous Linux. Cependant, lorsque je veux visionner une vidéo sur internet (Youtube, Dailymotion...) je n'ai pas du tout de son (je rappelle que j'utilise Iceweasel, c'est pareil avec Epiphany).

En configurant ALSA de manière très basique (c'est-à-dire du son en 2.0), j'arrive à avoir du son sur les vidéos internet (mais en 2.0), ce qui est très gênant.

Avez-vous donc une solution pour avoir du son en 5.1 sous Linux ET sous Youtube/Dailymotion/etc... ?

Voici ma conf dans /etc/asound.conf :

pcm.duplicate {
        type plug
        slave.pcm "surround51"
        slave.channels 6
        route_policy duplicate
}

#Ce qu'il y avait dans .asoundrc

ctl.ca0106 {
type hw
card 0
}

pcm.!default {
slave.pcm surround51
slave.channels 6
type route
ttable.0.0 1
ttable.1.1 1
ttable.0.2 1
ttable.1.3 1
ttable.0.4 0.5
ttable.1.4 0.5
ttable.0.5 0.5
ttable.1.5 0.5
}


Et dans /proc/asound/cards :

# cat /proc/asound/cards
 0 [CA0106         ]: CA0106 - CA0106
                      Audigy SE [SB0570] at 0xe880 irq 18
 2 [U0x46d0x9a2    ]: USB-Audio - USB Device 0x46d:0x9a2
                      USB Device 0x46d:0x9a2 at usb-0000:00:1a.7-4, high speed
 3 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe8fc000 irq 17


Merci smile

#4 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 05-05-2011 08:13:46

spz
Bonjour,

Ok Darien, merci d'avoir pris du temps pour m'aider, c'est cool wink

Pour Alsa je vais créer un nouveau topic ^^

Problème avec Flashplayer résolu.

#5 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 04-05-2011 20:21:13

spz
En fait, soit j'ai du son sur youtube et pas de son 5.1 sous Linux, soit j'ia du son 5.1 sous Linux et j'ai pas de son sur Youtube x_x.

#6 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 04-05-2011 19:56:32

spz
J'ai suivi ton lien, j'ai désactivé la carte son intégrée à ma CM et modifié l'ordre dans alsa-base.conf, mais hélas, toujours pas de son sur Youtube quand Alsa est configuré en 5.1 <.<

#7 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 04-05-2011 19:14:50

spz
J'ai trouvé ! cela venait du fichier .asoundrc dans mon /home, je l'ai déplacé et maintenant j'ai du son sous Youtube/Dailymotion etc...

Cependant, je n'ai plus le son en 5.1 >_<, dès que je veux mettre le 5.1, hop plus de son sur Youtube, voici le contenu de mon fichier /etc/asound.conf :

pcm.duplicate {
        type plug
        slave.pcm "surround51"
        slave.channels 6
        route_policy duplicate
}
#Ce qu'il y avait dans .asoundrc
ctl.ca0106 {
type hw
card 0
}

pcm.!default {
slave.pcm surround51
slave.channels 6
type route
ttable.0.0 1
ttable.1.1 1
ttable.0.2 1
ttable.1.3 1
ttable.0.4 0.5
ttable.1.4 0.5
ttable.0.5 0.5
ttable.1.5 0.5
}


Et le contenu de /proc/asound/cards :

# cat /proc/asound/cards
 0 [CA0106         ]: CA0106 - CA0106
                      Audigy SE [SB0570] at 0xe880 irq 18
 1 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe7f8000 irq 22
 2 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe8fc000 irq 17
 3 [U0x46d0x9a2    ]: USB-Audio - USB Device 0x46d:0x9a2
                      USB Device 0x46d:0x9a2 at usb-0000:00:1a.7-4, high speed


Merci de m'aider smile

#8 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 04-05-2011 17:54:27

spz
Alors, j'ai essayé la méthode de Quazaban, avec Firefox 64 bits téléchargé depuis le ftp de Mozilla, et c'est toujours pareil.

Je me suis demandé à un moment, est-ce que Iceweasel/Firefox utilise par défaut Pulse au lieu de Alsa, en sachant que :

dpkg -l |grep pulse
ii  libpulse-mainloop-glib0              0.9.21-3+squeeze1                 PulseAudio client libraries (glib support)
ii  libpulse0                            0.9.21-3+squeeze1                 PulseAudio client libraries
ii  vlc-plugin-pulse                     1.1.3-1squeeze5                   PulseAudio plugin for VLC


Edit : Mon hypothèse se vérifie :

http://img822.imageshack.us/i/flashv.png

(D'après le site http://kb2.adobe.com/cps/155/tn_15507.html )

#9 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 04-05-2011 15:02:50

spz

Darien a écrit :

spz a écrit :

npwrapper.libflashplayer.so a été mis en place quand j'ai installé avec les paquets flashplayer-mozilla et nspluginwrapper, donc c'est normal.


D'accord, c'est normal. J'aimerais seulement savoir pourquoi tu es obligé d'utiliser nspluginwrapper, c'est tout.
Est-ce que, maintenant, ça marche comme il faut avec npwrapper.libflashplayer.so ?


nspluginwrapper faisait parti des dépendances en installant flashplayer-mozilla wink et non ça ne fonctionne toujours pas.

@Quazaban : Si tu parles du Firefox authentique (et non le fork Iceweasel) non je n'ai pas tenté, j’essaierai ça ce soir wink

#10 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 04-05-2011 10:28:09

spz
npwrapper.libflashplayer.so a été mis en place quand j'ai installé avec les paquets flashplayer-mozilla et nspluginwrapper, donc c'est normal. Ta manip permet carrément de le virer ^^

#11 Re : Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 04-05-2011 07:55:18

spz
Bonjour à vous

Merci pour vos réponses smile ça fait plaisir

@smolski : Je modifierai mon profil promis wink

@Darien : J'ai essayé Midori et c'est pareil voire pire, pas de son et les vidéos saccades un peu. Pour le paquet flashplayer-mozilla, j'ai aussi éradiqué le plugin d'adobe (flashplugin-nonfree) avant de l'installer.

Je vous poste mon about:plugins sous Iceweasel (avec flashplayer-mozilla d'installer) :

http://imageshack.us/photo/my-images/85 … ginsi.png/

Merci smile

#12 Multimédia » [Résolu] Prob Flashplayer sous Debian Squeeze 64 bits » 03-05-2011 22:50:15

spz
Réponses : 21
Bonsoir

Je viens d'installer une Debian Squeeze 64 bits sur mon ordi, tout fonctionne bien (son 5.1 avec Alsa, etc...).

Cependant je rencontre un problème avec Flash 64 bits, je n'ai pas de son sur les vidéos Youtube/Dailymotion/jeuxvideo.com etc...

J'ai regardé les tutos sur internet, j'ai installe le paquet flashplugin-nonfree, mais y a rien à faire, toujours pas de son sad J'ai essayé aussi de placer le fichier libflashplayer.so dans /usr/lib/mozilla/plugins et ~/.mozilla/plugins, en vain. J'ai essayé la méthode avec nspluginwrapper, et je n'y arrive pas :s

En installant le paquet mozilla-plugin-gnash et browser-plugin-gnash, j'obtiens bien le son sur Youtube, mais je n'ai aucune vidéo sur jeuxvideo.com >.<

Puis, j'ai essayé le paquet flashplayer-mozilla à partir des dépôts Testing debian-multimedia (en prenant soin de bien désinstaller les paquets gnash) et c'est toujours pareil !

J'utilise comme navigateur Iceweasel 4.0.1

Merci de me venir en aide smile

Bien à vous.
spz

#13 Matériel » Pas de son 5.1 sous Lenny » 30-12-2010 20:59:17

spz
Réponses : 3
Bonjour,

Je viens d'installer une Debian Lenny 64 bits, je possède comme carte son une Sound Blaster Audigy LS (CA0106), seulement voilà, je n'arrive pas à avoir le son en 5.1 :s

Voici mon lspci :

05:02.0 Multimedia audio controller: Creative Labs SB Audigy LS

Merci de bien vouloir me guider pas à pas pour obtenir du son en 5.1 smile

Cordialement.

Pied de page des forums

Propulsé par FluxBB