Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Matériel » clés USB montées automatiquement en root seulement [RESOLU] » 07-01-2014 19:22:15

waouh, c'est de la compet !!
C'est vrai qu'on est pas toujours très rigoureux sur les forums, mais il faut pas mal de points pour pouvoir boulotter un peu de choco !

#2 Re : Matériel » clés USB montées automatiquement en root seulement [RESOLU] » 07-01-2014 18:39:07

fidèle à la philosophie de bendia, c'est quoi cette histoire de chocolat ??

Moi aussi j'aime le chocolat.

#3 Re : Matériel » clés USB montées automatiquement en root seulement [RESOLU] » 07-01-2014 00:17:42

Je pense avoir réglé mon problème mais je ne sais pas encore ce qui a été le remède, je m'explique :

- J'ai suivi les recommandations de Paskal à la lettre mais sans effet. J'ai fait les modifs de façon progressives, les plus pertinentes d'abord puis de plus en plus large. Cependant je remarque que les clés apparaissent toujours sous deux icones donc là je me souviens que je n'ai pas encore retiré usbmount et pmount.

- je me prépare à retirer usbmount et ses dépendances et par habitude je fais d'abord 'aptitude update' et 'upgrade' et là je vois passer update udev. Bref j'enlève ensuite usbmount, redémarre et les clés sont lues correctement (en fat ou ext3).
le log de aptitude :

7 paquets vont être installés, et 0 retirés.
158 ko d'espace disque vont être libérés
===============================================================================
[MIS A JOUR] fonts-gfs-theokritos:amd64 1.1-4 -> 1.1-5
[MIS A JOUR] libgudev-1.0-0:amd64 204-5 -> 204-6
[MIS A JOUR] libsystemd-login0:amd64 204-5 -> 204-6
[MIS A JOUR] libudev1:amd64 204-5 -> 204-6
[MIS A JOUR] manpages-fr-extra:amd64 20131201 -> 20131231
[MIS A JOUR] udev:amd64 204-5 -> 204-6
[MIS A JOUR] whois:amd64 5.0.26 -> 5.1.0
===============================================================================
 



- du coup j'essaie de revenir sur mon org.freedesktop.udisks2.policy d'origine pour vérifier l'origine du dépannage mais même avec le fichier de départ ça fonctionne.

J'ai tendance à penser que la mise à jour à solutionner le problème. Pour le vérifier, je demande à ma fille de faire cette modif sur le notebook (xfce4), d'abord la mise à jour puis éventuellement les modifs de fichiers si nécéssaire (en espérant que les màj sont équivalentes pour des machines assez différentes ACER x386 et ASUS x86_64).
Je vous tiens au courant.
En attendant, merci à tous pour votre aide, debian-facile porte bien son nom !
Yagermoe, je vais suivre tes recommandations et compléter mon profil.
Bonne nuit.

#4 Re : Matériel » clés USB montées automatiquement en root seulement [RESOLU] » 06-01-2014 19:12:49

Merci à tous pour vos réponses.

Polkit me fait un peu peur, je vais tenter de regarder ça pour la première fois mais j'ai le sentiment que c'est un vaste chantier. Une suggestion pour y entrer ?

Du coté du fstab, effectivement il y avait deux lignes correspondant à ma clé usb d'install générée par dd et l'image netinstall de jessie, je les ai déjà supprimées mais sans résultat. En l'état actuel, mon fstab ne comporte que les lignes du disque dur. (je ne suis pas sur ma machine)

Cordialement.

#5 Re : Matériel » clés USB montées automatiquement en root seulement [RESOLU] » 05-01-2014 22:30:40

Bonsoir,

merci pour ta réponse. A l'origine usbmount n'était pas présent je l'ai installé pour essayer de débloquer mais en vain.
Je regarde du coté des udisks.
A+

#6 Matériel » clés USB montées automatiquement en root seulement [RESOLU] » 05-01-2014 22:20:46

zentrobo
Réponses : 23
Bonjour,

j'ai fait deux install de debian jessie :

- la première sur un portable asus core i3 en mode minimaliste : openbox à partir du netinst,
- la deuxième sur un netbook acer avec xfce4.

Dans les deux cas, j'ai le même problème : montage automatique des clés usb quelque soit le format (ext4 ou fat16) mais pour root, donc pas d'écriture.
J'utilise Debian depuis pas mal d'années et je n'avais jamais eu ce problème.
J'ai suivi pas mal de post, fait de nombreuses manip mais rien à faire. Sur les machines j'ai bien gvfs, fuse, usbmount, sous xfce thunar + thunar-volman, j'ai également changé les droits des dossiers /media/usb... mais rien à faire.
J'ai aussi modifié le fstab pour qu'il n'y ait plus aucune entrée relative au clé, même résultat.
J'en suis à me demander s'il n'y aurait pas une bidouille dans la dernière testing. Je n'ai pas essayé les versions sous gnome ou KDE mais comme je ne rencontrais pas ce pb auparavant (sous wheeze) ...
Si quelqu'un veut bien me suggérer quelque chose.
Désolé de poster un Xème post sur ce thème mais aucune des solutions évoquées par ailleurs ne m'a secouru, j'ai besoin d'aide.
Merci.

Pied de page des forums

Propulsé par FluxBB