Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Installation de Debian » Ordinateur portable qui ne s'éteind pas. » Hier 12:04:42

Bonjour laguespa,

laguespa a écrit :

Pas d'idée pour ce portable qui ne s'éteint pas ?


Quel modèle ce portable ? quoi qu'il en soit installer le paquet acpi-support ne paraît pas déconnant.

#2 Re : Réseau » Pas de détection wifi sous Debian GNU/Linux 10 (buster) [Résolu] » 12-10-2019 21:58:42

Bonsoir Diamant40,

Diamant40 a écrit :

lspci -nnkd ::0280

02:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59)
        Subsystem: Intel Corporation Dual Band Wireless-AC 7265 [8086:5110]
        Kernel modules: iwlwifi

dmesg | grep firmw

[    4.416718] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-29.ucode (-2)
[    4.416781] ...
[    4.416849] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-29.ucode failed with error -2


Il te suffit d'installer le paquet firmware-iwlwifi (firmware-linux-nonfree non justifié), puis redémarrer.

#3 Re : Matériel » [Résolu] Installation imprimante canon MG550 » 11-10-2019 21:56:42

Bonsoir mo260842,

mo260842 a écrit :

lsusb -d 04a9:

Bus 003 Device 002: ID 04a9:1771 Canon, Inc.


Tu disposes d'une prise en charge : complète de la numérisation et expérimentale de l'impression...

apt install libsane printer-driver-gutenprint


/usr/sbin/lpinfo --make-and-model "MG5500" -m


Concernant CUPS tu n'es pas obligé de chercher les difficultés : system-config-printer fait le boulot.

#4 Re : Réseau » Pas de détection wifi sous Debian GNU/Linux 10 (buster) [Résolu] » 11-10-2019 19:18:42

Bonsoir Diamant40,

Diamant40 a écrit :

J'ai vu sur le forum que c'est un problème récurrent, mais avec des solutions difficiles à appliquer pour moi.


Le coup du firmware non libre manquant est effectivement un grand classique... pas insurmontable !

lspci -nnkd ::0280

dmesg | grep firmw


Ces retours permettront, avant toute chose, d'identifier le matériel et l'éventuel firmware manquant.

#5 Re : Matériel » Imprimante Epson XP-435 » 07-10-2019 14:48:42

Bonjour Kryzo,

Kryzo a écrit :

Une idée de où je peux trouver ce paquet [lsb] ?


Dans le dépôt principal de la distribution Debian 8 (ce paquet binaire n'existe plus depuis Debian 9).

Deux possibilités : (1), reconstruire le paquet Epson, ou (2), installer le paquet printer-driver-escpr.

apt install printer-driver-escpr


Le paquet printer-driver-escpr du dépôt buster est en version 1.6.33, tu vérifies la prise en charge :

/usr/sbin/lpinfo --make-and-model "435 Series" -m

escpr:0/cups/model/epson-inkjet-printer-escpr/Epson-XP-432_435_Series-epson-escpr-en.ppd EPSON XP-432 435 Series , Epson Inkjet Printer Driver (ESC/P-R) for Linux


Donc cela devrait être bon... pour la partie impression. Pour la partie scanner, avec SANE c'est mort.

#6 Re : Installation de Debian » [Résolu] Wifi ne fonctionne pas » 07-10-2019 10:41:42

Bonjour mo260842,

mo260842 a écrit :

cat /etc/apt/sources.list

deb-src http://ftp.fr.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main contrib
deb-src http://security.debian.org/debian-security buster/updates main contrib

# buster-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ buster-updates main contrib
deb-src http://ftp.fr.debian.org/debian/ buster-updates main contrib


La fée du logis a effectivement quelques dégâts à son actif... il te manque le dépôt binaire principal...

nano /etc/apt/sources.list

# Debian Buster, dépôt principal + paquets non libres
deb http://ftp.fr.debian.org/debian/ buster main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ buster main contrib non-free
     
# Debian Buster, mises à jour de sécurité + paquets non libres
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
     
# Debian Buster, mises à jour "volatiles" + paquets non libres
deb http://ftp.fr.debian.org/debian/ buster-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ buster-updates main contrib non-free


Ce sources.list, basé sur le tien, conviendrait déjà nettement mieux. Pour nano tu as le tuto du wiki.

Comme l'a souligné chalu sur un autre fil, en profiter pour apprendre à utiliser nano est intéressant.
On pourrait pinailler des heures, à propos de, deb-src ou pas, deb.debian.org ou pas, https ou pas.

#7 Re : Gestion des paquets Debian » non-free firware pour mac mini 2.1 (environs 2012) » 06-10-2019 10:39:42

Re-,

crap0 a écrit :

lspci -nnkd ::0280

02:00.0 Network controller [0280]: Broadcom Limited BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)
        Subsystem: Apple Inc. AirPort Extreme [106b:010e]
        Kernel driver in use: wl
        Kernel modules: bcma, wl


Pour le Wi-Fi tu n'as pas installé de firmware. wl : pilote propriétaire fourni par broadcom-sta-dkms.

crap0 a écrit :

dmesg | grep firmw

[    0.030820] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    5.666274] b43 bcma0:1: firmware: failed to load b43/ucode29_mimo.fw (-2)
[    5.666317] b43 bcma0:1: Direct firmware load for b43/ucode29_mimo.fw failed with error -2
...
[    5.666384] b43 bcma0:1: firmware: failed to load b43-open/ucode29_mimo.fw (-2)
[    5.666422] b43 bcma0:1: Direct firmware load for b43-open/ucode29_mimo.fw failed with error -2
...


Vois-tu autre chose qu'une demande de firmware pour le pilote b43, censément blacklisté d'ailleurs ?

#8 Re : Matériel » problème adaptateur graphique sur lenovo x395 » 05-10-2019 18:39:42

Bonjour hypnolux,

hypnolux a écrit :

Mais je n'ai droit qu'au mode texte. Que dois-je faire ?


Identifier et installer un firmware non libre manquant, très probablement... Dans une console texte :

dmesg | grep firmware


Permettra d'identifier le(s) firmware(s) manquant(s) ; puis installer firmware-amd-graphics si "Vega".
Alternative, en mode bourrin : installer le méta-paquet firmware-linux-nonfree, et réfléchir plus tard.

#9 Re : Installation de Debian » [Résolu] Wifi ne fonctionne pas » 05-10-2019 17:51:33

Re-,

mo260842 a écrit :

apt-cache search rtl8192sefw.bin

la commande n’affiche rien


L'installation d'un firmware non libre, implique l'ajout de la section non-free aux sources de paquets.

#10 Re : Réseau » problème connexion wifi » 05-10-2019 16:33:51

Re-,

Ayla a écrit :

nmcli device wifi connect 'NomDuReseau' password 'CleDeChiffrement'

Erreur : le délai d'attente de 90 sec a expiré.


La même erreur qu'il y a deux ans donc ! Il ne faut pas oublier que le problème peut venir de la box.

tr -dc [:xdigit:] < /dev/urandom | head -c 64 | xargs


Cette commande génère une chaîne de 64 chiffres hexadécimaux. Essaie de remplacer la clé actuelle.

#11 Re : Réseau » problème connexion wifi » 05-10-2019 15:13:42

Salut Ayla,

Ayla a écrit :

nmcli device connect wls1

Erreur : échec de l'activation de la connexion : (7) Des secrets étaient requis, mais aucun n'a été fourni.


Il semblerait que NetworkManager n'ait pas connaissance du mot de passe. Il est légitime de tenter :

nmcli device wifi connect 'NomDuReseau' password 'CleDeChiffrement'


L'utilisation de guillemets simples a pour finalité de se protéger des espaces et caractères exotiques.

#12 Re : Installation de Debian » [Résolu] Wifi ne fonctionne pas » 05-10-2019 10:29:42

Bonjour mo260842,

mo260842 a écrit :

lspci -nnkd ::0280

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8191SEvA Wireless LAN Controller [10ec:8171] (rev 10)
        Subsystem: Hewlett-Packard Company RTL8191SEvA Wireless LAN Controller [103c:1467]
        Kernel driver in use: rtl8192se
        Kernel modules: rtl8192se


Le noyau Linux fournit un pilote, l'étape suivante consiste à identifier l'éventuel firmware manquant :

#identifier le firmware manquant
dmesg | grep firmware


L'installation d'un firmware non libre, implique l'ajout de la section non-free aux sources de paquets.

#chercher quel paquet le fournit
apt-cache search rtl8192sefw.bin

firmware-realtek - Binary firmware for Realtek wired/wifi/BT adapters


#puis installer le fameux paquet
apt install firmware-realtek


En profiter pour installer les autres éventuels firmwares manquants. Le tuto du wiki détaille tout ça.

#13 Re : Réseau » [Contourné] Pas de connexion internet après nouvelle installation » 04-10-2019 10:29:42

Re-,

Harashi a écrit :

(j'ai déroulé tout le résultat en appuyant sur entrée)


La barre d'espace le fait bien aussi ; l'intérêt d'un "pager" est que l'intégralité des lignes est affichée.
Le retour n'est pas exploitable : on voit une déconnexion, mais pas de tentative d'authentification...

Harashi a écrit :

Effectivement ifup fonctionne, j'écris en ce moment en étant connecté avec. [...] Le problème étant que ce n'est pas très souple pour se connecter à un réseau public type eduspot.


Tout est possible mais il faut reconnaître que cela se corse un peu (scripter des trucs, des machins).

Harashi a écrit :

Et que cela implique-t-il ?


Que ça plante à la maison... Par contre je lis qu'eduroam fait effectivement appel à la norme 802.1X.

Harashi a écrit :

Du coup, le problème serait dû à Debian Buster ou bien à ma nouvelle carte Wi-Fi ?


Nous savons que la carte Wi-Fi fonctionne très correctement, avec l'installateur Debian, et avec ifup.
Et comme écrit précédemment, d'autres utilisateurs ont rencontré cette erreur sous Debian Stretch.

Harashi a écrit :

Peut-être puis-je tenter de faire fonctionner un système live avec un bureau utilisant NetworkManager pour voir ce que ça donne ?


Bonne idée. D'autant plus simple à mettre en œuvre que le pilote ath9k ne requiert pas de firmware.

#14 Re : Gestion des paquets Debian » non-free firware pour mac mini 2.1 (environs 2012) » 03-10-2019 20:39:42

Bonsoir crap0,

crap0 a écrit :

Grosso modo, j'en suis là.


Tu as brûlé quelques étapes... commencer par identifier le matériel et l'éventuel firmware manquant :

lspci -nnkd ::0280

dmesg | grep firmw


Il y a effectivement un petit tuto qui traîne sur le wiki. Note que tu as déjà ouvert un fil sur le sujet !

#15 Re : Réseau » [Contourné] Pas de connexion internet après nouvelle installation » 02-10-2019 22:05:42

Bonsoir Harashi,

Harashi a écrit :

nmcli device wifi connect <NomDeMaBox>-5GHz password <MonMotDePasse>

Erreur : échec de l'activation de la connexion : (10) Échec du supplicant 802.1X.


Pas cool cette erreur (la même que celle remontée par Ayla et Zelia... sous Debian 9), que retourne :

systemctl status wpa_supplicant | more


Perso je ne sais pas reproduire l'erreur. Si redémarrer le service ne servait à rien, je passerais à ifup.
Quoi qu'il en soit 802.1X me semble faire référence au WPA-Enterprise (EAP), pas au WPA-Personal.

nano /etc/network/interfaces

auto lo
iface lo inet loopback

auto enp9s0
iface enp9s0 inet dhcp

auto wlp12s0
iface wlp12s0 inet dhcp
wpa-ssid "SSID"
wpa-psk  "PASS"


systemctl stop connman network-manager

ifup wlp12s0


Harashi a écrit :

Je viens de penser en voyant le code de l'erreur [...], comme ConnMan et NetworkManager utilisent tous les deux wpa_supplicant, est-ce que ces deux profils (<NomDeMaBox>-5GHz et Connexion filaire 1) n'ont pas été créés par wpa_supplicant via ConnMan ?


Non, les profils de connexion vus par nmcli sont les profils de connexion créés par NetworkManager.

ls -l /etc/NetworkManager/system-connections

ls -l /var/lib/connman


Un utilisateur de ConnMan te dira où sont stockés les profils ; wpa_supplicant ne traite que le Wi-Fi.
Note que ConnMan est développé depuis 2008, et n'est, probablement, plus si expérimental que ça.

En dernier recours : Wicd (GTK+) qui te permet de passer de nl80211/cfg80211 à wext (cf. netcfg).

#16 Re : Réseau » [Contourné] Pas de connexion internet après nouvelle installation » 01-10-2019 21:39:42

Re-,

Harashi a écrit :

Et j'ai l'impression que NetworkManager, pour une raison inconnue, pense que le Wi-Fi n'est pas activé (alors qu'il fonctionne – bien que très aléatoirement – avec ConnMan) :


NetworkManager ne pense rien et ton interprétation est erronée, déconnecté n'est pas indisponible :

nmcli r wifi

nmcli d wifi rescan && nmcli d wifi list


Que cela ne fonctionne pas alors que l'installateur Debian s'en est très bien sorti, laisserait perplexe.

#17 Re : Réseau » [Contourné] Pas de connexion internet après nouvelle installation » 01-10-2019 10:23:42

Re-,

Harashi a écrit :

nmcli device wifi connect 'NomDeMaBox' password 'MotDePasse'

Erreur : aucun réseau avec le SSID « NomDeMaBox » trouvé.


Si NetworkManager ne trouve pas le SSID « NomDeMaBox », c'est qu'il n'en a pas la connaissance :

nmcli device wifi list


Affiche les réseaux Wi-Fi vus par NetworkManager. L'interface est créée, et le Wi-Fi est bien activé.

Harashi a écrit :

[...], j'aimerais tout de même réussir à faire tourner NetworkManager [...], et je ne désespère pas de trouver une appliquette pour le gérer en graphique dans le panel.


L'interface officielle est fournie par le paquet network-manager-gnome, tu peux simuler l'installation.

#18 Re : Réseau » [Contourné] Pas de connexion internet après nouvelle installation » 30-09-2019 22:03:42

Re-,

Harashi a écrit :

J'ai toutefois la trace de profils activés sous ConnMan (enfin je suppose), [...]


Non, les profils de connexion vus par nmcli sont les profils de connexion créés par NetworkManager.
Par contre, tu ne nous dis absolument pas comment tu as créé le profil de connexion Wi-Fi. Simple :

nmcli device wifi connect 'SSID' password 'CLÉ_WIFI'


Un nouveau profil sera créé, tu feras le ménage plus tard. Nous savons que la carte fonctionne bien.

#19 Re : Réseau » [Contourné] Pas de connexion internet après nouvelle installation » 29-09-2019 19:21:42

Re-,

Harashi a écrit :

Du coup, je vais tenter d'installer NetworkManager pour voir si cela fonctionne mieux. Pour avoir une interface graphique dans le panel du bas de LXQt, me suffit-il d'installer le paquet network-manager, ou bien faut-il un paquet supplémentaire pour l'interface ?


C'est le paquet network-manager-gnome qu'il faudrait installer... or le bureau LXQt est orienté... Qt.

Harashi a écrit :

Quelle serait la meilleure procédure à suivre pour remplacer ConnMan par NetworkManager (peut-être installer le paquet network-manager, désactiver ConnMan, le désinstaller et activer NetworkManager ? [...]) ?


Il n'y a aucune urgence à désinstaller, arrêter/démarrer et activer/désactiver les services fonctionne.

#20 Re : Réseau » [Contourné] Pas de connexion internet après nouvelle installation » 29-09-2019 17:03:42

Bonjour Harashi,

Harashi a écrit :

J'avais songé à télécharger le paquet de NetworkManager depuis le site de Debian, le transférer sur cet ordi avec une clef USB et l'installer avec apt directement, mais est-ce une bonne idée ?


Désactiver ConnMan, configurer le fichier interfaces et utiliser ifupdown serait une alternative propre.

Un retour sur l'autre fil aurait été sympa. Peux-tu confirmer qu'il s'agit de l'AzureWave AW-NE772 ?

#21 Re : Matériel » [pause]scanner epson ecotank ET-2750 » 29-09-2019 12:39:42

Re-,

matelas 4 a écrit :

[...] mon scanner ne fonctionne toujours pas [...]


Nous savons que tu es effectivement sur Stretch et que les paquets ont été installés, confirmation :

apt list --installed imagescan*


Par contre, je ne vois pas bien ce que vient faire HPLIP dans cette histoire... peux-tu nous montrer :

grep MakeModel /etc/cups/printers.conf


Ainsi, nous saurons également comment est prise en charge la partie impression réseau (ethernet).
Il serait, par ailleurs, très utile de préciser quel(s) logiciel(s) a/ont été testé(s)... Image Scan, autre ?

#22 Re : Matériel » [pause]scanner epson ecotank ET-2750 » 29-09-2019 00:09:41

Re-,

Debian Alain a écrit :

Si tu tiens à utiliser sudo [...]


Ce n'est pas matelas4 qui tient à utiliser sudo mais le script exécuté dans un shell utilisateur simple.

./install.sh


Règle le petit souci remonté au post #29, et pour information le logiciel Epson s'appelle Image Scan.

#23 Re : Matériel » [pause]scanner epson ecotank ET-2750 » 28-09-2019 22:07:42

Re-,

matelas 4 a écrit :

Très franchement, je ne sais pas comment décompacter et installer.


Juste en passant. Attention à télécharger l'archive adaptée (le lien de Debian Alain concerne Buster).

#24 Re : Matériel » [pause]scanner epson ecotank ET-2750 » 28-09-2019 20:13:42

Re-,

matelas 4 a écrit :

Mon imprimante est en courant porteur.


Mais encore ? et tu ne dis toujours pas à quoi le scanner « ne réagit pas », ni ce que tu as installé...

#25 Re : Matériel » [pause]scanner epson ecotank ET-2750 » 28-09-2019 16:49:42

Bonjour matelas 4,

matelas 4 a écrit :

Je me suis acheté une imprimante Epson EcoTank ET-2750, j'arrive à imprimer, mais le scanner ne réagit pas.


Pourrais-tu être un petit peu plus précis et nous dire si le machin est connecté en USB ou en Wi-Fi ?

lsusb -d 04b8:


Le modèle ET-2650 sera pris en charge par Debian 11... Pour l'ET-2750, il y a le pilote constructeur.

Pied de page des forums

Propulsé par FluxBB