Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#2 Autres » VMware, machine virtuelle dans Linux Debian » 20-05-2020 11:27:50

remy.labene
Réponses : 0
Nouveau sujet de discussion suite au tutos d'installation de VMware sur Debian 10.
https://debian-facile.org/atelier:chant … tilisation

#3 Re : Installation de Debian » Debian BUSTER (10) sur MSI GP72 et autres » 18-05-2020 09:26:29

Bien d'accord avec vos remarques, j'ai utilisé $USER, mais j'aurai du mettre "lambda" pour être plus clair. En se qui concerne les partitions, je laisse volontairement assez de place pour des bricolages futurs. Les disques actuels sont rarement en manque de place. La partition EFI fait en général 100 Mo, mais sur un disque de 1To, 900 Mo c'est pas grand chose.

#4 Installation de Debian » Debian BUSTER (10) sur MSI GP72 et autres » 17-05-2020 23:31:37

remy.labene
Réponses : 5
J'essaye depuis quelques temps d'installer correctement une Debian sur un portable MSI GP72-6QE. Cette machine à la particularité, comme d'autres, d'avoir deux cartes graphiques, Intel 530 et Nvidia GT950. Comme beaucoup de portable, l'ACPI n'est pas très bien géré par Linux et est assez difficile à comprendre et à paramétrer. Je vais donc essayer d'expliquer rapidement les paramétrages que j'ai fini par trouver en tâtonnant. Ceci doit s'appliquer à d'autres machines du même style.

La première chose est de vérifier que le BIOS boute en mode "UEFI avec CSM". J'ai longtemps hésité à utiliser cela car ça me paraissait compliqué et inutile. J'ai toujours configuré mes machines en mode héritage (Legacy). J'observais alors un certain nombre d'avertissement au moment du boot concernant le bus PCI. En mode UEFI ces avertissements ont disparu, les adressages sont mieux reconnus. Pour ceux qui veulent aller plus loin vous avez tout sur UEFI ici https://uefi.org/ c'est du lourd !

On boute ensuite sur le CD Debian 10 en mode UEFI. Je passe sur les différents paramétrages largement détaillés ailleurs. Simplement, il faut penser à créer une table de partition sur le disque en GPT (et pas en MSDOS) avec une première partition de 1Go pour l'EFI au début du disque. Après, vous partitionnez comme ça vous va, personnellement, je crée une partition de 2 Go en ext2 pour le /boot, 60 Go pour la racine / en ext4, 8 Go pour le swap, et le reste pour le /home en ext4. Pensez aussi à bien choisir les dépôts rétroportés (backport) dans votre installation.

Une fois votre installation terminée, vous n’êtes pas arrivé au bout de vos peines. En effet il y a deux problèmes à résoudre: l'un concernant la gestion d’énergie (ACPI) et l'autre la gestion de la carte Nvidia GT950 pour l'utilisation de la 3D.

Le premier problème se résout assez simplement en installant le noyau Linux 5.5 ou supérieur. Ce noyau à fait l'objet d'une correction de bug sur la gestion d’énergie sur pas mal de machines (voir ici https://bugzilla.kernel.org/show_bug.cgi?id=156341 ). Si le noyau Linux 5.5 n’apparaît pas, c'est que vous avez oublié le "backport" dans vos dépots. On peut le rajouter dans /etc/apt/sources.list, par exemple :

# buster-backports
deb http://deb.debian.org/debian buster-backports main contrib non-free


puis faire en ligne de commande :

apt-get update
apt-get install -t buster-backports linux-image-5.5 linux-headers-5.5



Une fois le noyau 5.5 ou supérieur installé, il faut rebouter la machine et vérifier s'il n'y a pas d'erreurs dans les logs du noyau (/var/log/kern.log). Si tout va bien on passe à l'installation du driver nvidia propriétaire.

On commence par désinstaller le driver "nouveau" avec la commande :

apt-get remove xserver-xorg-video-nouveau



et on reboute pour plus de sécurité.

On installe ensuite le driver propriétaire nvidia, mais pas n'importe lequel, celui du backport adapté et compilé avec votre noyau Linux 5.5.

apt-get install -t buster-backports nvidia-driver



Si tout c'est bien passé (regardez bien les messages d'erreur éventuel), on reboute encore (on se croirait sous Windows !).
On va alors installer le programme qui gère les deux cartes graphiques : Intel 530 en mode normal et Nvidia GT950 pour le 3D.

apt-get install -t buster-backports bumblebee-nvidia primus



après avoir rajouté à l'utilisateur lambda les droits pour utiliser bumblebee :

adduser $USER bumblebee



vous devriez pouvoir lancer un programme 3D en utilisant votre carte 3D Nvidia avec la commande "optirun", par exemple :

optirun glxgears



Bon courage, pour d'autres infos plus détaillés voir ici : https://wiki.debian.org/fr/NvidiaGraphi … ckports.29

#6 Re : Installation de Debian » Installation de debian 8 sans internet » 29-03-2017 19:39:25

Petite info pour ceux qui ont installé la debian 9, l'acpi à un bug que l'on peut contourner partiellement en rajoutant dans le fichier /etc/default/grub la ligne :

GRUB_CMDLINE_LINUX="acpi_osi=! acpi_osi=\"Windows 2009\" acpi_rev_override=5"
 



Ça doit fonctionner aussi avec Ubuntu.

#7 Re : Installation de Debian » Installation de debian 8 sans internet » 29-03-2017 15:59:05

Au moment de l'installation, il est demandé d'insérer les autres DVD afin de les analyser et de les référencer dans le fichier /etc/sources.list. On peut faire aussi "apt-cdrom add" en root pour ajouter un CD ou DVD.

#8 Re : Installation de Debian » Installation de debian 8 sans internet » 08-02-2017 13:31:54

lspci -nn


00:00.0 Host bridge [0600]: Intel Corporation Skylake Host Bridge/DRAM Registers [8086:1910] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Skylake PCIe Controller (x16) [8086:1901] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 530 [8086:191b] (rev 06)
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller [8086:a12f] (rev 31)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-H Thermal subsystem [8086:a131] (rev 31)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-H CSME HECI #1 [8086:a13a] (rev 31)
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] [8086:a103] (rev 31)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #1 [8086:a110] (rev f1)
00:1c.3 PCI bridge [0604]: Intel Corporation Sunrise Point-H PCI Express Root Port #4 [8086:a113] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point-H LPC Controller [8086:a14e] (rev 31)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-H PMC [8086:a121] (rev 31)
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-H HD Audio [8086:a170] (rev 31)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-H SMBus [8086:a123] (rev 31)
01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)
02:00.0 Network controller [0280]: Intel Corporation Wireless 3165 [8086:3165] (rev 81)
03:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller [1969:e0a1] (rev 10)

#9 Re : Installation de Debian » Installation de debian 8 sans internet » 08-02-2017 01:09:15

@ MicP

Ce n'est pas le même modèle, ici c'est le GP72-6QE leopard pro

#10 Re : Installation de Debian » Installation de debian 8 sans internet » 08-02-2017 00:18:11

Pour info, j'ai posté un bug sur l'ACPI ici https://bugzilla.kernel.org/show_bug.cgi?id=194431, on verra bien si on a un retour dans les prochains noyaux.

#11 Re : Installation de Debian » Installation de debian 8 sans internet » 06-02-2017 21:08:35

Tu es en root ? Sinon, ne te prend pas trop la tête, installe Debian 9, ça devrait mieux passer.

#12 Re : Installation de Debian » Installation de debian 8 sans internet » 06-02-2017 19:00:11

Effectivement la carte wifi n'est pas configuré, il faudrait le message suivant dans tes logs :

Intel(R) Wireless WiFi driver for Linux
[    3.366610] Copyright(c) 2003- 2015 Intel Corporation
[    3.366645] iwlwifi 0000:02:00.0: PCI->APIC IRQ transform: INT A -> IRQ 16
[    3.367060] snd_hda_intel 0000:00:1f.3: PCI->APIC IRQ transform: INT A -> IRQ 16
[    3.370897] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-26.ucode (-2)
[    3.370957] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-26.ucode failed with error -2
[    3.370965] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-25.ucode (-2)
[    3.371021] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-25.ucode failed with error -2
[    3.371026] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-24.ucode (-2)
[    3.371082] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-24.ucode failed with error -2
[    3.371087] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-7265D-23.ucode (-2)
[    3.371144] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-23.ucode failed with error -2
[    3.379643] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-7265D-22.ucode
[    3.379816] iwlwifi 0000:02:00.0: loaded firmware version 22.361476.0 op_mode iwlmvm
[    3.389918] intel_rapl: Found RAPL domain package
[    3.389920] intel_rapl: Found RAPL domain core
[    3.389921] intel_rapl: Found RAPL domain uncore
[    3.389922] intel_rapl: Found RAPL domain dram
[    3.394496] random: crng init done
[    3.397532] Adding 7812092k swap on /dev/sda3.  Priority:-1 extents:1 across:7812092k SSFS
[    3.410459] snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)
[    3.435482] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210


Il faut vérifier si le module se charge  : 

lsmod | grep iwlwifi


qui doit donner :

iwlwifi               151552  1 iwlmvm
cfg80211         589824  3 iwlmvm,iwlwifi,mac80211


sinon il faut tenter :

insmod iwlwifi


et voir la réponse...

Edit à toto :
Mis les retours de commande et les commandes user sous les balises du forum

#14 Re : Installation de Debian » Installation de debian 8 sans internet » 06-02-2017 13:13:58

Il faut vérifier que ton fichier /etc/apt/sources.list est les lignes suivantes :

# jessie-updates, previously known as 'volatile'
deb http://debian.proxad.net/debian/ jessie-updates main contrib non-free
deb-src http://debian.proxad.net/debian/ jessie-updates main contrib non-free

# jessie-backports, previously on backports.debian.org
deb http://debian.proxad.net/debian/ jessie-backports main contrib non-free
deb-src http://debian.proxad.net/debian/ jessie-backports main contrib non-free


Après ça tu fais un "

apt-get update


" si tu as une connexion réseau quelconque.

puis : 

apt-get install firmware-iwlwifi



Edit à toto :
Modifier les lignes sources et commandes root avec les balises qu'y faut du forum.

#15 Re : Installation de Debian » Installation de debian 8 sans internet » 06-02-2017 01:02:46

@ sora

J'ai installé Debian 9 (qui sera la prochaine version stable dans quelques mois) pour tester et pour avoir les drivers nvidia récents.

Pour faire fonctionner la carte wifi il faut installer le firmware  firmware-iwlwifi, je ne sais pas s'il est assez récent sur Debian 8, à tester. Si ça ne fonctionne pas c'est qu'il est trop vieux.

l'ACPI, c'est la gestion de l'énergie très utilisé sur les portables mais souvent buggé car les fabricants ne respectent pas les spécifications. Il semble que le MSI GP72 n'échappe pas à la règle, d'où l'option acpi=off pour le désactiver, mais du coup le touchpad ne fonctionne pas (j'ai pas compris pourquoi !) et la gestion d'énergie de la batterie n'est pas géré. l'option "nolapic" rend le système ACPI fonctionnel mais la 3D rame bizarrement. Voir ici pour les options ACPI : https://01.org/linux-acpi/documentation … cpi-issues

#16 Re : Installation de Debian » Installation de debian 8 sans internet » 05-02-2017 18:42:24

Bonjour,
Je viens d'installer debian 9 sur un MSI GP72 6QE + disque SSD M2 rajouté, pas simple, mais un avion de chasse à la sortie ! J'avais de nombreux freeze mais je ne savais pas trop d'où cela venait, en fait le responsable c'est la gestion ACPI qui bugge. Il faut rajouter acpi=off au démarrage de grub (appuyer sur e, rajouter acpi=off sur la ligne linux /vmlinuz-4.x , crtl x pour lancer). Je l'ai modifié ensuite définitivement dans /etc/default/grub.

Globalement et rapidement j'ai procédé ainsi :

Boot initial à partir du CD netinstall de debian testing (stretch ou 9) -> installation en mode expert pour les 3 partitions /boot->ext2   / et  /home -> ext4
Sélectionner les paquets propriétaires pour avoir les drivers et firmware constructeurs (intel, nvidia, atheros ...)

Premier redémarrage, installer les firmware manquants : firmware-linux, firmware-iwlwifi, firmware-intel-sound, firmware-linux-nonfree, firmware-linux-misc-nonfree ...

le wifi fonctionne maintenant.

Complément d'info qui peuvent servir si on veut utiliser la 3D et profiter des drivers nvidia propriétaires :

En tant que root, blacklister le pilote "nouveau", attention c'est délicat en cas de mauvaise manip, il faut rajouter un fichier dans /etc/modprobe.d/nouveau.conf.
Ce fichier doit contenir les lignes suivantes :

#etc/modprobe.d/nouveau.conf.
blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off



exécuter ensuite "

depmod -ae


" et "

update-initramfs -u


"

redémarrer à ce stade c'est préférable pour la suite.

Installer bumblebee-nvidia, le plus simple est de faire en ligne de commande en tant que root bien-sur : "

apt-get install dkms build-essential bumblebee-nvidia


" les dépendances seront gérées automatiquement. Une fois installé rebooter

Pour rappel ce pilote permet de gérer les 2 cartes graphiques : intel pour le bureau et Nvidia GTX950M pour la 3D.

Désolé pour mon post un peu long et partiellement hors sujet !

Edit à toto :
Mis les commandes etconfiguration sous balises du forum.

Pied de page des forums

Propulsé par FluxBB