Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 Re : Matériel » suspens ou extinction ? » 01-06-2020 16:45:00

Si c'est que ça Croutons, ça va je gère.
Ce qui m'interpellait c'est la précision de mesure,
un truc qui me sure de 0 à 10kw en étant précis ...

#2 Re : Autres » Ecran noir au démarage de temps en temps » 30-05-2020 10:31:05

Bonjour,

Un grand merci à tous ceux qui m'ont aidé.

Voilà ou j'en suis, je n'ai plus eu de démarrage bloquant sur écran noir

(grâce à laquelle des manip ? je ne sais pas :-) )

Les sorties de veille je n'ai pas testé, mais comme je ne laisse que rarement ordi allumé inactif je les ai désactivées.

A moins que vous estimiez que mes messages d'erreur fassent courir un risque au matériel

Ca va rester en l'état...

Encore un grand merci, j'ai appris beaucoup de choses grâce à vous.

#3 Re : Matériel » suspens ou extinction ? » 29-05-2020 16:26:16

Si je comprends bien Jarek celui du lien a othyug (16 APlage de tension: 175ACV–276VAC)

manquerait de précision pour (voire ne verrait pas)  la diode d'une multiprise ou d'une tv en veille

c'est ça ?

ou alors vous pensez au risque de cramer un "consomètre" trop sensible ?

#4 Re : Autres » Ecran noir au démarage de temps en temps » 28-05-2020 20:50:32

Voila mes dernières tentatives

réinstallation  complète avec un seul écran et mate au lieu de xfce

ce coup ci en installant intel-microcode j'ai lu le retour, ça me disait qu'il manquait des firmwares appartenant à i915

donc j'ai installé firmware-misc-non-free (ce qui est apparu dans synaptic en tapant i915)

j'ai refait ce que m'as conseillé raleur dans le grub

mis bios à jour

les messages de dmesg sont toujours les même

j'ai voulu installer intel-gpu-tools pour voir mais après je ne sais pas le trouver ...

on verra si j'ai encore des écrans noir au démarrage

sinon, je commence à me dire que ça va rester comme ça :-)

en tout cas, je crois que le prochain ordi, je  me le monterai avec du matériel sans bios bizarres, uefi et autres machins :-)

encore merci du temps que vous m'accordez

#5 Re : Matériel » suspens ou extinction ? » 28-05-2020 16:48:24

Super bonne idée :-)

je jetterai un oeuil merci :-)

#6 Re : Autres » Ecran noir au démarage de temps en temps » 28-05-2020 16:45:49

Déjà merci pour le temps que vous m'accordez :-)

j'ai fait la modif, une fois sur GRUB_CMDLINE_LINUX_DEFAULT  et une fois sur GRUB_CMDLINE_LINUX

a chaque fois

 update-grub



et redémarage de l'ordi

puis 

dmesg -l warn



pour vérifier

[    0.192598] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
[    0.192599] ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
[    0.203306] pmd_set_huge: Cannot satisfy [mem 0xf8000000-0xf8200000] with a huge-page mapping due to MTRR override.
[    1.162911] ACPI: Invalid active2 threshold
[    1.183086] usb: port power management may be unreliable
[    1.188016] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20180810/utaddress-213)
[    1.188026] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x00000000000008FF (\GPR) (20180810/utaddress-213)
[    1.188029] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPRL) (20180810/utaddress-213)
[    1.188031] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x00000000000008FF (\GPR) (20180810/utaddress-213)
[    1.188034] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPRL) (20180810/utaddress-213)
[    1.188036] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x00000000000008FF (\GPR) (20180810/utaddress-213)
[    1.188038] lpc_ich: Resource conflict(s) found affecting gpio_ich
[    1.558901] ata1.00: supports DRM functions and may not be fully accessible
[    1.562149] ata1.00: supports DRM functions and may not be fully accessible
[    7.766941] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
[    9.816621] hp_wmi: query 0x4 returned error 0x2
 



la ligne

    1.443651] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller,

n'as pas disparu

et la ligne (tout en bas) est apparue :-)

[    9.816621] hp_wmi: query 0x4 returned error 0x2

#7 Re : Matériel » suspens ou extinction ? » 28-05-2020 14:33:10

On est d'accord :-)

nous dire de raccourcir nos douches et continuer à arroser les terrains de golf :-)

mais pour la question de ottr c'était intéressant de chiffrer la chose,

vais m'en servir pour faire un exo de math a mes élèves qui laissent leur ordi allumé 10h par jour :-)

après, j'ai été élevé à l'ancienne, quand on peut ne pas gaspiller, réparer, récupérer  (bon des fois je le suis un peu trop) ...

et à l'arrivé, à mon boulot je suis un des plus petits salaires,

et un des seuls qui met de l'argent de côté en fin de moi au lieu d'être a découvert :-)

#8 Re : Autres » Ecran noir au démarage de temps en temps » 28-05-2020 13:26:40

raleur a écrit :

thierry_84 a écrit :

et ça " try module parameter "video.allow_duplicates=1"if the current driver doesn't work" je n'ai aucune idée de ou se trouve module parameter pour voir


A ajouter dans la valeur de la variable GRUB_COMMANDLINE_LINUX définie dans /etc/default/grub, et à appliquer avec update-grub.




nano grub


 # If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

 



je transforme GRUB_CMDLINE_LINUX="" en GRUB_CMDLINE_LINUX="video.allow_duplicates=1 "

c'est bien ça ?

dois je prévoir une sauvegarde.old et une libe usb pour rectifier si ça plante ?

désolé de la question, mais suis jamais allé aussi loin, j'ai déja des frissons rien que d'y penser  :-)

#9 Re : Matériel » suspens ou extinction ? » 28-05-2020 12:44:35

Merci otyugh et bravo pour tous ces tests


juste si ça peut intéresser, j'ai trouvé ça entre temps,

https://www.pourlascience.fr/sd/telecom … s-6556.php

je ne sais pas ce que ça vaut, car les avis diffèrent suivant les sites consultés



et ça sur un autre site : (https://www.papergeek.fr/pourquoi-il-ne … eille-5703)

Sur l’usure des disques SSD

Cet article avait fait beaucoup réagir au moment de sa publication originelle. Notamment du point de vue de l’usure des SSD, qui serait prématurée à cause des grands volumes d’écriture induits par le passage en mode hibernation. Le prix des SSD baisse autant que leur qualité augmente. J’ai réalisé un stress-test poussé qui montre que les SSD récents ont en fait une résistance surprenante aux cycles d’écriture.

La technologie a donc fait d’énormes progrès en quelques années avec une densité de stockage et une fiabilité en augmentation et des prix en baisse. Il est vrai pourtant, qu’aux débuts des SSD, l’emploi de ce type de mémoire impliquait quelques précautions.

donc a priori l'âge du ssd compte ...



pour le reste, dès que je découche, je débranche systématiquement tout ce qui consomme même éteint et dans ma cuisine, microdonde, plaque induction je ne branche que quand je m'en sert :-)

ce n'est pas tellement pour le peu économisé, quoique je préfère garder mon argent que le donner à la world compagnie

mais j'avais lu qu'au niveau mondial, les petits trucs de chacun ça faisait une quantité phénoménale d'électricité

d'accord, il y a de plus gros pollueurs, mais c'est pour ma conscience.

encore merci otyugh

#10 Re : Matériel » suspens ou extinction ? » 28-05-2020 12:12:03

Bonjour,

Je me suis posé la même question hier :-)

suis intéressé aussi par les réponses

des tests que j'ai fait hier pour un autre pb,  ( raleur ma parlé de ça :   Mise en veille simple (suspend-to-RAM) ou profonde (hibernation/suspend-to -disk) )

avec la profonde je n'entendais plus de bruit dans l'uc et avec la simple j'entendais encore le ventilo

la profonde doit être plus économe,

mais un redémarrage consomme combien d'énergie ? pour comparer à l'énergie consommée en veille ?

et si on veut pinailler quid de l'usure des composants dans chaque cas ...

#11 Re : Autres » Ecran noir au démarage de temps en temps » 28-05-2020 11:03:30

Croutons a écrit :

je me suis posé la question si un écran vga et un display port avec adaptateur (j'ai un vga et deux display ports sur l'ordi) ça semait pas la pagaille, comme j'ai l'impression qu'il n'y a pas de vrai carte graphique mais une intégrée à la carte mère ...


[    1.443651] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.


Il faudrait voir si avec un seul écran il n'y a plus de probléme



je viens de tester écran vga seul, redémarage
                            écran sur le display port seul redémarrage

dans les deux cas la ligne [firmware bug] est présente dans le retour de dmesg
pour info, j'ai fait l'install avec les deux écrans branchés, est ce que ça vaut le coup de se retaper l'install en mono écran ?

et ça " try module parameter "video.allow_duplicates=1"if the current driver doesn't work" je n'ai aucune idée de ou se trouve module parameter pour voir


Croutons a écrit :


que donne

 lspci -nnk |grep -iA3 vga



00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
  Subsystem: Hewlett-Packard Company Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [103c:18e7]
  Kernel driver in use: i915
  Kernel modules: i915
 

#12 Re : Autres » Ecran noir au démarage de temps en temps » 27-05-2020 21:50:20

Merci beaucoup bonyred

c'est vrai que ... vu ma config

   systemd-analyze


Startup finished in 9.869s (kernel) + 3.732s (userspace) = 13.601s
graphical.target reached after 3.724s in userspace
 



je ne connaissais pas cette commande, (bon c'est vrai je n'en connais pas beaucoup :-)

je pense que je vais faire le test  un de ces jours

encore merci :-)

#13 Re : Autres » Ecran noir au démarage de temps en temps » 27-05-2020 20:24:40

Merci bonyred, je me sens moins seul, je commençais a penser que c'était mon pc le problème

habituellement je faisait comme toi, je finissais par trouver une version qui fonctionnait.

c'est juste que maintenant que je potasse un peu j'aurais aimé trouver le pb,

surtout que j'ai 4 ordis en ce moment c'est  monté à 6 quand je faisait des install sur des portables pour les filles de mon amie

et c'est pratique d'avoir partout pareil :-) mais si c'est trop galère je ferai comme toi.

deux questions :

1 - quand tu parles du même problème, tu parle de mes deux questions ? écran noir aléatoire au démarrage et sortie de veille ou un seul des deux ?

2 - habitué a xfce, car j'ai eu beaucoup de vieux pc pas très puissants et que j'aime pas attendre, c'est rapide mate ? sinon autant j'essaie lxqt pour voir
     tu avais  réinstallé la distrib complète ou juste mate  sur ton install xfce ?

#14 Re : Autres » Ecran noir au démarage de temps en temps » 27-05-2020 20:13:09

Merci crouton,

je ne connaissais pas cette obligation d'appui sur bouton pour sortir de la vrille prolongée.
entre temps j'ai retesté, en enlevant le verrouillage auto de session et d'écran à la mise en veille prolongée
je ne sais pas si je rêve ou si j'ai fait un truc de travers
3 fois sur 4 pas eu besoin de taper id et mdp
et une fois il a fallut que je m'identifie.
je vais retester ça sur les jours qui viennent pour voir si ça se reproduit, pour aujourd'hui je fatigue un peu :-)

mais vu mon autre pb d'écran noir, il y a sûrement un problème quelque part ...
j'étais en train d'ouvrir des fichiers /var/log pour voir

commencé par  /var/log/auth.log et ~/boot.log , mais c'est du chinois pour moi :-)

non, pas de dual boot, il n'y a que débian dessus

je me suis posé la question si un écran vga et un display port avec adaptateur (j'ai un vga et deux display ports sur l'ordi) ça semait pas la pagaille, comme j'ai l'impression qu'il n'y a pas de vrai carte graphique mais une intégrée à la carte mère ...

#15 Re : Autres » Ecran noir au démarage de temps en temps » 27-05-2020 18:18:04

raleur a écrit :

thierry_84 a écrit :

de temps en temps au démarrage il bloque sur un écran noir,


A quel moment ?



Comme je ne savais pas, j'ai fait 3 redémarrages, les deux premiers ok,
au troisième après l'affichage de Grub, j'ai cliqué sur entrée pour zapper le compte a rebours et j'ai eu écran noir.
Obliger de forcer l'arrêt
Démarrage suivant nickel



raleur a écrit :


thierry_84 a écrit :

lorsqu'il se met en veille, j'ai beau agiter la souris ou tapoter des touches, il refuse de se réveillier


Mise en veille simple (suspend-to-RAM) ou profonde (hibernation/suspend-to -disk) ?




comme je ne savais pas j'ai fais les test suivants :

dans le gestionnaire d'alimentation xfce dans général
j'ai testé "appui sur le bouton d'alimentation = mettre en veille"
j'ai appuyé sur ledit bouton, ordi s'est mis en veille (plus entendu le bruit du ventilo) et en est sorti en touchant clavier

j'ai testé "appui sur le bouton d'alimentation = mettre en veille prolongée "
j'ai appuyé sur ledit bouton, ordi s'est mis en veille (plus entendu le bruit du ventilo)
il ne sort pas le la veille, je dois appuyer sur le bouton d'alim et il démarre comme si était éteint

dans le gestionnaire d'alimentation xfce dans écran :

j'ai mis écran vide après 2 mn  mettre en veille après 6mn éteindre après 24 mn
puis j'ai chronométré
au bout de 2 mn l'écran est devenu noir, on entendait toujours ventilo de l'ordi
et impossible de sortir de la veille

puis j'ai j'ai mis écran vide jamais  mettre en veille après 2mn éteindre après 24 mn
puis j'ai chronométré
au bout de 2 mn l'écran est devenu noir, on entendait toujours ventilo de l'ordi
sortie de veille sans pb

dans tous les cas, dans système j'ai : mise en veille du système sur "jamais"

après s'il y a un fichier a éditer pour mieux te répondre ...

#16 Autres » Ecran noir au démarage de temps en temps » 27-05-2020 15:04:28

thierry_84
Réponses : 17
Bonjour,

j'ai acheté un ordi d'occasion et installé debian-10.4.0-amd64 il y a 3 jours avec xfce comme bureau

j'ai deux écrans branchés, un sur le port vga (hp 19" carré) et un sur un display port avec adaptateur vga (lg 21" 16/9)

la majorité du temps il démarre normalement à la vitesse de la lumière

mais de temps en temps au démarrage il bloque sur un écran noir,

je force l'arrêt et après il redémarre correctement à la vitesse de la lumière.

Et aussi : lorsqu'il se met en veille, j'ai beau agiter la souris ou tapoter des touches, il refuse de se réveillier



l'ordi : Hp prodesk 600 G1 SFF
           Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
          8 g de ram (deux barettes de 4) ddr3
          système installé sur ssd samsung pro 250Go
          second disque dur wd blue 1 To pour sauvegarde avec grsync (un peu gros mais il était déja dedans)

          carte mère Manufacturer: Hewlett-Packard
       Product Name: 18E7
      Version: Not Specified
      Serial Number: CZC4144XCY
      Asset Tag: CZC4144XCY

          BIOS Information :
      Vendor: Hewlett-Packard
      Version: L01 v02.21
      Release Date: 12/17/2013

        carte graphique VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

dmesg -l crit
 



ne renvoie rien

  dmesg -l err


[    0.239307] pnp 00:01: can't evaluate _CRS: 12311
[    2.657758] kvm: disabled by bios
[    2.702330] kvm: disabled by bios
[    2.765257] kvm: disabled by bios
[    2.830495] kvm: disabled by bios

 



  dmesg -l warn


[    0.239307] pnp 00:01: can't evaluate _CRS: 12311
[    2.657758] kvm: disabled by bios
[    2.702330] kvm: disabled by bios
[    2.765257] kvm: disabled by bios
[    2.830495] kvm: disabled by bios
root@pc52:~# dmesg -l warn
[    0.194152] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
[    0.194153] ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
[    0.204854] pmd_set_huge: Cannot satisfy [mem 0xf8000000-0xf8200000] with a huge-page mapping due to MTRR override.
[    1.192294] ACPI: Invalid active2 threshold
[    1.209535] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20180810/utaddress-213)
[    1.209546] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x00000000000008FF (\GPR) (20180810/utaddress-213)
[    1.209548] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPRL) (20180810/utaddress-213)
[    1.209549] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x00000000000008FF (\GPR) (20180810/utaddress-213)
[    1.209551] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000053F (\GPRL) (20180810/utaddress-213)
[    1.209552] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x00000000000008FF (\GPR) (20180810/utaddress-213)
[    1.209554] lpc_ich: Resource conflict(s) found affecting gpio_ich
[    1.242223] usb: port power management may be unreliable
[    1.443651] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
[    1.581451] ata1.00: supports DRM functions and may not be fully accessible
[    1.585273] ata1.00: supports DRM functions and may not be fully accessible
[ 1275.469908] kauditd_printk_skb: 7 callbacks suppressed
 



j'ai quelques trucs de moins dans les retours dmesg depuis que j'ai installé intel-microcode (tsf-deadline a disparu)

Mais voila, je suis a fond de mes compétences la :-)

si quelqu'un peut me dire si le problème viens de ce que renvoi dmesg
ou sinon au chercher ...

Si quelqu'un se penche sur mon problème et désire plus d'infos, merci de me donner la commande à taper

Parce que je débute quand à tout ça (je progresse beaucoup depuis que je fréquente DF :-) )

Merci d'avance :-)

#17 Re : Le Blog DF » Les enquêtes Debian-Facile : on a volé mes commandes root sous Buster » 26-05-2020 20:53:46

Corrigé jarek :-)

quoique ... su- en root on deviens pas dieux ? non ? bah j'aurais essayé ;-)

#18 Re : Le Blog DF » Les enquêtes Debian-Facile : on a volé mes commandes root sous Buster » 26-05-2020 19:18:09

Bonjour,

un grand merci à tous

ça m'as bien dépanné et en plus j'ai appris plein de choses :-)

 su -



fonctionne nickel

#19 Re : Matériel » installation carte wifi » 22-05-2020 13:38:25

Bonjour chalu

j'étais dans le même cas que lherbaux mais sous débian 9

carte achetée ce matin,

vos réponses m'ont permis de régler le pb en 10 mn

merci beaucoup :-)

Pied de page des forums

Propulsé par FluxBB